Subject: Missing materials

From: Eric Rescorla <[email-masked]>
Date: Wed, 28 Nov 2007 08:08:39 -0800

As an experiment, I ran getdrafts this morning on the entire agenda
and what follows is the output. As you can see, a pretty substantial
number of WGs are without agendas and over 10% of drafts are not
found. Obviously, these could be bugs in getdrafts, but I've 
spot checked these and in most cases they're really not there
or are the wrong version or something.

-Ekr

P.S. This also revealed a few bugs in the TLS agenda. Fixing 
them now :)

WGs without agendas:
  autoconf
  intarea
  ntp
  softwire
  radext
  forces
  rpsec
  rtgarea
  rtgwg
  msec
  saag
  fecframe
  hiprg
  mobopts
  rrg

Missing drafts
  draft-ietf-ancp-protocol-01.txt (wg=ancp)
  draft-ietf-sipping-offeranswer-02.txt (wg=hip)
  draft-vogt-rrg-six-one-00.txt (wg=hip)
  draft-ietf-bmwg-ipsec-term-02.txt (wg=bmwg)
  draft-ietf-capwap-protocol-specification-07.txt (wg=capwap)
  draft-ietf-capwap-protocol-binding-ieee80211-04.txt (wg=capwap)
  draft-asveren-dime-dupcons-00.txt (wg=dime)
  draft-asveren-dime-state-recovery-01.txt (wg=dime)
  draft-ietf-ipfix-testing-02.txt (wg=ipfix)
  draft-dietz-ipfix-mib-01.txt (wg=ipfix)
  draft-muenz-ipfix-configuration-02.txt (wg=ipfix)
  draft-trammell-ipfix-file-04.txt (wg=ipfix)
  draft-kobayashi-ipfix-mediator-model-00.txt (wg=ipfix)
  draft-dressler-ipfix-aggregation-03.txt (wg=ipfix)
  draft-li-natale-smi-datatypes-in-xsd-00.txt (wg=opsarea)
  draft-romascanu-netconf-datatypes-03.txt (wg=opsawg)
  draft-ietf-avt-rtcp-non-compound-01.txt (wg=avt)
  draft-poetzl-bliss-call-completion-01.txt (wg=bliss)
  draft-schulzrinne-ecrit-lost-sync-00.txt (wg=ecrit)
  draft-ietf-mmusic-decoding-dependency-00.txt (wg=mmusic)
  draft-saito-mmusic-sdp-ike-02.txt (wg=mmusic)
  draft-niemi-simple-chat-06.txt (wg=simple)
  draft-niemi-simple-msrp-ice-00.txt (wg=simple)
  draft-ietf-speermint-voip-consolidated-usecases-04.txt (wg=speermint)
  draft-ietf-speermint-requirements-02.txt (wg=speermint)
  draft-ietf-xcon-bfcp-connection-05.txt (wg=xcon)
  draft-ietf-xcon-framework-08.txt (wg=xcon)
  draft-ietf-mpls-lsr-self-test-06.txt (wg=mpls)
  draft-ietf-mpls-32.txt (wg=mpls)
  draft-ietf-mpls-upstream-label-02.txt (wg=mpls)
  draft-ietf-pce-interas-pcecp-reqs-04.txt (wg=pce)
  draft-ietf-pce-tc-mib-01.txt (wg=pce)
  draft-ietf-pce-disc-mib-01.txt (wg=pce)
  draft-yasukawa-pce-p2mp-req-03.txt (wg=pce)
  draft-yasukawa-pce-p2mp-app-01.txt (wg=pce)
  draft-bernstein-ccamp-wson-info-00.txt (wg=pce)
  draft-ietf-pkix-2797-bis-04.txt (wg=pkix)
  draft-ietf-pkix-cmc-trans-05.txt (wg=pkix)
  draft-ietf-sasl-rfc2831bis-12.txt (wg=sasl)
  draft-cridland-sasl-hexa-00.txt (wg=sasl)
  draft-josefsson-password-auth-00.txt (wg=sasl)
  draft-newman-auth-scram-04.txt (wg=sasl)
  draft-zeilenga-sasl-yap-00.txt (wg=sasl)
  draft-harkins-tls-rsa-aes-siv-00.txt (wg=tls)
  draft-badra-ecdhe-tls-psk-00.txt (wg=tls)
  draft-ietf-ccid4-01.txt (wg=dccp)
  draft-fairhurst-tsvwg-qs-02.txt (wg=dccp)
  draft-jennings-sip-dtls-04.txt (wg=dccp)
  draft-manner-nsis-nslp-auth-03.txt (wg=nsis)
  draft-larsen-tsvwg-port-randomization-01.txt (wg=tsvwg)
  draft-ietf-tsvwg-rsvp-proxy-approaches-01.txt (wg=tsvwg)
  draft-ietf-tsvwg-rsvp-proxy-proto-01.txt (wg=tsvwg)
  draft-ietf-tsvwg-udp-guidelines-02.txt (wg=tsvwg)
  draft-ietf-tsvwg-admitted-voice-dscp-02.txt (wg=tsvwg)
Found 375 out of 429 drafts

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Frank Ellermann" <[email-masked]>
Date: Wed, 28 Nov 2007 20:19:14 +0100

>   draft-ietf-sasl-rfc2831bis-12.txt (wg=sasl)

Replaced by draft-melnikov-digest-to-historic
(not yet formally, WG Charter will be updated)

>   draft-newman-auth-scram-04.txt (wg=sasl)

Both expired, will be unified, later, maybe.

>   draft-josefsson-password-auth-00.txt (wg=sasl)

Also expired, maybe waiting for the GS2 Last Call.

>   draft-zeilenga-sasl-yap-00.txt (wg=sasl)

A -02 exists, IIRC not more intended as SASL I-D.

If your tool evaluated the SASL WG page on the 
IETF tools server it somehow missed the yap-02.

 Frank

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 28 Nov 2007 11:21:26 -0800

At Wed, 28 Nov 2007 20:19:14 +0100,
> IETF tools server it somehow missed the yap-02.

Nope, it's working from the agendas that are actually submitted for
the meeting, since that's what I figure people check, as 
opposed to the WG page.

Here's the SASL one
(from http://www3.ietf.org/proceedings/07dec/agenda/sasl.txt).
As you can see, the drafts are listed incorrectly.

-Ekr

Simple Authentication And Security Layer (SASL)
IETF70, Vancouver, BC, Canada

Wednesday, December 5, 2007, at 1300-1500
=========================================

Chairs:

Tom Yu <[email-masked]>
Kurt Zeilenga <[email-masked]>

DRAFT AGENDA: (2 hours)

* intro, scribe appointment, agenda bashing - 5 min

* document status - 5 min
  - draft-ietf-sasl-crammd5-09
  - draft-ietf-sasl-gs2-09
  - draft-ietf-sasl-rfc2831bis-12
  - draft-cridland-sasl-hexa-00
  - draft-josefsson-password-auth-00
  - draft-newman-auth-scram-04
  - draft-zeilenga-sasl-yap-00

* technical discussion - 90 min
  - password-based mechs
  - interop

* discuss milestones - 10 min

* open microphone - remaining time

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 29 Nov 2007 01:50:32 +0100

Eric Rescorla wrote on the general list:

> it's working from the agendas that are actually submitted
> for the meeting, since that's what I figure people check,
> as opposed to the WG page.

> As you can see, the drafts are listed incorrectly.

Yes, copied to the SASL list, maybe it's still possible to fix
the agenda before it ends up in the proceedings.

Thanks, 

 Frank