Subject: Re: Patents can be for good, not only evil

From: Scott Brim <[email-masked]>
Date: Thu, 1 Nov 2007 09:35:10 -0400

Excerpts from Hallam-Baker, Phillip on Wed, Oct 31, 2007 08:38:45AM
-0700:
> How many Working Group participants who vent on patent issues have
> read RFC 3669?
>  
> Of those who have read it, how many consider it to be binding?
>  
> All RFC 3669 does is to allow endless discussion of topics that most
> WGs do not consider core. They may be important considerations but
> the Working Groups themselves are the wrong place to do design work
> in the IPR space.

It was never intended to be "binding" in any way.  We decided that
there are no blanket rules or processes that can be applied to every
IPR situation in every working group.  Therefore we provided case
studies and principles that they can use -- if they choose -- as
guidance.  

> Very few Working Group participants have any real interest or
> understanding of the patent system other than to wish it would go
> away. The most likely reason a WG participant would have detailed
> knowedge is if they were an unwilling participant in a patent
> lawsuit or had a proposal shot down because some group of lawyers
> objected to the IPR terms (both have happend to me). 
>  
> The bulk of the opinions expressed might be characterized as
> ideological rather than informed. So what we get as a result is not
> a useful discussion, its more like a slashdot flamewa
>  
> Its not productive discussion, the arguments are entirely
> repetative.

I agree with all of this but ...

> Eliminating repetative, unproductive arguments is the function of
> the charter. We write charters that rule technical issues such as
> designing a new PKI, Web Services transport layer, cryptographic
> algorithm, &ct &ct out of scope. So why not rule the IPR question
> out of scope at the charter stage unlss there is a specific reason
> to beleive that a WG would need to deal with it?

... because as has been stated several times, it is rare that a WG
even knows the dimensions of possible IPR issues before they have got
their ideas sorted out.  

> Understanding the IPR landscape is one of the things I always try to
> do before starting or joining a group. IPR is always a BOF topic. It
> is not that we don't discuss in advance. In fact in many cases the
> whole raison d'etre for the group is to create an unencumbered
> standard to replace a proprietary protocol.

IPR should be discussed at *every* stage.  Just because you discuss it
in a BOF doesn't mean you can mandate it out of existence later.

> For example, take a look at the Ford-Wienner key management patent
> which is due to expire at some point in the not so distant future.
> The invention describes a lightweight CRM scheme. I can well imagine
> that someone might want to start a working group to produce an
> unencumbered CRM protocol based on Ford-Wienner and S/MIME. The
> whole point of chartering a group of that type would be to produce a
> RANDZ protocol and so it should be stated in the charter.

Or perhaps one that doesn't require a license at all.  RANDZ is not
the best outcome ... and yes, you could make statements like that in
the charter (some have), but that doesn't mean a requirement is
appropriate.

> I don't think that there are many cases where a non RANDZ IPR clause
> is going to fly. 

And yet they do, when people choose a slight encumbrance in order to
gain utility within a certain scope of use.  It's all about tradeoffs
that can only be made once you know exactly what you're trading.

> If we have two technologies on offer, A and B from different parties
> I want to be able to set up a bidding war between the parties to
> offer the most favorable terms.

Good idea ... but afaict most IPR claimants will want to know clearly
how their IPR intersects with the technology being standardized before
they play.  That means you can't do this until late in the process.

Scott

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 1 Nov 2007 07:52:25 -0700

From: Scott Brim [mailto:[email-masked]]
Sent: Thu 01/11/2007 9:35 AM
To: [email-masked]
Subject: Re: Patents can be for good, not only evil

>even knows the dimensions of possible IPR issues before they have got

I have never been involved in the formation of a working group where there were no candidate proposals before the first BOF was held. And in every case where someone has made a proposal there has been a pretty good idea of what IPR claims might affect it.

The only exception to this was SACRED where the whole point of the Working Group was to try to develop a technology that was not encumbered. When they discovered that this was not going to be possible they gave up. So even in SACRED where the state of IPR was in doubt the participants knew what their objective was.

>in a BOF doesn't mean you can mandate it out of existence later.

 All that I am proposing to rule out of scope is discussion of whether the IPR terms that would be acceptable (or not). The question of whether a proposal was effectively encumbered (or not) and thus incompatible with the charter would still be open for discussion. 

Also out of scope would be questions of the form 'are the terms offered by Very Large Corporation compatible with the MeeToo Open Sauce License which I have just made up to be deliberatively obstructive'.

If a WG was chartered with an open IPR clause, allowing RAND it would not be in scope to subsequently object to the encumbered technology on those grounds. 

The point is not that discussion of IPR is prohibited entirely, the point is that you can't move the goalposts after the fact. If a group is chartered as RAND and someone either works out a scheme that is unencumbered or is offered on W3C-RF terms they are almost certain to win the discussion in the Working Group.

What I am trying to do here is to set up the rules of the game so that they minimize repetative condition and create the optimal incentives for Patent Rights Holders to offer acceptable terms. 

>the charter (some have), but that doesn't mean a requirement is

Actually I have long been an advocate of Patent Access as opposed to Patent Licensing. As I pointed out in the wake of the MARID fiasco, all the parties want is to avoid being sued. Microsoft's Open Promise effectively avoids the need for a license.

The point is that we need a standard set of terms such as W3C-RF. Rather than go through the business of renegotiating those terms yet again I would prefer to simply adopt them as is. I would then like to see the IETF and W3C jointly ceed change control over the terms to a body that is specifically equiped to dicuss such legal issues. This could be a body like Creative Commons or possibly some other body like the E-Terms group that Michael Baum tried to set up in the early 90s.

I don't want this to continue as an IETF flamewar amongst people who really know very little about the legal issues. Except for Laurence Rosen, none of us are lawyers. I want to see folk like Larry Lessig and Joe Alhadeff and the Microsoft and IBM folk also hammering these terms out. Neither IETF or W3C is that forum but we can certainly help to create that forum or repurpose an existing one.

>that can only be made once you know exactly what you're trading.

I don't think that there is such a thing as a slight encumberance. Unless the IPR terms are completely specified any implementor can only rely on 'reasonable and non descriminatory' - whatever that might mean. 

Some standards organizations do in fact negotiate detailed IPR terms, the DVD folk for exmple. The IETF does not and cannot as we don't represent our employers and don't have a means of voting. 

>they play.  That means you can't do this until late in the process.

Absolutely, you cannot get agreement until the end but you can specify the acceptable terms for the agreement before that point.

At the moment we have a three way intesection with the third unknown being what IPR terms will be acceptable and from which parties.