Subject: RE: Last Call: draft-levin-mmusic-xml-media-control (XML Schema for Media Control) to Informational RFC

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 7 Nov 2007 12:18:44 -0500

> -----Original Message-----
> From: The IESG [mailto:[email-masked]] 
> Sent: Wednesday, November 07, 2007 11:09 AM
> To: IETF-Announce
> Subject: Last Call: draft-levin-mmusic-xml-media-control (XML 
> Schema for Media Control) to Informational RFC 
> 
> The IESG has received a request from an individual submitter 
> to consider the following document:
> 
> - 'XML Schema for Media Control '
>    <draft-levin-mmusic-xml-media-control-12.txt> as an 
> Informational RFC

The XML Schema found in section 5 is mildly broken.  It mixes use of two
prefixes, "xs" and "xsd".  One or the other needs to be used
consistently for the Schema to be valid.  Here's a fix using "xs":

<?xml version="1.0" encoding="utf-8" ?>

<xs:schema id="TightMediaControl"
 elementFormDefault="qualified"
 xmlns:xs="http://www.w3.org/2001/XMLSchema">

 <xs:element name="media_control">
   <xs:complexType>
     <xs:sequence>
       <xs:element name="vc_primitive"
         type="vc_primitive"
         minOccurs="0"
         maxOccurs="unbounded" />
       <xs:element name="general_error"
         type="xs:string"
         minOccurs="0"
         maxOccurs="unbounded" />
     </xs:sequence>
   </xs:complexType>
 </xs:element>

 <!-- Video control primitive.  -->

 <xs:complexType name="vc_primitive">
   <xs:sequence>
     <xs:element name="to_encoder" type="to_encoder" />
     <xs:element name="stream_id"
       type="xs:string"
       minOccurs="0"
       maxOccurs="unbounded" />
   </xs:sequence>
 </xs:complexType>

 <!-- Encoder Command:
      Picture Fast Update
 -->

 <xs:complexType name="to_encoder">
   <xs:choice>
     <xs:element name="picture_fast_update"/>
   </xs:choice>
 </xs:complexType>
</xs:schema>

-Scott-

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 8 Nov 2007 09:51:35 +0200

Scott,
Thanks for catching it. 
Roni

> From: Hollenbeck, Scott [mailto:[email-masked]]
> Sent: Wednesday, November 07, 2007 7:19 PM
> To: [email-masked]
> Subject: RE: Last Call: draft-levin-mmusic-xml-media-control (XML
Schema
> forMedia Control) to Informational RFC
>