Subject: Re: 2026, draft, full, etc.

From: Bob Braden <[email-masked]>
Date: Fri, 2 Nov 2007 10:00:56 -0700 (PDT)

*> 
  *> One idea that was floated a couple of years ago, as part of a one-level
  *> standards track, was to retain the register of implementation reports
  *> (http://www.ietf.org/IESG/implementation.html) and mark the entries
  *> that have been approved by the IESG. The RFC index could then point to
  *> approved implementation reports, without any formal "promotion" needed.
  *> 
  *>     Brian
  *> 

Brian,

So, this implementation report registry would be analogous to the
current errata registry>  E.g., the RFC search engine would note
the existence of implementation reports for a particular RFC, just
as it now notes the existence of errata?

Bob Braden

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 2 Nov 2007 10:27:12 -0700

I would prefer to have someone write an RFC describing the interoperability tests performed, and the implementatiopns that were found to complete the tests successfully at the conclusion of the test.

Implementations that fail would be simply ignored unless the implementor expressly wanted to include a caveat describing the inconsistency discovered. Nobody wants their dirty laundry written up.

If as often happens an ambiguity in the spec was noted this would be noted in the interop document and either a proposed resolution noted or a note to the effect that this must be decided by the WG.

Such a document would be Informational status and be produced after a specification had gone to Proposed Standard.
 
I would also suggest weakening the requirement for recycling at Proposed. At present this is required to change SHOULD to MUST. In some cases however this is found to be desirable as an effectively essential criteria for interop.

The normal series of events to get to standard would thus be:

Drafts* -> PROPOSED -> Interop & Erata reports -> DRAFT STANDARD -> ?? -> IETF-STANDARD

Where ?? stands for the unknown criteria for moving to full standard that some feel are essential even though only 4 RFCs other SNMP specs have gone to full standard since 1999.

> -----Original Message-----
> From: Bob Braden [mailto:[email-masked]] 
> Sent: Friday, November 02, 2007 1:01 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: 2026, draft, full, etc.
> 
> 
>   *>
> So, this implementation report registry would be analogous to 
> the current errata registry>  E.g., the RFC search engine 
> would note the existence of implementation reports for a 
> particular RFC, just as it now notes the existence of errata?
> 
> Bob Braden
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 03 Nov 2007 08:49:50 +1300

> as it now notes the existence of errata?

That makes a lot of sense to me. I don't see why we'd need the
overhead of making those reports into RFCs, and we'd have to ensure
that the IETF wasn't making any assertions that could carry
liability. (And I agree with the idea of reviving Larry Masinter's
draft.)

    Brian