Subject: Re: Last Call: draft-snell-atompub-bidi (Atom Bidirectional Attribute) to Experimental RFC

From: "Tim Bray" <[email-masked]>
Date: Fri, 11 Apr 2008 12:47:27 -0700

On Fri, Apr 11, 2008 at 12:03 PM, The IESG <[email-masked]> wrote:
> The IESG has received a request from an individual submitter to consider
>  the following document:
>
>  - 'Atom Bidirectional Attribute '
>    <draft-snell-atompub-bidi-06.txt> as an Experimental RFC

The name of this draft is a little misleading.  Shouldn't it be
"atom-bidi" not "atompub-bidi"?  It doesn't have anything to do with
the protocol, which is what atompub stands for in most people's minds.
-Tim
_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: James M Snell <[email-masked]>
Date: Fri, 11 Apr 2008 12:59:02 -0700

The "atompub" was originally in reference to the Atompub Working Group. 
  Now that the WG is closed, it probably would make sense to change this 
to just atom.  If another version of the draft is needed based on 
last-call comments, I can make the name change then.

- James

---

From: "Frank Ellermann" <[email-masked]>
Date: Fri, 11 Apr 2008 23:04:24 +0200

James M Snell wrote:

> If another version of the draft is needed based on 

Leave it alone, please.  Various tools have problems
with tracking changed names.  Changing the name to
"RFC xxxx" at some point in time is IMO good enough.

I don't find dir="" in the HTML 4.01 spec., why does
Atom need dir="" ?

 Frank

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 14 Apr 2008 09:32:27 +0200

On Fri, Apr 11, 2008 at 11:04:24PM +0200,
 Frank Ellermann <[email-masked]> wrote 
 a message of 13 lines which said:

> I don't find dir="" in the HTML 4.01 spec., 

http://www.w3.org/TR/html401/struct/dirlang.html#h-8.2

> 8.2.2 Inheritance of text direction information
...
> When the dir attribute is set for a block-level element, it remains
> in effect for the duration of the element and any nested block-level
> elements. Setting the dir attribute on a nested element overrides
> the inherited value.

The dir="" is probably here to reset the text direction to "I do not
know", something which is impossible in HTML because of the
inheritance.

---

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 14 Apr 2008 10:24:35 +0200

> http://www.w3.org/TR/html401/struct/dirlang.html#h-8.2

That permits LTR or RTL, bot not an empty dir="", or
is it another SGML oddity I've never before heard of ?
 
> The dir="" is probably here to reset the text direction
> to "I do not know", something which is impossible in
> HTML because of the inheritance.

Yes, my question was why the draft needs dir="" at all,
and if it also updates HTML and XHTML for the purposes
of ATOM. 

xml:lang="" in XML 1 turned out to be a major headache
for XHTML 1, because it is forced to mirror HTML 4.01
as good as possible, and an NMTOKEN cannot be empty.

 Frank

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 14 Apr 2008 10:37:20 +0200

On Mon, Apr 14, 2008 at 10:24:35AM +0200,
 Frank Ellermann <[email-masked]> wrote 
 a message of 22 lines which said:

> That permits LTR or RTL, bot not an empty dir="", or is it another
> SGML oddity I've never before heard of ?

No, no, you're right, the important point I wanted you to read was
INHERITANCE. 

<foo dir="ltr">
<bar> <!-- Has dir="ltr", from inheritance -->
Bla bla
</bar>
Bla again
</foo>

> Yes, my question was why the draft needs dir="" at all,

Because, as I said, otherwise, you could not express the fact that the
direction of the text in the <bar> element above is "Not
Known". Without dir="", you could not "cancel" the directionality of
<foo> in its nested elements.

---

From: "Frank Ellermann" <[email-masked]>
Date: Mon, 14 Apr 2008 11:29:52 +0200

Stephane Bortzmeyer wrote:

> as I said, otherwise, you could not express the fact that the
> direction of the text in the <bar> element above is "Not Known".
> Without dir="", you could not "cancel" the directionality of

Well, yes, but so far the Web with all its (X)HTML pages never 
needed an "unknown direction" feature, why is this necessary
in ATOM ?  And how would you implement an "unknown direction",
toss a coin ?

 Frank

---

From: James M Snell <[email-masked]>
Date: Mon, 21 Apr 2008 22:44:04 -0700

The dir="" is not really intended to specify that the direction is not 
known but that the direction has not been specified explicitly.  For 
instance, in an aggregate feed containing entries from multiple sources, 
the original entries may or may not have contained the bidi attribute. 
Because of the inheritance of direction from the feed, entries that do 
not have a dir="..." attribute will inherit the direction of the parent, 
which will change the context of the original entry and could 
potentially lead to the context being improperly or at least 
unexpectedly displayed relative to the original.

- James

---

From: James M Snell <[email-masked]>
Date: Mon, 21 Apr 2008 22:50:16 -0700

My apologies for not getting back to this sooner.  Comments below.

> "RFC xxxx" at some point in time is IMO good enough.

Understood.

> I don't find dir="" in the HTML 4.01 spec., why does

I answered this is another note that I just sent.  The main issue is one 
of inheritance.  With Atom, it is possible to construct aggregate feeds 
from multiple sources, each of which may or may not explicity specify 
the base directionality.  The dir="" option is provided to prevent 
children from inheriting the parent's directionality while preserving 
the lack of an explicitly set direction.

- James

---

From: "Frank Ellermann" <[email-masked]>
Date: Tue, 22 Apr 2008 18:27:20 +0200

James M Snell wrote:

> My apologies for not getting back to this sooner.

No problem, it's only that the proposal to "rename" 
the draft attracted my attention, and after I said
that this is dubious in a "Last Call" thread I read
the text, not only the file name... ;-)

All I know about BiDi issues could be summarized as
"if Harald / Martin / Tex / ... think it works it's
supposed to work".  But the acknowledgements in your
draft did not mention anybody I know as BiDi-expert,
that was the point when I started to worry about it.

Apparently 'dir' is strictly binary, "LTR" or "RTL",
and your draft adds a third value "".  Maybe this is
a good idea.  Or it is a case of "ternary bits", I
can't judge it.

Possibly you could convince me that it's a good idea
by giving an example where dir="ltr" and dir="" make
a difference, and/or by stating that dir="" MUST NOT
be used within the (X)HTML parts of an Atom document,
but actually that's beside the point.  What's really
interesting, did any BiDi expert confirm dir="" as a
good idea ?  If dir="" is a part of the experiment -
fine, let's see what happens.

 Frank

---

From: James M Snell <[email-masked]>
Date: Tue, 22 Apr 2008 10:16:53 -0700

I have had a number of conversations with i18n experts on the topic and 
none have complained about it thus far... which, of course, doesn't mean 
that much.  I would very much appreciate having folks like Harald, 
Martin and Tex weigh in on the issue.

Another comment that has come up is a question about why we can't just 
use the W3C ITS spec for this, which is definitely a valid question.  I 
would definitely appreciate feedback on that issue as well.

When it comes to the rendering of feeds in a UI, dir="" is likely not to 
have any significant effect since, as you and others have pointed out, 
(x)html has no similar notion and a direction has to be assumed.  The 
main point of dir="" is to ensure that the original directional context 
of an entry is preserved regardless of the specific feed that happens to 
contain the entry.

- James