Subject: Trustees Adopt New Procedures

From: Ray Pelletier <[email-masked]>
Date: Thu, 17 Apr 2008 12:46:35 -0400

The Trustees adopted modified procedures at its meeting today. 

The procedures can be found at:  
http://trustee.ietf.org/docs/Trust_Procedures_2008.pdf

Thanks for the review and feedback, they made for a better document.

Ray
_______________________________________________
IETF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 18 Apr 2008 16:40:04 +0300

Thank you, Ray.

In an attempt at imitating a broken record.... where can I go to find 
previous versions of the IETF Trust procedures, so that I can see what 
changed?

Yours for making history transparent....

                 Harald

---

From: Ray Pelletier <[email-masked]>
Date: Fri, 18 Apr 2008 13:33:07 -0400

> previous versions of the IETF Trust procedures, so that I can see what 

Why, in the Policy and Procedures Archive, of course! ;>)

http://trustee.ietf.org/policyandprocedures.html

Ray