Subject: Re: Last Call: draft-dawkins-nomcom-openlist (Nominating Committee Process: Open Disclosure of Willing Nominees) to BCP

From: Bob Hinden <[email-masked]>
Date: Wed, 10 Jun 2009 10:42:42 -0700

I too support publication of this document.  I think this fixes a  
serious weakness in the current nomcom process and this will make the  
selection process more transparent.   I understand the downsides, but  
think overall it is an improvement.

Bob

On Jun 5, 2009, at 4:45 PM, The IESG wrote:

> The IESG has received a request from an individual submitter to  
> consider
> the following document:
>
> - 'Nominating Committee Process: Open Disclosure of Willing Nominees '
>   <draft-dawkins-nomcom-openlist-04.txt> as a BCP
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to  
> the
> [email-masked] mailing lists by 2009-07-03. Exceptionally,
> comments may be sent to [email-masked] instead. In either case, please
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-dawkins-nomcom-openlist-04.txt
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=18213&rfc_flag=0
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 10 Jun 2009 20:37:34 +0200

Bob Hinden wrote:
> serious weakness in the current nomcom process

+1

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: John C Klensin <[email-masked]>
Date: Wed, 17 Jun 2009 08:56:54 -0400

--On Friday, June 05, 2009 16:45 -0700 The IESG
<[email-masked]> wrote:

> The IESG has received a request from an individual submitter
> to consider the following document:
> 
> - 'Nominating Committee Process: Open Disclosure of Willing
> Nominees '    <draft-dawkins-nomcom-openlist-04.txt> as a BCP
> 
> The IESG plans to make a decision in the next few weeks, and
> solicits final comments on this action.  Please send
> substantive comments to the [email-masked] mailing lists by
> 2009-07-03.
>...

On balance, my personal conclusion is that the community
probably wants to do something like this.  If it does, this is
close, but not ready for approval for at least three reasons:

	(1)  I believe that the issues in Sections 3 and 4 are
	real, and that those sections correctly describe a
	problem.    But, especially against the background of
	our apparently feeling a need to get the Nomcom started
	earlier (and to be sure that it can) and concerns about
	a shortage of plausible nominees for many positions, I
	believe that we need to rethink the Nomcom model and the
	way it works, rather than trying to apply minor patches.
	Such patches would be harmless except that they divert
	us from doing a real analysis on the issues and because
	we have proven unable to make them without unintended
	side-effects. Even this seemingly-innocuous patch has
	opened up discussion about fundamental issues about the
	limits Nomcom confidentiality that are outside its
	specific scope.
	
	(ii) We are still having discussions about, e.g.,
	solicitations of support -- not about whether they are a
	good idea, but about how strongly they should be
	prohibited, especially in an environment in which names
	are public.   In some sense, we should not be having
	that discussion now because it isn't in the scope of the
	change proposed by this document.  But we don't seem to
	have consensus about whether the changes specified here
	will have any consequences in terms of shifting things
	toward election models, solicitations of support and
	campaigning (positive or negative).  And, unless we  can
	somehow understand that better, this proposal --with all
	of the necessary opportunities for exceptions-- seems to
	be too high-risk to apply as a patch.
	
	(iii) We have had fairly extensive discussions about why
	it might be destructive to publish some specific names
	-- people who might be adversely affected by appearing
	to "run against" other nominees (possibly especially
	with incumbents), sensitive intra-company relationships,
	and so on.  I think we have reached agreement that the
	Nomcom should be able to suppress names when they
	conclude that is desirable --that they "may" publish
	lists of names if they decide to do so.  But the text of
	the document actually doesn't make that clear.  It
	provides that a list can be published, that updated list
	can be published if the Nomcom considers that desirable,
	and that there should be no ringers.  It does not
	explicitly provide for publishing a list that omits some
	willing candidates, no matter what the reason.   That is
	the sort of omission that leads us, often a few years
	later when a situation actually arises, into long and
	unpleasant arguments about what the procedures really
	intend and require.  
	
	The document should not go forward unless the
	community's intent in this area is absolutely clear.  I
	believe that intent is that the Nomcom should be able to
	decide to not include all willing nominees for a
	position in that list and that it should not be required
	to avoid publishing a list entirely if there are one or
	more names that should not be disclosed unless they are
	selected.  But, even if the intent is the opposite, the
	document should be absolutely clear on the subject.  At
	present, it is not.

I do continue to question whether this is a good idea on
balance, for reasons that have been discussed many times before.
I don't even agree with the document that the IAB publication of
ISOC Trustee Nominees has been without negative side effects
(maybe not "apparent" ones, but the community has no way to know
who decided to not put forward a name because of the disclosure
issues -- a problem that may repeat itself with the RSE and ISE
selections).  But, if this is what the community wants to do, we
should at least get it right.

    john

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 17 Jun 2009 14:27:08 +0100

While I hate commenting on pure process issues there's
one aspect of this that I don't think I've seen mentioned.
(Apologies if this is a repeat.)

I've been nominated a number of times and have agreed to
go forward, but when filling in the form have said something
like: "If you're willing to pick the incumbent, I think
that'd be better than going with me."

The current proposal doesn't allow for that aspect to be
public, which, for me at least, would be a disincentive
to allowing my name go forward, in the case where I think
the incumbent is actually likely to do a better job. Of
course, I won't necessarily know whether the incumbent
is re-upping when asked so it makes it harder to know
whether to accept a nomination or not. (And indeed the
incumbent might not know at that point if their employer
is still willing to fund IESG membership, so I can't
always just ask 'em.)

I think that could be handled by some wording that
describes the nominee list and that could be included in
the draft. Something like: "This is the list of those
nominated (or self-nominated) for IESG positions. The
nominees have said that they're willing to serve if
selected, but there is no implication that they consider
the incumbent unsuited for re-appointment."

I don't mind if that text is just in the RFC or is
actually posted with the list of names.

While I guess this aspect could also be handled by
nominee statements, I think that'd be too close to
electioneering so prefer the above. (Unless we only
allow self-deprecating nominee statements which
could be fun:-)

Other than that, publishing the list is fine by me.

S.

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 17 Jun 2009 14:38:24 +0100

Stephen Farrell wrote:
> Something like: "This is the list of those
Presumably there would need to be a second list of
names with the text: "These nominees have said that
they're willing to serve because they think the
incumbent is unsuitable for re-appointment."

... or maybe this would be expresses as just a
second list of names.

Stewart

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 17 Jun 2009 10:47:33 -0400

I really think we want to stay away from any statement which implies 
anything about the nominees views about anyone.
I do not think it is reasonable or practical to try to include 
disclaimers in the list of nominees about eveyr misapprehension that 
readers of the list may form.
We ought not be making any public statement about the nominees degree of 
willingness to serve, degree of desire for change or stability, or any 
other opinion about the nominee.  We are simply letting folks know that 
the nominee exists.

If we absolutely have to have a stronger disclaimer, I would think it 
would need to be quite general, not specific about nominees opinions on 
any one dimension.  And certainly not a list of thing on which the 
nominee is not expressing an opinion in public.

Yours,
Joel M. Halpern

Stewart Bryant wrote:
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Jari Arkko <[email-masked]>
Date: Wed, 17 Jun 2009 11:44:18 -0400

Joel M. Halpern wrote:
> We ought not be making any public statement about the nominees degree 
> of willingness to serve, degree of desire for change or stability, or 
> any other opinion about the nominee. We are simply letting folks know 
> that the nominee exists.
>
> would need to be quite general, not specific about nominees opinions 
> on any one dimension. And certainly not a list of thing on which the 

What he said. I do not think it is realistic to document the degree of 
willingness to serve or the opinion of the nominee about any of the 
other candidates. (And in fact, its not certain that there is always 
clear information to reveal.) The IETF community members who see a list 
of candidates should also take into account that they do not really know 
what the candidates' intents, desires, and abilities to serve are.

Jari

---

From: John C Klensin <[email-masked]>
Date: Wed, 17 Jun 2009 12:04:17 -0400

--On Wednesday, June 17, 2009 10:47 -0400 "Joel M. Halpern"
<[email-masked]> wrote:

> I really think we want to stay away from any statement which
> implies anything about the nominees views about anyone.
> disclaimers in the list of nominees about eveyr
> misapprehension that readers of the list may form.
> We ought not be making any public statement about the nominees
> degree of willingness to serve, degree of desire for change or
> stability, or any other opinion about the nominee.  We are
> simply letting folks know that the nominee exists.
> 
> If we absolutely have to have a stronger disclaimer, I would
> think it would need to be quite general, not specific about
> nominees opinions on any one dimension.  And certainly not a
> list of thing on which the nominee is not expressing an
> opinion in public.

And a strong disclaimer, perhaps any disclaimer, that applies to
all nominees would rapidly turn into boilerplate, i.e., a waste
of time that almost no one reads and fewer take seriously.

As we have seen in last year's round, there is nothing in the
confidentiality requirements that prevents a nominee from
posting anything he or she likes to the IETF list (or
elsewhere).  Presumably attacks on other candidates would be
frowned upon, both by the community as a whole and by a Nomcom
that was trying to evaluate whether the Nominee understood the
IETF well enough to play well with others.  And, if someone
wanted to post a public note saying "I think Elmer Fudd is doing
a really good job as Duck-hunting AD; I was asked to put my name
in and did so but I'm really not interested in the role unless
Elmer really doesn't want to serve another term", I think we
should neither encourage nor discourage that in any of these
documents.

    john

---

From: Jari Arkko <[email-masked]>
Date: Sun, 21 Jun 2009 20:50:25 +0200

John,

> I think we have reached agreement that the
> 	willing candidates, no matter what the reason.
>   

I agree that we should allow this.

Jari

P.S. For the other issues in your mail -- FWIW, I believe fairly 
strongly that we should make the specific changes proposed in this 
document, as opposed to starting a more general redesign.

---

From: John C Klensin <[email-masked]>
Date: Sun, 21 Jun 2009 19:41:12 -0400

--On Sunday, June 21, 2009 20:50 +0200 Jari Arkko
<[email-masked]> wrote:

> P.S. For the other issues in your mail -- FWIW, I believe
> fairly strongly that we should make the specific changes
> proposed in this document, as opposed to starting a more
> general redesign.

FWIW, I think I heard rather strong support from the floor
during the San Francisco plenary for at least asking the
questions and exploring options that could lead to a more
general redesign.  It is always hard to judge these things, so
your reading may well be different.

    john