Subject: Re: Call for Comments: "Uncoordinated Protocol Development Considered Harmful"

From: "Tom.Petch" <[email-masked]>
Date: Sat, 27 Jun 2009 11:42:20 +0200

I think that the conclusion in s.4, that this is the solution to problems of
cooperation, will turn out to be rather rose-tinted in years to come.

It reminds me of a Professor of Engineering in my student days, who one year,
told us how successful his redesign of a road junction was, relieving congestion
all round to the benefit of all.  A year later, I heard him again, and this time
he concluded that after spending vast sums of money, all he had achieved was to
lift the traffic jam 25 feet into the air.

I track the mpls-tp list and see two very different styles, of process, of
commenting, of consensus (know any other IETF lists where 10 successive posts
were each about one Megabyte in size?) which tells me that the differences
between ITU-T and IETF have just been moved to another forum.

The MEAD team and JWT, and the changes to IETF process, as described in
draft-andersson-mpls-tp-process, may be a step forward, but there is still a
long way to go before there is a mutually agreeable set of standards which must
be the acid test of cooperation.

Tom Petch

----- Original Message -----
From: "IAB Chair" <[email-masked]>
To: "IETF Announcement list" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, June 11, 2009 12:07 PM
Subject: Call for Comments: "Uncoordinated Protocol Development Considered
Harmful"

>
> The IAB intends to publish the following document and invites any
> comments you might have:
>
> "Uncoordinated Protocol Development Considered Harmful"
>  http://tools.ietf.org/html/draft-iab-mpls-tp-uncoord-harmful-00
>
> Abstract
>
>   This document identifies various types of damage that may occur
>   without formal coordination and joint development on protocols of
>   mutual interest between standards development organizations.  The IAB
>   has selected T-MPLS as recent case study to describe hazard to both
>   the MPLS and Internet architecture as a result of uncoordinated
>   adaptation of a protocol.
>
>
>   This experience has resulted in a considerable improvement in the
>   relationship between the two organisations.  In particular, this was
>   achieved via the establishment of the "Joint working team on MPLS-TP"
>   which was the first ever joint ITU/IETF group.  In addition, the
>   leadership of the two organisations have agreed to improve inter-
>   organizational working practices so as to avoid conflict in future
>   between ITU-T Recommendations and IETF RFCs.
>
>
>
> Please provide your feedback before June 28, 2009.
>
> For the IAB,
>
> --Olaf Kolkman
>  IAB Chair
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 27 Jun 2009 21:43:53 +0900

> cooperation, will turn out to be rather rose-tinted in years to come.

It virtually means that IETF stop working as an independent
standaradization organization and, considering continuous failures
of IETF to standardize useful protocols these days, is rather
welcome.

> between ITU-T and IETF have just been moved to another forum.

MPLS failed merely because the concept of MPLS is broken from the
beginning.

MPLS started with "topology driven with nested labels", which was
advertised to scale because of route aggregation.

However, to let senders specify inner labels, the senders MUST know
routing tables internal to destinations, which denys route
aggregation and dose NOT SCALE.

Later, people working on MPLS start saying TE.

However, before MPLS, TE means L1 TE to provide sufficient resouce
to L1 on which large traffic is expected.

There is no point to use MPLS as L2 forwarding is as expensive as
L3 forwarding and TE at L2 is mostly useless.

							Masataka Ohta

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 27 Jun 2009 19:38:15 +0100

So, Masataka, are you saying that ITU-T SG15 was mistaken to even consider 
MPLS-TP? After all, MPLS-TP is traffic engineered MPLS.

Adrian
----- Original Message ----- 
From: "Masataka Ohta" <[email-masked]>
To: "Tom.Petch" <[email-masked]>
Cc: "IAB Chair" <[email-masked]>; <[email-masked]>; "ietf" 
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Saturday, June 27, 2009 1:43 PM
Subject: Re: Call for Comments: "Uncoordinated Protocol Development 
ConsideredHarmful"

> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 28 Jun 2009 08:24:49 +0900

Adrian Farrel wrote:

> So, Masataka, are you saying that ITU-T SG15 was mistaken to even 
> consider MPLS-TP? After all, MPLS-TP is traffic engineered MPLS.

It's a lot better to buy more bandwidth than wasting money on
expensive MPLS equipments.

TE is merely a weak excuse to continue standardization of MPLS
after the fallacy of topology driven became so obvious.

						Masataka Ohta