Subject: Re: Last Call: <draft-lear-iana-timezone-database-03.txt> (IANA Procedures for Maintaining the Timezone Database) to BCP

From: SM <[email-masked]>
Date: Tue, 12 Apr 2011 12:49:22 -0700

At 05:31 11-04-2011, The IESG wrote:
>The IESG has received a request from an individual submitter to consider
>the following document:
>- 'IANA Procedures for Maintaining the Timezone Database'
>   <draft-lear-iana-timezone-database-03.txt> as a BCP
>
>The IESG plans to make a decision in the next few weeks, and solicits
>final comments on this action. Please send substantive comments to the

I support the publication of this document.

The Introduction Section mentions "National Institutes of Health".  I 
suggest add "U.S." in brackets.

Tony Finch already commented [1] on using "TZ name" instead of 
"key".  I don't think that naming schemes should be documented in this draft.

Regards,
-sm

1. http://www.ietf.org/mail-archive/web/ietf/current/msg66133.html

---

From: Barry Leiba <[email-masked]>
Date: Tue, 12 Apr 2011 19:30:19 -0400

This document is ready to go, modulo some nits.

Herein, my list of nits:

General
Because you define the terms, you should use them consistently.
Please check for "Coordinator" (replace with "TZ Coordinator") and "TZ
list" (replace with "TZ mailing list").

Sec 1.0
OLD
   The TZ mailing list would fit nicely just as such a list.
NEW
   The TZ mailing list would fit nicely as just such a list.

Sec 1.1
OLD
   The TZ Coordinator also has responsibility
   for maintaining the TZ mailing list.
NEW
   The TZ Coordinator also has responsibility
   for managing the TZ mailing list.

OLD
   2.  Procedures for selecting a technical expert for the technical
       expert who will play the role of TZ Coordinator and release
       manager for the TZ database;
NEW
   2.  Procedures for selecting a technical expert who will play the
       role of TZ Coordinator and release manager for the TZ database;

Sec 2
OLD
   The list will be used just as it has been, to learn of, discuss, and
   confirm TZ definition changes, as well as an announcement list for
   new versions of the database.
NEW
   The list will be used just as it has been: to learn of, discuss, and
   confirm TZ definition changes, as well to serve as an announcement
   list for new versions of the database.

Sec 3
OLD
   Moving forward, the TZ database and supporting code SHOULD be signed
   prior to release using a well known key, along with any appropriate
   supporting information and distributed from a well known location
   that is advertised by IANA in a manner of its choosing.
NEW
   Moving forward, the TZ database, supporting code, and any appropriate
   supporting information SHOULD be signed prior to release using a well
   known key and distributed from a well known location that is
   advertised by IANA in a manner of its choosing.

OLD
   1.  New keys are only to be created when the region a key was
       envisioned to cover is not accurately reflected by an existing
       key.
COMMENT
Because you just mentioned "key", meaning "cryptographic key", in the
previous paragraph, it needs to be clear that these are not those.

OLD
   To be clear, the TZ Coordinator SHALL NOT set timezone policy policy
   for a region
NEW
   To be clear, the TZ Coordinator SHALL NOT set timezone policy
   for a region

OLD
   actually is, or in case of historical corrections, was.
NEW
   actually is (or, in case of historical corrections, was).

Sec 4
OLD
   The IESG will
   use rough consensus of the TZ mailing list as their primary guide to
   further action, when it exists, and whatever other means they have at
   their disposal, when rough consensus cannot be found.
NEW
   The IESG will
   use rough consensus of the TZ mailing list, when such consensus exists,
   as their primary guide to further action.  When rough consensus cannot
   be found, they will use whatever other means they have at their disposal.

Sec 5
OLD
   apellants MUST show material harm from the decision
NEW
   appellants MUST show material harm from the decision

Sec 8
OLD
   The IANA SHALL assist the IESG, as required, in filling of the TZ
   Coordinator, based on the procedures set forth above.
NEW
   The IANA SHALL assist the IESG, as required, in selection of the TZ
   Coordinator, based on the procedures set forth above.

--
Barry

---

From: Eliot Lear <[email-masked]>
Date: Wed, 13 Apr 2011 11:45:28 +0200

Hi Barry,

Thanks VERY VERY much for your detailed review.  I have accepted ALL of
your changes modulo one.  And to your comment:

> previous paragraph, it needs to be clear that these are not those.
I've changed the term key to TZ name, as suggested by Tony Finch.

>    actually is (or, in case of historical corrections, was).
This is the one I would prefer to leave alone.  I try my best to avoid
parentheticals in formal work.

Again, thanks for your review!

Eliot

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 13 Apr 2011 09:28:56 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of The IESG
> Sent: Monday, April 11, 2011 5:32 AM
> To: IETF-Announce
> Subject: Last Call: <draft-lear-iana-timezone-database-03.txt> (IANA
> Procedures for Maintaining the Timezone Database) to BCP
> 
> [email-masked] mailing lists by 2011-05-09. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> [...]

I've read this and seen the presentations about it at IETF 80.  Looks good, especially with the edits Barry and others have proposed.

Good work, folks.

-MSK