Subject: Re: IAOC: delegating ex-officio responsibility

From: Bob Hinden <[email-masked]>
Date: Fri, 1 Apr 2011 09:50:45 +0200

Brian,

On Apr 1, 2011, at 6:36 AM, Brian E Carpenter wrote:

> On 2011-04-01 08:38, SM wrote:
>> Hi Brian,
>> At 00:07 31-03-2011, Brian E Carpenter wrote:
>>> And that is exactly the problem with 'non-voting' status in a committee
>>> that mainly operates by consensus. It allows people who really ought
>>> to share accountability to apear to avoid it.
>> 
>> According to IOAC procedures:
>> 
>>  "All decisions of the members must be approved by majority vote of
>>   the members then in office."
>> 
>> I don't consider that as operating by consensus.  
> 
> That is the tie-break rule. I can't speak for recent IAOCs, but when
> I was a member we esentially always achieved consensus.

In my time on the IAOC, we usually reach consensus, but not always.  The votes are recorded in the public minutes.  

> 
> But my point is that I believe the IETF Chair *should* have accountability
> and that means being a formal voting member.

I agree.

Given the roles the IAB is taking on, such as the selection of an RSE, that have a close relationship with the IAOC, I am concerned if the IAB Chair is not also a IAOC voting member, or if the vote can or should be delegated.  I do note that the IAB chair is different from the IETF chair as the IAB chair is selected by the IAB vs. the IETF chair is selected directly by the NOMCOM.

Bob

---

From: Olaf Kolkman <[email-masked]>
Date: Sat, 2 Apr 2011 10:28:49 +0200

[as editor:]

It seems that the high order bit of this discussion circles around the question on whether it a requirement for the IETF Chair to have a voting position in order to effectively perform oversight. Once we figured out where we want to go with that we can think about delegation by the chair vs appointment by the bodies and the implementation details with respect to the trust.

[as olaf:]

I agree that the IETF chair needs to have a good oversight about what goes on in the IETF, to a lesser extend it is good that the IAB has that oversight too (specifically with respect to its chartered responsibilities) but I wonder if a voting membership is the appropriate instrument.

I believe effective oversight depends on having the appropriate high level information and having the opportunity to timely inject information that is needed to steer an outcome. An alternative method for sharing and injecting is having regular meetings between the I* chairs and the ISOC President/CEO. I believe that such meetings are much more effective for the parties involved than being exposed to all details.

This only an illustration of an instrument, there may be other instruments for oversight as well. But I do not think the ex-officio membership is the only method.

--Olaf

________________________________________________________ 

Olaf M. Kolkman                        NLnet Labs
                                       Science Park 140, 
http://www.nlnetlabs.nl/               1098 XG Amsterdam

---

From: Bob Hinden <[email-masked]>
Date: Wed, 13 Apr 2011 11:19:33 -0700

Olaf,

> It seems that the high order bit of this discussion circles around the question on whether it a requirement for the IETF Chair to have a voting position in order to effectively perform oversight. O…

For the record, I don't agree with this summary.  That is, I still question the basic assumption in the proposal.  We have "running code" in the IASA model and it appears to work reasonable well.  Not perfect, of course.  In particular I think that having the IETF chair, IAB chair, and ISOC president as voting members of the IAOC (and IETF Trust) has worked very well.  It makes them an active part of decisions the IAOC and IETF Trust are making and helps keep the IAOC from getting disconnected from the community.  It also makes them share the responsibility for decisions by having their vote be publicly recorded.  

I also don't understand what the effect of the proposal is on the IETF Trust.  Currently all IAOC members are members of the IETF Trust.  They have to sign a letter accepting this role.  I don't think it can then be delegated.  

Your draft focuses on one area (that is, reducing the burden of these positions), but does not discuss any other aspects of making this change.  What might the negative aspects of delegating this responsibility be?  How will this be dealt with?

Each of the positions (IETF Chair, IAB chair, ISOC President) are different in the way they are selected and this effects their ability to delegate their responsibility and who they might delegate it to.  For example, the IETF chair is selected by the NOMCOM and one of his/her responsibilities is to sit on the IAB, IAOC, and IETF Trust.  The IAB chair is selected by the IAB.  The ISOC president is hired by the ISOC Board of Trustees.  Consequently, I think the authority to delegate differs and they should be considered separately.  

> I agree that the IETF chair needs to have a good oversight about what goes on in the IETF, to a lesser extend it is good that the IAB has that oversight too (specifically with respect to its charte…

Why not?  It does appear to work.

> I believe effective oversight depends on having the appropriate high level information and having the opportunity to timely inject information that is needed to steer an outcome. An alternative met…

Do we really need to have another regular meeting?  Would this give the I* chairs more authority than they have now?  Sort of an executive committee.  Would these meetings be public, have votes, have public minutes?  

> This only an illustration of an instrument, there may be other instruments for oversight as well. But I do not think the ex-officio membership is the only method.

It's not perfect but it is the one we have now and it is working.   We should only change it if we are sure that it will improve the overall IASA operation.  I am seriously concerned about the current proposal.

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 14 Apr 2011 19:17:13 +1200

On 2011-04-14 06:19, Bob Hinden wrote:
>> It seems that the high order bit of this discussion circles
>> around the question on whether it a requirement for the
>> IETF Chair to have a voting position in order to
>> effectively perform oversight. Once we figured out where we
>> want to go with that we can think about delegation by the
>> chair vs appointment by the bodies and the implementation
>> details with respect to the trust.
> 
> For the record, I don't agree with this summary.  That is, I
> still question the basic assumption in the proposal.  We have
> "running code" in the IASA model and it appears to work
> reasonable well.  Not perfect, of course.  In particular I
> think that having the IETF chair, IAB chair, and ISOC
> president as voting members of the IAOC (and IETF Trust) has
> worked very well.  It makes them an active part of decisions
> the IAOC and IETF Trust are making and helps keep the IAOC
> from getting disconnected from the community.  It also makes
> them share the responsibility for decisions by having their
> vote be publicly recorded.

I agree. I think this responsibility should not be delegated.
It's fundamental to the success of the IETF (and the ISOC for
that matter - the IETF is a major source of ISOC's legitimacy).
The IAOC delegates execution to the IAD etc. - maybe the real
bug is that the IAOC itself needs to delegate more?

> I also don't understand what the effect of the proposal is on
> the IETF Trust.  Currently all IAOC members are members of
> the IETF Trust.  They have to sign a letter accepting this
> role.  I don't think it can then be delegated.

It can't be delegated. However, a duly approved update to BCP101
can change the definition of the formal membership of the
IAOC, and that would automatically change the membership of
the Trust. An alternative would be a formal change to the Trust
Agreement, but since IANAL, I don't know whether a change to
allow delegation or proxies would be possible under the law of
the Commonwealth of Virginia, where the Trust was established.

    Brian
> 
> Your draft focuses on one area (that is, reducing the burden
> of these positions), but does not discuss any other aspects
> of making this change.  What might the negative aspects of
> delegating this responsibility be?  How will this be dealt
> with?
> 
> Each of the positions (IETF Chair, IAB chair, ISOC President)
> are different in the way they are selected and this effects
> their ability to delegate their responsibility and who they
> might delegate it to.  For example, the IETF chair is
> selected by the NOMCOM and one of his/her responsibilities is
> to sit on the IAB, IAOC, and IETF Trust.  The IAB chair is
> selected by the IAB.  The ISOC president is hired by the ISOC
> Board of Trustees.  Consequently, I think the authority to
> delegate differs and they should be considered separately.
> 
>> [as olaf:]
>> 
>> I agree that the IETF chair needs to have a good oversight
>> about what goes on in the IETF, to a lesser extend it is
>> good that the IAB has that oversight too (specifically with
>> respect to its chartered responsibilities) but I wonder if
>> a voting membership is the appropriate instrument.
> 
>> I believe effective oversight depends on having the
>> appropriate high level information and having the
>> opportunity to timely inject information that is needed to
>> steer an outcome. An alternative method for sharing and
>> injecting is having regular meetings between the I* chairs
>> and the ISOC President/CEO. I believe that such meetings
>> are much more effective for the parties involved than being
>> exposed to all details.
> 
> Do we really need to have another regular meeting?  Would
> this give the I* chairs more authority than they have now?
> Sort of an executive committee.  Would these meetings be
> public, have votes, have public minutes?
> 
>> This only an illustration of an instrument, there may be
>> other instruments for oversight as well. But I do not think
>> the ex-officio membership is the only method.
> 
> It's not perfect but it is the one we have now and it is
> working.   We should only change it if we are sure that it
> will improve the overall IASA operation.  I am seriously
> concerned about the current proposal.
> 
> Bob
> 
> 
> _______________________________________________ Ietf mailing
> list [email-masked] https://www.ietf.org/mailman/listinfo/ietf
> 
>

---

From: Olaf Kolkman <[email-masked]>
Date: Thu, 14 Apr 2011 11:01:48 +0200

> bug is that the IAOC itself needs to delegate more?

I agree the IASA model is working well and I also agree that the chairs have played an important role. 

But I am not convinced that it is the only way to keep the IAOC from getting disconnected from the community. To turn that argument around: If it is the case that we need the IAB chair, IETF chair and ISOC president [iChiefs] to keep the IAOC on track then why do we have NOMCOM appointments? One could easily argue that the NOMCOM appointments are made to keep the IAOC connected to the community.

I also do not see why it 'it's fundamental to the success of the IETF'. I do agree that the iChiefs need to understand what is going on, there is no dispute about, but I question whether IAOC membership is best and most efficient instrument.

> the Commonwealth of Virginia, where the Trust was established.

I do not want to brush over this important detail. But, let us first figure out what we want with the IAOC. If there is no consensus on having the iChiefs play a less involved role then fine tuning the details doesn't make sense. If we gain consensus then fixing the Trust is doable.

>> delegating this responsibility be?  How will this be dealt

Help me out.

The main _potential_ negative aspect is a drop of iChiefs' awareness of what is going on; and the ability to directly influence decisions.

>> delegate differs and they should be considered separately.

I agree, this needs discussion. But lets first see if there is any consensus on going down the path of getting the iChiefs out day-to-day IAOC business.

>> Why not?  It does appear to work.

Yes it works. But it consumes a lot of time too. IAOC retreat, meetings at the IETF, regular tele-chats, participation in sub committees, etc, etc... 

We have a responsibility to our leadership to make their jobs scalable and manageable. We need to have our leadership positions accessible to our peers, who may not have the support of their company for more than a half time job, or, not to forget, may not have the support of their families for the travel and the long evenings with telechats. Being effective in what committees and meetings one participates in is part of making the job scalable. 

The Best Current Practice is that the iChiefs _must_ participate in the IAOC, I like that _must_ being removed.

>> public, have votes, have public minutes?

It is not another meeting, it is replacing a lot of other meetings by one regular meeting that talks about issues at the right level of detail. Also, sharing information is not decision making. Russ and I had weekly calls planned (we didn't have them weekly, but that aside) to share information and brainstorm about potential issues. 

I don't see the 'more authority' argument, not in the context where one argues for direct votes in order to get effective oversight. I think that having a weekly iChiefs meeting gives less formal authority and (yes) a bit more informal authority.

>> concerned about the current proposal.

My question is whether there is any will to pursue a change to the BCP to work towards removing the _must_. (The Best Current Practice is that the iChiefs _must_ participate in the IAOC, I like that _must_ being removed.)

I have seen Brian and Bob argue against. And not very many people argue 'for'

- --Olaf

Olaf M. Kolkman                        NLnet Labs
http://www.nlnetlabs.nl/            
I will start to use a new PGP key (ID 0x3B6AAA64) at the beginning
of May 2011.

---

From: John C Klensin <[email-masked]>
Date: Thu, 14 Apr 2011 09:10:26 -0400

--On Wednesday, April 13, 2011 11:19 -0700 Bob Hinden
<[email-masked]> wrote:

>> around the question on whether it a requirement for the IETF
>> Chair to have a voting position in order to effectively
>> perform oversight. Once we figured out where we want to go
>> with that we can think about delegation by the chair vs
>> appointment by the bodies and the implementation details with
>> respect to the trust.
> 
>...

Bob,

I think you and Olaf (and myself and others) are addressing two
rather different questions.  Your note seems to assume the
question is "how to make the IAOC work better".  Your answer, if
I understand it correctly, is "it works fairly well today isn't
broken, let's not fix it".  If that were the question, I'd agree.

But, remembering that the IASA has only the purpose of making
the extended IETF (including the IAB) work more efficiently, I
see a somewhat different question.  The roles and resource
requirements of the IAB and IETF Chairs have expanded
dramatically over the last several years.. expanded to the point
that the appointing bodies may soon have to choose, not among
the best people for the job, but from those who have spare time
and resources on their hands or, worse, who work for
organizations who see particular value in having one of their
employees in those positions.  We have been lucky so far in
finding very good people despite those pressures, but we can't
count on its lasting.

That situation suggests to me that we should be asking the
question of how we can reduce the absolute requirements
associated with the IAB and IETF Chair positions.  If whomever
is in those positions has the time, resources, and interest to
also serve on the IAOC, I'm very much in favor of that.   But,
if an individual --or the Nomcom-- have to choose between
exclusion of the best candidate because there aren't enough
resources for him or her to do the [rest of the] Chair job _and_
the IAOC versus spreading the workload out, then I think it is
in the community's interest to have an alternative.    My
personal preference continues to be to make the decision of who
from the IAB (and potentially the IESG) serves on the IAOC be
the decision of the IAB or IESG respectively rather than using
the "delegation" model Olaf suggests but, in practice, I think
it really makes no difference because any reasonable Chair is
going to discuss those options with the relevant body.

Even if we were not worried about overall workload, we've
discovered at several recent IETF meetings that the schedule for
IAOC-related meetings keeps the IAB and IETF Chairs out of other
meetings that might, objectively, have been important for them
to attend.  So it is not clear to me that having those two
people on the IAOC in person is optimal for the community,
independent of whether or not it is desirable for IASA.

>From that point of view, the right question from the IASA/IAOC
perspective should not be "is it working well enough that there
is no internal reason to make a change" but "can this type of
change be made without serious damage".

As far as the Trust is concerned, while we couldn't change the
relationship until recently, we can now: if the linkage between
Trust and IAOC membership is interfering with the simultaneous
successful operation of the Trust and the efficient operation of
the IAB and/or IESG, let's just change it.

    john

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 15 Apr 2011 03:34:32 +1200

John,

On 2011-04-15 01:10, John C Klensin wrote:
...
> dramatically over the last several years.. 

We really need to understand that better, and the underlying
reasons for it, in some detail. I don't think that cherry-picking
parts of the jobs to be delegated should be the starting point.
We really need to start by reviewing all the tasks together and
then decide what should be changed. I'd really like to hear from
Olaf, Bernard and Russ what has changed in the workload in the
last few years. You are of course correct that if the workload
is constantly increasing, it will make NomCom's task very hard.

Certainly the IASA/IAD/IAOC reorganisation produced a noticeable
reduction in the IETF Chair workload, but what has changed since
http://tools.ietf.org/html/draft-carpenter-ietf-chair-tasks-00 ?
It would be good to have a similar analysis for the IAB chair role.

Regards

     Brian

---

From: Olaf Kolkman <[email-masked]>
Date: Thu, 14 Apr 2011 18:25:43 +0200

> It would be good to have a similar analysis for the IAB chair role.

Below is a copy from a note I mailed to the IAB dd Feb 17, 2011. It wis a variation on a note that I mailed to the Nomcom in 2009. It may not map exactly to what you are asking, but I believe it is close enough.

Also, my wish to remove the _must_ in the 'iChiefs must be a member of the IAOC' best current practice is not a cherry picking act. The IAB has hired secretarial assistance for the agenda keeping, todo-list maintenance, minutes, etc. It is pushing forward the 'programs and initiatives' model that allows for subgroups to do a lot of actual work without the chair driving that (i.e. much more formal delegation of activities to sub-groups with possibly external members).

> Starting off with a personal note.
> As you know the IAB chair is selected by and from the IAB membership on a yearly basis. I first volunteered for the role of chair in March 2007. When I volunteered the first time I committed myself for 3 to 5 years (obviously subject to Nomcom and IAB decision). A minimum of 3 years because anything shorter is almost not worth the investment in the learning curve and the personal network that is needed to do the job effectively. Not longer than 5 years because of the fact that(much) longer terms tend to result in strong identification of a person with the role, sharpness and creativity decline, and possibly forms of mannerism in dealing with issues.
> From my perspective the most ideal scenario was (remember I wrote this in 2009) that I'd be allowed by the Nomcom and the IAB to serve as a chair for one more year and then be around for another to allow for continuity. In any case I think that it would be good for the Nomcom to look out for 'chair material'.
> The main reason why I want to step down now is that there have been some developments in the NLnet Labs situation that need my attention as director of that organization that can not be combined with a 0.7 FTE that I seem to be putting in at the moment.
> 
> As for the responsibilities of the chair.
> 	∙ A number of 'mechanical/managerial' tasks:
> 		∙ Managing and organizing the IAB work-flow both on architectural and organizational items
> 		∙ Setting priorities, planning activities to be aligned, identify actionable items and make sure next steps are taken
> 		∙ Set up various meetings, manage agendas
> 	∙ Track minutes creation and publication
> 		∙ A chair's job can be relieved by having an executive director that complements a chairs talents in organizing these activities.
> 	∙ Drive discussions
> 		∙ defining goals
> 		∙ moderate discussions
> 		∙ call consensus
> 	∙ Identify work items
> 		∙ Incoming appeals
> 		∙ Specific questions to the IAB from external bodies
> 		∙ Track (or make sure they are tracked) various developments that may have impact on the IETF.
> 	∙ IASA/IAOC and Trust
> 		∙ As ex-officio membership, to represent IAB (and IRTF) matters
> Because the chair is involved in all these activities (s)he becomes a de-facto information hub, besides because the chair often act as spokes person there isa tendency for all major organizational work items to gravitate towards the chair, specifically if the interests of the other members are mostly architectural. There are arguments that the load on the IAB chair is to high and it causes the job to be more than a half-time position (depending on personal effectively, delegation skill, organizational skills and the quality of an executive director[*], it may even be closer to 3 quarters). And I believe that there are some structural questions one can ask, such as in the ex-officio membership of the IASA/IOAC.
> If we manage to get the Programs ran as more or less autonomous motors that produce recommendations to the IAB it may be that the chairs job becomes relatively bearable.
> While I think that with the Programs we have put a good structure in place it will need serious efforts of the next chair and the NEW IAB to make working with programs part of the common mindset.
> I think, and I realize that I am biased, that an IAB chair has some of the following skills, properties:
> 	∙ Organizational: tracking actions, poking people, planning the work load. A good Executive Director can be of tremendous help
> 	∙ Moderating and motivating: The ability to herd cats where occasionally a cat will have its claws out.
> 	∙ Diplomatic: In inter-organizational contacts taking the diplomatic way to where you would like to end up.
> 	∙ Strategic: Constantly trying to up-level and see bigger picture while remembering that actionable progress needs to be made.
> 	∙ Open and sharing: Open to information received and conscious about timely sharing of that information.
> Note that I did not list technical/architectural skills in the above. Obviously an IAB chair needs to understand the technical issues but I do not believe that the IAB needs to be the 'chief architect'. While having an inspiring "Architect" leading the IAB would be nice I don't think it is a requirement. More important is that architectural work is being organized and the chair allows others to excel in their technical expertise.
> I am not saying that I had all the skills and properties above, but not feeling the need to be "the technical champion" and not feeling the pressure from my fellow members to act like one helped a great deal.
> FWIW I am committed to several IAB projects that do not automagically travel with the chair (e.g. RSE project and IANA strategy) and I plan to continue to be involved in those
> Folding these requirements with the thoughts on alignment with the day-job of a chair candidate and the possible willingness of an employer to sponsor more than half-time of a function that has fairly little technical return might be a challenge.
> [*] as mentioned in my other note, a dedicated (i.e. payed staff) Executive Director may be a great way to reduce the time efforts needed by an IAB chair, and other members. I should hurry to say that this is not mend as a comment on Dow, day-job interference plagues us all.
>

---

From: Bob Hinden <[email-masked]>
Date: Thu, 14 Apr 2011 09:31:41 -0700

Brian,

> It would be good to have a similar analysis for the IAB chair role.

+1

If there is a systemic problem, let's talk about that before proposing point solutions.  The overload problem also affects other leadership positions such as the IESG AD members.  

Bob

---

From: Bob Hinden <[email-masked]>
Date: Thu, 14 Apr 2011 09:51:57 -0700

John,

> broken, let's not fix it".  If that were the question, I'd agree.

No that is not correct, you have it reversed.  My concern is that this proposed change would likely make the IAOC work worse.  That is, I think it would have a negative impact on the operations of the IETF and that is why I am concerned.

I am sympathetic to the leadership's overload problem, but think we should take a broader view.  For example, another approach might be to split the IAB's responsibilities into two groups, one focused on architecture (the IAB's traditional role) and another new group to deal with the parts of the job that seems to be growing (liaisons, RFC Editor, etc.).  Something like this might make the NOMCOM job easier in the sense that it wouldn't have find people who were strong in architecture and policy administration (I don't think that is the best description of the rest, but can't think of anything better at the moment).

Bob

---

From: Russ Housley <[email-masked]>
Date: Thu, 14 Apr 2011 17:13:22 -0400

Brian:

> I'd really like to hear from
> last few years.

I am fortunate that my sponsorship situation lets me spend almost full time on the IETF Chair position.  Even so, there are aspects of the job that exceed full time.  I am not talking about IETF meeting week -- the job far exceeds full time for many others too during that week.  That said, the answer to your question is not simple.

The IETF Chair is a member of the IAOC, the IETF Trust, the IAB, and the IESG.

The IAOC has many committees, and I am unable to participate in all of them.  Even though I am interested in all of the topics, it is just not possible to participate in all of them.  So, I rely on the people that do participate and review their recommendations when they come to the whole IAOC for a vote.

The IETF Trust is the least time commitment.  It is important, but it is not usually time consuming.

The IAB has recently adopted a structure of  "projects" and "initiatives."  These are much like IAOC committees, and it will not be possible for any IAB member to participate in all of them.  This is necessary and healthy.  It also lets the IAB draw on expertise from outside the IAB more easily.

The IESG does much less work by committee, but some ADs have directorates or review teams to help with the vast amount of document review.  The IETF Chair has relied on Gen-ART since it was established by Harald about eight years ago.  I know that I depend on these reviews heavily.

The IETF Chair also depends upon the IETF Executive Director and other members of the Secretariat for many day-to-day tasks.  I believe that I have made greater use of the Secretariat than many previous IETF Chairs.

So, you can readilly see that there is a significant amount of delegation going on.  Still, some tasks get starved, simply because other things are more important at the time.  Recently, for example, activities around the relationship with ITU SG15 have consumed all available cycles.

The proposed update to BCP 101 permits further delegation of the IAOC voting position.  While I do not see myself taking advantage of this new feature, I do think we should give future IETF Chairs this option.  It is a cohesive part of the work that can be delegated.  Some coordination between the IETF Chair and the delegate would be necessary, but the time commitment would be significantly less than participating in the IAOC and a subset of its committees.

Russ

---

From: Bob Hinden <[email-masked]>
Date: Thu, 14 Apr 2011 14:26:26 -0700

Russ,

> The proposed update to BCP 101 permits further delegation of the IAOC voting position.  While I do not see myself taking advantage of this new feature, I do think we should give future IETF Chairs…

This prompts me to ask a question.  Who would the IETF Chair delegate this responsibility to?  The draft doesn't specify.  

An Area Director is the obvious answer, except from what I understand ADs are also extremely busy.  This trades one problem for another.  If it is someone not on the IESG, then this is effectively turning into giving the IESG another IAOC slot to select. 

As a general comment on the draft, I think it needs to be clear as to who the delegation can be made to and how much authority is delegated.

Thanks,
Bob

---

From: Ole Jacobsen <[email-masked]>
Date: Thu, 14 Apr 2011 15:51:02 -0700 (PDT)

On Thu, 14 Apr 2011, Bob Hinden wrote:

> Russ,
> 
> 
> This prompts me to ask a question.  Who would the IETF Chair 
> delegate this responsibility to?  The draft doesn't specify.

I am thinking it would be someone like the IESG Secretary (if there is 
such a person), and I mean a member of the IESG, not some contractor.

Suppose, for a moment, we were talking about the ISOC BoT here instead 
of the IESG, the *obvious* choice would be Scott Bradner who has been 
Board Secretary for longer than any one can remember and clearly has a 
very good idea about the "sense of the board" at any given time.

So, is there an "equivalent" person in the IESG, that isn't also the
IESG (IETF) Chair?

Ole

Ole J. Jacobsen 
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj
Skype: organdemo

---

From: Leslie Daigle <[email-masked]>
Date: Thu, 14 Apr 2011 19:19:26 -0400

Speaking as an individual, but an individual who helped set up this 
structure and who sat in the non-delegated ex officio IAB Chair position 
on the IAOC (and IETF Trust) for a couple of years, let me offer some 
comments.

As Bob noted, elsewhere in the thread, your draft does not describe how 
to delegate responsibilities, it describes how to allow alternatively 
fill the positions.  And I believe that is a fatal flaw.

The discussion on this thread certainly indicates that there isn't a 
clear grasp of what the responsibilities are for the positions in 
question.  The responsibilities are not:  show up for meetings/telecons, 
offer opinions about how to administer the IETF, and put in a vote when 
called upon, although those certainly are the functions expected.

You described the IAB Chair as "hub" as if that was a bad thing.   In 
fact, the one thing the Chair (of the IAB -- but it applies in analog to 
the IETF) needs to do is to support the IAB's functioning (through 
leadership, organization, note-taking, cajoling, listening, etc).  That 
doesn't mean the IAB Chair has to do the work of the whole IAB, but it 
does mean that an overall perspective is critical, and each Chair has to 
best organize her/himself to achieve the one task.

In setting up the IAOC as it is, the intent was to inject the IAB 
Chair's overall perspective into the IAOC's discussions, including the 
support for IAB activities.  It was not a question of simply finding 
more credible people to put on the IAOC.

If change is needed, the one path away from the fatal flaw seems to be 
to articulate the actual responsibilities of the IAB Chair (and IETF 
Chair and ISOC CEO, as appropriate) in the intended ex officio 
positions, such that it is possible to get agreement and external 
confirmation that the role is being properly fulfilled by whomever is 
selected to perform them.

Anything else, IMO, is mindless deconstruction.

Leslie.

On 4/14/11 5:01 AM, Olaf Kolkman wrote:
> -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
>
>
>>>> Chair to have a voting position in order to effectively perform
>>>> oversight. Once we figured out where we want to go with that we
>>>> can think about delegation by the chair vs appointment by the
>>>> bodies and the implementation details with respect to the
>>>> trust.
>>>
>>> reasonable well.  Not perfect, of course.  In particular I think
>>> that having the IETF chair, IAB chair, and ISOC president as
>>> voting members of the IAOC (and IETF Trust) has worked very well.
>>> It makes them an active part of decisions the IAOC and IETF Trust
>>> are making and helps keep the IAOC from getting disconnected from
>>> the community.  It also makes them share the responsibility for
>>> decisions by having their vote be publicly recorded.
>>
>> I agree. I think this responsibility should not be delegated. It's
>> fundamental to the success of the IETF (and the ISOC for that
>> matter - the IETF is a major source of ISOC's legitimacy). The IAOC
>> delegates execution to the IAD etc. - maybe the real bug is that
>> the IAOC itself needs to delegate more?
>>
>
>
>
> But I am not convinced that it is the only way to keep the IAOC from
> getting disconnected from the community. To turn that argument
> around: If it is the case that we need the IAB chair, IETF chair and
> ISOC president [iChiefs] to keep the IAOC on track then why do we
> have NOMCOM appointments? One could easily argue that the NOMCOM
> appointments are made to keep the IAOC connected to the community.
>
> I also do not see why it 'it's fundamental to the success of the
> IETF'. I do agree that the iChiefs need to understand what is going
> on, there is no dispute about, but I question whether IAOC membership
> is best and most efficient instrument.
>
>
>
>>> I also don't understand what the effect of the proposal is on the
>>> IETF Trust.  Currently all IAOC members are members of the IETF
>>> Trust.  They have to sign a letter accepting this role.  I don't
>>> think it can then be delegated.
>>
>> can change the definition of the formal membership of the IAOC, and
>> that would automatically change the membership of the Trust. An
>> alternative would be a formal change to the Trust Agreement, but
>> since IANAL, I don't know whether a change to allow delegation or
>> proxies would be possible under the law of the Commonwealth of
>> Virginia, where the Trust was established.
>>
>
> I do not want to brush over this important detail. But, let us first
> figure out what we want with the IAOC. If there is no consensus on
> having the iChiefs play a less involved role then fine tuning the
> details doesn't make sense. If we gain consensus then fixing the
> Trust is doable.
>
>>>
>>> Your draft focuses on one area (that is, reducing the burden of
>>> these positions), but does not discuss any other aspects of
>>> making this change.  What might the negative aspects of
>>> delegating this responsibility be?  How will this be dealt with?
>
> Help me out.
>
> The main _potential_ negative aspect is a drop of iChiefs' awareness
> of what is going on; and the ability to directly influence
> decisions.
>
>
>>>
>>> Each of the positions (IETF Chair, IAB chair, ISOC President) are
>>> different in the way they are selected and this effects their
>>> ability to delegate their responsibility and who they might
>>> delegate it to.  For example, the IETF chair is selected by the
>>> NOMCOM and one of his/her responsibilities is to sit on the IAB,
>>> IAOC, and IETF Trust.  The IAB chair is selected by the IAB.  The
>>> ISOC president is hired by the ISOC Board of Trustees.
>>> Consequently, I think the authority to delegate differs and they
>>> should be considered separately.
>
> I agree, this needs discussion. But lets first see if there is any
> consensus on going down the path of getting the iChiefs out
> day-to-day IAOC business.
>
>
>>>
>>>> [as olaf:]
>>>>
>>>> about what goes on in the IETF, to a lesser extend it is good
>>>> that the IAB has that oversight too (specifically with respect
>>>> to its chartered responsibilities) but I wonder if a voting
>>>> membership is the appropriate instrument.
>>>
> Yes it works. But it consumes a lot of time too. IAOC retreat,
> meetings at the IETF, regular tele-chats, participation in sub
> committees, etc, etc...
>
> We have a responsibility to our leadership to make their jobs
> scalable and manageable. We need to have our leadership positions
> accessible to our peers, who may not have the support of their
> company for more than a half time job, or, not to forget, may not
> have the support of their families for the travel and the long
> evenings with telechats. Being effective in what committees and
> meetings one participates in is part of making the job scalable.
>
> The Best Current Practice is that the iChiefs _must_ participate in
> the IAOC, I like that _must_ being removed.
>
>
>>>
>>>> I believe effective oversight depends on having the appropriate
>>>> high level information and having the opportunity to timely
>>>> inject information that is needed to steer an outcome. An
>>>> alternative method for sharing and injecting is having regular
>>>> meetings between the I* chairs and the ISOC President/CEO. I
>>>> believe that such meetings are much more effective for the
>>>> parties involved than being exposed to all details.
>>>
>>> Do we really need to have another regular meeting?  Would this
>>> give the I* chairs more authority than they have now? Sort of an
>>> executive committee.  Would these meetings be public, have votes,
>>> have public minutes?
>
>
> It is not another meeting, it is replacing a lot of other meetings by
> one regular meeting that talks about issues at the right level of
> detail. Also, sharing information is not decision making. Russ and I
> had weekly calls planned (we didn't have them weekly, but that aside)
> to share information and brainstorm about potential issues.
>
> I don't see the 'more authority' argument, not in the context where
> one argues for direct votes in order to get effective oversight. I
> think that having a weekly iChiefs meeting gives less formal
> authority and (yes) a bit more informal authority.
>
>
>>>> This only an illustration of an instrument, there may be other
>>>> instruments for oversight as well. But I do not think the
>>>> ex-officio membership is the only method.
>>>
>>> It's not perfect but it is the one we have now and it is working.
>>> We should only change it if we are sure that it will improve the
>>> overall IASA operation.  I am seriously concerned about the
>>> current proposal.
>
>
> My question is whether there is any will to pursue a change to the
> BCP to work towards removing the _must_. (The Best Current Practice
> is that the iChiefs _must_ participate in the IAOC, I like that
> _must_ being removed.)
>
> http://www.nlnetlabs.nl/ I will start to use a new PGP key (ID
> 0x3B6AAA64) at the beginning of May 2011.
>
> -----BEGIN PGP SIGNATURE----- Version: GnuPG/MacGPG2 v2.0.17
> (Darwin) Comment: This message is locally signed. Comment: GPGTools -
> http://gpgtools.org
>
> iEYEARECAAYFAk2muAIACgkQtN/ca3YJIocKGwCggV3Z5um2cmWrUdXcba19SLNr
> cH4AoI0vilyFYRIa5Bx1j6i7T45klrYs =F6bJ -----END PGP SIGNATURE-----
> _______________________________________________ Ietf mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/ietf

-- 

-------------------------------------------------------------------
"Reality:
      Yours to discover."
                                 -- ThinkingCat
Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: Russ Housley <[email-masked]>
Date: Thu, 14 Apr 2011 19:22:43 -0400

> As a general comment on the draft, I think it needs to be clear as to who the delegation can be made to and how much authority is delegated.

I think that the delegate would have t be an IESG member, otherwise it the expected insight would not be provided.

Russ

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 14 Apr 2011 21:57:30 -0400

> I do not want to brush over this important detail. But, let us first figure out what we want with the IAOC. If there is no consensus on having the iChiefs play a less involved role then fine tuning…

Please note that, as I am sure you are aware, the consensus that would have to be gained to modify the Trust agreement is among the
Trustees. 

> The main _potential_ negative aspect is a drop of iChiefs' awareness of what is going on; and the ability to directly influence decisions.

I think that you are neglecting the potential impact on the IAOC/Trust. 

When the IETF Chair or the IAB Chair speaks in the IAOC or the Trust on a matter in their area of responsibility, their words carry a lot of weight. 
Their representative will inevitably lose some of that weight, and their use will thus change the balance in the IAOC and the Trust. 

Suppose, for example, that the iChief in question has been negotiating some issue with the US DoC or the ITU or ICANN or a potential host country's IT Ministry. Such negotiations frequently impact either the IAOC or the Trust (or both) - in terms of the budget, sponsors, 
meeting locations, etc. 

Will their IAOC/Trust representative be part of any such negotiations as a matter of course ? If not, then they will not speak 
authoritatively about them.  No matter how carefully they are briefed, there may be matters arising that the briefing did not
anticipate. That will for sure delay matters (as questions will have to them be relayed back and forth) and
may adversely affect the decisions made (when the representative thinks that they fully understand some issue, and do not).  

Regards
Marshall

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
> Comment: This message is locally signed.
> Comment: GPGTools - http://gpgtools.org
> 
> cH4AoI0vilyFYRIa5Bx1j6i7T45klrYs
> =F6bJ
> -----END PGP SIGNATURE-----
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 15 Apr 2011 20:05:29 +1200

Olaf,

Thanks for posting this analysis. I'm on travel but will have
a careful look in a few days.

   Brian

On 2011-04-15 04:25, Olaf Kolkman wrote:
> iEYEARECAAYFAk2nIAgACgkQtN/ca3YJIocPVgCdEEPdzw/VTmkmgznbX73Nokan
> uIIAn37ABvdLR3z7Mtu7v2FVPJXWkWgr
> =C205

---

From: Olaf Kolkman <[email-masked]>
Date: Fri, 15 Apr 2011 10:59:40 +0200

On Apr 15, 2011, at 1:19 AM, Leslie Daigle wrote:

> 
> Speaking as an individual, but an individual who helped set up this structure and who sat in the non-delegated ex officio IAB Chair position on the IAOC (and IETF Trust) for a couple of years, let me offer some comments.
> 
> As Bob noted, elsewhere in the thread, your draft does not describe how to delegate responsibilities, it describes how to allow alternatively fill the positions.  And I believe that is a fatal flaw.
> 
> The discussion on this thread certainly indicates that there isn't a clear grasp of what the responsibilities are for the positions in question.  The responsibilities are not:  show up for meetings/telecons, offer opinions about how to administer the IETF, and put in a vote when called upon, although those certainly are the functions expected.
> 
> You described the IAB Chair as "hub" as if that was a bad thing.   

Certainly not my intention to qualify it as 'bad'. The note was written from the perspective of "what is the work load and what are the tasks". Not from the perspective of what are the responsibilities of the chair. 

> In fact, the one thing the Chair (of the IAB -- but it applies in analog to the IETF) needs to do is to support the IAB's functioning (through leadership, organization, note-taking, cajoling, listening, etc).  That doesn't mean the IAB Chair has to do the work of the whole IAB, but it does mean that an overall perspective is critical, and each Chair has to best organize her/himself to achieve the one task.

Agreed, being informed (as 'information hub') seems to be a prerequisite for gaining that overall perspective.

> 
> In setting up the IAOC as it is, the intent was to inject the IAB Chair's overall perspective into the IAOC's discussions, including the support for IAB activities.  It was not a question of simply finding more credible people to put on the IAOC.
> 
> If change is needed, the one path away from the fatal flaw seems to be to articulate the actual responsibilities of the IAB Chair (and IETF Chair and ISOC CEO, as appropriate) in the intended ex officio positions, such that it is possible to get agreement and external confirmation that the role is being properly fulfilled by whomever is selected to perform them.

Fair enough, and in addition, as a take-away from the thread so far:  those responsibilities go two ways: incoming and outgoing. It is not only the general perspective that the iChiefs bring to the IAOC but also what they take out of it. For instance; getting informed about the general state and health of things.

I guess I have some homework to do because at the moment I am not able to formulate the responsibility in a way that goes beyond (for the IAB role): providing the IAB perspective into IAOC decisions; and getting informed about IAOC activities that are relevant for the IAB and the activities it oversees.

- --Olaf

PS: Why does the following phrase come to mind: when in a hole stop digging...

---

From: Jari Arkko <[email-masked]>
Date: Fri, 15 Apr 2011 13:59:09 +0300

A couple of observations from my personal viewpoint.

I tend to agree with others that we need to think about this in a 
top-down fashion, i.e. start from what is the problem that we intend to 
solve. I do have a serious concern about the workload for the people 
involved, particularly the chairs. But I wanted to make a couple of 
additional points.

First, I would not necessarily take it for granted that we have an 
infinite supply of people for various tasks. Finding an IESG member with 
enough time on their hands to participate the IAOC is not a given. We 
could of course always choose from outside the IESG, but again, most of 
the IETF participants are not here for administrative work, so while 
many can do it, I'm guessing some arm twisting would be required.

Second, even if you do find one, its not given that it provides the kind 
of connection between the chair and the IAOC that we want. Olaf pointed 
out that its bidirectional information transfer. Only a very small part 
of the IESG work is actually talking about IAOC matters, so I'm guessing 
that even if the delegate is another AD, the chair would still have to 
arrange extra time with this other AD in order to ensure that 
information transfer happens.

Third, I forget if it was Bob who noted that if we are strained by the 
tasks that we are doing, perhaps its time to outsource a bigger part of 
it to paid employees or businesses. For instance, I'm kind of hoping 
that 99% of the meeting selection load is on the IAD and the 
secretariat, not on the IAOC members. The members should set the policy, 
adjust the policy, and monitor implementation. If you are meeting every 
two weeks and deciding details then maybe you are on the wrong track. It 
should be the board, not the work horse.

Fourth, I think we are bringing on some of the load by our own actions. 
We have increased the number of entities that need to have a board and 
increased the amount of coordination needed. For instance, the RFC 
Editor was at one time one person, and today I'm honestly not sure I 
know how many entities it consists of. Of course, we needed much of this 
restructuring as the IETF has grown and has changed its operational mode 
also in other ways. But we should also watch it and avoid creating 
unnecessary structure where none is needed. I'm a little bit scared that 
adding a layer of delegation may cause the collective us to have more 
meetings, not less.

I also had a couple of thoughts on possible alternative directions to 
reducing the problem. Outsourcing more is one approach. Another one is 
to not have more people from the IESG and IAB attend the IAOC, but have 
people from the IAOC bring more information to these bodies. For 
instance, in the IESG we always have an "IAB report" but we don't 
normally have a Trust or IAOC report. Should we? A third direction is 
separating the role of the chairs as *working* members of the IAOC from 
their ability to attend and vote where needed. Would this detach the 
chairs too much? I don't know, but I think there might actually be less 
detaching than if you delegated your role away for a year. Russ, Olaf, 
how much do you normally participate the IAOC work? Are you in the 
subcommittees, do you work on details of agreements with our service 
providers?

Jari

---

From: Henk Uijterwaal <[email-masked]>
Date: Fri, 15 Apr 2011 10:03:22 +0200

On 14/04/2011 23:26, Bob Hinden wrote:

> This prompts me to ask a question.  Who would the IETF Chair delegate this
> responsibility to?  The draft doesn't specify.

I would say one of the (nomcom appointed) members of the IESG (or IAB).

> An Area Director is the obvious answer, except from what I understand ADs are
> also extremely busy.  This trades one problem for another.  

The IESG chair definitely has more tasks than any of the AD's and I think it
would be helpful if there were options to distribute work over the IESG,
rather than assume that the chair can do them all.   This is not only a matter
of time, but also of expertise and personal interests.   (The same applies
to the IAB chair).

Henk

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk(at)uijterwaal.nl
RIPE NCC                                  http://www.xs4all.nl/~henku
                                          Phone: +31.6.55861746
------------------------------------------------------------------------------

There appears to have been a collective retreat from reality that day.
                                 (John Glanfield, on an engineering project)

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 15 Apr 2011 08:46:39 -0700

On 4/14/2011 9:51 AM, Bob Hinden wrote:
> My concern is that this proposed change would likely make the IAOC work
> worse.   That is, I think it would have a negative impact on the operations of
 > the IETF and that is why I am concerned.

Bob,

That is a concrete and basic assertion.  Please put some flesh on its bones so 
that the basis for your view can be understood better.

The implication is that the people sitting in the positions of IAB Chair and 
IETF Chair are essential to the good operation of the IAOC/Trust.  Someone else 
from their groups or even someone else that they appoint from outside cannot 
perform the task of IAOC/Trust member adequately.

Why?

What are the specific contributions (insights and skills) that these roles 
regularly perform, in the conduct of the IAOC/Trust that cannot be performed 
adequately by others?

d/

ps. Reminder: I've just joined the IAOC/Trust, which means I've attended a few 
meetings and seen some operation.  As always, my comments have nothing to do 
with the individuals; this is about organizational design.

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 15 Apr 2011 08:52:58 -0700

Russ,

> The proposed update to BCP 101 permits further delegation of the IAOC voting position.  While I do not see myself taking advantage of this new feature, I do think we should give future IETF Chairs…

As SM noted, there is an important difference between delegation and 
appointment.  There also is a difference between having the choice made by the 
head of the group, versus the entire group.

Having the new person be delegated by the Chair makes that person an agent of 
the chair and serve at their whim.  It's been noted that this is probably the 
least stable arrangement for continuity of participation.  It's difficult to 
imagine a person working on this basis and having a healthy ability to 
participate and vote in the IAOC/Trust.

Having the new person be appointed for a period of time and chosen by the group 
(IAB or IESG) provides a stronger basis for their working independently and with 
continuity.

Can you clarify the reasons for the choices you made in the proposal?

d/

-- 

   Dave Crocker

---

From: Russ Housley <[email-masked]>
Date: Fri, 15 Apr 2011 13:37:47 -0400

Jari:

> Russ, Olaf, how much do you normally participate the IAOC work? Are you in the subcommittees, do you work on details of agreements with our service providers?

As I said in my previous note, I participate in some committees, but not all of them.  I am very active in the tools-related committees and the proposal evaluations.  It is a judgement call since every committee has some impact on the IETF and its participants.

Russ

---

From: Russ Housley <[email-masked]>
Date: Fri, 15 Apr 2011 14:10:10 -0400

Dave:

> As SM noted, there is an important difference between delegation and appointment.  There also is a difference between having the choice made by the head of the group, versus the entire group.
> 
> Having the new person be delegated by the Chair makes that person an agent of the chair and serve at their whim.  It's been noted that this is probably the least stable arrangement for continuity of participation.  It's difficult to imagine a person working on this basis and having a healthy ability to participate and vote in the IAOC/Trust.
> 
> Having the new person be appointed for a period of time and chosen by the group (IAB or IESG) provides a stronger basis for their working independently and with continuity.
> 

It never occurred to me that the delegation would be made without the consent of the entire group. This was clarified in the current version of the document:

   ...  The delegations by
   the IETF chair and the IAB chair need to be confirmed by the IESG and
   IAB respectively.  The terms of delegation is for a longer term for
   instance aligned with the IESG and IAB appointment cycles (roughly
   anual).

Russ

---

From: Lucy Lynch <[email-masked]>
Date: Sat, 16 Apr 2011 07:51:26 -0700 (PDT)

On Fri, 15 Apr 2011, Dave CROCKER wrote:

> That is a concrete and basic assertion.  Please put some flesh on its bones 
> so that the basis for your view can be understood better.

Let me take a run at this.

Back in the pre-history of BCP 101 we had very little control over many of 
the administrative functions that support the actual work of the IETF. We 
had a single long term relationship with an organization that run the 
meetings and collected fees "on behalf" of the the IETF and performed many 
of the secretariat functions. Over time, this relationship had frayed 
considerably (on both sides) and the community become increasingly 
restive, looking for more autonomy and a better understanding of our own 
internal business processes.

There were a number of drivers for the (extended) discussions about 
process and one of these was overload on the volunteers in the leadership 
roles. Among the solutions crafted up were the creation of the IASA and 
the hiring of our first paid employee (IAD). We also ended our 
relationship with the existing secretariat and moved to a process of 
contracting for services through the IAD with over site from what became 
the IAOC. The termination of our relationship with CNRI then spawned the 
creation of the IETF Trust. All of this took an enormous amount of 
community time and energy and a lot of tough questions had to be asked and 
answered. I'll just highlight a couple:

- an all volunteer organization hired it's first paid employee.
     note that this can be a slippery and expensive slope and there
     was always a risk that this might change the volunteer culture
- the IASA/IAOC/IETF Trust were tasked with stewardship for the
   administrative health of the IETF.
- the Trust formalized the future disposition of IETF assets and
   allowed an orderly transition from claims from previous administrations.

My belief at the time was that the primary concerns in all of this were a 
desire for greater transparency and organizational autonomy. There was a 
clear demand from many that the IETF "own" it's own processes.

> IETF Chair are essential to the good operation of the IAOC/Trust.  Someone 
> else from their groups or even someone else that they appoint from outside 
> cannot perform the task of IAOC/Trust member adequately.

I think this is the wrong question. I don't think this is about the
people who sit on the IAOC or the Trust, it is about the roles. Their
participation is part of the chain of accountability to the community.
The IAOC was crafted to include both the IAB and IETF Chairs as well
as the ISOC CEO in their respective roles and not as Fred, Harold, and
Lynn (as members of the IETF community).

> regularly perform, in the conduct of the IAOC/Trust that cannot be performed 

see above.

One more point here: as a former Chair of the IAOC (IAB appointed
member from the community) I'm sympathetic the the overload arguments
but I'll note that absent the IAB/IETF chairs the work of the IAOC
chair and the weight put on that role may increase in unexpected ways.

I agree with many of the points that Bob, Brian, Leslie, and Jari
have made in earlier posts and think that we need to take a broader
view of the problems we're trying to solve here. Role overload is
an on-going problem but I'm not sure we solve this by moving the
administrative accountability we gained through BCP 101 to additional
volunteers.

- Lucy

> d/
>
> ps. Reminder: I've just joined the IAOC/Trust, which means I've attended a 
> few meetings and seen some operation.  As always, my comments have nothing to 
> do with the individuals; this is about organizational design.
>
>

---

From: Lucy Lynch <[email-masked]>
Date: Sun, 17 Apr 2011 09:14:40 -0700 (PDT)

On Sat, 16 Apr 2011, John C Klensin wrote:
<snip>
>
> At the risk of agreeing violently with Dave, I think the series
> of comments above, and referenced above, are missing something.
> None of this familiy of "delegation" or "someone else" proposals
> requires that the IAB or IESG Chairs not serve on the IAOC.  If
> they think that is sensible and they have the time, they are
> free to do that.  We might even strongly encourage it.  However,
> if those people conclude that limited available time is better
> spent in other ways or that, if they take the IAOC position,
> they would not be able to devote adequate attention to it,
> aren't we better off giving them the flexibility and discretion
> to make that decision?  Similarly, if someone tells the
> appointing body "I have the time and resources to take on the
> IAB Chair or IETF Chair position but only if that position does
> not include the responsibility of sitting on the IAOC" isn't it
> better to give those bodies the option of considering that
> person rather than limiting the choices to those who can sign up
> for all of the job?

I'm not arguing that any of the IETF/IAB/etc hat wearers are
inexhaustible resources, I'm saying that the AdminRest process
looked hard at the composition and duties of the IAOC and if
the needs have changed, or the community concerns have shifted,
we should approach the current problems in a holistic manner and not
engineer short term solutions on the fly. I'll point you at your
own last paragraph here;

http://www.ietf.org/mail-archive/web/ietf/current/msg33932.html

> At least from my perspective, broadening the flexibility
> available to already-appointed IAB and IETF Chairs and to the
> bodies that appoint them is the real issue here.  _Requiring_
> that they serve on the IAOC does not create more time or
> resources, it just limits the range of people who can take those
> positions or, more likely, raises the odds of getting someone
> onto the IAOC who won't be able to pay full (or even adequate)
> attention.

certainly one possible outcome

> So. in addition to the questions Dave posed, the question I
> would address to you and Bob is whether, given a hypothetical
> choice of someone sitting on the IAOC ex-officio but not being
> able to really pay attention because he or she concludes that
> there are more pressing priorities and having someone
> representing the IAB or IESG who really can pay attention, which
> one you would pick.  In the worst case, if you prefer to have
> the Chairs nominally present but not paying complete attention,
> then keep insisting that they are the only ones who can possibly
> occupy the IAOC slot.

I would of course prefer full attention and skilled participation.
I'd also like the full confidence of the community in the process.

> As part of that, figure out how you are going to convince the
> Nomcom and the IAB that selecting people for the Chair roles
> should have "will give IAOC first priority regardless of their
> judgment about the importance of other aspects of their roles"
> as an absolute criterion and/or how you are going to convince
> the community to recall anyone in the Chair roles who does not
> give the IAOC that priority.

New/old  problem that may require additional revision on several
fronts - not just the IAOC.

- Lucy

> best,

---

From: Dave CROCKER <[email-masked]>
Date: Sun, 17 Apr 2011 09:45:12 -0700

On 4/16/2011 7:51 AM, Lucy Lynch wrote:
> Back in the pre-history of BCP 101 we had very little control over many of the
...

I do not see anything in the extended history you provide that explains Bob's 
assertion of what is needed now.

Perhaps I missed it.  If so, please point to the specific requirements that 
apply now.

Better still, let's let Bob explain his own assertion of the requirement.

(It's of course fine for you to explain your own view, but Bob is the current 
chair of the IAOC and speaks from a different, current vantage point than anyone 
else.)

> people who sit on the IAOC or the Trust, it is about the roles.

That's what I was referring to. No idea how my text appears to say otherwise.

However "roles" do not perform.  People occupying those roles do.

>> regularly perform, in the conduct of the IAOC/Trust that cannot be performed

That's unfortunately circular and ambiguous reference.  What text specifically 
provide the answer to this question?

> chair and the weight put on that role may increase in unexpected ways.

This is another assertion without providing substance.  My original note asked 
for the substance so that the discussion can include more than expert assertions 
of agreement or disagreement.

Folks need to note some rather basic points:

1.   Things are working fine, except that they aren't.

      This entire thread comes from a proposal from folk who are overloaded and 
who need things to change.

When someone says "I cannot keep doing the task I've been assigned" either they 
are not competent to the task or the nature or terms of task need to change.  I 
don't see any basis for considering the former, which leaves us with the latter.

By any reasonable measure, the IETF has concentrated far too much work onto its 
two Chairs.  For an organization devoted to an industry based on distributed 
control, we have a remarkable dislike to distributing control within the 
organization.  One effect of this is to dramatically reduce the pool of people 
available for those concentrated jobs.  Here we have a request for a particular 
reduction.  If that reduction is not tolerable, we need to understand why?

Separately, of course, we need to consider the details of the change and 
consider tradeoffs for alternative solutions.  To do that, we need to understand 
the requirements that are at issue.  Hence my questions to Bob.

2.   The view that no change should occur without a "holistic" review is a 
consistently effective way to kill any change effort.  We have plenty of 
experience with its effectiveness.

      Note that the most effective enhancements to successful IETF work is by 
incremental change, not "holistic" re-evaluation.

Here we have a proposal from those experiencing the problem.  A proposal states 
the problem and offers a solution.

My original question to Bob was to help us assess the assertion of the problem 
and the assertion of the solution.  (One or another notes implies that I've 
stated an opinion about the proposal, but I haven't.  For now, I'm trying to get 
source data, including performance requirements and the logic behind the 
proposal.)

d/
-- 

   Dave Crocker

---

From: Bob Hinden <[email-masked]>
Date: Mon, 18 Apr 2011 14:25:27 -0700

Dave,

> That is a concrete and basic assertion.  Please put some flesh on its bones so that the basis for your view can be understood better.
> 
> The implication is that the people sitting in the positions of IAB Chair and IETF Chair are essential to the good operation of the IAOC/Trust.  Someone else from their groups or even someone else that they appoint from outside cannot perform the task of IAOC/Trust member adequately.

I didn't say no one else could do the job adequately.  I said "would have a negative impact" on the operations of the IETF.  

Some examples where an I* chair had a significant influence on a decision that IAOC made include:

 - The hiring of the Transitional RSE
 - Many of the Beijing meeting issues (prior and post signing the MOU)
 - Specific venue selections (in one case avoiding a less than ideal venue)
 - The need for transparency in certain IAOC actions (day passes, venue rotation)
 - Discussion of what policy decisions that the IAOC can make vs. the IESG vs. community
 - Discussion about when to get community feedback
 - Secretariat contract (RFP, bidders review, selection, etc.)
 - RFC Publisher and Publisher contracts  (RFP, bidders review, selection, etc.)

Some of these decision might have been different without one or more I* chairs being directly involved in the decision.  Please review the minutes for more detail.

If I generalize this, I would say that the I* chairs have been actively involved in the most significant decisions the IAOC makes, they tend to be less active in many of the day to day operational issues.  For example, there are weekly calls in the months before an IETF meeting that the host, NOC team, IAD, and a few other people attend.  I don't think an I* chair has every been involved at this level.

I think the I* chairs, in my view bring a broad view of the community and operational needs based on what's involved in doing their jobs than another person would not have.  

> 
> Why?
> 
> What are the specific contributions (insights and skills) that these roles regularly perform, in the conduct of the IAOC/Trust that cannot be performed adequately by others?

I think it because the role has the individual doing the job getting involved in the many related activities that gives them more insight than someone else, even a member of the same group.  To cite an example, I was on the IAB in the past, but I wouldn't claim to have the same total understanding of the IAB (and the things the IAB is responsible for) as the IAB chair at the time.  It's not the skill per se, it's being involved in the all of the topics that the chair is naturally involved in.  

> 
> d/
> 
> ps. Reminder: I've just joined the IAOC/Trust, which means I've attended a few meetings and seen some operation.  As always, my comments have nothing to do with the individuals; this is about organizational design.

My concern is as you say about the "organizational design", not the current set of individuals.  I want to make sure this keeps working well with the next set of leaders and the set after that.

Bob

---

From: John C Klensin <[email-masked]>
Date: Sat, 16 Apr 2011 20:08:58 -0400

--On Saturday, April 16, 2011 07:51 -0700 Lucy Lynch
<[email-masked]> wrote:

>> The implication is that the people sitting in the positions
>> of IAB Chair and  IETF Chair are essential to the good
>> operation of the IAOC/Trust.  Someone  else from their groups
>> or even someone else that they appoint from outside  cannot
>> What are the specific contributions (insights and skills)
>> that these roles  regularly perform, in the conduct of the
>> IAOC/Trust that cannot be performed  adequately by others?
> 
> see above.
> 
> administrative accountability we gained through BCP 101 to
> additional volunteers.

best,
  john

---

From: Dave CROCKER <[email-masked]>
Date: Tue, 19 Apr 2011 10:33:12 -0700

Bob, et al,

On 4/18/2011 2:25 PM, Bob Hinden wrote:
> I didn't say no one else could do the job adequately.  I said "would have a
> negative impact" on the operations of the IETF.

Right. And my second sentence did go farther than I meant.

However rejecting an effort to change the current arrangement -- especially when 
it is initiated by a principal -- means that alternatives are not acceptable, 
which translates roughly to saying the alternatives will not produce adequate 
performance.  Otherwise it looks like a difference between 'adequate' and 
perhaps "perfect"?

There is a core reality, here, that the I* Chairs are overburdened. This is 
obvious from looking at the list of their duties and underscored by the source 
of the current initiative.  We can choose to defer doing anything, under the 
guise of taking a 'holistic' view or we can try to help with the specific burden 
that is the focus of the overburdened folk.  On the average, we do better with 
incremental change and this is the one before us now.

> If I generalize this, I would say that the I* chairs have been actively
> involved in the most significant decisions the IAOC makes, they tend to be
> less active in many of the day to day operational issues.
...
> I think the I* chairs, in my view bring a broad view of the community and
> operational needs based on what's involved in doing their jobs than another
> person would not have.

My own simplistic summary:  For some topics it is extremely helpful to have the 
broader knowledge and insight that can be provided by an I* chair. For many 
topics, this is not needed, but for some it makes a significant difference.

To that end, here's a very simple proposal that resolves the issue cleanly:

      1. ISOC, IAB and IESG each appoint one person currently.  Change this to 
be two each, the same as Nomcom.  Each year, they would appoint one person.

      2. Move the I* Chairs to be non-voting ex-officio participants, the same 
as the IETF Administrative Director.  They are welcome to participate or be 
explicitly invited to all IAOC/Trust activities.

This produces the continuity that is needed for the admin work, but also retains 
access to the expertise of the I* chairs.

d/
-- 

   Dave Crocker

---

From: SM <[email-masked]>
Date: Tue, 19 Apr 2011 10:58:53 -0700

Hi Bob,
At 14:25 18-04-2011, Bob Hinden wrote:
>I didn't say no one else could do the job adequately.  I said "would 
>have a negative impact" on the operations of the IETF.
>
>Some of these decision might have been different without one or more 
>I* chairs being directly involved in the decision.  Please review 
>the minutes for more detail.

 From RFC 4071:

   "The IAOC shall be accountable to the IETF community for the
    effectiveness, efficiency, and transparency of the IASA."

In a personal note that Olaf posted ( 
http://www.ietf.org/mail-archive/web/ietf/current/msg66161.html ), it 
is mentioned that it takes 0.7 FTE.  I do not believe that the 
decisions mentioned above are unimportant.  However, you have to 
consider which decisions require your attention when you have a 
limited amount of time available.

The current members of the IAOC, excluding ex officio, are:

  Eric Burger
  Dave Crocker
  Marshall Eubanks
  Bob Hinden
  Ray Pelletier (non-voting)

None of them are new to the IETF.  If it requires I* Chairs for the 
IAOC to be transparent, something is not right.

>I think the I* chairs, in my view bring a broad view of the 
>community and operational needs based on what's involved in doing 
>their jobs than another person would not have.

If I understand your arguments, it is also about avoiding a 
disconnect between the administrative side of the IETF and the IAB/IESG.

draft-kolkman-iasa-ex-officio-membership-00 argues for a change to 
reduce the workload and make the I* Chair positions more 
attractive.  Would it help if the IAOC Chair has a liaison position 
on the IAB and IESG?  The IAB and IESG Chairs can use their 
discretion to determine which IAOC meetings they should attend.  The 
IAOC Chair gets a broader view.

The above pushes the workload around instead of addressing the 
problem.  If this trend continues, the best fit people will turn down 
I* positions.

Regards,
-sm

---

From: Bob Hinden <[email-masked]>
Date: Tue, 19 Apr 2011 12:53:50 -0700

Dave,

On Apr 19, 2011, at 10:33 AM, Dave CROCKER wrote:

> However rejecting an effort to change the current arrangement -- especially when it is initiated by a principal -- means that alternatives are not acceptable, which translates roughly to saying the alternatives will not produce adequate performance.  Otherwise it looks like a difference between 'adequate' and perhaps "perfect"?

We don't get perfect :-)

> 
> There is a core reality, here, that the I* Chairs are overburdened. This is obvious from looking at the list of their duties and underscored by the source of the current initiative.  We can choose to defer doing anything, under the guise of taking a 'holistic' view or we can try to help with the specific burden that is the focus of the overburdened folk.  On the average, we do better with incremental change and this is the one before us now.

Then let's talk about the overall problem and not a point solution.

> My own simplistic summary:  For some topics it is extremely helpful to have the broader knowledge and insight that can be provided by an I* chair. For many topics, this is not needed, but for some it makes a significant difference.

I agree, and it is representative of the level of current participation of I* chairs.

>     1. ISOC, IAB and IESG each appoint one person currently.  Change this to be two each, the same as Nomcom.  Each year, they would appoint one person.
> 
>     2. Move the I* Chairs to be non-voting ex-officio participants, the same as the IETF Administrative Director.  They are welcome to participate or be explicitly invited to all IAOC/Trust activities.
> 
> This produces the continuity that is needed for the admin work, but also retains access to the expertise of the I* chairs.

I don't agree.  Appointing two people (or more?) doesn't solve the problem I am concerned about, it still doesn't bring the chairs perspective.  It also significantly changes the governance model by changing the balance between between nomcom, iab, iesg, and ISOC appointed members.  Also, adding six people (still counting the chairs) will make the IAOC much larger and unwieldy.  

Bob

---

From: Bob Hinden <[email-masked]>
Date: Tue, 19 Apr 2011 14:04:28 -0700

SM,

> None of them are new to the IETF.  If it requires I* Chairs for the IAOC to be transparent, something is not right.

But that may not always be the case that all IAOC members have a lot of IETF experience.  We need to have a governance model that works into the future.  

> If I understand your arguments, it is also about avoiding a disconnect between the administrative side of the IETF and the IAB/IESG.

Yes

> 
> draft-kolkman-iasa-ex-officio-membership-00 argues for a change to reduce the workload and make the I* Chair positions more attractive.  Would it help if the IAOC Chair has a liaison position on the IAB and IESG?  The IAB and IESG Chairs can use their discretion to determine which IAOC meetings they should attend.  The IAOC Chair gets a broader view.
> 
> The above pushes the workload around instead of addressing the problem.  If this trend continues, the best fit people will turn down I* positions.

It would certainly give the IAOC chair a broader view, but still not the views of the I* chair.  Also, if the I* chairs (3 of 9 voting members) regularly didn't attend, it would be much harder to get a quorum for a meeting and pass motions.  

Bob

---

From: SM <[email-masked]>
Date: Wed, 20 Apr 2011 02:13:14 -0700

Hi Bob,
At 14:04 19-04-2011, Bob Hinden wrote:
>But that may not always be the case that all IAOC members have a lot 
>of IETF experience.  We need to have a governance model that works 
>into the future.

Yes, it may happen that some IAOC members may not have a lot of IETF 
experience.  How do you ensure that the IAOC members have a lot of 
IETF experience?  You can tweak the governance model.  The IETF 
community also have to be convinced that it is the better model or 
else it will be changed.  There are some safeguards in the IETF model 
that I won't get into.  It's merely a matter of time for that to 
change.  I'll list the names of the people who have participated on 
this thread:

  Dave Crocker
  Lucy Lynch
  John Klensin
  Russ Housley
  Jari Arkko
  Olaf Kolkman
  Brian Carpenter
  Henk Uijterwaal
  Leslie Daigle
  Ole Jacobsen
  Marshall Eubanks
  Joe Touch
  Joel Jaeggli
  Steve Crocker
  Michael Richardson
  Barry Leiba
  Spencer Dawkins
  Bert Wijnen

The people listed below were part of NomCom:

  Gregory Cauchie
  Mehmet Ersue
  Dorothy Gellert
  Tony Hansen
  Suresh Krishnan
  Dirk Kroeselberg
  Jan Seedorf
  Pete St. Pierre
  Rolf Winter

You may notice that there isn't any intersection with the previous list.

>It would certainly give the IAOC chair a broader view, but still not 
>the views of the I* chair.  Also, if the I* chairs (3 of 9 voting 
>members) regularly didn't attend, it would be much harder to get a 
>quorum for a meeting and pass motions.

I did not comment on getting a quorum previously as it's only adding 
one more problem to the mix.  "The IAOC decides the details about its 
decision-making rules, including its rules for quorum, conflict of 
interest, and breaking of ties".

I agree with you that the views of the I* Chairs are important.  It 
also helps avoid back and forth discussion between I* bodies; e.g. is 
this an IESG decision or can the IAOC decide.  I don't think that the 
IAB or the IESG can be absolved from the responsibility if the IAOC 
takes a negative turn as each of them chooses an IAOC member.

If the ex-IAB Chair and the IESG Chair ask for a change to the model 
due to the workload, is it on a whim?  This is where people walk away 
from a problem because they tried and got stone-walled.  If the IETF 
believes that it is appropriate to mince everything they can get out 
of a person in the name of good governance, so be it.

Regards,
-sm

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 20 Apr 2011 09:37:15 -0700

On 4/19/2011 12:53 PM, Bob Hinden wrote:
>> 1. ISOC, IAB and IESG each appoint one person currently.  Change this to be
>> two each, the same as Nomcom.  Each year, they would appoint one person.
>>
>> 2. Move the I* Chairs to be non-voting ex-officio participants, the same as
>> the IETF Administrative Director.  They are welcome to participate or be
>> This produces the continuity that is needed for the admin work, but also
>> retains access to the expertise of the I* chairs.
>
> I don't agree.  Appointing two people (or more?) doesn't solve the problem I
> am concerned about, it still doesn't bring the chairs perspective.  It also
> significantly changes the governance model by changing the balance between
> between nomcom, iab, iesg, and ISOC appointed members.  Also, adding six
> people (still counting the chairs) will make the IAOC much larger and
> unwieldy.

For clarification:

1.  The IAB, IESG and ISOC each put two voting people onto the IAOC/Trust today. 
  My proposal preserves that.

2. The intent behind moving the I* Chairs to non-voting status, like the IAD, is 
to ensure that they can continue to participate but remove from the the 
requirement for daily IAOC/Trust activities.  The presumption is that they dive 
in for the big stuff, of the sort you cited, but do not have the burden of 
regular participation.

For emphasis:

As SM notes, my starting point is two of these folk saying they have to have a 
change.  Looking at the list of their duties, no one should be surprised that 
they feel (and are) overloaded.  So, they looked over their current duties and 
decided this is the one they'd like to change.  I don't have -- and haven't 
heard anyone else suggest -- that some other change in their duties would be 
more appropriate.  So I see the relevant question as how to make a change, not 
whether.

d/

ps. As for the broader concern about having a sufficient base of experience on 
the IAOC/Trust, that applies for all appointments to all of our management 
groups.  Worse, we have a continuing challenge to select for the right kinds of 
experience.  For example, merely hanging around the IETF for a long time does 
not mean one knows how to manage an area or manage a budget.  (I'm stating the 
obvious.  The reason is that I don't see the current effort to change I* Chair 
participation in the IAOC/Trust as changing this issue.)

-- 

   Dave Crocker

---

From: John Leslie <[email-masked]>
Date: Wed, 20 Apr 2011 13:16:59 -0400

Dave CROCKER <[email-masked]> wrote:
>> [Dave CROCKER <[email-masked]> wrote:]
>> 
>>> 1. ISOC, IAB and IESG each appoint one person currently.  Change this
>>>    to be two each, the same as Nomcom.  Each year, they would appoint
>>>    one person.
>>>
>>> 2. Move the I* Chairs to be non-voting ex-officio participants, the
>>>    same as the IETF Administrative Director. They are welcome to
>>>    participate or be explicitly invited to all IAOC/Trust activities.
>>>
>>> This produces the continuity that is needed for the admin work, but
>>> also retains access to the expertise of the I* chairs.

   I always respect Dave's suggestions. (Of course, I don't always agree
with them... ;^)

>> I don't agree. Appointing two people (or more?) doesn't solve the
>> problem I am concerned about, it still doesn't bring the chairs
>> perspective.

   I usually respect Bob's suggestions, but I don't always understand
them. (In particular, he's lost me here.)

>> It also significantly changes the governance model by changing the
>> balance between between nomcom, iab, iesg, and ISOC appointed members.

   The change in "balance" seems rather minimal -- but that could
certainly be fine-tuned.

>> Also, adding six people (still counting the chairs) will make the
>> IAOC much larger and unwieldy.

   That I understand. Perhaps we shouldn't be adding any...

   However, Russ & Olaf seem to think there's work they have been
expected to do. How will that work get done? Is the proposal first
floated simply telling them the work is their responsibility -- and
they need to find volunteers to do it?

   Us hoi-polloi aren't getting these details!

> For clarification:
> 
> 1.  The IAB, IESG and ISOC each put two voting people onto the IAOC/Trust 
> today. My proposal preserves that.
> 
> 2. The intent behind moving the I* Chairs to non-voting status, like the 
> IAD, is to ensure that they can continue to participate but remove from
> the the requirement for daily IAOC/Trust activities. The presumption is
> that they dive in for the big stuff, of the sort you cited, but do not
> have the burden of regular participation.

   I have a slightly different view: that the IAOC is entitled to try to
entice them into participation, but they would have the right to say "No".

> For emphasis:
> 
> As SM notes, my starting point is two of these folk saying they have to 
> have a change. Looking at the list of their duties, no one should be 
> surprised that they feel (and are) overloaded. So, they looked over
> their current duties and decided this is the one they'd like to change.
> I don't have -- and haven't heard anyone else suggest -- that some other
> change in their duties would be more appropriate. So I see the relevant
> question as how to make a change, not whether.

   I agree. Hopefully most of us can agree.

   Charging them to find someone to do the work feels wrong to me.

   Moving them to non-voting status feels right.

   Enabling them to participate in areas they feel critical feels right.

   Adding other individuals with voting status seems reasonable, but
not-exactly-right.

   Perhaps the most important change would be simply not counting them
for purposes of quorum...

--
John Leslie <[email-masked]>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Apr 2011 09:21:58 +1200

...

> You may notice that there isn't any intersection with the previous list.

I think you are overlooking that some of the people in the first list
have been in liaison positions in NomCom; in terms of understanding
NomCom's challenges, that is sufficient. In any case, the difficulty
of finding available candidates is quite apparent.
...

> I agree with you that the views of the I* Chairs are important.

In the case of the IETF Chair I believe the issue is that it's
highly desirable, from a governance viewpoint, that the IETF Chair
has *personal* responsibility in IAOC decisions, and therefore should
be a voting member as a matter of principle.

I don't believe that argument applies to the IAB Chair - we should
IMHO have a collective goal to sharply reduce the IAB's involvement
in administrative issues, so that it can do its architectural and
liaison jobs properly. Delegating the IAB Chair role in the IAOC
would be a step in that direction, along with appointing the permanent
RFC Series Editor.

We haven't discussed the third proposed delegation, that of the ISOC
President's seat, very much. Assuming it was delegated to another
officer of ISOC, that would seem reasonable too. But it shouldn't
be delegated to just anybody, IMHO.

   Brian

    Brian

---

From: Bob Hinden <[email-masked]>
Date: Wed, 20 Apr 2011 14:40:40 -0700

Brian,

If we are going to do this, then I tend to agree with your conclusions.

> be a voting member as a matter of principle.

My preference is that the IETF not delegate this responsibility.  One additional reason for this is that the IETF chair is appointed by the nomcom (vs. the IAB who appoints their own chair).  It is part of the job and an important part.

> would be a step in that direction, along with appointing the permanent

In the case of the IAB, I would prefer that the IAB selected it's representative to the IAOC and that they become the full IAOC voting member (and a member of the IETF trust).  That is, it be completely delegated for a fixed term.  The IAB could consider this person as a vice-chair or even a co-chair.  The both represent other ways to reduce the load on the chair.  

> be delegated to just anybody, IMHO.

Also agree.  I think it should be limited to the CFO or COO.  I think, as above with the IAB, it should be fully delegated.

Bob

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 21 Apr 2011 10:38:41 -0700

On 4/20/2011 2:21 PM, Brian E Carpenter wrote:
> has *personal* responsibility in IAOC decisions,

Why?

What happens if the person in that role is not specifically "accountable"?

And by the way, what does it mean to be accountable in the way that you consider 
so important?

What actions flow from that accountability?

d/

-- 

   Dave Crocker

---

From: Joel Jaeggli <[email-masked]>
Date: Thu, 21 Apr 2011 10:49:45 -0700

> What happens if the person in that role is not specifically "accountable"?

We have the potential for disconnect between the business of the ietf
and the business of running the ietf. We had that before so it's not a
hypothetical scenario.

> And by the way, what does it mean to be accountable in the way that you
> consider so important?

It means that the ability to perform the iaoc function is a
consideration for filling and retaining the role of ietf chair.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Apr 2011 08:52:45 +1200

> and the business of running the ietf. We had that before so it's not a

Exactly. My personal experience as IETF Chair was that the administrative
work, which we engineers have a lordly tendency to dismiss as trivial,
is truly vital to making the IETF work properly. I just can't conceive
of an IETF Chair decoupling from the chain of responsibility for this.

Just to repeat myself: the IAOC workload represents a substantial
*reduction* of the IETF Chair workload (and stress load) compared to the
pre-IAOC situation.

> consideration for filling and retaining the role of ietf chair.

Exactly. An IETF Chair who doesn't see this as fundamental would be
a bad choice.

>> What actions flow from that accountability?

Failure in this part of the role would be a strong signal
to NomCom if the Chair wants to re-up, and dramatic failure
would be potential grounds for recall.

   Brian

---

From: John C Klensin <[email-masked]>
Date: Thu, 21 Apr 2011 17:00:06 -0400

--On Thursday, April 21, 2011 10:49 -0700 Joel Jaeggli
<[email-masked]> wrote:

>>> In the case of the IETF Chair I believe the issue is that
>>> it's highly desirable, from a governance viewpoint, that the
>>> IETF Chair has *personal* responsibility in IAOC decisions,
>> 
>> Why?
>> 
> We have the potential for disconnect between the business of
> the ietf and the business of running the ietf. We had that
> before so it's not a hypothetical scenario.

But, if it is the "business of running the IETF" that we are
after, why is it better to try to blame/ hold accountable one
individual than to hold the IESG accountable and let them manage
the question of who goes to IAOC meetings as they (with the
Chair's active participation in the IESG discussions) think fit?
There is nothing in any of our document that either crowns the
IETF Chair King or endows him or her with divine guidance or
wisdom.
 
>> And by the way, what does it mean to be accountable in the
>> way that you consider so important?
> 

And that takes us back around the loop of requiring that the
criteria for selection of the IETF Chair include a combination
of skills and interests that we are unlikely to find, ability to
devote unlimited time and attention to the job (and I mean
"unlimited" as in ability to create and utilize 32 hour days),
and resources to match.  It also suggests that Nomcoms are able
to understand all of those skills and optimize for all of them
at once, choosing from the relatively small number of people who
meet the criteria.   Noting that Russ has done, IMO, a
superhuman job of balancing the various tasks and demands that
we've placed on him but is still feeling overloaded, you will
forgive me if my reaction to imposing those requirements as
minimum conditions on future candidates is a little skeptical.

      john