Subject: Re: Call for a Jasmine Revolution in the IETF: Privacy, Integrity, Obscurity

From: todd glassey <[email-masked]>
Date: Mon, 11 Apr 2011 13:56:11 -0700

On 3/23/2011 12:02 AM, Hannes Tschofenig wrote:
> On Mar 23, 2011, at 6:52 AM, SM wrote:
>
>> The IETF can only address the technical problems.
> This is an argument I often hear. I do, however, believe that you cannot see technology in isolation.
Yeah - sure you can... if you want to be totally about the original 
design and practice of the IETF and its vision. It was built to advance 
protocol standardization and not to decide what protocols it would allow 
on the Internet and which it wouldn't.  But  lately many have forgotten 
this and are using the IETF as a formal lobby for technological policy 
advancement and that's a no-no.

Bluntly the IETF members are becoming more and more aggressively 
politically and this statement is based on IAB and other publication on 
what the IETF does and does not allow through its frameworks. In doing 
so their statements about allowing protocols or not allowing protocols 
to be standardized based on their stated perception of "what damages the 
Internet" or what they personally want to see as a "free access to all 
information and ideas" model, creates a real serious divergence from the 
Standards Practice this organization was set up as, and IMHO is one 
which is designed clearly to destroy global Intellectual Property law 
and practice.
> However, in many cases the technology, regulatory environment, business aspects, and the social context gets mixed together.
No Hannes  - it doesn't unless the Chair allows it to - meaning that the 
Chair in this instance has allowed political materials to be fielded 
(filed in this instance) into the IETF and trust me I am already filing 
a formal complaint with the Treasury about ISOC's becoming a formal PAC 
and its locking out protocol efforts based on its own desires therein...

http://tools.ietf.org/html/draft-morris-policy-cons-00

I suggest that the Chair immediately post a formal statement that the 
IETF is a-political and will not do anything but standardize 
technology.  Also that ONLY technology drafts can be accepted since the 
IETF is part of ISOC and not registered as a political PAC or Lobbying 
Agency which it clearly has become in direct violation of the NTIA MOU 
which gave it (ISOC and its ARIN) the real power.

Todd Glassey
Please have a look at: 
http://tools.ietf.org/html/draft-morris-policy-cons-00
> Ciao
> Hannes

Hannes - this is the issue with the IETF and the gross number of flaming 
idiots inside of it. The IETF is not a Social Reform Agency, nor is it a 
freaking political action group since its financial filings prevent this.

Todd Glassey
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 12 Apr 2011 12:31:30 -0400

Todd,

This is totally confused and you are completely wrong.

Under the Federal Election Campaign
Act<http://en.wikipedia.org/wiki/Federal_Election_Campaign_Act>,
an organization becomes a "political committee" by receiving contributions
or making expenditures in excess of $1,000 for the purpose of influencing a
federal election
[Source Wikipedia]

Since neither the IETF nor ISOC has any interest in influencing a federal
election, nor does it engage in any activity intended to do so, it is not a
political committee under the terms of the act.

On Mon, Apr 11, 2011 at 4:56 PM, todd glassey <[email-masked]>wrote:

> Yeah - sure you can... if you want to be totally about the original design
> and practice of the IETF and its vision. It was built to advance protocol
> standardization and not to decide what protocols it would allow on the
> Internet and which it wouldn't.  But  lately many have forgotten this and
> are using the IETF as a formal lobby for technological policy advancement
> and that's a no-no.
>
> politically and this statement is based on IAB and other publication on what
> the IETF does and does not allow through its frameworks. In doing so their
> statements about allowing protocols or not allowing protocols to be
> standardized based on their stated perception of "what damages the Internet"
> or what they personally want to see as a "free access to all information and
> ideas" model, creates a real serious divergence from the Standards Practice
> this organization was set up as, and IMHO is one which is designed clearly
> to destroy global Intellectual Property law and practice.
>
>  However, in many cases the technology, regulatory environment, business
>> aspects, and the social context gets mixed together.
>>
> Chair in this instance has allowed political materials to be fielded (filed
> in this instance) into the IETF and trust me I am already filing a formal
> complaint with the Treasury about ISOC's becoming a formal PAC and its
> locking out protocol efforts based on its own desires therein...
>
>
> I suggest that the Chair immediately post a formal statement that the IETF
> is a-political and will not do anything but standardize technology.  Also
> that ONLY technology drafts can be accepted since the IETF is part of ISOC
> and not registered as a political PAC or Lobbying Agency which it clearly
> has become in direct violation of the NTIA MOU which gave it (ISOC and its
> ARIN) the real power.
>
>
> Todd Glassey
>
> Please have a look at:

-- 
Website: http://hallambaker.com/

---

From: Alessandro Vesely <[email-masked]>
Date: Wed, 20 Apr 2011 13:32:25 +0200

On 12/Apr/11 18:31, Phillip Hallam-Baker wrote:
>    Under the Federal Election Campaign Act
>    <http://en.wikipedia.org/wiki/Federal_Election_Campaign_Act>, an
>    organization becomes a "political committee" by receiving
>    contributions or making expenditures in excess of $1,000 for the
>    purpose of influencing a federal election
>    [Source Wikipedia]
> 
> Since neither the IETF nor ISOC has any interest in influencing a
> federal election, nor does it engage in any activity intended to do
> so, it is not a political committee under the terms of the act.

The way politics is currently being done is not necessarily adequate.

Let me just note that the root problem is that we are sharing this
planet among a few billions individuals.  That is certainly a
political problem.  However, given that communication is potentially
proportional to the square of the communicating parties, it is also a
technical problem.  I claim that it is not possible to neatly discern
between political and technical issues, although only one of those
two aspects appears to be dominant in many specific cases.  To
justify this claim, suffice it to say that the /amount/ of traffic
has a paramount physical limit, time, whose use cannot be regulated
by any single-sided approach --either political or technical, only.
For an example: spam.

Is it an only-technical problem to devise adequate means for politics?
For the reciprocal question, whether politics should intrude into
technology, the ISOC, talking about the IETF and similar bodies,
recommends that politics do not "assert any authority over those
organizations by any mechanism" [1].  So, how do we tackle spam and
similar issues where neither aspect is prevalent?

1. ISOC's response to NTIA request for comments on IANA functions
http://isoc.org/wp/newsletter/files/2011/03/Internet-Society-Response-Docket.pdf
30 March 2011
> On Mon, Apr 11, 2011 at 4:56 PM, todd glassey <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Yeah - sure you can... if you want to be totally about the
>     original design and practice of the IETF and its vision. It was
>     built to advance protocol standardization and not to decide what
>     protocols it would allow on the Internet and which it wouldn't.
>      But  lately many have forgotten this and are using the IETF as a
>     formal lobby for technological policy advancement and that's a no-no.
> 
>     politically and this statement is based on IAB and other
>     publication on what the IETF does and does not allow through its
>     frameworks. In doing so their statements about allowing protocols
>     or not allowing protocols to be standardized based on their stated
>     perception of "what damages the Internet" or what they personally
>     want to see as a "free access to all information and ideas" model,
>     creates a real serious divergence from the Standards Practice this
>     organization was set up as, and IMHO is one which is designed
>     clearly to destroy global Intellectual Property law and practice.
> 
>         However, in many cases the technology, regulatory environment,
>         business aspects, and the social context gets mixed together.
> 
>     No Hannes  - it doesn't unless the Chair allows it to - meaning
>     that the Chair in this instance has allowed political materials to
>     be fielded (filed in this instance) into the IETF and trust me I
>     am already filing a formal complaint with the Treasury about
>     ISOC's becoming a formal PAC and its locking out protocol efforts
>     based on its own desires therein...
> 
> 
>     I suggest that the Chair immediately post a formal statement that
>     the IETF is a-political and will not do anything but standardize
>     technology.  Also that ONLY technology drafts can be accepted
>     since the IETF is part of ISOC and not registered as a political
>     PAC or Lobbying Agency which it clearly has become in direct
>     violation of the NTIA MOU which gave it (ISOC and its ARIN) the
>     real power.
> 
> 
>     Todd Glassey
> 
>     Please have a look at:
>     Hannes - this is the issue with the IETF and the gross number of
>     flaming idiots inside of it. The IETF is not a Social Reform
>     Agency, nor is it a freaking political action group since its
>     financial filings prevent this.
> 
>     Todd Glassey

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 22 Apr 2011 12:19:11 +0300

I just notice your mail and thought I should respond given that you may have misunderstood something in this email conversation or in one of my responses. 

When a working group works on a specific problem then they get requirements from many different sources. Some of these requirements may be purely technical (such as performance aspects, encoding related questions, etc.) but there are also requirements that come from the desire to meet certain deployment constraints. Often protocols build on top of something existing; they do not make the assumption of a clean slate. By doing this they take business models into consideration, and consider a certain type of responsibility sharing. There may also be regulatory actions that influenced the work. http://tools.ietf.org/html/draft-morris-policy-cons-00 summarize these observations. It is not an IAB document but, as the filename indicates, an individual submission. The authors are soliciting input from the IETF community on the document and to share their protocol development experience with us. 

In any case, there are many requirements and the large number of guidelines we have protocol developers reflect this. Protocol design is not easy. Since a single person typically does not have the complete range of expertise needed we make use of directorates as well in the development of high-quality specifications. 

Despite all these different sources for requirements the actual result (the output of the working group) is a technical specification. It may provide background information, instructions for implementers or for those who deploy. 

The IAB and ISOC documents you mentioned in your other mails are slightly different. IAB documents, for example, may provide broader architectural advice. RFC 2804 "IETF Policy on Wiretapping" is such a document (written by IESG/IAB). 
Again other documents concern the core role of the IAB, such as the RFC Editor and IANA.

You like to call everything "politics" particularly if you do not like a certain argument. This is not a particularly useful approach since it does not help me (and maybe others) to get insight into the argument you are trying to make. 

Ciao
Hannes
(speaking for myself as an individual contributor to the IETF standardization process) 

On Mar 23, 2011, at 5:43 PM, todd glassey wrote:

> That's because you are being a political animal and not a pure technologist here which violates the charter of the IETF in spades.
> 
> If the IETF is only set up to standardize technology then it cannot refuse to accept anything, further its members who try and block protocol's standardization regularly commit antitrust and TI by sabotaging various initiatives, and IMHO they need to be formally spanked (by lawyers) and sent to bed with no supper. There is no political or legal activity of the IETF in its standardization practice and it cannot implement social policy around what it standardizes and doesn't IMHO.
>> Please have a look at: http://tools.ietf.org/html/draft-morris-policy-cons-00
> only in the limited world of Social Networking...
> 
> Todd Glasssey
> 
> 
>> Ciao
>> Hannes
>>