Subject: Adventures in IPv6

From: Sabahattin Gucukoglu <[email-masked]>
Date: Mon, 11 Apr 2011 21:41:48 +0100

This is just a blog posting, but I think it has valid illustrative points of the general frustration in it:
http://bens.me.uk/2011/adventures-in-ipv6

Of course, I think the conclusion is basically wrong, *not* doing IPv6 is much worse than breaking the finger-pointing circle, and making it work by whatever means necessary.  We won't make the situation better by not doing anything.  And yes, I know how tired this all is, but it's starting to look like some people in this world just aren't going to be convinced until there's an actual, real crisis on top of us.

Cheers,
Sabahattin

---

From: Doug Barton <[email-masked]>
Date: Mon, 11 Apr 2011 16:39:39 -0700

On 04/11/2011 13:41, Sabahattin Gucukoglu wrote:
> Of course, I think the conclusion is basically wrong, *not* doing
> IPv6 is much worse than breaking the finger-pointing circle, and
> making it work by whatever means necessary.

"Much worse" for who? Just because we (may) believe that IPv6 is the way 
forward doesn't mean that the providers or consumers of Internet 
services will agree with us. The consumers just want to watch their 
videos and read their mail. The providers just want to sell them that 
capability. IPv6 needs to solve more problems than it creates, or else 
it's not the right answer.

Doug

-- 

	Nothin' ever doesn't change, but nothin' changes much.
			-- OK Go

	Breadth of IT experience, and depth of knowledge in the DNS.
	Yours for the right price.  :)  http://SupersetSolutions.com/

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 12 Apr 2011 10:10:56 +0900

Sabahattin Gucukoglu wrote:

> IPv6 is much worse than breaking the finger-pointing circle,
> and making it work by whatever means necessary.

The problem is that, operationally, IPv6 does not work.

> We won't make the situation better by not doing anything.

Insisting on IPv6 is worse than not doing anything, because
it gives people insisting on IPv6 false feeling of doing
something.

> And yes, I know how tired this all is, but it's starting to
> look like some people in this world just aren't going to be
> convinced until there's an actual, real crisis on top of us.

That's so true for you and other people insisting on IPv6.

						Masataka Ohta

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 12 Apr 2011 11:56:28 +0200

>> http://bens.me.uk/2011/adventures-in-ipv6

What a bunch of whining.

When I first started doing IPv4 it was much harder than this.

> "Much worse" for who? Just because we (may) believe that IPv6 is the way forward doesn't mean that the providers or consumers of Internet services will agree with us.

I'm sure most airline passengers have few opinions on the merits of wingtips, either. The engineers can tell you they are a good thing. We don't let the public's ignorance override that judgement.

> The consumers just want to watch their videos and read their mail. The providers just want to sell them that capability. IPv6 needs to solve more problems than it creates, or else it's not the right answer.

It's too late for that discussion now.

If there is some aspect to IPv6 that is broken, we need to fix it as soon as possible. But IPv6 is been around for 15 years with ONE WEEK to go before APNIC runs dry of addresses it can give out through the regular process, so debating the merits of design choices now is pointless.

If you read that whiney blogpost you'll see that none of it is about problems that the IETF can fix.

It's also important that we show a little understanding and compassion when people whine (unlike what I've been doing here) but only a little, mostly we have to convey that IPv6 is ready for prime time and no negotiation is possible at this point. It's strange, but people actually get angrier when you agree with them when they complain. They want and expect you to hold your ground while they vent and afterwards they are usually ready to face reality.

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Tue, 12 Apr 2011 12:00:07 -0400

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Sabahattin Gucukoglu [[email-masked]]

This is just a blog posting, but I think it has valid illustrative points of the general frustration in it:
http://bens.me.uk/2011/adventures-in-ipv6
_______________________________________________

I don't see anything remarkable about this -- it's fairly standard frustration when one is attempting to be a leading-edge
user of a new technological infrastructure.  And his conclusion isn't particularly surprising, either, it's just "Don't be the earliest
adopters -- wait until the service/equipment providers have ironed out the bugs."

Of course, this leads back to the original problem:  Essentially none of the users who will gain the long-term benefits from the
transition to IPv6 want to be the early adopters who will force the bugs to be ironed out.

Dale