Subject: Re: LISP is not a Loc-ID Separation protocol

From: Robin Whittle <[email-masked]>
Date: Wed, 02 Nov 2011 04:34:01 +1100

I wrote another explanation of why the LISP protocol does not involve a
separate namespace for Identifiers - and so why it is not a Loc-ID
Separation protocol.

  http://www.firstpr.com.au/ip/ivip/namespace/lisp-not-loc-id/

This is a longer version of my arguments earlier in this thread because
it assumes no knowledge of the LISP protocol or of the IRTF Routing
Research Group work in recent years on scalable routing.

Its good that the LISP protocol, Ivip and Iron are not Locator -
Identifier Separation protocols:

  "Overloading" of Loc & ID functions is good for hosts and should be
  maintained    2010-06-22
  http://www.ietf.org/mail-archive/web/rrg/current/msg07017.html

 - Robin

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 2 Nov 2011 15:23:23 -0700

Thankfully, I missed most of the earlier threads related
to this. But, on the subject of identifiers, Robin is right.
What the IETF protocol known as LISP calls "identifiers" are
actually IP addresses. And, IP addresses name *interfaces*;
they do not name *end systems*. Same is true also of IRON.

Thanks - Fred
[email-masked]  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Robin Whittle
> Sent: Tuesday, November 01, 2011 10:34 AM
> To: [email-masked]
> Subject: Re: LISP is not a Loc-ID Separation protocol
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Luigi Iannone <[email-masked]>
Date: Thu, 3 Nov 2011 10:45:24 +0100

> they do not name *end systems*. Same is true also of IRON.

In LISP (Locator/ID Separation Protocol) EID stands for Endpoint-ID.

Isn't the interface the endpoint of the Internet communication pipe? 

AFAIR LISP never claims that an LEID identifies a host or a general end-system.

Luigi