Subject: Netfilter (Linux) Does IPv6 NAT

From: Sabahattin Gucukoglu <[email-masked]>
Date: Thu, 1 Dec 2011 00:07:55 +0000

In case you didn't see this:
http://www.h-online.com/open/news/item/Netfilter-developers-working-on-NAT-for-ip6tables-1385877.html

It's a complete IPv6 NAT implementation with the functionality of the IPv4 one in the same stack.  ALGs.  Port translation.  Connection tracking.  You don't need me to tell you why I don't like this.

Cheers,
Sabahattin

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 01 Dec 2011 14:20:31 +1300

Does it support RFC 6296?

Regards
   Brian Carpenter

On 2011-12-01 13:07, Sabahattin Gucukoglu wrote:
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Thu, 1 Dec 2011 02:11:45 +0000

> Does it support RFC 6296?

That was done in a separate, non-official implementation here:
http://lwn.net/Articles/451914/

With this one, you can NAT between ranges, and that's it, if I've got this right.  Fragmentation is also an issue.  I'm not a netfilter expert, though, so I can't say whether it's possible to implement RFC6296 with it.  The checksum difference calculation is obviously going to pose a problem.

Cheers,
Sabahattin