Subject: RE: Last Calls: [SOME RFCs] to HISTORIC RFCs

From: Ross Callon <[email-masked]>
Date: Tue, 1 Nov 2011 15:17:44 -0400

It appears Ron that you are in cahoots with my wife. ;-(

Without commenting on my attic (or basement), I do agree that documents that are clearly outdated should be reclassified as "historic". Any attempt to do this (or to clean out my basement) is inevitably going to be incomplete, but we should do what is obvious anyway. 

Ross

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ronald Bonica
Sent: Friday, October 28, 2011 3:57 PM
To: Randy Bush; Frank Ellermann
Cc: IETF Discussion
Subject: RE: Last Calls: [SOME RFCs] to HISTORIC RFCs

Randy,

Reclassifying old documents to historic is like cleaning your attic. Cleaning the attic may seem like a terrible waste of time and effort while you are doing it, but it makes your life much easier the next time you have to find or store something up there.

                                                Ron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Randy Bush
> Sent: Friday, October 28, 2011 2:47 PM
> To: Frank Ellermann
> Cc: IETF Discussion
> Subject: Re: Last Calls: [SOME RFCs] to HISTORIC RFCs
> 
> >> we don't have enough real work to do?
> >
> > Clean up is necessary work.  Some hours ago
> > I tried to understand a discussion about the
> > "ISE" (independent stream), and gave up on
> > it when the maze of updates obsoleting RFCs
> > which updated other RFCs turned out to be
> > as complex as the colossal cave adventure.
> 
> QED
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: RJ Atkinson <[email-masked]>
Date: Wed, 2 Nov 2011 13:23:35 -0400

Earlier, on 29th October 2011, Mike StJohns wrote, in part:
> With respect to the other four documents (e.g. Milo's baby et al) --
> they aren't IETF documents, they weren't adopted as
> Internet Standards (unlike TCP and IP) and we shouldn't be
> twiddling with their status.   They don't belong to us.  

Agreed.  

The IETF/IESG do not have the authority to change the
status of any RFC that is neither (A) an Internet 
standards-track document nor (B) an IETF Track document.

For ancient documents believed to be in category (A),
the various "IAB Official Protocol Standards" RFCs 
(e.g. RFC-1083) are authoritative about which ancient 
RFCs are or have been on the Internet standards-track.

I raised this same issue in the past, and the issue was
resolved then without the IETF/IESG incorrectly claiming 
overly broad authority.  A reasonable resolution in such
cases, if/when the IETF/IESG really consider it important
and a wise use of time, is to gain the advance explicit 
permission of the authors of the RFC being reclassified 
and documenting that their permission to reclassify 
was obtained in advance of the reclassification.

Perhaps this needs to be written down somewhere 
so there won't be confusion on this point in future ?

> Most of the pre-1000 RFCs are neither standards nor even
> technical in nature.  A number of them are administrivia
> of the early Internet and ARPANET.  

Agreed, and frankly the status of such documents generally
is not worth thinking about, let alone changing.

Yours,

Ran