Subject: RE: LISP is not a Loc-ID Separation protocol

From: [email-masked] (Noel Chiappa)
Date: Thu, 3 Nov 2011 10:42:52 -0400 (EDT)

> From: "Templin, Fred L" <[email-masked]>

    > one to one correspondence with the end system's multiple VPN
    > connections. The internal virtual interfaces keep the VPNs separate.

As logically separate sources for incoming/outbound packets, they are just
like multiple real interfaces. The name used for neither is really the
'identity' of the host, the names applied to those things just identify
sources/sinks of packets.

    >> Suppose I assign two endpoint identifiers to a host. Which is the
    >> host's identity?

    > Neither - that's the point. The host's identify is not bound to any one
    > or multiple IP addresses.

I said "endpoint identifiers" (under whatever definition of that term one
wishes to use), not "addresses".

So, a single host can have multiple identities (whether one does so via
multiple interfaces/interface addresses, or endpoint identifiers). So?

	Noel

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 3 Nov 2011 07:54:53 -0700

Hi Noel, 

> -----Original Message-----
> From: Noel Chiappa [mailto:[email-masked]] 
> Sent: Thursday, November 03, 2011 7:43 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: LISP is not a Loc-ID Separation protocol
> 

OK, so then let's consider a related analogy. It is
not uncommon for a person (e.g., John Doe) to have
dual citizenship with countries A and B, i.e, John
"interfaces" with both countries. John would receive
a separate taxpayer identifier from each of A and B,
which has relevance only within the respective
country's "routing system". But, John's identity is
neither A nor B; John's identity is John.

> multiple interfaces/interface addresses, or endpoint identifiers). So?

No; not multiple identities. One identity; multiple
interfaces and multiple addresses. Same as for the
taxpayer ID analogy.

Thanks - Fred
[email-masked]

---

From: "t.petch" <[email-masked]>
Date: Fri, 4 Nov 2011 11:58:16 +0100

----- Original Message -----
From: "Templin, Fred L" <[email-masked]>
To: "Noel Chiappa" <[email-masked]>; <[email-masked]>
Sent: Thursday, November 03, 2011 3:54 PM
> neither A nor B; John's identity is John.

Not necessarily so.  I agree with you so far, but the question is, when John
contributes to this list as AD and then as individual, is that one identity or
two?  Arguably, it is two, each of which could have multiple identifiers.

Likewise, a host can be differentiated from the applications running on it, and
in a large server farm, the relationship can be m:n, so there is an application
identity, with multiple identifiers, which is distinct from a host identity,
with multiple identifiers.

Identity is a slippery thing and much of the discussion on RRG, which I
faithfully followed, seemed to me to be a lack of agreement on identity, not
about identifiers.

That said, no way is LISP a separation of Locator and ID:-)  It seems to me a
bit like countries which included 'Democratic' in their identifier, which always
make me want to see some proof that they were indeed democratic:-)

Tom Petch

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>
>