Subject: Re: Consensus Call: draft-weil-shared-transition-space-request

From: Mark Townsley <[email-masked]>
Date: Tue, 29 Nov 2011 18:39:20 +0100

> On October 10, 2011, the IESG issued a last call for comments regarding draft-weil-shared-transition-space-request-09 (IANA Reserved IPv4 Prefix for Shared CGN Space). While the community did not display consensus supporting the draft, it also did not display consensus against the draft. Therefore, I will submit the draft to the full IESG for its consideration at its December 1 teleconference. The draft will be published as a BCP if a sufficient number of IESG members ballot "Yes" or "No Objection", and if no IESG member ballots "Discuss".
If I recall correctly from my days on the IESG, a "sufficient number" of IESG members with a "Yes" for document advancement is exactly one. Often, that is the AD bringing the document forward to the IESG. The shepherding AD is saying, "Yes" I have read this document, seen a sufficient level of support in the IETF for it, etc. Sometimes, other ADs jump on board with their own "Yes", but it's not required.

Ron, if I read this email from you correctly, you are saying that you have not seen that level of consensus yourself, yet you are bringing the document forward to the IESG to weigh advancement anyway. The process is flexible enough to allow that and I'm not questioning this action alone, but I do think it would be a good idea for you to not put in your own "Yes" for the document in this case. This raises the bar ever so slightly for advancement, forcing the IESG deliberations to convince at least one AD to stand behind what is being done with a "Yes" vs. a "No Objection". 

- Mark

> 
> Because the decision to submit this draft to the full IESG is controversial, I will explain the decision making process.
> 
> The IETF has a precedent for interpreting silence as consent. Typically, if a last call elicits no response, the draft is brought to the full IESG for consideration. The October 10 last call regarding draft-weil-shared-transition-space-request-09 evoked only two responses. One response supported publication of the draft while the other was opposed to it. The respondent voicing support for the draft offered no rationale. The respondent objecting offered many editorial comments, but almost no rationale for blocking the draft once the editorial comments are addressed.
> 
> Because the October 10 last call elicited so little response, and because many community members have privately expressed strong opinions regarding this draft, I will summarize outstanding issues below. The following are arguments *against* draft-weil-shared-transition-space-request:
> 
> - Allocation of a special-use /10 does not hasten the deployment of IPv6. It only extends the life of the IPv4 network.
> - If a special-use /10 is allocated, it will be used as additional RFC 1918 address space, despite a specific prohibition against such use stated by the draft.
> - If a special-use /10 is allocated, it will encourage others to request still more special-use address space.
> - Some applications will break. These applications share the characteristic of assuming that an interface is globally reachable if it is numbered by an non-RFC 1918 address. To date, the only application that has been identified as breaking is 6to4, but others may be identified in the future.
> 
> Arguments *supporting* draft-weil-shared-transition-space-request-09 assume that operators will deploy CGNs and will number the interfaces between CGN and CPE. If the /10 proposed by draft-weil-shared-transition-space-request is not allocated, operators will number from one of the following:
> 
> - public address space 
> - RFC 1918 address space
> - squat space
> 
> If operators number from public address space, they will deplete an already scarce resource. If operators number from RFC 1918 space and the same RFC 1918 space is used on the customer premise, some CPE will behave badly. The consequences of numbering from squat space are determined by the squat space that is chosen.
> 
> In summary, allocation of the /10 will have certain adverse effects upon the community. However, failure to allocate the /10 will have different adverse effects on the community. The IESG is being asked to choose the lesser of two evils.
>                                                                
> 
> --------------------------
> Ron Bonica
> vcard:       www.bonica.org/ron/ronbonica.vcf

---

From: Måns Nilsson <[email-masked]>
Date: Wed, 30 Nov 2011 09:39:15 +0100

I do not support forwarding the draft (In fact, i oppose it
strongly.). Chopping away bits of the usable v4 space to create more
unusable space does not in any way help.

I can but hope to emulate Randys terse and on-the-spot argumentation,
so I'll have to make do with concurring.

-- 
Måns Nilsson     primary/secondary/besserwisser/machina
MN-1334-RIPE                             +46 705 989668
LBJ, LBJ, how many JOKES did you tell today??!

---

From: [email-masked] (Noel Chiappa)
Date: Wed, 30 Nov 2011 11:53:25 -0500 (EST)

> From: Ronald Bonica <[email-masked]>

    > Allocation of a special-use /10 does not hasten the deployment of IPv6.

<Snark=0 - or as close to it as I can humanly manage.>

So, after reading the back-and-forth in the thread, I'm moved to come back to
this. Just what measures, within the I*'s purview, do you (and the rest of
the IESG, and the IAB) think _will_ hasten the deployment of IPv6?

Because the I* has had very little success in getting IPv6 deployed over the
last couple of decades. With this many smart people involved, you'd think
that if there was a good way to make it happen, somebody would have worked it
out by now.

And if there is no good way to "hasten the deployment of IPv6", if something
_does not_ have that property - is that really a strike against it?

	Noel