Subject: Re: The death John McCarthy

From: Donald Eastlake <[email-masked]>
Date: Tue, 1 Nov 2011 08:04:17 -0400

I worked at the MIT AI Lab for a number of years and visited SAIL several times.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Mon, Oct 31, 2011 at 5:59 PM, Steve Crocker <[email-masked]> wrote:
> I was at the MIT AI Lab 1967-68 and at ARPA/IPTO 1961-74 where I funded and reviewed the Stanford AI Lab.  Later I based my PhD thesis on McCarthy's memo on situational fluents.  I also designed but didn't implement Lisp for the Sigma 7.
>
> Later I ran research groups and insisted on Lisp as a requirement.
>
> Steve
>
> Sent from my iPhone
>
> On Oct 31, 2011, at 3:44 PM, todd glassey <[email-masked]> wrote:
>
>> On 10/28/2011 1:25 PM, Randy Bush wrote:
>>>>> First, as someone who chartered the working group, who has
>>>>> implemented Lisp (the programming language) at least four times, and
>>>>> who views Dr. McCarthy as a hero I disagree that name is problematic
>>>>> or disrespectful. And I almost take offense in the claim that this is
>>>>> a generational thing.
>>>> And frankly, if there's disrespect to be found here, IMO it lies in
>>>> using this sad event as a proxy to criticize some IETF work some
>>>> people apparently don't like.
>>
>> So how many people here actually knew or worked with John... or what he was working on?  its a relevant question because there seem to be a number of people speaking from authority... so how many of you were around in the 1960's and 1970's at AI (either MIT or SU)?
>>
>> I bring this up as [email-masked]...
>>
>> T///
>>> <aol>
>>> _______________________________________________
>>> Ietf mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ietf
>>>
>>
>>
>> --
>> Todd S. Glassey
>> This is from my personal email account and any materials from this account come with personal disclaimers.
>>
>> Further I OPT OUT of any and all commercial emailings.
>>
>> _______________________________________________
>> Ietf mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ietf
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Eric Burger <[email-masked]>
Date: Tue, 1 Nov 2011 09:21:34 -0400

By the time period Steve talks about I was out of diapers and able to toddle on my own.

Fast forward a few years and I was exposed to LISP (the real one, not the IETF one) when I did my thesis at the MIT LCS and fell in love with it.  To the point that I regularly argued with various cretins from Berkeley who felt that C, not LISP, was the language of the gods.  It took a true grey beard to interject and say that assembly language was the language of the gods, because both LISP and C compiled into machine language, so if you could not write a program in assembly language, you could not write it at all. My rebuttal that we had lots of LISP machines hanging around didn't make much of an impact on the argument.

Since the relative demise of LISP/Scheme and the ascension of the semicolon over the parenthesis, MIT has gotten its revenge, inflicting the angle bracket in the parenthesis' place through the global adoption of XML.

Yes, I *have* seen XML language proposals that look deceptively identical to the lambda calculus...

---

From: Jari Arkko <[email-masked]>
Date: Fri, 04 Nov 2011 13:53:38 +0200

FYI - we talked about the name of the group in the IESG meeting last night. After a review of the thread, the IESG concluded that there is no consensus to change the name of the LISP working group. But judging from the interest in the rest of the discussion, I'm standing by and awaiting for the large amount of feedback that we will get when the main spec goes to IETF Last Call (which is expected to happen soon).

Jari