Subject: Re: I-D Action: draft-balaji-mpls-lawful-intercept-thru-label-dis-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Mon, 30 Jul 2012 10:04:33 +0100

Under the long-standing IETF policy defined in RFC 2804, I trust
we will not be discussing this draft, or
draft-balaji-l2vpn-lawful-intercept-thru-label-dis, in the IETF.

Regards
   Brian Carpenter

On 30/07/2012 09:26, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : Label-based Provider-Provisioned Lawful Intercept for L3 VPNs
> 	Author(s)       : Shankar Raman
>                           Balaji Venkat Venkataswami
>                           Gaurav Raina
>                           Vasan Srini
>                           Bhargav Bhikkaji
> 	Filename        : draft-balaji-mpls-lawful-intercept-thru-label-dis-00.txt
> 	Pages           : 12
> 	Date            : 2012-07-30
> 
> Abstract:
>    In models of Single-AS and inter-provider Multi- Protocol Label
>    Switching (MPLS) based Virtual Private Networks (VPNs) Lawful
>    Intercept is a key requirement. For example, MPLS-based Layer 3 VPN
>    models like VPLS and the like do not have any provider provisioned
>    methods of lawful intercept that are comprehensive, quick and easy to
>    provision from one single point. More particularly the auto-
>    provisioning of lawful intercept for all sets of streams travelling
>    between VPN sites and consequent re-direction of these streams to the
>    appropriate government network has not been covered without multiple
>    instances of having to configure the intercept at various points in
>    the network both in the Single-AS case and the Inter-Provider VPN
>    case.
> 
>    this paper, we propose a technique which uses a set of pre-defined
>    labels called Lawful Intercept labels and a method for provisioning
>    lawful intercept amongst the various PE devices using these labels
>    both in the Single-AS and the inter-provider VPN cases. A single
>    point of configuration is the key to this idea. The intercepted
>    traffic is mirrored on a PE or a whole set of PEs or on all the PEs
>    participating in the VPN. A technique called the Domino-effect
>    provisioning of these Label-based Provider Provisioned Lawful
>    Intercept mechanism is also outlined.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-balaji-mpls-lawful-intercept-thru-label-dis
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-balaji-mpls-lawful-intercept-thru-label-dis-00
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Randy Bush <[email-masked]>
Date: Mon, 30 Jul 2012 08:57:07 -0700

> draft-balaji-l2vpn-lawful-intercept-thru-label-dis, in the IETF.

<aol>

---

From: Scott O Bradner <[email-masked]>
Date: Mon, 30 Jul 2012 12:33:54 -0400

2804 does not say not to talk about such things - or that such documents should
not be published as RFCs  - 2804 says that the IETF will not do standards work
in this area

Scott

---

From: Eric Burger <[email-masked]>
Date: Mon, 30 Jul 2012 10:08:21 -0700

We seem to be doing a lot of talking about the draft.

---

From: Randy Bush <[email-masked]>
Date: Mon, 30 Jul 2012 10:33:53 -0700

> not be published as RFCs  - 2804 says that the IETF will not do standards work

for those of us who are easily confused, could you differentiate between
working on douments and publishing them as rfcs from doing standards
work?

randy

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 30 Jul 2012 18:51:06 +0100

Yes, Scott, that is correct, sorry for my poor phrasing.

   Brian

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 30 Jul 2012 19:26:35 +0100

I agree with the comments about 2804.

I do note a lot of April 1 RFCs in the references
though, so maybe its all a joke.

S

---

From: Glen Zorn <[email-masked]>
Date: Mon, 30 Jul 2012 11:35:57 -0700

> though, so maybe its all a joke.

Gotta be!

---

From: Loa Andersson <[email-masked]>
Date: Tue, 31 Jul 2012 12:40:13 +0200

Scott,

would you say that drafts aimed for experimental status are "standards
work".

/Loa

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 31 Jul 2012 12:14:06 +0100

Loa,

I can't speak for Scott, but I think the problem arises if any
IANA assignments are needed, regardless of RFC status. That's
because RFC 2804 speaks of "the process for creating and maintaining
IETF standards." IANA assignments are part of standards maintenance
(IMHO, of course).

Don't forget that 2804 *also* says

"  - On the other hand, the IETF believes that mechanisms designed to
     facilitate or enable wiretapping, or methods of using other
     facilities for such purposes, should be openly described, so as to
     ensure the maximum review of the mechanisms and ensure that they
     adhere as closely as possible to their design constraints. The IETF
     believes that the publication of such mechanisms, and the
     publication of known weaknesses in such mechanisms, is a Good
     Thing."

So it's a delicate balance.

    Brian

On 31/07/2012 11:40, Loa Andersson wrote:
>>>>     Filename        :
>>>> draft-balaji-mpls-lawful-intercept-thru-label-dis-00.txt
>>>>     Pages           : 12
>>>>     Date            : 2012-07-30
>>>>
>>>> Abstract:

---

From: Steven Bellovin <[email-masked]>
Date: Tue, 31 Jul 2012 07:30:07 -0700

Also note that RFC 3924 exists.

>>>>> ftp://ftp.ietf.org/internet-drafts/

		--Steve Bellovin, https://www.cs.columbia.edu/~smb