Subject: Re: Last Call: <draft-hoffman-tao-as-web-page-02.txt> (Publishing the "Tao of the IETF" as a Web Page) to Informational RFC

From: John C Klensin <[email-masked]>
Date: Thu, 05 Jul 2012 10:43:27 -0400

--On Friday, June 15, 2012 13:29 -0700 The IESG
<[email-masked]> wrote:

> The IESG has received a request from an individual submitter
> to consider the following document:
> - 'Publishing the "Tao of the IETF" as a Web Page'
>   <draft-hoffman-tao-as-web-page-02.txt> as Informational RFC

> The IESG plans to make a decision in the next few weeks, and
> solicits final comments on this action. Please send
> substantive comments to the [email-masked] mailing lists by
> 2012-07-13.

Hi.

Just to make a pair of comments that I've sort of made in other
contexts in the particular context of the Last Call.   I won't
repeat the details.

(1) As a general strategy, doing the Tao as a web page seems
like exactly the right thing to do.  Some sort of staging
process and opportunity for review of working drafts by the
community as well as the IETF seems important.  As far as I can
tell, the document covers that adequately although some details
are not spelled out as well as some would perhaps prefer.

(2) The document itself mixes a historical discussion of how
things got to where they are with what is being done going
forward.   I believe it would be desirable to more clearly
separate that material, into either separate documents or into a
brief core document that focuses of the three questions of "what
is the Tao", "where can it be found", and "what is the revision/
update procedure" and an appendix that includes whatever else is
determined to be necessary.  In that regard, the abstract of the
core (or only) document should not concentrate on when
discussions occurred, etc., but simply on what the Tao is and
why it might be useful.  Liberal borrowing from the abstract of
RFC 4677 (or just copying it) would be, IMO, quite appropriate.  

This is less of a problem than it might otherwise be because the
document is so short, but a document that obsoletes RFC 4677 and
its predecessors should address the substances addressed by
4677, not serve as a historical summary of a few months of
community discussion.

Nits: 
(i) In recent years, the IESG has insisted on specific
documentation when one RFC obsoletes another.  This draft does
not mention the "obsoletes" relationship in the Abstract,
Introduction, or any other prominent place.

(ii) Second paragraph of current Introduction, first sentence,
should contain "discussion that led..." rather than "discussion
that lead...".  I believe that paragraph is part of the
historical discussion that belongs somewhere else.

thanks,
   john

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 5 Jul 2012 14:19:06 -0700

Based on many people's input (most recently, John's), I have updated the draft to more cleanly separate out the history of the Tao from the change that is happening.

--Paul Hoffman

A new version of I-D, draft-hoffman-tao-as-web-page-03.txt
has been successfully submitted by Paul Hoffman and posted to the
IETF repository.

Filename:	 draft-hoffman-tao-as-web-page
Revision:	 03
Title:		 Publishing the "Tao of the IETF" as a Web Page
Creation date:	 2012-07-05
WG ID:		 Individual Submission
Number of pages: 3
URL:             http://www.ietf.org/internet-drafts/draft-hoffman-tao-as-web-page-03.txt
Status:          http://datatracker.ietf.org/doc/draft-hoffman-tao-as-web-page
Htmlized:        http://tools.ietf.org/html/draft-hoffman-tao-as-web-page-03
Diff:            http://tools.ietf.org/rfcdiff?url2=draft-hoffman-tao-as-web-page-03

Abstract:
  This document describes how the "Tao of the IETF", which has been
  published as a series of RFCs in the past, will instead be published
  as a web page.

---

From: John C Klensin <[email-masked]>
Date: Thu, 05 Jul 2012 17:34:55 -0400

--On Thursday, July 05, 2012 14:19 -0700 Paul Hoffman
<[email-masked]> wrote:

> Based on many people's input (most recently, John's), I have
> updated the draft to more cleanly separate out the history of
> the Tao from the change that is happening.

Paul,

While I'd prefer to see you go even further in that direction
(e.g., incorporating more of the RFC 4677 Abstract in this
abstract, constructing things so that changes in the details of
editing procedures doesn't require a revised RFC), this version
is, IMO, greatly improved.

thanks
   john

---

From: Tony Hansen <[email-masked]>
Date: Thu, 05 Jul 2012 17:45:59 -0400

I've read this version and think it's an excellent revision.

Is there going to be a way of seeing a list of all the versions of the 
tao? Or links within tao.html to the previous version? Perhaps a 
www.ietf.org/tao/ should be maintained that has pointers to all the 
versions as well any proposed update.

     Tony Hansen
     [email-masked]

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 5 Jul 2012 15:02:37 -0700

On Jul 5, 2012, at 2:45 PM, Tony Hansen wrote:

> Is there going to be a way of seeing a list of all the versions of the tao? Or links within tao.html to the previous version? Perhaps a www.ietf.org/tao/ should be maintained that has pointers to all the versions as well any proposed update.

I think the Tao web page should point to RFC 4677 in a "well, how did I get here?" section, given that this is not the same as it ever was.

--Paul Hoffman

---

From: Tony Hansen <[email-masked]>
Date: Thu, 05 Jul 2012 23:22:24 -0400

I think my point was missed. Section 2 says:

All published versions will be archived using URLs of the form 
<http://www.ietf.org/tao-YYYYMMDD.html>.

My question is: Where is there a list of all of the tao version files? 
How would one be able to find out the name of the previous version so 
they could do a diff and see what has changed? How can I see a history 
of the files?

Here is a suggested addition to section 2:

     Each version of the Tao will also have a link to a history page of 
all versions.

Or something like that. The mechanics what that page looks like can be 
determined later -- it doesn't really matter right now, nor does it 
matter right now what the address is.

     Tony Hansen

---

From: John C Klensin <[email-masked]>
Date: Thu, 05 Jul 2012 23:57:35 -0400

--On Thursday, July 05, 2012 23:22 -0400 Tony Hansen
<[email-masked]> wrote:

> My question is: Where is there a list of all of the tao
> version files? How would one be able to find out the name of
> the previous version so they could do a diff and see what has
> changed? How can I see a history of the files?
>...

Tony,

Mostly out of curiosity, why do you think it is important.   If
the Tao were a reference document that was authoritative on IETF
procedures or the like, it would be a different matter: I can
think of many reasons why it might be important to establish
exactly what the rules and procedures were at any given time.
But, given that it is a non-authoritative tutorial summary
description of how we do things, I have a certain amount of
trouble understanding why going to extra effort to maintain a
long-term back trace is actually important.

What am I missing?

    john

---

From: Tony Hansen <[email-masked]>
Date: Fri, 06 Jul 2012 00:28:50 -0400

Authoritative, no. But definitely referenced by many, many people and 
IMO worthy of a certain amount of care.

     Tony Hansen

---

From: John C Klensin <[email-masked]>
Date: Fri, 06 Jul 2012 07:04:31 -0400

--On Friday, July 06, 2012 00:28 -0400 Tony Hansen
<[email-masked]> wrote:

> Authoritative, no. But definitely referenced by many, many
> people and IMO worthy of a certain amount of care.

No disagreement about care.  But it seems to me that adequate
care requires keeping track of a future version, a current
version, and a previous version (or maybe two).   The ability to
easily find and trace back through the entire history of the
document seems appropriate for something normative but well
beyond what is required for reasonable care with a document like
this.

Just my opinion, however.  I have trouble convincing myself that
the issue is really important enough to hold things up.

    john

---

From: SM <[email-masked]>
Date: Fri, 06 Jul 2012 04:12:37 -0700

At 20:22 05-07-2012, Tony Hansen wrote:
>My question is: Where is there a list of all of the tao version 
>files? How would one be able to find out the name of the previous 
>version so they could do a diff and see what has changed? How can I 
>see a history of the files?

The interesting question is at 
http://www.ietf.org/mail-archive/web/ietf/current/msg73889.html  I 
did not ask Julian whether he was thinking about cool URIs [1].  The 
information about common HTTP implementation problems [2] may be 
relevant to the discussion.  After I read the message at 
http://www.ietf.org/mail-archive/web/ietf/current/msg73892.html I 
could not understand why it was not possible as there is mod_rewrite.

I don't think that all this is important in a draft which is about of 
a tutorial.

Regards,
-sm

1. http://www.w3.org/Provider/Style/URI
2. http://www.w3.org/TR/chips/