Subject: Re: Will mailing lists survive DMARC?

From: S Moonesamy <[email-masked]>
Date: Tue, 29 Apr 2014 09:25:16 -0700

Hi Alessandro, Mikael, Patrik, John,
At 04:10 29-04-2014, Alessandro Vesely wrote:
>There has been some discussion on what should the IETF do about the
>collateral damage experienced by several mailing lists when major
>mailbox providers switch their DMARC policies to p=reject.

[snip]

>The DMARC draft is currently in "AD Followup" state.  A review was
>posted here last week, a process which doesn't seem to affect
>deployment much.

My review was sent to the ISE.  It was copied to 
the [email-masked] mailing list for informational 
purposes.  I did not expect the review to affect deployment.

>How is the IETF going to proceed on this issue?

The above question could be ignored as it is 
addressed to everybody and nobody on this mailing list. :-)

At 04:22 29-04-2014, Mikael Abrahamsson wrote:
>I would really like to see the standards process 
>for this mechanism be stopped until the mailing 
>list problem has been sorted out. I don't really 
>understand how it got that far with this problem unsolved.

It is likely because only a few persons tried to 
do something when it was possible to do so.  A 
significant number of possible (IETF) issues go 
unnoticed as it is not always clear whether they will cause problems.

At 05:55 29-04-2014, Patrik Fältström wrote:
>The problem exists if A is publishing such a 
>policy, B is acknowledging the policy, B is 
>generating a bounce, and the bounce is hitting the mailing list provider.
>
>I do not understand why a bounce should be 
>generated (and not the incoming mail to B would 
>be tagged as spam and/or null-routed).

I posted a simplified example of the problem at 
http://www.ietf.org/mail-archive/web/ietf/current/msg87286.html 
Silently dropping messages (null-routed) creates mail blackholes.

At 07:39 29-04-2014, John C Klensin wrote:
>So, as a purely hypothetical set of questions (I am not
>recommending anything), I wonder what would happen if some of
>the people who have been claiming they or the general public are
>harmed by this would, instead of asking what the IETF can do
>about something that is not an IETF Standard, went to their
>local "competitiveness" or "antitrust" authorities, explained
>the situation and started complaining?   I also wonder whether

The regulator might start an investigation.  The 
(lack of) results can be used as input for governance issues.

There is someone from the European Union reading 
this mailing list.  The person might be able to comment to help Alessandro.

Regards,
S. Moonesamy

---

From: Patrik Fältström <[email-masked]>
Date: Tue, 29 Apr 2014 20:05:07 +0200

On 29 apr 2014, at 18:25, S Moonesamy <[email-masked]> wrote:

>> The problem exists if A is publishing such a policy, B is acknowledging the policy, B is generating a bounce, and the bounce is hitting the mailing list provider.
>> 
>> I do not understand why a bounce should be generated (and not the incoming mail to B would be tagged as spam and/or null-routed).
> 
> I posted a simplified example of the problem at http://www.ietf.org/mail-archive/web/ietf/current/msg87286.html Silently dropping messages (null-routed) creates mail blackholes.

Yes, correct, but I already see lots of this.

I.e. just like any >N points in spamassassin.

Anyway, I do now understand the issue and thank everyone that onlist and offlist have explained the issue to me.

   Patrik