Subject: Call for Review of draft-iab-itat-report, "Report from the IAB workshop on Internet Technology Adoption and Transition (ITAT)"

From: IAB Chair <[email-masked]>
Date: Thu, 17 Apr 2014 22:11:13 -0400

This is a call for review of "Report from the IAB workshop on Internet Technology Adoption and Transition (ITAT)" prior to potential approval as an IAB stream RFC.

The document is available for inspection here:
https://datatracker.ietf.org/doc/draft-iab-itat-report-/

The Call for Review will last until 16 May 2014.  Please send comments to [email-masked]. 

On behalf of the IAB,
Russ Housley
IAB Chair

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 18 Apr 2014 07:10:58 +0200

> https://datatracker.ietf.org/doc/draft-iab-itat-report-/

FWIW, the correct URL is:

<https://datatracker.ietf.org/doc/draft-iab-itat-report/>

> The Call for Review will last until 16 May 2014.  Please send comments to [email-masked]. 

   Patrik

---

From: S Moonesamy <[email-masked]>
Date: Thu, 17 Apr 2014 23:11:31 -0700

Hello,
At 19:11 17-04-2014, IAB Chair wrote:
>This is a call for review of "Report from the IAB workshop on 
>Internet Technology Adoption and Transition (ITAT)" prior to 
>potential approval as an IAB stream RFC.
>

I read the report.  Section 2 mentions that SMTP and IMAP in the 
applications space have continued to evolve.  I have not see much 
evolution in the SMTP space.  I'll leave the relevant people to 
comment about IMAP.  As a nit, the reference for IPv6 is incorrect.

Section 5.1 mentioned that the workshop looked at patents as a means 
to improve interoperability.  Are there any papers about the two 
sides of the argument?

Section 7 mentions that the role of the IAB (in respect to working 
group formation) consists of providing guidance to the IESG on which 
birds of a feather sessions should be held, review of proposed 
working group charters, and shepherding some work so that it can 
reach a suitable stage for standardization.  What is the role of the 
IAB in respect to technology adoption?  A protocol, as viewed by the 
IETF, is one part of the technology.  How does the IAB communicate 
that "big picture" to the average IETF participant?  How does the IAB 
reach out to governments?

Section 7.3 mentions that "As we considered work in the workshop, our 
partners such as ICANN and the RIRs can continue to play a role in 
encouraging deployment of protocols through their policies".  That's 
names and numbers.  Is it the view of members of the IAB (in an 
individual capacity) that these bodies can provide incentives for 
IPv6 adoption?

The reports mentions that IETF working groups could leverage graduate 
students in many universities around the world in helping review 
documents (drafts, RFCs etc.).  I personally do not think that it 
would help the review workload.  Anyway, what's the technology 
adoption angle here?

The questions which were asked recently is who takes (some) 
responsibility for the technology and how things are being done 
outside the IETF.  The report does not provide new light about 
that.  I did not find the report interesting as it discussed about 
the same old stuff and the conclusion is that the topics deserve 
further exploration.  The same conclusion could be reached if a 
similar workshop was organized next year.  The report does not 
discussion about transition in any way.  How does the IETF move from 
Technology X to Technology Y?  What are the impediments created by 
the IETF?  Does the IETF even have the ability to influence the 
deployment of the technology?

Regards,
S. Moonesamy

---

From: <[email-masked]>
Date: Fri, 18 Apr 2014 08:57:46 +0100

the correct url is
https://datatracker.ietf.org/doc/draft-iab-itat-report/
no trailing minus. why cite a broken url?

evolution in the smtp space? Um, DMARC?

for thoughts on http as an hourglass waist, see
http://personal.ee.surrey.ac.uk/Personal/L.Wood/publications/internet-drafts/draft-wood-dtnrg-http-dtn-delivery/lloyd-wood-turning-http-into-a-standalone-layer-ietf-75-tsvarea-slides.pdf
- it's a little hard to see http as a waist when it's so tightly coupled to tcp. That is unlikely to change, as the benefits of uncoupling are for edge cases.

many involved in the ietf, myself included, began contributing as grad students. As with academic paper review, it's how the interested/enthusiastic/unpaid learn.

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf [[email-masked]] On Behalf Of S Moonesamy [[email-masked]]
Sent: 18 April 2014 07:11
To: [email-masked]
Cc: [email-masked]
Subject: Internet Technology Adoption and Transition

Hello,

Regards,
S. Moonesamy

---

From: S Moonesamy <[email-masked]>
Date: Fri, 18 Apr 2014 06:41:13 -0700

Hi Lloyd,
>no trailing minus. why cite a broken url?

I should have removed the URL instead of citing it.

>evolution in the smtp space? Um, DMARC?

I am reading "SMTP" narrowly and did not consider DMARC as part of the space.

 From 
<http://www.iab.org/wp-content/IAB-uploads/2013/06/itat-2013_submission_5.docx>http://www.iab.org/wp-content/IAB-uploads/2013/06/itat-2013_submission_5.docx 
examples of DNSSEC-based applications are mentioned and there is the following:

    "The DMARC wg is working on higher-level use of DKIM and SPF."

The technology for those two specifications is mostly related to DNS.

>- it's a little hard to see http as a waist when it's so tightly 
>coupled to tcp. That is unlikely to change, as the benefits of 
>uncoupling are for edge cases.

Thanks for the URL.  I would say yes to the comment about tightly 
coupled.  I'd say that they are seen as the transport and you end up 
with other protocols being designed on top of that.

>many involved in the ietf, myself included, began contributing as 
>grad students. As with academic paper review, it's how the 
>interested/enthusiastic/unpaid learn.

Yes.

Regards,
S. Moonesamy

---

From: [email-masked]
Date: Tue, 22 Apr 2014 19:53:37 -0700 (PDT)

> comment about IMAP.  As a nit, the reference for IPv6 is incorrect.

I'm not sure what the report means by "evolve", but by any reasonable
definition, I believe SMTP continues to evolve.

If you're talking about standards work, the IESG just approved the RRVS
document which specifies a new SMTP extension. In recent times we've approved
other extensions such as MT-PRIORITY. And let's not forget about EAI, which is
a pretty major evolution of the protocol.

And this process continues. I rather expect we'll see changes in the 
STARTTLS space in the not too distant future.

If you're talking about implementations, the first thing to note is that
given the relatively small number of implementations in wide use, a change
to even one or two of them is significant. And while progess is slow,
it's pretty constant from my perspective.

As for actual deployment, things are even more skewed, which makes them
difficult to measure. For example, if a major wireless vendor implements the
BINARY extension in both their client and their own server, that can affect a
huge swath of traffic without any need for anyone else to change.

The deployment of older extensions also changes over time, and it doesn't
always increase. I'm fairly sure I'm seeing more of ENHANCEDSTATUSCODES but
less of NOTARY. (And yeah, I know given the relationship between the two that's
wierd. I'm just reporing what I've observed.)

Moreover, there can be evolutionary changes having nothing to do with
extensions per se. For example, it seems that not only is use of STARTTLS on
the rise, what cipher suites are enabled seems to be changing, probably because
a lot of sites are actually paying attention to such details when prior to the
Snoden thing they care.

				Ned

---

From: S Moonesamy <[email-masked]>
Date: Thu, 24 Apr 2014 08:05:43 -0700

Hi Ned,
>definition, I believe SMTP continues to evolve.

Ok.

>it's pretty constant from my perspective.

I was looking at it in terms of what is implemented and what is 
deployed.  There has been standards work; some of examples are 
mentioned above.  I agree that EAI is a pretty major evolution of the protocol.

>huge swath of traffic without any need for anyone else to change.

There are different ways to look at usage.  As an example, BINARY may 
be about 25% of what's deployed (please treat that figure as unverified).

>wierd. I'm just reporing what I've observed.)

The statistics I looked at show a little more of ENHANCEDSTATUSCODES.

>a lot of sites are actually paying attention to such details when prior to the

I haven't look into the STARTTLS statistics recently to be able to 
compare the figures with the ones before the Snow thing.

Regards,
S. Moonesamy