Subject: Re: [secdir] secdir review of draft-moonesamy-sshfp-ed25519-01

From: Stephen Farrell <[email-masked]>
Date: Fri, 30 May 2014 23:42:31 +0100

On 30/05/14 23:22, S Moonesamy wrote:
> Hi Joe,
> At 13:42 30-05-2014, Joseph Salowey (jsalowey) wrote:
>> [Joe] My concern is that there is not enough information in the draft
>> to know what goes into the hash that is the subject of the code point
>> assignment.  Perhaps it is obvious to someone who implemented the SSH
>> code that is not documented in this draft, but it is not obvious to me
>> as a reader of the draft.
> 
> That's a fair point.  I propose adding the following text in Section 2
> as a warning to the reader:
> 
>   The format of the ED25519 public key with SHA-256 fingerprint is
>   not documented in an authoritative specification.

Why? Why not just look at the code and write down what that does
in terms of formatting the input.

If >1 implementation interoperates it can't be that hard.

S.

> Regards,
> S. Moonesamy

---

From: Uri Blumenthal <[email-masked]>
Date: Sat, 31 May 2014 22:53:06 -0400

I reject S. Moonesamy's proposal, and strongly support Stephen's recommendation.

Sent from my iPad

> On May 30, 2014, at 18:42, Stephen Farrell <[email-masked]> wrote:
> 
> 
>