Subject: RFP: IETF Website Revamp

From: IETF Administrative Director <[email-masked]>
Date: Mon, 16 Jun 2014 17:20:35 -0700

The IETF Administrative Oversight Committee (IAOC), on behalf of the IETF, announces this 
Request for Proposals for a revamp of the IETF website, www.ietf.org.  The successful bidder 
will enter into a contract with the Internet Society.

The Internet Engineering Task Force (IETF) desires a revamp of its website to update the IETF's
 public-facing website, providing a "front door" for the IETF, including access to all the information 
that IETF participants need to accomplish their work.  Intended audiences include active participants, 
new or potential participants, and those looking to learn more about the IETF.  Goals include improving 
ease of navigation, accessibility by mobile devices, and content maintenance.

The RFP can be found at: <https://iaoc.ietf.org/rfps.html>.

Proposals must be received via email at [email-masked] no later than July 7, 2012.  All questions,
inquiries must be submitted by June 23, 2014.  Responses to questions and inquiries shall be posted 
online at:  <https://iaoc.ietf.org/rfps.html> by June 27, 2014. 

The point of contact regarding this RFP is the IETF Administrative Director, Ray Pelletier, [email-masked].

Ray Pelletier
IAD

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 17 Jun 2014 09:15:44 -0700

Oh whow...

Almost every time in the last few years that i have seen web pages
of other companies/organizations being "revamped", it ended up
being worse in before. I caution you to refine the requirements
to consider the following problems:

 - Loading must not be slower than now, especially not because of
   a lot of use of graphical elements. Consider large RTT performance
   testing results as a factor.
 - The ability to translate ietf pages via web based translate services
   must be equal or better than now. This btw also mean that
   graphical elements are NOT helpfull in general..
 - The quality of representation in lynx must be equal or better than now.
 - The ability to correctly view the content when zooming in/out in
   a browser must be equal or better than now. Some graphical
   SDKs start cutting of visible text when zooming in. Really bad.
 - The ability to print out web pages must be equal or better than now.
 - The version for mobile devices must not be just a subset of information,
   unless it is very easy to also get to the full set of information.

Btw: I think the current IETF pages are for me as a user compared
to all the other graphicrap out there pretty darn good to get real
work done. Which makes me especially nervuous when i hear revamp...

Cheers
    Toerless

-- 
---
Toerless Eckert, [email-masked]
Cisco NSSTG Systems & Technology Architecture
SDN: Let me play with the network, mommy!

---

From: Russ Housley <[email-masked]>
Date: Tue, 17 Jun 2014 12:57:13 -0400

Toerless:

You know that the statement of work was sent out twice for review and comment.

https://mailarchive.ietf.org/arch/msg/ietf-announce/4hL91GT5za24PTS-LZ1M-ztAA6s
https://mailarchive.ietf.org/arch/msg/ietf-announce/o9csPR_gabYYiXBb-0kMQZvM98c

These comments would have been much more useful at either of those times.

Russ

---

From: John C Klensin <[email-masked]>
Date: Wed, 18 Jun 2014 10:11:51 -0400

> These comments would have been much more useful at either of

Russ,

(1) Yes

(2) I believe that, other than reinforcing prior messages, there
is little or nothing in Torless's message that is actually new,
i.e., that did not appear in those prior rounds or that was
implied by comments that did appear then.

(3) It would have been really helpful had the IAOC or IAD chosen
to summarize what is different about the request/ SOW this time
relative to its predecessors.  As an equivalent, a summary by
the IAOC of its responses to comments on the prior draft SOWs
would have been helpful.  Either would have led, I believe, to a
much more focused discussion this time around.

best,
    john