Subject: Re: RFP: IETF Website Revamp

From: Randy Presuhn <[email-masked]>
Date: Tue, 17 Jun 2014 09:58:56 -0700 (GMT-07:00)

Hi -

>From: Toerless Eckert <[email-masked]>
>Sent: Jun 17, 2014 9:15 AM
>To: [email-masked], [email-masked]
>Cc: IETF Announcement List <[email-masked]>
>Subject: Re: RFP: IETF Website Revamp
>
>Oh whow...
>
>Almost every time in the last few years that i have seen web pages
>of other companies/organizations being "revamped", it ended up
>being worse in before.

Yes.

>I caution you to refine the requirements
>to consider the following problems:
>
> - Loading must not be slower than now, especially not because of
>   a lot of use of graphical elements. Consider large RTT performance
>   testing results as a factor.

Yes.

> - The ability to translate ietf pages via web based translate services
>   must be equal or better than now. This btw also mean that
>   graphical elements are NOT helpfull in general..

Yes.

> - The quality of representation in lynx must be equal or better than now.

Ok.  I wouldn't just single Lynx out...

> - The ability to correctly view the content when zooming in/out in
>   a browser must be equal or better than now. Some graphical
>   SDKs start cutting of visible text when zooming in. Really bad.

Yes.  In particular, it should not be necessary to zoom under
normal circumstances.  Using the "text size" setting of browsers
having such a feature should just work.

> - The ability to print out web pages must be equal or better than now.

Yes.

> - The version for mobile devices must not be just a subset of information,
>   unless it is very easy to also get to the full set of information.

Ok.

>Btw: I think the current IETF pages are for me as a user compared
>to all the other graphicrap out there pretty darn good to get real
>work done. Which makes me especially nervuous when i hear revamp...

Amen.  Though I'd still prefer the *previous* version of the
IETF website.  Much less cluttered.

Randy

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 18 Jun 2014 08:13:46 +1200

On 18/06/2014 04:58, Randy Presuhn wrote:
...
> IETF website.  Much less cluttered.

Why I use http://www.ietf.org/content.html

  Brian

---

From: Andy Bierman <[email-masked]>
Date: Wed, 18 Jun 2014 17:39:13 -0700

On Tue, Jun 17, 2014 at 9:58 AM, Randy Presuhn <[email-masked]
> wrote:

> >of other companies/organizations being "revamped", it ended up

I think the IETF WEB site is getting better over time, especially wrt/
auto-generated links to tools on various pages. (Thank you tools team! :-)

> >   testing results as a factor.

Sure, but if there are better auto-generated navigation links, perhaps you
find the right content in 2 clicks instead of 3 and save a page load.
Faster user experience is more than individual RTT.

Andy

---

From: [email-masked]
Date: Thu, 19 Jun 2014 14:02:24 -0400

> Faster user experience is more than individual RTT.

It's not even about clicks anymore.

For grins, hit www.google.com, and use tcpdump or similar to watch how many
network interactions happen for auto-complete suggestions as you type a query.