Subject: Re: [weirds] Last Call: <draft-ietf-weirds-json-response-10.txt> (JSON Responses for the Registration Data Access Protocol (RDAP)) to Proposed Standard

From: Edward Lewis <[email-masked]>
Date: Fri, 17 Oct 2014 17:41:34 +0000

Just two nits:

Comment 1

In section 5.2 the term/phrase “first-class” as in "name server model” is
used twice but never defined.

I don’t have a suggested fix.

Comment 2

While looking for something else, I noted one use of “secure DNSSEC” in
section 14, probably meant “secure DNS” there.

---

From: Andy Newton <[email-masked]>
Date: Wed, 22 Oct 2014 00:09:47 +0000

From: Edward Lewis <[email-masked]<mailto:[email-masked]>>
Date: Friday, October 17, 2014 at 1:41 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Andrew Newton <[email-masked]<mailto:[email-masked]>>, Scott Hollenbeck <[email-masked]<mailto:[email-masked]>>
Subject: Re: [weirds] Last Call: <draft-ietf-weirds-json-response-10.txt> (JSON Responses for the Registration Data Access Protocol (RDAP)) to Proposed Standard

Just two nits:

Comment 1

In section 5.2 the term/phrase “first-class” as in "name server model” is used twice but never defined.

It’s a generic term of art. Do we really want to be defining it in RFCs?
http://en.wikipedia.org/wiki/First-class_citizen

Comment 2

While looking for something else, I noted one use of “secure DNSSEC” in section 14, probably meant “secure DNS” there.

Yup. Will fix.

-andy

---

From: Naoki Kambe <[email-masked]>
Date: Thu, 23 Oct 2014 14:57:30 +0900 (JST)

Hello,

Here is also a minor nit.  I thinks we need an "objectClassName"
element in each result object of the following "domainSearchResults"
example in Section 8:

OLD
         ...
         "domainSearchResults" :
         [
           {
             "handle" : "1-XXXX",
             "ldhName" : "1.example.com",
             ...
           },
           {
             "handle" : "2-XXXX",
             "ldhName" : "2.example.com",
             ...
           }
         ]

NEW
         ...
         "domainSearchResults" :
         [
           {
             "objectClassName" : "domain",
             "handle" : "1-XXXX",
             "ldhName" : "1.example.com",
             ...
           },
           {
             "objectClassName" : "domain",
             "handle" : "2-XXXX",
             "ldhName" : "2.example.com",
             ...
           }
         ]

Regards,
Naoki Kambe