Subject: RE: History behind RFC numbers

From: Hosnieh Rafiee <[email-masked]>
Date: Thu, 2 Oct 2014 12:16:42 +0000

> 
> Can someone tell me what is broken?
> 

Nothing is broken. It is only some new ideas for pointing to RFCs and making the numbers meaningful so that when someone hear RFC xxxxxxx that person knows what its general area and what WGs it might be related to.

Because at the moment the RFC numbers are only numbers that nobody can get more information only by knowing the number. Maybe just guess it might be for year 2014 or year 2013... because of its start but nothing more and sometimes the titles are really long and cannot be used as a reference.

---

From: Janet P Gunn <[email-masked]>
Date: Thu, 2 Oct 2014 10:58:58 -0400

Trying to resist - but can't help myself.

Just need to point out that Working Groups, and even Areas, are pretty 
fluid. 

 I can think of quite a few cases where RFCabcd was developed by WG X in 
Area Y, but RFCefgh, which is a DIRECT update of RFCabcd, was developed in 
WG Z in Area W.

Janet

"ietf" <[email-masked]> wrote on 10/02/2014 08:16:42 AM:

> From: Hosnieh Rafiee <[email-masked]>
> To: ietf <[email-masked]>
> Date: 10/02/2014 08:17 AM
> Subject: RE: History behind RFC numbers
> Sent by: "ietf" <[email-masked]>
> 
> > 
> Nothing is broken. It is only some new ideas for pointing to RFCs 
> and making the numbers meaningful so that when someone hear RFC 
> xxxxxxx that person knows what its general area and what WGs it 
> might be related to.
> 
> Because at the moment the RFC numbers are only numbers that nobody 
> can get more information only by knowing the number. Maybe just 
> guess it might be for year 2014 or year 2013... because of its start
> but nothing more and sometimes the titles are really long and cannot
> be used as a reference.
> 
> 
>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Sat, 4 Oct 2014 00:59:15 +0000

On Oct 2, 2014, at 7:58 AM, Janet P Gunn <[email-masked]> wrote:

>  I can think of quite a few cases where RFCabcd was developed by WG X in Area Y, but RFCefgh, which is a DIRECT update of RFCabcd, was developed in WG Z in Area W. 

Or developed by a person and used for a number of years before being standardized in the IETF at all, such as GRE.

I think there are two broad categories of nomenclature. One is what we use, enumerating RFCs. The ITU and IEEE do something in naming; IEEE 802.11ac, for example, is downward compatible with 802.11a/b/g/n, and yes, we call them by their working group names. There are other bodies, such as the CCITT, that date their updates - X.25 in 1976, 1980, 1984, 1888, and 1992 were all "X.25-date”, and generically referred to as “X.25”.

I don’t know that any given approach is “right”. They are, each of them, “what we use”, complete with the benefits and caveats that go with them.