Subject: Proposed IESG structure change

From: IETF Chair <[email-masked]>
Date: Tue, 7 Oct 2014 15:24:00 -0700

Dear Community:

The IESG is considering a change in structure, with the intent to increase
flexibility as IETF work evolves, to ensure that all IETF work is covered by
an AD, and to balance and reduce the workload across the ADs. A significant
amount of the work that is going on in the APP area pertains to the web
protocols, but that has a good deal of crossover with work in RAI. There is
also some crossover work between the APP and TSV areas. While the specific
amount of work in any IETF area fluctuates over time, we have noticed that
the number of WGs in the APP area, particularly on the non-web protocols, is
currently shrinking. So we are starting to think about reorganizing the areas
a bit, possibly merging parts (or all) of the APP and RAI areas into a single
area, possibly redistributing work in other ways between all of the areas,
but in any event changing the load balance among the areas and the ADs,
while continuing the work that the WGs are currently doing. It is explicitly
not our intention to bar any existing or new work from the IETF with these
changes.  We are committing to coming up with a proposal to the community
for that by May 2015. We believe the end result of that could be to reduce the
number of areas by one.

In the short term, however, we would like to advise the NomCom to *not* fill
the APP AD vacancy in this NomCom cycle. We believe the current load can be
handled by the one remaining APP AD, and the RAI and TSV ADs are committed
to helping out if need be. We believe that it is unreasonable to have the
NomCom find a new AD and ask them to commit to two years only to discover
later that we may want to eliminate or significantly change the responsibilities
for that position within a year. Whether the end result is that we end up with a
combined larger RAI/APP area that requires three ADs, or recombining in some
other way, we think reducing down to 14 ADs in this NomCom cycle is the right
thing to do.

We want and need community consultation on this topic. We believe this is the
correct path, but we need to hear if there are any concerns from the rest of
the community before we tell the NomCom to do this. Please send your
comments [email-masked], or alternatively to [email-masked] if you prefer, by 13
October 2014.  We need to let the NomCom know ASAP if we decide to move
forward with this.

Jari Arkko for the IESG

---

From: S Moonesamy <[email-masked]>
Date: Tue, 07 Oct 2014 21:43:43 -0700

Hello,
>for that by May 2015. We believe the end result of that could be to reduce the

I did a quick list of the working groups from non-Application Areas 
with work that intersects with the Applications Areas:

   DANE
   HTTPAUTH
   JOSE
   MILE
   OAUTH
   ALTO
   CDNI
   GEOPRIV

The active groups in the Applications Area [1] are:

   APPSAWG
   DMARC
   HTTPBIS

It worthwhile to consider a change in structure.  There isn't much in 
common between Applications and Real-time Applications and 
Infrastructure Area.  My guess is that there is a difference in 
culture between those two Areas.

My mild preference would be to select an Applications Area Director 
for a year.  The IESG can review the structure meanwhile and choose a 
medium-term solution.  For what it is worth, the Applications Area 
has been on a downhill since a while.

Regards,
S. Moonesamy

1. I may have missed a few.

---

From: Ray Bellis <[email-masked]>
Date: Wed, 8 Oct 2014 08:58:33 +0000

On 8 Oct 2014, at 05:43, S Moonesamy <[email-masked]> wrote:

> I did a quick list of the working groups from non-Application Areas with work that intersects with the Applications Areas:
> 
>  DANE
>  HTTPAUTH
>  JOSE
>  MILE
>  OAUTH
>  ALTO
>  CDNI
>  GEOPRIV

GEOPRIV is imminently close to shutting down - we have one final document that just finished IETF LC.  As soon as it gets through the IESG and goes to the RFC Editors we’re done.

Ray

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 8 Oct 2014 07:30:33 -0700

The plan seems reasonable. It gives the one remaining Apps AD a year to figure out which active WGs should go where, and gives the IESG time to determine where the best home for "general apps stuff" would be. RAI seems like a good target, and a better one than Transport. As someone who has been active in Apps WGs for 20 years (sigh), I would hate to see the area disappear, but that kind of thinking has caused the IETF to hold on to other things much too long. 

--Paul Hoffman

---

From: Jari Arkko <[email-masked]>
Date: Wed, 8 Oct 2014 22:36:16 -0700

Paul,

> As someone who has been active in Apps WGs for 20 years (sigh), I would hate to see the area disappear, but that kind of thinking has caused the IETF to hold on to other things much too long. 

I wanted to say that while we are talking about changing organisation, we are *not* abandoning any work. The number of WGs and topics fluctuates, but I cannot think of many more significant standards efforts at the moment than what we are doing with HTTP 2.0 for instance. Apps work is very important, and we continue to be happy to create new working groups and sponsor BOFs. However, we also feel that slightly bigger group of ADs would allow some flexibility to deal with the fluctuations, distribute workload better, etc. So - no disappearance but rather a change in form.

Jari

---

From: John C Klensin <[email-masked]>
Date: Thu, 09 Oct 2014 04:39:41 -0400

--On Wednesday, October 08, 2014 22:36 -0700 Jari Arkko
<[email-masked]> wrote:

> Paul,
> 
>> As someone who has been active in Apps WGs for 20 years
>> (sigh), I would hate to see the area disappear, but that kind
>> of thinking has caused the IETF to hold on to other things
>> much too long. 

First, having been active in what is now IETF applications work
on and off for longer than many IETF participants have been
active in breathing, I agree with Paul.

I also note that a lot of the work that became RAI was split off
from Apps so, in some respects, this discussion is just about
recombining or rebalancing the work.  That is consistent with
the original announcement and Jari's remarks below.
 
> I wanted to say that while we are talking about changing
> organisation, we are *not* abandoning any work. The number of
> WGs and topics fluctuates, but I cannot think of many more
> significant standards efforts at the moment than what we are
> doing with HTTP 2.0 for instance. Apps work is very important,
> and we continue to be happy to create new working groups and
> sponsor BOFs. However, we also feel that slightly bigger group
> of ADs would allow some flexibility to deal with the
> fluctuations, distribute workload better, etc. So - no
> disappearance but rather a change in form.

This isn't quite a suggestion since the IESG has apparently made
up its mind, but, especially in a time of transition, there are
some major advantages to having two ADs in an area, including
the ability of two specialists with different perspectives to
talk with each other and sort out ideas.  Everyone who has
gotten a cross-area review comment that seemed to be off the
wall from an out-of-area AD will understand why general
conversations with the rest of the IESG are no substitute (even
though they may be very helpful and important for other
reasons).  

So, all other things being equal, I think it would have been
better to ask the Nomcom to make a one-year appointment if they
could find someone satisfactory [1] and then sort things out
during the next year as planned but with two Apps ADs rather
than cutting the slot now  on the assumption that one AD could
and would be able to handle all relevant working groups,
thinking about new plans, and all other IESG responsibilities.
That would be a non-issue if the IESG already had a plan worked
out to transition some specific WGs into other areas by March 27
or earlier, but the announcement implies that is not the case.

    john

[1] If the IESG and Nomcom could interpret the rules
appropriately, my thought would be to explicitly tell the Nomcom
that it would be ok to not make an appointment if they concluded
that they couldn't find someone satisfactory for the role, i.e.,
without either making an appointment of someone inexperienced in
the area or scraping the bottom of the proverbial barrel.

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 9 Oct 2014 12:45:09 +0000

Great sentiment from Paul! IMO it is a sign of a healthy organization that
it can recognize and make these kinds of organizational changes.

As they say, adapt or die, change with the times, and don¹t be like the
ITU. ;-)

Jason

On 10/9/14, 1:36 AM, "Jari Arkko" <[email-masked]> wrote:

>Paul,
>
>> As someone who has been active in Apps WGs for 20 years (sigh), I would
>>hate to see the area disappear, but that kind of thinking has caused the
>>IETF to hold on to other things much too long.
>
>I wanted to say that while we are talking about changing organisation, we
>are *not* abandoning any work. The number of WGs and topics fluctuates,
>but I cannot think of many more significant standards efforts at the
>moment than what we are doing with HTTP 2.0 for instance. Apps work is
>very important, and we continue to be happy to create new working groups
>and sponsor BOFs. However, we also feel that slightly bigger group of ADs
>would allow some flexibility to deal with the fluctuations, distribute
>workload better, etc. So - no disappearance but rather a change in form.
>
>Jari
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 9 Oct 2014 06:00:19 -0700

John,

Thanks for your comments.

> ….

This could have been another alternative. And still is, because we are indeed asking for feedback and want to understand if the suggested path is the best one.

And having two ADs to discuss amongst themselves what to do is very useful. It certainly was essential for me when I was the INT AD. And especially useful in the first year or two.

However, I wanted to just talk a bit about the timing and the number of ADs. And again, some of this is theoretical because we have definitely not decided _what_ to do; we are still exploring the exact re-organisation that we would like to make. But for the sake of argument, lets assume that we’d for instance combine APP and RAI and put in three ADs. Now, today we *do* have two ADs in APP. For the recruitment of proper number of ADs with the suitable expertise in next year’s Nomcom cycle, the restructuring should be ready in the summer, preferably in June. So that we could inform the Nomcom of what the desired expertise is. If we have the right number of ADs at that point, we can just go ahead and make the transition. So we wouldn’t be without a second AD in the area for a long time.

> or earlier, but the announcement implies that is not the case.

I think the key is that we do not have the plan worked out _today_ so that we can not inform the Nomcom what kind of a person(s) and how many we’d like to recruit. We might have a plan by March and certainly will have a plan by May which even the new IESG can stand behind. But that is not today and therefore it would be difficult for anyone to volunteer for that undefined task today.

Jari

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 9 Oct 2014 07:42:46 -0700

> I wanted to say that while we are talking about changing organisation, we are *not* abandoning any work. The number of WGs and topics fluctuates, but I cannot think of many more significant standar…

Of course. There will periodically be a group of people who want to create a new format for data about people or calendar events, or some possibly-useful way to use HTTP or email, and so on. With this change, they will have to go to an area that is not filled with people who have done that themselves earlier. That's fine: keeping the area around just for that is not a good use of human resources.

--Paul Hoffman

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 9 Oct 2014 09:43:18 -0500

For what it's worth ...

On Thu, Oct 9, 2014 at 8:00 AM, Jari Arkko <[email-masked]> wrote:

> This could have been another alternative. And still is, because we are
> indeed asking for feedback and want to understand if the suggested path is
> the best one.
>
> And having two ADs to discuss amongst themselves what to do is very
> useful. It certainly was essential for me when I was the INT AD. And
> especially useful in the first year or two.
>
> However, I wanted to just talk a bit about the timing and the number of
> ADs. And again, some of this is theoretical because we have definitely not
> decided _what_ to do; we are still exploring the exact re-organisation that
> we would like to make. But for the sake of argument, lets assume that we’d
> for instance combine APP and RAI and put in three ADs. Now, today we *do*
> have two ADs in APP. For the recruitment of proper number of ADs with the
> suitable expertise in next year’s Nomcom cycle, the restructuring should be
> ready in the summer, preferably in June. So that we could inform the Nomcom
> of what the desired expertise is. If we have the right number of ADs at
> that point, we can just go ahead and make the transition. So we wouldn’t be
> without a second AD in the area for a long time.
>
> I think the key is that we do not have the plan worked out _today_ so that
> we can not inform the Nomcom what kind of a person(s) and how many we’d
> like to recruit. We might have a plan by March and certainly will have a
> plan by May which even the new IESG can stand behind. But that is not today
> and therefore it would be difficult for anyone to volunteer for that
> undefined task today.
>
>
Several years ago, Russ gathered what was then all of the previous Nomcom
chairs who would still answer his e-mail into a design team, to see what
issues came up year after year. I was honored to be the scribe for that
design team.

The past chairs (not ¨we, including Spencer¨, because I was just typing)
came up with http://tools.ietf.org/html/draft-dawkins-nomcom-3777-issues-00,
which is a fairly interesting document to look over. In my opinion.

Some of the issues they identified have been addressed (for example, ¨5.3
<http://tools.ietf.org/html/draft-dawkins-nomcom-3777-issues-00#section-5.3>.
Soliciting Feedback on Non-Incumbent Candidates¨ led to Open List/
http://tools.ietf.org/html/rfc5680), but others have not been.

I have been thinking about ¨3.1
<http://tools.ietf.org/html/draft-dawkins-nomcom-3777-issues-00#section-3.1>.
Shortening the NomCom Epoch¨ recently, because it would be really handy if
the Nomcom epoch wasn't like 9 months long, and basically a train that
leaves once a year, when we are talking about proposed IESG structural
changes ... and the consensus of the past chairs was that shorter would be
better ...

Speaking only for myself, of course.

Of course.

Spencer

---

From: John C Klensin <[email-masked]>
Date: Thu, 09 Oct 2014 11:11:46 -0400

Jari,

Largely playing devil's advocate and with the understanding that
I probably won't post further on this...

--On Thursday, October 09, 2014 06:00 -0700 Jari Arkko
<[email-masked]> wrote:

>...
> However, I wanted to just talk a bit about the timing and the
> number of ADs. And again, some of this is theoretical because
> we have definitely not decided _what_ to do; we are still
> exploring the exact re-organisation that we would like to
> make. But for the sake of argument, lets assume that we'd
> for instance combine APP and RAI and put in three ADs. Now,
> today we *do* have two ADs in APP. For the recruitment of
> proper number of ADs with the suitable expertise in next
> year's Nomcom cycle, the restructuring should be ready in
> the summer, preferably in June. So that we could inform the
> Nomcom of what the desired expertise is. If we have the right
> number of ADs at that point, we can just go ahead and make the
> transition. So we wouldn't be without a second AD in the
> area for a long time.

On the other hand, some of us perceive that some topics and WGs
in the area are being somewhat underserved already, with two
ADs.  I don't know whether that opinion is either generally
shared or correct but, if it were even partially so, unless it
could be guaranteed that everything would be sorted out before
March, that would imply a single AD who is already close to the
available-time limit having to deal with both some additional
WGs _and_ a key role in the discussion of what to do next.  That
would be bad news whether the priorities chosen were to let the
discussion slip or to pay less attention to some WGs.   If Barry
had neither a day job nor limits on the number of hours in a
day, it would presumably not be a problem but many of us have
discovered that getting more than 24 hour into a day, or giving
up sleep entirely, are fairly difficult even before day jobs are
considered.

>> That would be a non-issue if the IESG already had a plan
>> worked out to transition some specific WGs into other areas
>> by March 27 or earlier, but the announcement implies that is
>> not the case.
> 
> I think the key is that we do not have the plan worked out
> _today_ so that we can not inform the Nomcom what kind of a
> person(s) and how many we'd like to recruit. We might have a
> plan by March and certainly will have a plan by May which even
> the new IESG can stand behind. But that is not today and
> therefore it would be difficult for anyone to volunteer for
> that undefined task today.

A different view of the same issue is that one of the barriers
to candidacies for the IESG is the requirement to make a
two-year commitment (and, in practice, really a four-year one).
There might well be people who would be able and willing to
volunteer for a transition job with the understanding that it
would be a one-year commitment at most and might even turn out
to be a six month one with a graceful opportunity to step down
because the needed job was completed.    In addition, one of the
reasons I'd encourage giving the Nomcom a request to fill the
position if someone appropriate could be found but just let it
go otherwise is that the latter choice, if made, would leave the
IESG no worse off than simply indicating that the position not
be filled.  And, if someone could be appointed, it would either
be a really easy job for a while or avoid the risks of being
short-handed during a transition.

Again, just a thought...
best,
   john

---

From: Ted Lemon <[email-masked]>
Date: Thu, 9 Oct 2014 12:14:29 -0400

On Oct 9, 2014, at 11:11 AM, John C Klensin <[email-masked]> wrote:
> because the needed job was completed.

The problem is that the learning curve is longer than a year, so there's not likely to be a great deal of utility in doing this.   A new AD is better than no AD if you need a new AD, but if you don't, what's the point?   I would have been very frustrated if my first year of being an AD were my only year.

---

From: joel jaeggli <[email-masked]>
Date: Thu, 09 Oct 2014 09:23:23 -0700

On 10/9/14 9:14 AM, Ted Lemon wrote:
>> volunteer for a transition job with the understanding that it would
>> be a one-year commitment at most and might even turn out to be a
>> six month one with a graceful opportunity to step down because the
>> needed job was completed.
> 
> The problem is that the learning curve is longer than a year, so
> there's not likely to be a great deal of utility in doing this.   A
> new AD is better than no AD if you need a new AD, but if you don't,
> what's the point?   I would have been very frustrated if my first
> year of being an AD were my only year.

yeah no I don't see that as a good idea.

---

From: Michael StJohns <[email-masked]>
Date: Thu, 09 Oct 2014 13:53:27 -0400

At 06:24 PM 10/7/2014, IETF Chair wrote:

>  We are committing to coming up with a proposal to the community
>the APP AD vacancy in this NomCom cycle. 

I've read most of the other responses on this thread and I agree that the APPs area is in need of attention and I applaud the desire to restructure.

However, I'm concerned that we are proposing to not follow our own rules.  

The first issue is that once the IETF ExecDir passes on the vacancies to the Nomcom, there is no provision for the Nomcom not to fill those vacancies, nor is there provision for that vacancy list to change.  The IESG could have changed the vacancy slate any time up to the announcement of vacancies (29 Aug according to what I saw), but delayed making the decision for a month past the deadline.  That's not insoluble, but it disturbs me that we're attempting to use exception processing rather than what's programmed in.

The second issue (related to other comments) is that 3777 has no provision for appointing anyone for a term of a year or less.  Again, not insoluble, but begs the question of why we have rules if we don't follow them.

Other comments, especially JCK's, have noted that the work will not decrease as there will continue to be some similar number of WGs and questioning on that basis the desire to not appoint a new APPs AD.

Instead, let me suggest the IESG put its head together and figure out where a more general AD might be of use for two years.  Given the large number of cross area WGs, perhaps re-working the job description into husbanding the transition of some number of as yet to be defined WGs to the different areas might be useful and might actually be a 2 year task.   Or other tasks related to the closure of the area that will no doubt occur to the IESG between now and next year.  Also, AFAIK, there is no requirement that a WG be owned by one of the area directors of its primary area  - stick the APPs AD as the primary owner for the WG, but pick a secondary owner from the gaining area to ease transition.  (I would thing that you should be doing this now for the WGs owned by the continuing APPs AD if you expect to close out the area next year )

The AD's have a primary focus for the topics of their areas, but their secondary focus needs to be on the IETF standards process. Having a 2 year AD who can spend some additional time maybe helping the IESG with the workload of the standards process would not be a bad idea.

Mike

---

From: Michael Richardson <[email-masked]>
Date: Thu, 09 Oct 2014 16:03:35 -0400

Michael StJohns <[email-masked]> wrote:
    > The second issue (related to other comments) is that 3777 has no
    > provision for appointing anyone for a term of a year or less.  Again,
    > not insoluble, but begs the question of why we have rules if we don't
    > follow them.

Is the issue, what will a nomcom do in May 2015, if the IESG decides they
need another AD?  My opinion is that the nomcom would appoint someone for
either 2 or 3 years (subtracting March/April/May).  The term of ADs turns out
not to be "2 years", but rather a duration such that that about half should
be replaced every year.

    > Instead, let me suggest the IESG put its head together and figure out
    > where a more general AD might be of use for two years.  Given the large
    > number of cross area WGs, perhaps re-working the job description into
    > husbanding the transition of some number of as yet to be defined WGs to
    > the different areas might be useful and might actually be a 2 year
    > task.  Or other tasks related to the closure of the area that will no
    > doubt occur to the IESG between now and next year.  Also, AFAIK, there
    > is no requirement that a WG be owned by one of the area directors of
    > its primary area - stick the APPs AD as the primary owner for the WG,
    > but pick a secondary owner from the gaining area to ease transition.
    > (I would thing that you should be doing this now for the WGs owned by
    > the continuing APPs AD if you expect to close out the area next year )

    > The AD's have a primary focus for the topics of their areas, but their
    > secondary focus needs to be on the IETF standards process. Having a 2
    > year AD who can spend some additional time maybe helping the IESG with
    > the workload of the standards process would not be a bad idea.

These are good idea as well.

My take on this is that asking the nomcom not to fill a spot, at this late
hour, is just barely acceptable.  Changing the job description might not be.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Leslie Daigle <[email-masked]>
Date: Thu, 09 Oct 2014 18:20:53 -0400

As others, I applaud the IESG for reviewing its structure and 
considering alternatives to "the way things have always been".

The particular proposal brings to the front of my mind some questions 
I've had about a gap in IETF work and Internet technical specifications. 
  Now seems like the time to ask :^)

In terms of specifications to "make the Internet work better", there is 
a lot of work that is not Transport[*], isn't web, and isn't RealTime 
Applications (infrastructure).  Beyond mail, http, and calendaring, 
there is a whole bunch of interconnective goo that I, at least, have 
called "application infrastructure".   While the standards may not have 
been fully developed or taken up, the same questions the APP area 
wrestled with a decade ago are appearing in modern efforts -- 
identifiers, localization, discovery, search, lookup are all part of 
Content Centric Name Based Network Routing, content handling for IPR, 
identity and certs, and pretty much anything that pops up a level into 
information structures.

Those efforts are each working through the same problems in their own 
unique way, and/or they are not perceiving the IETF as a useful home for 
the work.

IMO, there needs to be an answer about how to address those questions in 
the Internet context -- whether in standalone standards (like the URI 
suite) or by developing and applying general expertise to address them 
in a consistent fashion across developing standards for particular purposes.

I think that means having someone/some people on the IESG who can 1/ 
recognize and 2/ cultivate that work (and, to a lesser extent,  3/ 
provide that input into cross-area review).

So, I'd like to hear from the IESG (and the IAB) how they see the 
landscape of application infrastructure being handled in a way that's 
consistent with the IETF's mission, especially in the light of this 
proposed structure change.

Leslie.
[*] Wasn't TSV all but dead a few years ago, because all the interesting 
transport stuff was obvious RAI work?

-- 

-------------------------------------------------------------------
"Reality:
      Yours to discover."
                                 -- ThinkingCat
Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 9 Oct 2014 17:33:40 -0500

On one point (out of many, all interesting) ...

On Thursday, October 9, 2014, Leslie Daigle <[email-masked]> wrote:

>
> As others, I applaud the IESG for reviewing its structure and considering
> alternatives to "the way things have always been".
>
> The particular proposal brings to the front of my mind some questions I've
> had about a gap in IETF work and Internet technical specifications.  Now
> seems like the time to ask :^)
>
> In terms of specifications to "make the Internet work better", there is a
> lot of work that is not Transport[*], isn't web, and isn't RealTime
> Applications (infrastructure).  Beyond mail, http, and calendaring, there
> is a whole bunch of interconnective goo that I, at least, have called
> "application infrastructure".   While the standards may not have been fully
> developed or taken up, the same questions the APP area wrestled with a
> decade ago are appearing in modern efforts -- identifiers, localization,
> discovery, search, lookup are all part of Content Centric Name Based
> Network Routing, content handling for IPR, identity and certs, and pretty
> much anything that pops up a level into information structures.
>
> suite) or by developing and applying general expertise to address them in a
> consistent fashion across developing standards for particular purposes.
>
> recognize and 2/ cultivate that work (and, to a lesser extent,  3/ provide
> that input into cross-area review).
>

That's certainly the way it looks to me :-)

I've been saying that putting new transport protocols in UDP (for NAT
traversal) and implementing them in user space (so not requiring kernel
updates to do anything) has been a huge game-changer for classic TSV work
... as opposed to storage, CDNI, and such things.

Spencer

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 9 Oct 2014 19:31:29 -0400

When security applications got their own area it was because doing
secure applications was unusual and considered specialist. Then when
realtime came along it was considered unusual and considered
specialist.

>From here on all application protocols will need security and
virtually all will be realtime. So realtime becomes just 'apps'.

Security area should be like transport, security infrastructure, not
applications that happen to be secure.

---

From: Pete Resnick <[email-masked]>
Date: Thu, 9 Oct 2014 18:31:22 -0500

On 10/9/14 3:03 PM, Michael Richardson wrote:
> Michael StJohns<[email-masked]>  wrote:
>      >  The IESG could have changed the vacancy slate any time up to the
>      >  announcement of vacancies (29 Aug according to what I saw), but
>      >  delayed making the decision for a month past the deadline.  That's
>      >  not insoluble, but it disturbs me that we're attempting to use
>      >  exception processing rather than what's programmed in.
>    

Yeah, I think we all wish we could have seen this coming earlier and 
started on it before the NomCom got underway. Scheduling maintenance and 
reconfiguration on the plane is hard enough, and doing so while in 
flight is even harder. As you say, not great that we're using exception 
processing for this, but not insoluble.

> not to be "2 years", but rather a duration such that that about half should

I think MR's correct here: 3777 3.4 says,

       The intent of this rule is to ensure that members of the IESG and
       IAB serve the number of years that best facilitates the review of
       one-half of the members each year.

If a new AD position is created, I think doing a 3 year appointment is 
most consonant with 3777 3.4, but I don't think 1 year is forbidden.

>      >  Other comments, especially JCK's, have noted that the work will
>      >  not decrease as there will continue to be some similar number of
>      >  WGs and questioning on that basis the desire to not appoint a new
>      >  APPs AD.
>    

On this point, which MR didn't address: One of the motivations for going 
down one APP AD now is that there *is* a current lull in APP work. 
Several APP WGs are currently in FIN_WAIT, or close too it. We expect 
that in the short term, there are going to be 8-10 APP WGs for a single 
AD to deal with, which is pretty average across the IESG. Given that we 
will not know what particular expertise is needed once that re-org is 
complete, this seemed like the perfect time to hold off on filling the 
position.

>      >  task.

> hour, is just barely acceptable.  Changing the job description might not be.

Not only would changing the job description to "generalist" right now be 
simply a different "breaking of the rules", it's probably a bit more 
problematic, especially in terms of NomCom logistics: We would have to 
ask them to restart the search for candidates of this generalist 
category. It's also not clear to me if we have a good handle on how this 
would affect the operation of the IESG. We've done "one person short" 
before and know how that works. Having a generalist is uncharted waters.

>      >  Or other tasks related to the closure of the area that will no
>      >  doubt occur to the IESG between now and next year.

A tangent, but I don't think Jari's point can be over-stressed: Whether 
we end up with a combined APP/RAI area, or a redistribution of work from 
assorted areas and we're back to 8 areas, or some other configuration, 
we shouldn't think of this as a "closure of the area". The work will 
continue, and we are quite sure there will continue to be work. And we 
certainly have not concluded what the re-org will result in.

>      >  Also, AFAIK, there

Hmmm....

2418, 2:

    Anyone interested in creating an
    IETF working group MUST obtain the advice and consent of the IETF
    Area Director(s) in whose area the working group would fall and MUST
    proceed through the formal steps detailed in this section.

Pushing the boundaries. Doesn't mean we can't do it.

Yes, there are other ways to approach this. My sense is the IESG thinks 
the "1) drop an AD; 2) re-shuffle the groups/areas/categories; 3) see 
what ADs we need for next go-round" is the least disruptive at this point.

pr

-- 

Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Michael StJohns <[email-masked]>
Date: Thu, 09 Oct 2014 20:59:57 -0400

At 07:31 PM 10/9/2014, Pete Resnick wrote:
>If a new AD position is created, I think doing a 3 year appointment is most consonant with 3777 3.4, but I don't think 1 year is forbidden.

You need to read it all.   Regular candidates serve a 2 or 3 year appointment.  Mid-term vacancy fillers serve between 1 to three years depending on when the vacancy occurs.   AFAIK we've never made a normal vacancy 1 year appointment.  And I think its been a while since we've had a 3 year term appointment.

>4. Confirmed candidates are expected to serve at least a 2 year term.
>
>      The term of a confirmed candidate selected according to the mid-
>      term vacancy rules may be less than 2 years, as stated elsewhere
>      in this document.
>
>      It is consistent with this rule for the nominating committee to
>      choose one or more of the currently open positions to which it may
>      assign a term of not more than 3 years in order to ensure the
>      ideal application of this rule in the future.

>On this point, which MR didn't address: One of the motivations for going down one APP AD now is that there *is* a current lull in APP work. Several APP WGs are currently in FIN_WAIT, or close too it. We expect that in the short term, there are going to be 8-10 APP WGs for a single AD to deal with, which is pretty average across the IESG. Given that we will not know what particular expertise is needed once that re-org is complete, this seemed like the perfect time to hold off on filling the position.
>
>Not only would changing the job description to "generalist" right now be simply a different "breaking of the rules",

It's actually not a breaking of the rules:

>  The IESG and IAB are responsible for providing summary of the
>         expertise desired of the candidates selected for their
>         respective open positions to the Executive Director.  The
>         summaries are provided to the nominating committee for its
>         consideration.

> it's probably a bit more problematic, especially in terms of NomCom logistics: We would have to ask them to restart the search for candidates of this generalist category. It's also not clear to me if we have a good handle on how this would affect the operation of the IESG. We've done "one person short" before and know how that works. Having a generalist is uncharted waters.

Not really.   The IETF chair is by definition something of a generalist and usually has work in more than one area during their participation.  In the past, the Nomcom has moved ADs around like chess pieces to ensure coverage and we've had our shares of loosely defined temporary areas managed by ADs that had other responsibilities in other areas.   This really isn't new territory.

If you decide to bring up a new area to replace APP.... does that even count as a mid-term vacancy or do you wait until a year from this coming January to put a new AD in place?  Nevermind....

>A tangent, but I don't think Jari's point can be over-stressed: Whether we end up with a combined APP/RAI area, or a redistribution of work from assorted areas and we're back to 8 areas, or some other configuration, we shouldn't think of this as a "closure of the area". The work will continue, and we are quite sure there will continue to be work. And we certainly have not concluded what the re-org will result in.

Thanks for making my point.  If you don't know what the re-org will result in, how is deciding that the APPs area AD going away is the correct decision?    

Admittedly, you seem to be arguing yourself out of a job....

>   proceed through the formal steps detailed in this section.

You're conflating apples and oranges.  The APPs AD still has to approve new WGs in the APPs area - but that won't happen (e.g. he/she will say no) if there is a final decision to close out the area.  The APPs AD isn't an area director in the new area, just helping out in the transition.

>Yes, there are other ways to approach this. My sense is the IESG thinks the "1) drop an AD; 2) re-shuffle the groups/areas/categories; 3) see what ADs we need for next go-round" is the least disruptive at this point.

I'd say  0) figure out if APPs is really closing  then 1) figure out which groups need to go where, then 2) drop an AD.  

Again, nothing is insoluble, but this feels rushed and possibly not well thought through for implications and unintended consequences.

Mike

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 10 Oct 2014 15:43:02 +1300

On 10/10/2014 13:59, Michael StJohns wrote:
...
> You need to read it all.   Regular candidates serve a 2 or 3 year appointment.  Mid-term vacancy fillers serve between 1 to three years depending on when the vacancy occurs.   AFAIK we've never mad…

I very much hope we can still apply common sense (with a rough consensus) when
we encounter a case that doesn't fit the letter of the rules.

'"If the law supposes that," said Mr. Bumble, squeezing his hat emphatically
in both hands, "the law is a ass - a idiot."' (Charles Dickens, Oliver Twist, 1838)

   Brian

---

From: John C Klensin <[email-masked]>
Date: Fri, 10 Oct 2014 03:10:02 -0400

--On Thursday, October 09, 2014 13:53 -0400 Michael StJohns
<[email-masked]> wrote:

> The first issue is that once the IETF ExecDir passes on the
> vacancies to the Nomcom, there is no provision for the Nomcom
> not to fill those vacancies, nor is there provision for that
>...

Mike,

I think we have a little bit of a philosophical disagreement
that has a lot to do with what the IETF is about and much less
to do with this particular case.

I spent many years of my life in assorted positions, often
oversight or management, in standards bodies in which the main
(or only) criterion for almost anything --including standards
approval and leadership appointment-- was that rigid procedures
were followed to the letter.  To a considerable extent,
technical quality, implementability, relevance to anything
actual users or any likely producer of implementations actually
cared about, and so on were secondary to careful step-by-step
procedure following if they counted at all.

The IETF, by contrast, tended to focus on identifying the right
things to do and getting them done.  That meant broad review,
rough consensus, and technical quality of standards and
designing our procedures so that, as long as things remained
open, transparent, and consistent with rough consensus, careful
thinking and good sense would trump arguments for rigid
adherence to narrow interpretations of the rules.  

Where the Internet is concerned, in the talk that was arguably
part of the origin of the IETF's current structural and
procedural model, Marshall Rose memorably described where the
model of rigid rules and primacy of procedures over good
judgment led with the phrase "road kill on the information
superhighway".

For the specifics of this issue, I think Michael Richardson's
interpretation of what the Nomcom can do and his response
--whether you agree or not -- shows that we have not yet run out
of flexibility in thinking through issues and trying to put
"find the right solution" first.  I can't add much to that,
other than to applaud the direction it seems to represent
regardless of what is done with this particular position.

The more general situation is why, in recent years, I've
consistently opposed efforts to turn guidelines into rules and
to substitute ever more detailed rules for requirements to think
and apply good sense.  It may well be that, if and as the IETF
participant profile shifts toward more professional
standardizers and folks whose interests and participation are
limited to a single topic and it becomes harder for anyone who
lacks significant organizational or corporate support to serve
on the IESG or IAB, we will need to become more like those other
bodies and, in particular, rely more on formal rules and
checking for conformance to procedures rather than good sense
and technical judgments supported, where possible, by "running
code".  IMO, that would be an unfortunate outcome that would
ultimately lead to elimination of the things that have made the
IETF both special and effective.  YMMD, of course.

best,
   john

---

From: John C Klensin <[email-masked]>
Date: Fri, 10 Oct 2014 03:18:13 -0400

--On Thursday, October 09, 2014 20:59 -0400 Michael StJohns
<[email-masked]> wrote:

>...
> I'd say  0) figure out if APPs is really closing  then 1)
> figure out which groups need to go where, then 2) drop an AD.  
> 
> Again, nothing is insoluble, but this feels rushed and
> possibly not well thought through for implications and
> unintended consequences.

Having just disagreed about principles, I think the above is
probably the right conclusion.  We really do not need to argue
about whether one-year appointments are possible because, if the
IESG decides to eliminate an area or AD slot and the relevant
ADs are so attached to the jobs that one or more is willing to
resign for the good of the community and to free herself from a
non-existent position, I suggest that we have far greater
problems than the number of years for which a Nomcom can make an
appointment.

Again, I think that reevaluating the Apps Area is a good idea.
There have been years when I've thought that we should
periodically sunset and reevaluate every area and its
relationship to others.  My issue here is just about whether the
sequencing and timing of the present plan is optimal for the
Area, the relevant WGs, future work that might come to the IETF
if the climate is right, and the IETF generally.

    john

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 10 Oct 2014 08:58:37 +0100

Jari

I wonder whether the change you propose is radical enough to
serve the IETF's needs as we move through greater industry
austerity, structural changes in the industry and as the pace
of change speeds up.

For some time it has been difficult to get companies to
release some of their best engineers to AD duty. This
difficulty is compounded by the need to find engineers
who are also skilled managers, talented communicators,
and have a technical span that covers not only their
own area but who have sufficient knowledge of the
other areas to understand the implications of wider
issues on the work they are responsible for.

I wonder whether it is time to consider more of a team
approach to area management with perhaps one AD
per area supported by a number of assistants, who
may deputize for them where needed. Clearly the devil
lies in the detail, but such an approach would allow us
the flexibility in the size of each area's management
team that you seek here.

Note, I am not proposing to increase the number of
possible discuss holders, or the number of people
that need to reach consensus on IESG decisions,
because ADs would retain those powers as they do today,
but an assistant could deputize in the day to day
running of a WG, or preparing and speaking to
a telechat position.

Clearly any such proposal would need careful thought
but I do think that it is time address some of the deeper
issues rather than patching things up on a case by case
basis.

- Stewart

---

From: John C Klensin <[email-masked]>
Date: Fri, 10 Oct 2014 04:46:39 -0400

> approach to area management with perhaps one AD

Stewart,

Let me extend your suggestion in another direction, not to
support that direction (I have mixed feelings at best) but to
follow your lead in trying to open up the thinking and
discussion a bit.   Many of us have observed over the years
that, as the community changes, the pool of people who can and
do volunteer for the IESG keeps getting narrower.  I have
attributed part of that to various impulses to expand the job,
expansions that have the side effect of excluding anyone with
limited travel support and equivalent resources and/or time to
spend on the IETF.

Many other standards bodies have eased the management and
administrative burdens on volunteer leaders by moving toward
secretariats (and document editing and production processes)
that have significant technical skill and that manage much of
the standardization process other than decisions about creation
of new groups and projects and determination of consensus.

The IETF has steadily resisted going in that direction except
for the RFC Editor function.   We've taken some tiny steps in
that direction in recent years by using secretariat staff as
minute-takers for some bodies but we could, in principle at
least, shift a lot more.   There are many reasons for the
resistance.  Some are probably still valid, others may not be.
A choice to move more in the "strong, technically-able,
secretariat" direction is not all or nothing -- perhaps there
are some tasks that we should be moving out of the IESG entirely
except for oversight.

In the light of the recent discussion about increases in the
meeting fees, I should note that expanding the secretariat's
role and increasing the skills required would certainly not be
free (or even cheap).  But, if we are reaching the point at
which the burdens and workload for ADs are finally being
recognized as a problem that needs solving, perhaps it is time
to consider something along those lines.

     john

Note that the above could be applied either separately from your
suggestion or in parallel to it.

---

From: Eric Burger <[email-masked]>
Date: Fri, 10 Oct 2014 07:54:59 -0400

This is really tempting and has a lot going for it. However, my main concern is once we build a bureaucracy, it never goes away. In the case under discussion, the Division of Applications would still be with us in 2050 (if the IETF lasted that long). So, I think a professional secretariat helping with the technology would help in the short term, but will kill the relevance of the IETF in the long term.

On Oct 10, 2014, at 4:46 AM, John C Klensin <[email-masked]> wrote:
> discussion a bit.
[snip]

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 10 Oct 2014 08:53:04 -0400

This does seem to have strayed from the original topic.

I don't see any reason not to appoint an Apps area AD. There are three
possible outcomes from the process.

1) No change
2) The job of apps AD goes away and a new seat created
3) The job of apps AD goes away and is not replaced

Given the way this organization operates I think the chances of (3)
occurring within two years are not worth worrying about.

There is a broader issue though. Organizing around specialities does
not work when everything needs to have real time and security input.
There is a charter being circulated for DPRIVE (DNS Privacy). It took
me quite a while to work out it was being proposed in Internet area
and I don't think it fits there any better than security, transport or
applications. But I could make a case for it being RAI.

I have come to the conclusion that the OSI folk were right that there
is an intermediate layer between Transport and Applications. And that
is where TLS and DNS sit (and JSON). So call it Presentation because
its the familiar term. But its not the OSI presentation layer.

OSI were so very good at making the soup from the finest of
ingredients and then throwing an elephant turd in the pot before
serving.

Yes, the OSI model is junk. But not because models don't have any
value. The problem is that the model is describing what takes place in
the box rather than the interfaces between that box and the boxes it
connects to.

If we took an object oriented view [1] then we would define the system
in terms of the interfaces. And those are defined in terms of
identifiers and syntax (for the layers we deal with).

If we define the model this way the identifiers are:

Applications - Presentation :  DNS names
Presentation - Transport : IP Address, Port, TCP/UDP/wev
Transport - Internet : IP Address

Software defined networking and VPNs can fit very nicely into this
model and it illustrates the difference between them. If the upper and
lower interfaces are IP addresses then its a VPN. If only the upper
interface is IP Addresses then its SDN.

[1] Actually defining the interfaces is more characteristic of formal
specification languages such as Z/VDM.

---

From: John C Klensin <[email-masked]>
Date: Fri, 10 Oct 2014 09:41:57 -0400

--On Friday, October 10, 2014 07:54 -0400 Eric Burger
<[email-masked]> wrote:

> This is really tempting and has a lot going for it. However,
> my main concern is once we build a bureaucracy, it never goes
> away. In the case under discussion, the Division of
> Applications would still be with us in 2050 (if the IETF
> lasted that long). So, I think a professional secretariat
> helping with the technology would help in the short term, but
> will kill the relevance of the IETF in the long term.

Eric,

Yes, that is one of the important counterarguments although one
can imagine cultural and structural safeguards against it.
There are others, probably equally important.  It is not an
accident that many people in the IETF community have spent
energy deriding the organizations that use that model and their
outputs over the years.

It is probably not particularly important but moving to more
technical secretariat support does not require staff dedicated
to areas.  Some organizations do that, some don't.  And, as soon
as very long-lived WGs became common in the IETF rather than an
exceptional case or two that many people accepted grudgingly but
as necessities, we started to develop the patterns you describe
with no help from a technically professional secretariat.  The
latter, if not controlled, would probably accelerate the trend,
but one can ossify almost any environment.

My broader point was that, as we start looking beyond seeing an
issue with Apps and start wanting to make some adjustments into
thinking about how our basic "steering" and management structure
should evolve with the times, things similar to Stewart's model
of AD-plus-assistants aren't the only alternative.  There are
others, including several variations on a more active
technical/standardization role for the secretariat.  Indeed,
those two might converge at the point that one looked at
Stewart's suggestion and asked how we could staff ADs and a
bunch of assistants without turning everyone who is actually
willing to invest time beyond one or two topics or WG into
managers with no one left over to do the work: paying someone
would be one fairly obvious answer, just as it has been the
answer some minute-taking needs.  

If we really have an issue with Apps and Area boundaries, then
let's address that issue.  There is, however, a chance that the
current Apps issue, the recent issues with Transport, increasing
homogeneity in the IESG and exclusion of people who don't have
strong corporate/organization support, and questions about work
migrating out of the IETF that used to be obviously done here
are part of a pattern.  If that were the case, then, IMO, we
should be taking a broader look at organizational structure and
the evolving environment in which we work as more important than
trying to tune one Area a bit.   

I took Stewart's comment as starting to address those broader
questions --questions I personally think are important-- and
tried to respond in the same context.

   john

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 10 Oct 2014 10:18:37 -0400

On Fri, Oct 10, 2014 at 9:41 AM, John C Klensin <[email-masked]> wrote:

> to areas.  Some organizations do that, some don't.

If we are going to consider organization changes then we should be
looking more at the OASIS model that seems to work rather than the ITU
model which we have never liked and is poised to demonstrate a rather
spectacular failure model.

What I like about the OASIS model is that it dispenses with hierarchy
almost completely. What I dislike is that there are no structures to
encourage coherence between proposals at all.

My experience of SAML was that I spent 18 months making more or less
weekly tweaks to a specification document that mostly reflected
changes in opinion about the way we should use XML. And then after 1.0
shipped these were completely revisited to produce 2.0.

So when IETF groups started using XML and we had the same debates I
was suggesting that we have one group make one set of decisions that
we apply to all protocols unless there is good reason to do otherwise.
But that was of course a mistake. The fact the discussions were
necessary was due to the fact that we were using a screwdriver on a
nail and what we really needed was to ditch XML for JSON.

I would like some technical coherence direction but I don't see the
IESG or the IAB as providing it or really having the accountability to
do so.

> of AD-plus-assistants aren't the only alternative.

I agree. But returning to my earlier discussion on models. There is a
need for well defined interfaces at many different levels. The
transport area can do whatever it likes internally provided that it is
compatible with the laws of physics. But it can't change the interface
to applications or to the Internet layer without agreement on the
other side.

The approaches to standardization at the lower levels in the stack are
not necessarily optimal for the higher levels. It is really important
that the Internet area be 'stable' but what at the Applications level
we want to have as few constraints as possible. Applications level
'architecture' work is almost all digging ourselves out of holes
created by divergence.

---

From: Dave Cridland <[email-masked]>
Date: Fri, 10 Oct 2014 16:11:03 +0100

> applications that happen to be secure.
I suspect that for the most part, many of the security area groups are
applications which concern themselves with security. If you consider how
TLS is used within Applications as essentially a Transport protocol, or how
the SASL Working Group was almost entirely populated with Applications
people, there's a reasonable argument that the Security Area should shed
its working groups into other areas, and concentrate instead on cross-area
review.

That's not saying that we should drop a Security AD, mind - but saying that
working groups do not an area make.

What concerns me with dropping Applications is that without applications,
we have an interesting academic exercise rather than a product. Dropping
Applications expertise is decreasing user focus from the IESG, and I don't
see how this is a positive step, or one in which the overall "relevance" of
the IETF will increase. As an organization, I think we should be working
across the entire stack, of course, but we should be working to improve the
internet for its users. And while each layer of the stack has, or should
have, an impact on end users, the closest edge to those users is
Applications.

In fairness, I'm also worried that we're conflating the management
functions of the Area Directors with the technical expertise functions,
and, noting a reduced requirement for management function, we are removing
the expertise as well. I would rather a surplus of management capability
than a dearth of technical skill. While separating these two functions
entirely would also be a disaster of a different colour, maintaining an
awareness that there are two factors at play would put my mind  more at
ease.

Dave.

---

From: Michael StJohns <[email-masked]>
Date: Fri, 10 Oct 2014 11:18:00 -0400

>we encounter a case that doesn't fit the letter of the rules.

Yup.  The answer above was in response to "what does 3777 mean" more or less.

*laugh*  As an aside, I was about to comment on the differences between the UK's mostly unwritten constitution and the US's written one with respect to the IETF's approach.  We made a decision a while back to become an international standards organizations and that imposed some conditions of regular behavior and rule following based on written rules.

As I general matter, I agree with you about flexibility but I'm loath to apply the "rough consensus" approach to exception handling unless absolutely necessary.  My personal opinion is that the reasons given don't rise anywhere near "absolutely necessary".

Mike

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 10 Oct 2014 11:30:29 -0400

On Fri, Oct 10, 2014 at 11:11 AM, Dave Cridland <[email-masked]> wrote:

> What concerns me with dropping Applications is that without applications, we
> have an interesting academic exercise rather than a product. Dropping
> the IETF will increase.

What is proposed is to drop the Applications area. But there will
still be Real-Time Applications.

Absent an applications area to distinguish itself from, surely RAI
becomes applications?

So isn't this debate about merging RAI back into applications rather
than killing apps? If we did kill off apps, what do we do if we need
to revise SMTP?

Now I don't think we will ever do SMTP but not for the reason Dave
Crocker and John Klensin will agree with.

Dividing messaging into different streams depending on whether it is
real time or asynchronous is bogus. So is dividing on message size. So
eventually there will be one protocol that covers SMTP, XMPP, NNTP,
RSS, Social media and more and it will eventually replace all the
legacy protocols.

---

From: Pete Resnick <[email-masked]>
Date: Fri, 10 Oct 2014 10:33:51 -0500

On 10/10/14 2:18 AM, John C Klensin wrote:
>>> Having a generalist is uncharted waters.
>>
>> Not really.   The IETF chair is by definition something of a
>> generalist and usually has work in more than one area during their
>> participation.
>>      

Not a good parallel. The WG management responsibilities of the IETF 
chair are extremely small. Jari has his first WG in his tenure as chair, 
and AFAICT Russ didn't have any. And also AFAICT the IETF chair does not 
manage technical work from WGs.

Sure, we could say to the NomCom, "Don't fill the APP slot with another 
APP person; find a generalist who could be cross-area." But I think that 
would be much more disruptive to the current operation of the IESG, 
having to figure out how to re-organize our current work to accommodate 
this new generalist, and would slow our ability to accomplish the 
re-organization we really need to be doing.

>> If you don't know what the re-org will
>> result in, how is deciding that the APPs area AD going away is the
>> correct decision?
>>      

Tactics vs. strategy. We know that we want to redistribute load 
throughout the areas. We know that there is currently a small load for 
the APP area, as constituted, and we believe that the current single APP 
AD can handle the load easily. We're not sure what (if any) skillset 
will be most useful for the current APP slot once we go through 
re-organizing thing, but we're pretty convinced it's not going to be the 
skillset that we generally recruit for the APP area.

By appointing someone to the slot now, we're making the re-org harder. 

> problems than the number of years for which a Nomcom can make an

Assuming you meant "not willing", I think you're being a bit 
unrealistic, or at least not being nuanced enough, about this. For 
better or worse, the way we select folks for the IESG now, we ask for a 
serious two year commitment, one that normally involves talking to 
employers and re-arranging life for quite some period of time. Even if 
*theoretically* a given AD would be willing to resign for the good of 
the community, there are going to be cultural and social pressures on 
the IESG not to "re-organize one of their own out of a job". I'd like to 
think we weren't susceptible to such influences, but I think it's there 
in the background. Furthermore, it's not really fair to ask someone to 
make a commitment in such a nebulous state. Taking this opportunity 
(when you have an incumbent AD stepping down anyway from an area that 
currently has a light(er) work load and is clearly going to be part of 
the re-organization) to not fill the position until the re-org is done 
makes the most sense to me.

Trying to re-org and drop an AD later if we decide we need to is not a 
good plan forward. In my judgment, it simply won't work.

pr

---

From: Pete Resnick <[email-masked]>
Date: Fri, 10 Oct 2014 10:33:56 -0500

On 10/10/14 10:30 AM, Phillip Hallam-Baker wrote:
> What is proposed is to drop the Applications area.

No. That's not being proposed.

pr

---

From: Michael StJohns <[email-masked]>
Date: Fri, 10 Oct 2014 11:37:51 -0400

>to do with this particular case.

I'm going to pseudo-top post here.  I don't think of this as so much a disagreement in the philosophy of how flexible we should be, but more a disagreement about when it's expedient and appropriate to throw the rules away.   Most of the stuff we've come up with has a deliberative component to it - "figure out what you need, socialize it and get consensus" coupled with procedural items ("normal AD appointees take office during the First IETF").    If you follow the rules, you mostly get a predictable outcome and predictable times.   If you want to bypass the rules, then you *still* need to "figure out what you need, socialize it and get consensus", but not just for the change, but for the change in procedures.

In the instant case we got "The IESG has decided to close out the APPs area - discuss.  Oh and by the way, while the discussion is taking place you guys over at the Nomcom should ignore the open slot in APPs in your deliberations."     The first piece of it is fine; the second less so.  As has been evident by the discussion, the form of the IESG in fall of 2015 is still up in the air; leaving me to wonder if there's something else going on that's not been made public.

I've no idea how far the Nomcom is along the process.  AIRC, Nominations were supposed to be in as of 8 October or right about when this got started. 

>things to do and getting them done. 

Yes but.  There's a difference on getting documents through the process (and it's unclear we're doing better there than we used to be) and all the rest of the cruft that makes up an organizations operating system.  I'm not saying that applying "do what's right" to the operation of the IETF is necessarily wrong, but that's the place were we touch the legal systems of various jurisdictions.  Not following our own rules is one way to get in trouble.

All of the above said, my large objection to this is that it seems rushed, and not well thought out with possible hidden implications and unintended consequences.  It's unclear the need espoused by Jari rises to the level of exception processing and I would feel uncomfortable acceding to the IESGs desire to not fill the slot at this time.

Mike

---

From: Dave Crocker <[email-masked]>
Date: Fri, 10 Oct 2014 08:55:51 -0700

> By appointing someone to the slot now, we're making the re-org harder.

Not really.

By the IESG's own admission, the current proposal is only partial.  It
does not fully attend to the concerns the IESG has nor does it fully
resolve any of the concerns.  As such it appears to represent a tactical
response, albeit with strategic implications.  As proposed, it has a bit
of ready-fire-aim quality to it.

It would be far more productive for the IESG to take the requisite time
to formulate a complete proposal, including careful justification for
whatever constitutes the full set of changes in mind.  That will permit
integrated analysis and discussion, rather than the piecemeal kind
currently happening.

Making these sorts of deeper and more substantial organizational changes
to the IESG is not made easier or hard by having one fewer or more ADs.

On the other hand, decrementally dropping an AD position rather suddenly
like this has the aura of making significant organizational change but
without a real opportunity for considering implications.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 10 Oct 2014 08:59:41 -0700

On Thu, Oct 9, 2014 at 7:42 AM, Paul Hoffman <[email-masked]> wrote:

> Of course. There will periodically be a group of people who want to create
> a new format for data about people or calendar events, or some
> possibly-useful way to use HTTP or email, and so on. With this change, they
> will have to go to an area that is not filled with people who have done
> that themselves earlier. That's fine: keeping the area around just for that
> is not a good use of human resources.
>

I agree with the lauding of any organization that undertakes this sort of
structural review from time to time.  However, I'm a little uneasy about
doing away with APP completely.  I do agree that a lot of APP area work is
going into the web and there's a lot of overlap with RAI in that realm, but
APP also looks after a lot of much older but still relevant protocols, and
also things like the media type registries.  Into which of the remaining
areas might that work fall?  People might find it confusing to have to take
their new email-related idea or media type, for example, and shop it around
to SEC, INT, RAI, TSV, RTG, GEN or OPS looking for a new WG or a sponsoring
AD, and if I were an AD of any of those areas, I'm not sure I'd want it in
mine.  One could argue that stuff without an obvious home lands in GEN, but
the IESG Chair is busy enough as it is.  Or should we expand the definition
of GEN to cover such things, and find a second AD for that?

-MSK

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 10 Oct 2014 12:26:22 -0400

>> By appointing someone to the slot now, we're making the re-org harder.

I agree with Dave,

What is being proposed here is essentially that the IESG wants to jump
out of the plane now so that by doing so they are encouraged to
complete their parachute design and implementation before they hit
their hard deadline.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 10 Oct 2014 11:36:48 -0500

I'm doing my best not to comment, but on two points here ...

On Fri, Oct 10, 2014 at 10:59 AM, Murray S. Kucherawy <[email-masked]>
wrote:

>> Of course. There will periodically be a group of people who want to
>> create a new format for data about people or calendar events, or some
> doing away with APP completely.
>

Speaking as 1/15th of the IESG, that's not on the table. I haven't heard
any of the ADs saying "APP goes away completely". But beyond that ...

> I do agree that a lot of APP area work is going into the web and there's a
> lot of overlap with RAI in that realm, but APP also looks after a lot of
> much older but still relevant protocols, and also things like the media
> type registries.  Into which of the remaining areas might that work fall?
> People might find it confusing to have to take their new email-related idea
> or media type, for example, and shop it around to SEC, INT, RAI, TSV, RTG,
> GEN or OPS looking for a new WG or a sponsoring AD, and if I were an AD of
> any of those areas, I'm not sure I'd want it in mine.  One could argue that
> stuff without an obvious home lands in GEN, but the IESG Chair is busy
> enough as it is.  Or should we expand the definition of GEN to cover such
> things, and find a second AD for that?
>
>
Speaking as one of the TSV ADs ... if you think "transport" is "end to end,
above IP, below the application", and I do, a bit more than half of TSV is
"transport". We've got storage (both iSCSI--ish and NFS). We've got ALTO.
We've got CDNI. We've got IPPM.

At the Orlando TSVAREA session, with the area was talking about TSV AD
position expectations, David Black got a rousing round of applause when he
said he'd never had an AD who understood the work on storage, and he wasn't
sure he wanted one (*).

Historically, SIGTRAN produced more SS7 applications (like M3UA) than
"transport" protocols (SCTP).

Several of the areas are chartering working groups that could reasonably be
in any of two or three areas. We just chartered TCPINC, which could just as
well have ended up in SEC, and Martin's hoping to get DTN chartered before
Honolulu, which could reasonably have ended up in APP.

We can end up talking about appropriate areas at several points in the
BOF/WG charter process.

So, I won't comment on anything else, but I did want to assure folks that
if the IETF needs to do work on a protocol, we'll find a place to do that
work, no matter what the current areas are called.

Thanks,

Spencer

(*) The minutes from the AD expectations discussion in Orlando at
http://www.ietf.org/proceedings/86/minutes/minutes-86-tsvarea are actually
pretty interesting.

---

From: S Moonesamy <[email-masked]>
Date: Fri, 10 Oct 2014 10:11:26 -0700

Hi Pete,
At 08:33 10-10-2014, Pete Resnick wrote:
>better or worse, the way we select folks for the IESG now, we ask 
>for a serious two year commitment, one that normally involves 
>talking to employers and re-arranging life for quite some period of 
>time. Even if *theoretically* a given AD would be willing to resign 
>for the good of the community, there are going to be cultural and 
>social pressures on the IESG not to "re-organize one of their own 
>out of a job". I'd like to think we weren't susceptible to such 
>influences, but I think it's there in the background. Furthermore, 
>it's not really fair to ask someone to make a commitment

I'll highlight a point in the above: pressure not to reorganize one 
of their own out of a job.  Here's what APPS may be in 2016:

   - The current APPS AD deciding whether to stay or not

If the IESG drops one of the APPS AD roles the new APPS AD would stay 
on and the current APPS AD role is redundant [1].

If the IESG is creating a Area A it would have to define the 
expertise for "A".  This might entail reviewing all the AD roles for 
that area.  The IESG still ends up with reorganizing one or more of 
their own out of a job.

I would say:

   (a) Shut down APPS in 2016

   (b) Define the expertise for "A" for 2016

Some of the working groups in (a) does not necessarily have to move 
to "A".  By doing this in 2016 you get to push in desired expertise 
into more than one area [2].

Regards,
S. Moonesamy

1. This is the process angle.
2. One does not have to look for rare birds.

---

From: Leslie Daigle <[email-masked]>
Date: Fri, 10 Oct 2014 15:35:16 -0400

Below:

> No. That's not being proposed.

Well,

[Jari wrote, in the announcement:]
> A significant
> protocols, but that has a good deal of crossover with work in RAI.
[snip]
 >  we have noticed that
> area,
[snip]
> the APP AD vacancy in this NomCom cycle.

So, I really can't imagine why people have the impression doing away 
with the APP Area isn't _exactly_ what is being proposed...

Leslie.

--

---

From: Barry Leiba <[email-masked]>
Date: Fri, 10 Oct 2014 17:15:41 -0400

Just a point of fact:

> You need to read it all.   Regular candidates serve a 2 or 3 year
> appointment.  Mid-term vacancy fillers serve between 1 to three years
> depending on when the vacancy occurs.   AFAIK we've never made a normal
> vacancy 1 year appointment.

We did it on the IESG when we created the RAI area in 2006: Jon
Peterson was appointed RAI AD for a one-year term, and Lars Eggert was
give a one-year term in TSV to fill the mid-term vacancy.

We did it on the IAB when we appointed Eliot Lear for a second
one-year term in 2014 (his first one-year term was to fill the
mid-term vacancy created when Jari became IETF Chair in 2013).

Barry

---

From: Jari Arkko <[email-masked]>
Date: Fri, 10 Oct 2014 17:06:38 -0700

Stewart:

Thanks. Certainly food for thought.

The proposed change relates to how the organisation is divided into parts, what areas we have. I think that is a necessary part, but it should not be the only part. Additional changes are certainly worth considering, and the IESG has been considering them as well. In particular, I would be very interested in lowering the per-person workload so that a broader set of people could consider IETF leadership positions. Including even more people who are great engineers and also needed elsewhere.

(FWIW, we have a few ADs who are succeeding with a fully-loaded day job and their AD task. By the way, strangely enough, one of the difficulties in “letting go” in the IESG and having even more of the work performed in the working groups relates to how view ADs decide to run our daily business. There certainly is a lot to do, and on large areas or in difficult situations a lot of effort is needed. However, personal management styles differ greatly. It is also about the culture and personal choice and not only about how we’ve defined the AD tasks in our process RFCs.)

Jari

---

From: Tim Chown <[email-masked]>
Date: Sat, 11 Oct 2014 10:07:50 +0100

> The proposed change relates to how the organisation is divided into parts, what areas we have. I think that is a necessary part, but it should not be the only part. Additional changes are certainly…

This seems a highly desirable goal of any adjustments to the IESG structure.

> (FWIW, we have a few ADs who are succeeding with a fully-loaded day job and their AD task. By the way, strangely enough, one of the difficulties in “letting go” in the IESG and having even more of…

Tim

---

From: John C Klensin <[email-masked]>
Date: Sat, 11 Oct 2014 09:03:03 -0400

--On Friday, 10 October, 2014 10:33 -0500 Pete Resnick
<[email-masked]> wrote:

>>> generalist and usually has work in more than one area during
>>> their participation.
>>>      
> 
> Not a good parallel. The WG management responsibilities of the
> IETF chair are extremely small. Jari has his first WG in his
> tenure as chair, and AFAICT Russ didn't have any. And also
> AFAICT the IETF chair does not manage technical work from WGs.

I'd go further.  The original conception was that the IETF Chair
would have _no_ specific WG oversight responsibility, only
responsibility for oversight and management.  Mike will remember
the period when the IAB appointed the IESG Chair and the IETF
Chair appointed the other ADs, who served at his pleasure.  An
inference of "generalist" from that would be entirely
reasonable, but it is not because of the profile of WGs, work in
more than one area, or even, IMO, a specific part of the job
description.  THe so-called General Area was created entirely as
a process workaround to make process WGs fit somewhere in the
conventional IESG-WG relationship structure.

In reality, since 1992, there has rarely (if ever) actually been
a General Area as an Area, just an administrative/ terminology
convenience to make some of the written procedures work.  To my
knowledge, the area has never held a meeting, never had a
directorate, never had any specific coordination among WGs (even
when there have been more than zero or one of them).  

IMO, the above, including the whole idea of the "General Area"
demonstrates our long tradition of being flexible about The
Rules in order to get things done.  I note that an alternative
to the General Area concept (clearly falling within the IESG's
authority to create and define Areas) would have been to simply
modify 2025, 2028, etc., except process WGs from the Area model.
IIR, the IESG chose the former as simply more expedient than
opening the basic process documents and, again IIR, no one
objected.

To be clear, there are several things that persuade me that the
proposed course of action is not optimal.   I believe, however,
that modulo the potential for an appeal, it is within the IESG's
authority and precedent to do it.

     john

---

From: John C Klensin <[email-masked]>
Date: Sat, 11 Oct 2014 12:12:07 -0400

--On Friday, 10 October, 2014 11:37 -0400 Michael StJohns
<[email-masked]> wrote:

> I'm going to pseudo-top post here.  I don't think of this as
> so much a disagreement in the philosophy of how flexible we
> should be, but more a disagreement about when it's expedient
> and appropriate to throw the rules away.   Most of the stuff

It seems to me that we aren't going to convince each other or
much of anything else, so this will be my last posting on the
subthread of whether the IESG can do this.  I also believe the
Nomcom can make one-year appointments.  It has certainly done
so: Michael's note and see Barry's note that lists recent
precedents.  

FWIW, I also believe that the Nomcom can leave a position that
the IESG or IAB requested open.  If nothing else, a Nomcom can
say, "unable to fill that on schedule, so sorry" -- as was done
with Transport not that long ago-- and then never quite get
along to filling it.  That could get quite ugly if the community
did not understand and accept the reasons but we have no
procedure that I'm aware of that would allow forcing the Nomcom
to do anything, no procedure to force the Nomcom to explain any
of its personnel decisions to the community, much less get
community consensus for them, etc.  Under most circumstances, we
see that degree of independence as a necessary safeguard.  If
one believes strongly that the Nomcom MUST do something like
fill all requested positions, it is a little awkward.

> we've come up with has a deliberative component to it -
> "figure out what you need, socialize it and get consensus"
> coupled with procedural items ("normal AD appointees take
> office during the First IETF").    If you follow the rules,
> you mostly get a predictable outcome and predictable times.
> If you want to bypass the rules, then you *still* need to
> "figure out what you need, socialize it and get consensus",
> but not just for the change, but for the change in procedures.

Per the above, I don't even see the alternatives that have been
proposed as changes in procedures, much less ones that are so
basic as to constitute "throwing the rules away".  

While the tendency has been for the IESG to expand, adding areas
and moving, one area at a time, from one AD to two, we've also
eliminated them, usually but not always either coincident with a
Nomcom cycle or by shifting the AD into another area.  Remember
"OSI Transition"?  "Applications Support"? (My memory may not be
good enough to remember exact names, but the Areas definitely
existed.)  IIR, we even had Operations and Management separated
at some point.

> In the instant case we got "The IESG has decided to close out
> the APPs area - discuss.  Oh and by the way, while the
> discussion is taking place you guys over at the Nomcom should
> ignore the open slot in APPs in your deliberations."     The
> first piece of it is fine; the second less so.  As has been
> evident by the discussion, the form of the IESG in fall of
> 2015 is still up in the air; leaving me to wonder if there's
> something else going on that's not been made public.

Again, at least as I read the procedures, the IESG has the
right/authority to tell the Nomcom what slots to fill and,
procedurally, this seems consistent with that authority if
uncomfortably late.  I also don't see a lot of difference in
practice between appointing an AD to a one-year term and
appointing an AD for two years with the explicit understanding
that the Area is probably being reorganized and that, while the
newly-appointed AD will get a voice in that discussion, he or
she may be expected to step down or shift into work with another
designation before the term is up.   See below.

It is actually not even clear to me that the IESG is required to
see community consensus to reorganize itself.  I'm quite sure it
has reorganized areas in the past by announcement, without any
effort to get such consensus or even a discussion.

None of the above suggests that I think either this move or the
timing are wise or in good taste.  Those are separate issues.  I
just don't see a huge procedural problem, much less one that
rises to "throwing away the rules".

> I've no idea how far the Nomcom is along the process.  AIRC,
> Nominations were supposed to be in as of 8 October or right
> about when this got started. 

Another example, in a way.  The only way that the close of
nominations interacts with this is that, if there are applicants
for Apps in the pot and we continue on the course selected by
the IESG. then the Nomcom says "in combination with the IESG"
(or "at the direction of the IESG") "we aren't filling the Apps
slot.  Thanks for your interest in the position".  In part
because I believe that the Nomcom has the ability to go
recruiting and even arm-twisting of people who didn't volunteer
pre-the nominal nominations cutoff, I believe they could also
interpret a nomination for Apps as a potential nomination for
some other Area, go back to the individual, and say "you were
nominated for the Apps  slot and there isn't one, would you be
willing to serve in XYA". You might disagree about that too,
but, again, there is precedent for candidates being appointed to
particular positions who where not nominated prior to the
nominal cutoff so, if there were a procedural violation, it
would be old news.

>...
>> The IETF, by contrast, tended to focus on identifying the
>> right things to do and getting them done. 
> 
> Yes but.  There's a difference on getting documents through
> the process (and it's unclear we're doing better there than we
> used to be) and all the rest of the cruft that makes up an
> organizations operating system.  I'm not saying that applying
> "do what's right" to the operation of the IETF is necessarily
> wrong, but that's the place were we touch the legal systems of
> various jurisdictions.  Not following our own rules is one way
> to get in trouble.

I completely agree and worry about that a lot.  I am, for
example, very concerned when we make standards-track decisions
based on individual submissions where there is not clear
evidence of community review and consensus (not just silence by
everyone but the author and a small circle of supporters with
personal or corporate connections).    But this particular issue
seems less significant, less of a deviation, to me than it
apparently does to you.  I also believe that almost every aspect
of it, even if not the combination, has precedents so it
wouldn't put us in any stew we aren't in already.   Of course,
if there were any evidence that either the decision or the
timing were motivated by personal or corporate considerations
that have not been exposed to the community, that would be a
rather different matter.

> All of the above said, my large objection to this is that it
> seems rushed, and not well thought out with possible hidden
> implications and unintended consequences.  

Again, we are in complete agreement on that subject.
Personally, I'm particularly concerned about positive feedback
influencing work choices, e.g., the chilling effect on someone
thinking about bringing new work into toe Apps area or even
keeping work within the IETF that is struggling.   Area
designations and specialties do make a difference.  Anyone who
needs an example should consider the course of DNS work
(including IDN work) since the DNS was shifted from being
considered as an application, into an applications
infrastructure area, and then into Internet.   It is not clear
that the work taken up and many of the decisions made would be
different, but some of the outcomes certainly would have been.

Because it seems directly relevant...

--On Friday, 10 October, 2014 10:33 -0500 Pete Resnick
<[email-masked]> wrote:

>...
>> We really do not need to argue
>> about whether one-year appointments are possible because, if
>> the IESG decides to eliminate an area or AD slot and the
>> relevant ADs are so attached to the jobs that one or more is
>> willing to resign for the good of the community and to free
>> herself from a non-existent position, I suggest that we have
>> far greater problems than the number of years for which a
>> Nomcom can make an appointment.    
> 
> Assuming you meant "not willing",

yes, sorry.

> I think you're being a bit
> unrealistic, or at least not being nuanced enough, about this.
> For better or worse, the way we select folks for the IESG now,
> we ask for a serious two year commitment, one that normally
> involves talking to employers and re-arranging life for quite
> some period of time. Even if *theoretically* a given AD would
> be willing to resign for the good of the community, there are
> going to be cultural and social pressures on the IESG not to
> "re-organize one of their own out of a job". I'd like to think
> we weren't susceptible to such influences, but I think it's
> there in the background. Furthermore, it's not really fair to
> ask someone to make a commitment in such a nebulous state.
> Taking this opportunity (when you have an incumbent AD
> stepping down anyway from an area that currently has a
> light(er) work load and is clearly going to be part of the
> re-organization) to not fill the position until the re-org is
> done makes the most sense to me.

First of all, to the degree the situation is as you describe
(and it probably is) the subthread that Stewart started is
extremely relevant.   The model we are using today is more than
20 years old.  A lot has changed in that time.   Unless we want
the IESG role to explicitly become a career choice [1] and a
commitment decision that can be made only by large organizations
and the independently wealthy, it is probably time to reconsider
how we organized ourselves and try to get work done.  

That said, 

> Trying to re-org and drop an AD later if we decide we need to
> is not a good plan forward. In my judgment, it simply won't
> work.

Interesting, because there is lots of precedent for it.  I don't
remember anyone stepping down mid-term, but I remember creation
of special areas that expire with the individual, assignment of
someone as an extra AD to another area, and similar moves.   My
bigger concern about putting an AD in for a short term is the
issue that Ted mentioned: the start up time is pretty painful.
On the other hand, as was pointed out in an off list comment,
perhaps there is a former AD or someone else with a head start
on the learning process who would be willing and able to take on
a short term commitment... possibly even one who couldn't commit
to the long periods and workload you cite [2].  One doesn't know
if one forecloses the possibility of asking.

In this particular case, given an extrapolation from the
combination of your note to the Apps Area about stepping down,
your obvious interest in how the IETF is organized and reaches
consensus, and dropping Apps workload, it might be sensible to
create a temporary "fishy" area (i.e., an offspring of a WG I
once chaired), put you in charge of it on a ramp-up transition
basis, and then persuade you to put in an extra six months to
shepherd and complete that work.  That would make the timing
about right, would eliminate some of my concerns about WGs
suffering from even further reduced attention, and so on.

I don't know if it is a good idea or not.  But it is yet more
evidence that, if the IESG actually considered the full range of
options, they haven't shared those considerations with the
community.

    john

[1] A choice that, in many cases, makes sense only for
professional standardizers and not for architects, designers,
developers or those we traditionally think of as your primary
participants.

[2] For the record, I would absolutely not be a candidate.  Too
old, insufficient support, feeling pretty burned out about the
IETF, and generally the wrong person for the job.  So I'm not
shopping for a position, just identifying a possibility.

---

From: Michael StJohns <[email-masked]>
Date: Sat, 11 Oct 2014 12:26:47 -0400

>mid-term vacancy created when Jari became IETF Chair in 2013).

Interesting... I didn't catch that last one at the time.  I'm not quite sure why the Nomcom didn't follow the rules and appoint someone to a three year catch up term instead of just giving Eliot a 1 year term.  Actually, I'm not sure why the previous Nomcom didn't give Eliot a 2 year term in the first place - that would have solved the rebalancing thing then.  (Hmm... ok, maybe the rule about poaching IAB members needs clarification again - it doesn't exactly fit the mid-term vacancy rules)

All of this is water under the bridge, but I do remember the topic of short terms being hotly debated during 3777's creation and soundly rejected resulting in the rule as written.

No worries - Mike

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 11 Oct 2014 13:33:57 -0400

There is a big difference between having the right to do something and
it being wise.

The origin of the IETF was a DARPA program manager handing out the
money. Which is perfectly fine for people like me who come from a
country based on the principle of strange women lying around in ponds
distributing swords. It might not be as acceptable to folk whose
foundation myths are different.

There might be a good reason for this change but I certainly don't see
that a case has been made for urgency.

There is certainly something odd about the way apps is working right
now. But I don't think the IESG has made a case that they understand
the problem, let alone what the solution should be.

I am also rather concerned about the possibility of setting an
unfortunate precedent.

---

From: Michael Richardson <[email-masked]>
Date: Sat, 11 Oct 2014 15:58:30 -0400

> Interesting... I didn't catch that last one at the time.  I'm not quite
    > sure why the Nomcom didn't follow the rules and appoint someone to a
    > three year catch up term instead of just giving Eliot a 1 year term.
    > Actually, I'm not sure why the previous Nomcom didn't give Eliot a 2
    > year term in the first place - that would have solved the rebalancing
    > thing then.  (Hmm... ok, maybe the rule about poaching IAB members
    > needs clarification again - it doesn't exactly fit the mid-term vacancy
    > rules)

The nomcom had to give someone a 1 year term if half of the IAB was going to
be reviewed each year.   

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Harald Alvestrand <[email-masked]>
Date: Sun, 12 Oct 2014 10:30:41 +0200

>> On 10/9/14 3:03 PM, Michael Richardson wrote:
....
>>
>> If a new AD position is created, I think doing a 3 year appointment
>> is most consonant with 3777 3.4, but I don't think 1 year is forbidden.
>
> depending on when the vacancy occurs.   AFAIK we've never made a
> normal vacancy 1 year appointment.  And I think its been a while since
> we've had a 3 year term appointment.

I'm going to read the whole thread before I comment on the current
situation, but we have done an one-year appointment at least once.

In 1998, I was appointed AD for the O&M area for a period of 1 year.
This was a special situation, because:

a) Both O&M ADs were resigning at the same time, so we needed to do
either 1+2 or 3+2
b) I was already on the IESG (switch from apps), so learning curve was
percieved to be shorter
c) I expressly did not want to change my intention of departing the IESG
after 4 years

The only lesson worth noting here is that we have a tradition of doing
what makes sense.

---

From: Michael StJohns <[email-masked]>
Date: Sun, 12 Oct 2014 12:12:53 -0400

>This was a special situation, because:

There's a slight difference between a one-year mid-term and a one year normal appointment.  

I was the chair of the Nomcom that nominated you for the move.  That Nomcom had unusual results in a number of ways, including the O&M area.

>c) I expressly did not want to change my intention of departing the IESG

Actually, no.  You were a "mid term" appointment, that happened to coincide with the normal Nomcom deliberative cycle.

We met to consider Mike O'Dell's O&M slot.  During the period between when vacancy announcements were made and we'd completed deliberations, John Curran resigned.   We re-appointed Mike for a 2 year term, and moved you from Apps to cover John's slot (mid-term vacancy in current terms).   

Between the time we completed deliberations (and I think *after* we'd gotten a confirmation on Mike and you from the IAB) and the First IETF for 1998, Mike O'Dell had some medical issues and resigned.  The Nomcom ended up selecting Bert Wijnen to fill Mike's slot.  Your term was long fixed by the time that happened.

As part of that Nomcom, we did the first "rebalancing"  term adjustments and appointed *I think* two people for three year terms.  I know one of them was Fred Baker, I believe the other was Patrik Faalstrom to fill your vacated Apps slot.  There *might* have been one other, but I'd have to go do some digging.

That Nomcom ended up making 17 nominations, all of which were confirmed.  We filled 3 O&M slots prior to First IETF.  I *think* your move from Apps to Ops was the first mid-term poaching (the prior year Nomcom had moved Scott B from Ops to Transport, but I think that was on a normal 2 year boundary).

Incidentally, that Nomcom also suggested to the IESG that perhaps it was time to not fill the User Services area vacancy (which Area was mostly meeting as a committee of the whole).  The IESG considered that comment and still asked us to complete the process.  User Services took another 4 years to phase out, even though there were few (no?) extant WGs in the area.

>The only lesson worth noting here is that we have a tradition of doing

Note that a number of the actions the '98 Nomcom took would be prohibited or substantially modified by 3777 which was put in place a couple years after.  Specifically, the way we moved you from Apps to Ops would have required two steps rather than the one it took. 

There also was no real notion of what a mid-term vacancy was as John's resigning was *I think* the first one we'd had.

Processes evolve and mostly codify existing practice.  At the time of the '98 Nomcom, the body of existing practice was a lot smaller than today's and that gave us a bit more flexibility than is the current norm.

Mike

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 14 Oct 2014 17:46:27 +0200

I support reducing the number of WGs and the number of ietf areas but not
the ADs.

AB

On Wednesday, October 8, 2014, IETF Chair <[email-masked]> wrote:

> comments [email-masked] <javascript:;>, or alternatively to [email-masked]
> <javascript:;> if you prefer, by 13

---

From: Jari Arkko <[email-masked]>
Date: Thu, 16 Oct 2014 07:27:27 -0700

> are part of a pattern.

I think both of those are issues. But I think addressing the latter and harder problem
should not prevent us from addressing the former. The management structure needs
to scale, but we still need the right areas, matching where the work is.

Jari

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 Oct 2014 10:34:55 -0400

--On Thursday, October 16, 2014 07:27 -0700 Jari Arkko
<[email-masked]> wrote:

>> let's address that issue.  There is, however, a chance that
>> the current Apps issue, the recent issues with Transport,
>> increasing homogeneity in the IESG and exclusion of people
>> who don't have strong corporate/organization support, and
>> questions about work migrating out of the IETF that used to
>> be obviously done here are part of a pattern.
> 
> I think both of those are issues. But I think addressing the
> latter and harder problem should not prevent us from
> addressing the former. The management structure needs to
> scale, but we still need the right areas, matching where the
> work is.

I completely agree.  Sorry if I was not clear.
   john