Subject: Thoughts triggered by "Proposed IESG structure change"

From: Harald Alvestrand <[email-masked]>
Date: Tue, 14 Oct 2014 17:53:54 +0200

Having read this thread.....

- The IESG considers a structural change to its organization of work.
- The IESG considers that the timeframe for figuring out details of this 
change is on the order of a year.
- The IESG thinks that as part of the details of this change, it's 
unlikely to add more workload to an area that has quite few groups in 
the near future.
- The IESG therefore thinks that it should leave an AD position in this 
area open for a while.

It's clear that the roles and job descriptions on the IESG are described 
by the IESG. It's perfectly reasonable for them to say "this post needs 
to be eliminated".

The procedural objections here seem to all be of the form "the IESG 
should have told the nomcom this when it sent the position descriptions 
to the Nomcom".

Now consider the timing.

It's October. The new AD (if selected) will be added to the IESG in 
March, and will be selected for a period of 2 years (unless he resigns). 
In July, there would not have been a procedural issue with this request 
at all.

So - we're talking about a lead time of 5 months here, and having a 
procedural tizzy because the lead time isn't 8 months. For something 
that (if the person remains on the IESG for 2 years) will have effect 29 
months from now.

I'm in a rapidly changing organziation during my day work. When a 
decision on structure was reached, it got *implemented* on a timeframe 
shorter than the nomcom getting its brief and the IESG saying that "you 
might want to consider this point".

The timeframes we're dealing with for changes in the IETF have lost 
touch with the needs of the world the IETF operates in; the world has 
become considerably faster, and the IETF has not.

I, for one, welcome the signs of change. If the change requested makes 
sense, do it.
Procedures exist to make the organization work better. Not the other way 
round.

Harald

---

From: [email-masked]
Date: Tue, 14 Oct 2014 09:26:58 -0700 (PDT)

> ...

> Procedures exist to make the organization work better. Not the other way

Very nicely put and I agree 100%. Sure, it would have been better all around if
the conclusion not to staff had been made sooner. But given a choice between
making a change the IESG has concluded is needed and insisting on following
procedures to the last detail, the former overwhelmingly makes more sense.

				Ned

---

From: Michael StJohns <[email-masked]>
Date: Tue, 14 Oct 2014 13:55:13 -0400

At 11:53 AM 10/14/2014, Harald Alvestrand wrote:
>- The IESG considers that the timeframe for figuring out details of this change is on the order of a year.
>- The IESG thinks that as part of the details of this change, it's unlikely to add more workload to an area that has quite few groups in the near future.
>- The IESG therefore thinks that it should leave an AD position in this area open for a while.
>
>It's clear that the roles and job descriptions on the IESG are described by the IESG. It's perfectly reasonable for them to say "this post needs to be eliminated".
>
>The procedural objections here seem to all be of the form "the IESG should have told the nomcom this when it sent the position descriptions to the Nomcom".

Actually, that is one of the comments I made.  Another was that the relationship between not filling the slot and the as yet to be determined changes was unclear.  My suggestion was to complete the socialization of the changes before interrupting other things.

E.g. if Jari had said: "The IESG has consulted with the APPs ADs and with the APPs area WGs and has come to consensus with them that its time to begin the process of closing out the area.  As part of this process, we're asking the Nomcom to no longer consider the APP slot vacancy open and to not fill it.  We expect to have more complete details on this process within the next month or so as we decide how to handle the remaining groups and workload."

I'd go - "OK - thoughtful and complete.  They have a plan.  This is one step".

Instead what he said was:  "...So we are starting to think about reorganizing the areas
a bit,..."  [Yup there was a whole lot more, but that was the indication that there was no plan and that the process was only just beginning.] and followed with 

>Now consider the timing.
>
>It's October. The new AD (if selected) will be added to the IESG in March, and will be selected for a period of 2 years (unless he resigns). In July, there would not have been a procedural issue with this request at all.
>
>So - we're talking about a lead time of 5 months here, and having a procedural tizzy because the lead time isn't 8 months. For something that (if the person remains on the IESG for 2 years) will have effect 29 months from now.

That's not really it at all.  If there's a plan and consensus to close out the area, that sounds like it might be a good idea (with more details).  Unfortunately, that's not what the record says.   In any event, at a bare minimum, we've got an AD around for another 17 months in that area who is going to have to find something else useful to do if everything gets moved. 

>I'm in a rapidly changing organziation during my day work. When a decision on structure was reached, it got *implemented* on a timeframe shorter than the nomcom getting its brief and the IESG saying that "you might want to consider this point".
>
>The timeframes we're dealing with for changes in the IETF have lost touch with the needs of the world the IETF operates in; the world has become considerably faster, and the IETF has not.

What you've described is a hierarchically, top-down managed for profit company where the line employees have no say in the organizational structure.   Do you really think that model applies to the current bottom-up consensus driven IETF structure?  If you're suggesting changes along that line for the IETF, then that's a much longer and probably more fraught conversation that the current instance.

Things take time because consensus takes time.  To change that, we'd have to give the various ADs and  I* Chairs and even WG chairs a lot more power to make broader decisions than I think we've currently granted them.

>I, for one, welcome the signs of change. If the change requested makes sense, do it.
>Procedures exist to make the organization work better. Not the other way round.

Procedures sometimes exist to constrain the "management" from doing things that the "employees" would find problematic.  

The other use for procedures is to get pre-agreement  (consensus or whatever appropriate) on what can be done when and by who and how.  When those are brushed aside, good and proper reasons should be necessary and inquiring into those reasons shouldn't be met with suspicion and disdain.

In any event, given the email from the Nomcom chair, this inquiry is moot and the non-appointment of the APPs AD is a fait accompli.

Later, Mike

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 14 Oct 2014 13:55:43 -0400

> procedures to the last detail, the former overwhelmingly makes more sense.

You are both missing the point that if this is a consultative
organization, the IESG should have solicited comment and discussion
from the wider community before beginning to implement their decision.

Comparisons to corporate restructures are irrelevant because
corporations are not consultative organizations, nor do they pretend
to be. Under US employment law a corporation can reassign jobs for 'at
will' employees almost at whim (modulo the WARN act).

So far I have seen a lot of chatter attempting to justify the process
with no discussion at all about what is driving this change or the
urgency for doing so right now.

---

From: Larry Masinter <[email-masked]>
Date: Tue, 14 Oct 2014 18:11:16 +0000

Perhaps it's just me, but I think a more web-focused Apps AD taking on some of the divergence between IETF and WHATWG/W3C would be helpful.

MIME sniffing
In general MIME use in web
Origin
URL/URI/IRI/URN/IDNA
Encodings

Are areas where interfaces between web and non-web suffer.  Rather than asking Nomcom to hold off on nominating, I'd ask Nomcom to focus on cluefulness on the topics. 

The line between 'web' and 'non-web' is shifting, and more leadership in coordination from within IETF would be helpful.

(IMHO of course)

Larry
--
http://larry.masinter.net

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 14 Oct 2014 20:37:54 +0200

> The line between 'web' and 'non-web' is shifting, and more leadership in coordination from within IETF would be helpful.

My personal opinion about the W3C and the IETF is that the separation 
(both in terms of their procedures and in terms of the disparity of 
who-works-where) is harmful at this point in time.

Fixing that issue would, I think, require much faster movement than we, 
as a (self)consultative body, seem to be able to apply - so I haven't 
tried to suggest solutions to that problem.

I don't see how we can get there from here.

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 15 Oct 2014 03:28:18 +0200

Hi Harald,

On Tuesday, October 14, 2014, Harald Alvestrand <[email-masked]
<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:

> unlikely to add more workload to an area that has quite few groups in the
> near future.

IMO, The change is only in numbers but not much in roles. I think IESG
should rethink its structure and relationship with IETF Areas/WGs.

> by the IESG. It's perfectly reasonable for them to say "this post needs to
> be eliminated".
>
> The procedural objections here seem to all be of the form "the IESG should
> have told the nomcom this when it sent the position descriptions to the
> Nomcom".
>
> Now consider the timing.
>
> It's October. The new AD (if selected) will be added to the IESG in March,
> and will be selected for a period of 2 years (unless he resigns). In July,
> there would not have been a procedural issue with this request at all.

Situations can get worse for IESG with high probability level that many
factors can affect performance especially when the IESG members are blocked
by world challenges or personal problems or congested with many IDs
submitted.

> procedural tizzy because the lead time isn't 8 months. For something that
> (if the person remains on the IESG for 2 years) will have effect 29 months
> from now.
>
> I'm in a rapidly changing organziation during my day work. When a decision
> on structure was reached, it got *implemented* on a timeframe shorter than
> the nomcom getting its brief and the IESG saying that "you might want to
> consider this point".
>
> The timeframes we're dealing with for changes in the IETF have lost touch
> with the needs of the world the IETF operates in; the world has become
> considerably faster, and the IETF has not.

The delay performance with in IESG is due to the increase in
WGs/IDs/World_challenges and the shortage in leadership.

> I, for one, welcome the signs of change. If the change requested makes

The proposal is change of IESG structure but I think it meant to say the
IETF structure. If I want to change IESG structure (which is a world need
to increase diversity) I will propose to add more different roles in IESG
and add more ADs not related to the number of IETF areas. This will need
amending some of IESG procedure which is old. The main problem in IETF is
shortage of welling experts to join IESG which may be because of its old
structure and overload volunteering load.

> Procedures exist to make the organization work better. Not the other way

IESG proposed to reduce participation while there may be decrease of IETF
participation, but by increasing leadership we will solve many of IESG
problems. By changing IESG structure/procedure we well have better delay
performance and better output work published.

Best regards

AB

IETF participant from Africa.