Subject: "Per Area" and "Per AD" review ballots?

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 26 Mar 2015 11:20:44 -0500

Hi, David,

You mentioned "per-AD" at the Admin Plenary open mike last night, and I
wanted to make sure I understood your point.

I think you were pointing to the ballot display on
https://datatracker.ietf.org/iesg/agenda/documents/, where there is a box
for each AD to ballot on each document, and suggesting that maybe balloting
for each area on each document might would work about as well, giving
equivalent coverage while reducing the review load on each AD (except Jari,
of course - there being only one GEN AD).

Does that sound familiar?

Thanks,

Spencer

---

From: Melinda Shore <[email-masked]>
Date: Thu, 26 Mar 2015 11:35:51 -0500

Is there a real problem here?

If we're concerned that IETF participation is increasingly
limited to professional standardizers, and I think many of
us are, we should probably be somewhat circumspect about
adding new process, particularly if it's something that just
sort of seems useful but doesn't address any real-world
problems.

Melinda

---

From: "Black, David" <[email-masked]>
Date: Thu, 26 Mar 2015 17:51:37 +0000

Hi Spencer,

I would suggest balloting by Area as a baseline, with additional ADs added as appropriate when a draft is of particular relevance or interest to an Area or a specific AD, perhaps to one of the At-Large ADs proposed in the other thread (who might be able to free up Jari from having to deal with every draft).

The 15-box ballot display is part of our tooling and culture that sets expectations that each AD will pay some attention to every draft.  The results of moving to a structure and tooling in which every Area (instead of each AD) is expected to pay some attention to every draft could vary by draft and Area, e.g.,

- If one Routing AD says “no routing concerns here,” that could well suffice for the entire area.
- At the other end of the spectrum, perhaps both Security ADs should look at most drafts, because
      there’s always a Security Considerations section.
- For really important drafts, it may make sense for every AD to participate in the ballot.

Creating a culture and expectations where a significant fraction of ADs are not expected to (but are always welcome to) participate in the ballot of every draft ought to help reduce AD workload.

Thanks,
--David

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Thursday, March 26, 2015 12:21 PM
To: Black, David
Cc: [email-masked]
Subject: "Per Area" and "Per AD" review ballots?

Hi, David,

You mentioned "per-AD" at the Admin Plenary open mike last night, and I wanted to make sure I understood your point.

I think you were pointing to the ballot display on https://datatracker.ietf.org/iesg/agenda/documents/, where there is a box for each AD to ballot on each document, and suggesting that maybe balloting for each area on each document might would work about as well, giving equivalent coverage while reducing the review load on each AD (except Jari, of course - there being only one GEN AD).

Thanks,

Spencer

---

From: Ted Lemon <[email-masked]>
Date: Thu, 26 Mar 2015 13:12:00 -0500

> Is there a real problem here?

Speaking for myself, it would have been helpful to have had a clearer sense of what to look at and what not to waste my time on early on.   I got a solid reality check from Stewart Bryant about this midway through my first year, but it took well into my second year to really figure out which drafts to review closely and which to skim.   However, I think it's worth having ADs skim drafts so that they can notice cross-area issues, and for that to work they either have to be able to ballot, or else they have to use peer pressure.   I think being able to ballot is probably better.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 26 Mar 2015 13:23:18 -0500

Maybe introduce a new state 'Other AD' which would be set
automatically if an AD has not entered a ballot but another in their
area has.

So if there are three ADs and one enters a ACCEPT, her two colleagues
state will be set to OTHER-AD. Then another reads the draft and
decides it is a disaster area, they change their vote from OTHER-AD to
 DISCUSS.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 27 Mar 2015 08:36:43 +1300

> Speaking for myself, it would have been helpful to have had a clearer sense of what to look at and what not to waste my time on early on.   I got a solid reality check from Stewart Bryant about thi…

+1 to Ted. However, I have to say that a stint as a Gen-ART reviewer
before becoming an AD was very helpful to me, since I had already developed
a good sense of what to look for.

Also, please note that the ADs in an area can choose to operate as David
proposes already: the primary on a draft ballots YES or NO-OBJ, and the
partner follows with NO-OBJ. I suspect that is standard operating procedure
in some areas already. The partner AD will most likely pay more attention
if the first one ballots DISCUSS.

    Brian

---

From: Alia Atlas <[email-masked]>
Date: Thu, 26 Mar 2015 15:48:38 -0400

How much attention to pay to particular drafts varies by area and time.
It does take self discipline to decide how much time to dedicate to reading
drafts for the telechat.  It is tempting to try and "show value" by having
comments out of one's knowledge base.  It is also tempting to take time
to self-educate (still bummed about not finishing a couple particularly fun
drafts).  However, No Objection is there for a reason.

In my more cynical moments, I do theorize that the draft reviews for
telechats
exist to make sure that the IESG doesn't have time to do very much rapid or
active management or organizational change.

Alia

On Thu, Mar 26, 2015 at 3:36 PM, Brian E Carpenter <
[email-masked]> wrote:

> > Speaking for myself, it would have been helpful to have had a clearer
> sense of what to look at and what not to waste my time on early on.   I got
> a solid reality check from Stewart Bryant about this midway through my
> first year, but it took well into my second year to really figure out which
> drafts to review closely and which to skim.   However, I think it's worth
> having ADs skim drafts so that they can notice cross-area issues, and for
> that to work they either have to be able to ballot, or else they have to
> use peer pressure.   I think being able to ballot is probably better.
>