Subject: Fwd: [agent design] using esteem or reputation (was: Fwd: Re: New Cog VMs available)

From: Robert Withers <[email-masked]>
Date: Tue, 23 Jun 2015 15:44:26 -0400

Kinda related to what's discussed on ietf: "Randomness sources for the 
IETF 2015-2016 Nomcom Selection".

As well, I hope you folks on the Collective Dynamics of Complex Systems 
mailing list, considering a physical basis of virtualization, may find 
this to be a illuminating, optimizing search space: 
http://coco.binghamton.edu/.

Sincerely,
Robert

-------- Forwarded Message --------
Subject: 	[agent design] using esteem or reputation (was: Fwd: Re: New 
Cog VMs available)
Date: 	Tue, 23 Jun 2015 13:00:14 -0400
From: 	Robert Withers <[email-masked]>
To: 	[email-masked], [email-masked], 
[email-masked], [email-masked]

I'm disabled, they tell me. My experiences inform me I have a complete 
inability to code to completion. In addition, I am thoroughly tired of 
being solo in this life and coding pulls me in that direction.  So, I'm 
done, it's too much. I don't want to sail alone, anymore, but I do like 
to sail. Please sail with us.

I'll share these thoughts to the public domain, pull in a couple of more 
sets of passionate folks, in the form of Augur.net and swarm.org, and 
pray with all my heart for cross-cultural synergy.

Best Regards,
Robert

(I apologize for failing the challenge of email, in the previous post.  
You see what I mean about having disability?)

-------- Forwarded Message --------
Subject: 	Re: New Cog VMs available
Date: 	Tue, 23 Jun 2015 11:01:07 -0400
From: 	Robert Withers <[email-masked]>
To: 	[email-masked]
CC: 	[email-masked]

Yes, pleaaase Eliot!

I must release my ideas into the public domain, in hopes that y'all here 
with NewSpeak and Code For America may be able to make something of it, 
or even make sense of it, released under the MIT license. I pray you 
wonderful, wonderful, wunderkind can hook up and make it happen, perhaps 
in time for the Awards Ceremony, September 30th. ;-}

Who really knows what is possible? Only God Knows and that's beyond time.

God bless you,
Robert

On 6/23/2015 10:33 AM, Carl Gundel wrote:
> Hey Eliot!
> Does this VM allow Newspeak to run on the Raspberry Pi?
> -Carl
>
> On Saturday, June 20, 2015 at 9:26:18 PM UTC-4, Eliot wrote:
>
>     ... at http://www.mirandabanda.org/files/Cog/VM/VM.r3386
>     <http://www.mirandabanda.org/files/Cog/VM/VM.r3386>
>
>     CogVM binaries as per VMMaker.oscog-eem.1370/r3386
>
>     Add the ARMv5/ARMv6 Cog Spur JIT VM!
>
>     Add explicit read barriers to primitives which access an argument
>     as the
>     receiver (i.e. the mirror primitives).  Don't check if the actual
>     receiver is
>     used.  Simplify failure where appropriate cuz the primitives will
>     be retried.
>
>     Add -fwrapv to all linux gcc builds (to insist on 2's complement
>     arithmetic)
>     and add makeallclean, making makeall do the dirty build.
>
>     Provide a -exitonwarn command line switch for the Mac and Unix VMs
>     to allow for
>     CI testing of asserts.
>
>     Unix: restore the SCCS revision after the version number in
>     -version output.
>
>     Spur:
>     Remember to count shrink requests
>
>     Cogit:
>     Fix bug in rewriting compiler primitives on module unload, etc. 
>     The old code
>     didn't change the assignment to the primitiveFunctionPointer,
>     which is needed
>     for correct management of failing primitive calls on Spur. 
>     Simplify the post
>     compile hook to eliminate the label parameter; this is local to
>     the Cogit.
>
>     ARM Cogit:
>     Use out-of-line literals for compactness.
>     -- 
>     best,
>     Eliot
>

---

From: Robert Withers <[email-masked]>
Date: Tue, 23 Jun 2015 15:55:53 -0400

Seems related to what's discussed on ietf: "Randomness sources for the 
IETF 2015-2016 Nomcom Selection".

Sincerely,
Robert

-------- Forwarded Message --------

Best Regards,
Robert

-------- Forwarded Message --------
Subject: 	Re: New Cog VMs available
Date: 	Tue, 23 Jun 2015 11:01:07 -0400
From: 	Robert Withers <[email-masked]>
To: 	[email-masked]
CC: 	[email-masked]

Yes, pleaaase Eliot!

God bless you,
Robert