Subject: Re: Response to Jari's blog

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 5 Jan 2016 10:15:16 +0100

> On 31 Dec 2015, at 00:59, Brian E Carpenter <[email-masked]> wrote:
> 
> On 31/12/2015 09:26, Olle E. Johansson wrote:
> ...
>> So we have bugs related to IPv6, we have a group of authors and the documents still are not going anywhere because a lack of interest.
> 
> Interest is usually generated by unhappy users, and there isn't quite enough of
> the world depending on IPv6 yet to create the necessary unhappiness. I'm not
> pessimistic though: we just have to be patient, and eventually the pointy-haired
> bosses will start to insist on fixing IPv6 bugs.
And when they do, I want the IETF to support the efforts and put energy into it.
We need IPv6 and dual stack to work properly in all applications.

I don’t want the efforts of these pointy-haired-boss-supported engineers to be met 
like our work was handled. I know there’s a lot of more sexy stuff than fixing bugs in 
old protocols, but I am personally surprised that it has required so much time and effort 
to fix small issues. Considering we found the issues at SIPit almost five years ago and 
started to make noises about it, I’m disappointed that developers still haven’t got the 
needed information to code things right.

We have found issues surrounding TLS use in SIP  at SIPit events, but the interest
in fixing that seems even smaller. Based on my experience of the IPv6 work, I am not
sure I have the resources and energy to even start working with it funded by myself.

> And it isn't just the IETF. Just to take a random example that bit me recently,
> why doesn't the Python socket module define IPPROTO_IPV6? A tiny thing that is
> easy to work around, but I gather it's been like that for years.

Ouch.

Documents (in response to Jari’s question)
----------------------------------------------------------
Here’s one (now expired) draft we put a lot of efforts into and it got stuck somewhere
in dispatch or sipcore - the chairs couldn’t make up their mind what to do with it.
I personally still feel that developers can get a lot of help by a document like this.
This document was more of a foundation for the other work, an informational document
based on experiences we found at SIPit and other tests.
https://tools.ietf.org/html/draft-klatsky-dispatch-ipv6-impact-ipv4-03

The other draft got dispatched to the SIPcore wg, has gotten a review after a long time. We
started working on an update based on the review in time for an IETF meeting
(don’t remember which one) but then the WG meeting got cancelled and I think we lost energy
there. Yes, we should pursue the work at some point.
https://datatracker.ietf.org/doc/draft-johansson-sip-dual-stack/

The third one was never written, but discussed and planned. That’s the one
where we discuss happy eyeballs for SIP transports. Basically “avoid UDP,
it can’t easily be solved unless you use DNS records in a clever way."

/O

---

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 5 Jan 2016 10:28:16 +0100

BTW, I had a short talk at NetNod’s Spring meeting 2015 about my efforts in the SIP/IPv6 area. 
Maybe some slides give you some ideas. 

I am pretty sure that SIP is not alone in having issues amongst the application level protocols.

http://www.slideshare.net/oej/2015-update-sip-and-ipv6-issues-staying-happy-in-sip

/O

---

From: Mary Barnes <[email-masked]>
Date: Tue, 5 Jan 2016 08:36:26 -0600

On Tue, Jan 5, 2016 at 3:15 AM, Olle E. Johansson <[email-masked]> wrote:

> >> So we have bugs related to IPv6, we have a group of authors and the
> documents still are not going anywhere because a lack of interest.
> >

[MB] Olle - you may want to go back into your email archives (and I've just
re-forwarded it).  I sent an email to Carl and the draft authors on October
17th, 2013 to which there was never a response.  I'd be happy to forward to
this mailing list if you'd like.  That email makes it quite clear that the
actions are with the authors.
[/MB]