Subject: IETF turns 30

From: IETF Chair <[email-masked]>
Date: Thu, 14 Jan 2016 12:43:50 +0200

This week marks the 30th anniversary of the meeting that became the
very first edition of IETF meetings now held three times per year.
On 16-17 January 1986 in San Diego, California, 21 people attended
what is now known as IETF 1.

As we work on the day-to-day tasks needed to make the Internet work
better, from time-to-time it is useful to consider our work on longer
timescales.

Here are my thoughts about the occasion:

https://www.ietf.org/blog/2016/01/30-years-of-engineering-the-internet/

And happy birthday, IETF, on Saturday!

What are your thoughts?

Jari Arkko, IETF Chair

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 14 Jan 2016 10:50:58 +0000

Happy Birthday!

So, at IETF 1 the following areas of concern were identified: 

IETF Areas of Concern -
o Protocol Development and Stabilization,
o Protocol Conformance,
o An Implementors Support Organization,
o Internet Performance Measurements,
o ISO Conversion.

Only one of them seems clearly out of scope 30 years after. 

Regards,

Dan

> -----Original Message-----
> From: IETF-Announce [mailto:[email-masked]] On Behalf Of
> IETF Chair
> Sent: Thursday, January 14, 2016 12:44 PM
> To: IETF Announcement List
> Cc: IETF Discussion
> Subject: IETF turns 30
> 
> This week marks the 30th anniversary of the meeting that became the very
> first edition of IETF meetings now held three times per year.
> On 16-17 January 1986 in San Diego, California, 21 people attended what is
> now known as IETF 1.
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_blog_2016_01_30-2Dyears-2Dof-2Dengineering-2Dthe-
> 2Dinternet_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXC
> JfQzvlsiLQfucBXRucPvdrphpBsFA&m=lVs7YLc9kjCjSIQbJSrAW899OSF4i_ZGM
> pzfc_GGOWI&s=4roDhUM9LqDONEh-Bhvo90yN39jUWegn5wqr14Fh_RE&e=
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 14 Jan 2016 14:23:34 +0100 (CET)

> Only one of them seems clearly out of scope 30 years after.

I imagine you mean the last bullet point? It was only the last 1-2 IETFs 
where a new draft was published that (again) suggested a profile to carry 
IS-IS over IPv6, so depending on what you mean by "ISO conversion", I'm 
not so sure this is out of scope yet :P

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 14 Jan 2016 13:27:14 +0000

Right.

Arguably, it's rather the second bullet that may be a better candidate. We are not concerned (and never were) with 'Protocol Conformance' but rather with interoperability.  

Regards,

Dan

> From: Mikael Abrahamsson [mailto:[email-masked]]
> Sent: Thursday, January 14, 2016 3:24 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: RE: IETF turns 30
> 
> > o Protocol Development and Stabilization, o Protocol Conformance, o An
> > Implementors Support Organization, o Internet Performance
> > Measurements, o ISO Conversion.
> >
> I imagine you mean the last bullet point? It was only the last 1-2 IETFs where
> a new draft was published that (again) suggested a profile to carry IS-IS over
> IPv6, so depending on what you mean by "ISO conversion", I'm not so sure
> this is out of scope yet :P
> 
> --

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 14 Jan 2016 15:33:54 +0100

Le 14/01/2016 14:23, Mikael Abrahamsson a écrit :
> where a new draft was published that (again) suggested a profile to
> carry IS-IS over IPv6, so depending on what you mean by "ISO
> conversion", I'm not so sure this is out of scope yet :P

:-) there is active ISO liaison.

I thought he thought maybe the conformance part may be out of scope. 
Although that's arguable as well because conformance test suites often 
cite RFCs.

Alex

---

From: Eliot Lear <[email-masked]>
Date: Thu, 14 Jan 2016 15:48:38 +0100

Hi Dan,

> Only one of them seems clearly out of scope 30 years after. 

As I recall, the interesting thing about the last bullet when I started
in the IETF just a little later was that there was general industry
agreement that such a conversion was needed.  The only debate was over
which direction it should occur.

Eliot

---

From: John C Klensin <[email-masked]>
Date: Thu, 14 Jan 2016 19:00:49 -0500

--On Thursday, January 14, 2016 15:48 +0100 Eliot Lear
<[email-masked]> wrote:

> As I recall, the interesting thing about the last bullet when
> I started in the IETF just a little later was that there was
> general industry agreement that such a conversion was needed.
> The only debate was over which direction it should occur.

Whatever debate you are referring to, the IETF wasn't having it.
We didn't retire the "OSI Integration" Area (with Erik Huizer
and Dave Piscitello as the last two co-chairs) until circa IETF
25 in November 1992 and my recollection is that it was clear
until not long before that that the plan was to get Internet
applications and upper layers running over an OSI substrate.
By the time the area was finally shut down (and most or all of
the remaining WGs folded into Applications, with Eric moving
over), the goal was clearly to figure out which OSI applications
were in use and/or likely to be worth anything going forward and
get them to work over TCP and/or IP.

--On Thursday, January 14, 2016 15:33 +0100 Alexandre Petrescu
<[email-masked]> wrote:

>> I imagine you mean the last bullet point? It was only the
>> last 1-2 IETFs where a new draft was published that (again)
>> suggested a profile to carry IS-IS over IPv6, so depending on
>> what you mean by "ISO conversion", I'm not so sure this is
>> out of scope yet :P
> 

Not sure what you are thinking about.  We've never had a liaison
to ISO: it really wouldn't make any sense even if either we or
they were interested.  We've never even had a liaison to ISO/IEC
JTC1.   One could argue either way about a JTC1 liaison making
sense, but the politics, justification, and interest have never
come together at the same time to make that happen.  We do have
active liaison relationships with a number of ISO TCs and a
number of ISO/IEC JTC1 SCs but, AFAIK, none of them are working
on the OSI stack any more either.

   john

---

From: Eliot Lear <[email-masked]>
Date: Fri, 15 Jan 2016 07:00:08 +0100

So...  {useless history discussion follows}

> applications and upper layers running over an OSI substrate.

TCP/IP over OSI first...
> get them to work over TCP and/or IP.

OSI over TCP/IP later...

GOSIP wars in the industry in between.  Ross Callon probably remembers more.

And also in between, there was an amusing discussion about what people
actually put on their business cards re X.400 (Chuck Hedrick from
Rutgers @ Hawaii - I was in the room; it was quite funny, which is why I
remember it).

Eliot

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 15 Jan 2016 12:50:10 -0500

> Rutgers @ Hawaii - I was in the room; it was quite funny, which is why I

I wasn't part of the IETF end of the OSI discussion but either your
dates are off or they are hilarious.

Thing is that the first time I was in a meeting at which an OSI
transition plan was discussed was July or so of 1992. And it was very
much pre-planning since the only vendor that was pushing OSI
networking was Digital and DECnet Phase V wasn't due for several
years.

So we were starting efforts at the very time IETF was shutting them down.

Exactly 12 months later, July 1993, OSI was effectively dead. The Web
content was all on the Internet and the Web was growing at 10,000% a
month. The only thing OSI could do would be to provide a slower, less
reliable Web through a proxy.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 16 Jan 2016 08:20:41 +1300

On 16/01/2016 06:50, Phillip Hallam-Baker wrote:
...
> networking was Digital and DECnet Phase V wasn't due for several

Funny that, since I wrote CERN's networking policy in 1985 and it was
OSI based [1][2]. And then I demolished it in 1988 [3] and 1989 [4].

However, do remember that in July 1992, OSI/CLNP was a very serious
candidate for IPng, and remained so for the next two years.

> So we were starting efforts at the very time IETF was shutting them down.

DECnet Phase IV had already run out of addresses and we needed Phase V
for that reason alone. It was indeed a dead end, but you may recall
that some of the physics experiments were so deeply committed to VAX/VMS
that they wouldn't contemplate anything other than DECnet. We did deploy
Phase V starting late 1994 [5], and we did repeatedly ask Digital to support
DECnet upper layers over TCP/IP. But we all know how that ended. Quoting
my own book "The end of that story is a sad one: we just about got the
high-energy physics DECnets converted to Phase V when it was time to switch
them off, since everyone had started using TCP/IP instead."

All the same, the history of the IETF would have been utterly different
if they had ignored OSI back in 1986.

   Brian

[1] Computer Communications at CERN, Conf. 'Computing in High Energy Physics', Amsterdam, June 1985, proceedings ed.
L.O.Hertzberger and W.Hoogland, North-Holland, 1986.
[2] CERN Data Communications Policy, CERN internal report DD/85/14, July 1985.
[3] COSINE Implementation Phase: the View from a Major Site, RARE Networkshop 1988, Computer Networks and ISDN Systems, 16
(1988) 121.
[4] Is OSI Too Late?, RARE Networkshop 1989, Computer Networks and ISDN Systems, 17 (1989) 284.
[5] Denise Heagerty, 'Running DECnet/OSI (Phase V) at CERN', CERN Computer Newsletter 217, 1994.

---

From: Lixia Zhang <[email-masked]>
Date: Sat, 16 Jan 2016 23:15:28 -0800

> On Jan 14, 2016, at 2:43 AM, IETF Chair <[email-masked]> wrote:
> 

30 years!  Time really flies !!
But changes seem going even faster: it's hard to believe how much the world has changed in this 30 years. Not only Internet changed from connecting a few K's hosts to connecting over 3 billion users as Jari mentioned, but behind these numbers are some really fundamental changes in Internet applications, user communities (shouldn't we count IoT devices and smart cars here), infrastructures, and almost everything else (except IPv4 packet format didn't change, though its address interpretation changed).

Now looking back, the world at that time was really simple, though one didn't feel that way then: the dawn of inter-domain routing, multicast was coming, congestion, not to mention ISO...  but that really has no comparison to what we have today.
- ART is the largest area now(back then there was little app)--45 WGs? almost twice as many as the 2nd largest area (routing)
- routing wise now we do anycast routing, multicast routing, ad hoc routing, DTN routing (and I dont know if I should group things like MPLS and VPNs here, or SDN and openflow for that matter)
- back then we had simple IP routers, now firewalls, load balancers, NATs and all sorts of other middleboxes.
- back then there was no security, now we have DNSSEC, BGPSEC, IPSEC, TLS, DTLS, and bunch other security related things not mentioned (like DKIM)
- how many new WGs have been created to address IoT challenges?

If we keep going like this, one has to wonder how IETF/IETF products might look like another 20 years down the road.
I must also add that we learned tremendous amount of stuff too over 30 years, though that could take a lot time and hard work to collect and summarize.

maybe an interesting discussion at IETF 100?  which is also coming in no time.

Lixia

---

From: Scott Brim <[email-masked]>
Date: Sun, 17 Jan 2016 14:12:46 -0500

On Sun, Jan 17, 2016 at 2:15 AM, Lixia Zhang <[email-masked]> wrote:

> - ART is the largest area now(back then there was little app)--45 WGs?
> almost twice as many as the 2nd largest area (routing)
>

I sometimes wonder why the IETF is (still) the home for this work.

> maybe an interesting discussion at IETF 100?  which is also coming in no

We could all show up at IETF 100 and reenact one of the early meetings, for
example discussing how to solve problems with EGP metrics. :-)

---

From: John C Klensin <[email-masked]>
Date: Sun, 17 Jan 2016 14:46:49 -0500

--On Sunday, January 17, 2016 14:12 -0500 Scott Brim
<[email-masked]> wrote:

> We could all show up at IETF 100 and reenact one of the early
> meetings, for example discussing how to solve problems with
> EGP metrics. :-)

I wasn't at any of those very early meetings, but perhaps it
would also be appropriate to bring collections of tee shirts,
coffee mugs, etc., from companies and organizations that were
important to the Internet at that stage but that are no longer
in existence and/or relevant.  Another measure of progress ...
:-(

   john

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 18 Jan 2016 09:44:42 +0100

Le 15/01/2016 01:00, John C Klensin a écrit :
[...]

> Not sure what you are thinking about.  We've never had a liaison to
> ISO: it really wouldn't make any sense even if either we or they were
> interested.  We've never even had a liaison to ISO/IEC JTC1.   One
> could argue either way about a JTC1 liaison making sense, but the
> politics, justification, and interest have never come together at the
> same time to make that happen.  We do have active liaison
> relationships with a number of ISO TCs and a number of ISO/IEC JTC1
> SCs but, AFAIK, none of them are working on the OSI stack any more
> either.

YEs, that's what I meant about liaison to ISO Technical Committees,
although one could argue about working or not working on OSI stack.

Common IETF discussion uses terms inherited from the OSI layer terminology.

And many ISO TC documents make extensive use of IETF protocols like IPv6.

Alex