Subject: RFC format evolution and IETF documents

From: IETF Chair <[email-masked]>
Date: Wed, 27 Jan 2016 17:31:43 +0200

For background, the RFC Editor and the IAB have been
working on the evolution  of the RFC format. The IAB
will be sending a number of documents soon out
for review. At the same time, the tools team have
been working on what the new format requires
from the tools. Both the documents and the tools
requirements are available from the reading list
below.

The IESG has discussed what this all means for
the IETF documents. The evolution is important
for the IETF as well, and we look forward to
being able to use possibilities in the new format.

The IESG wanted to offer five points:

1. Please review the documents and send
feedback to the rfc-interest list at
https://www.rfc-editor.org/mailman/listinfo/rfc-interest
or the authors.

2. We would like to see the new format be
available as the base format for Internet
Drafts as well, supported by the relevant
tools, and usable by each of the RFC
streams as needed. Each stream may
of course have a policy on what content or
format features they prefer.

3. We expect the RFC Editor, the IAB, and
the tools team (incl. IAOC support) to make
the above possible.

4. From an IETF stream perspective, we are
in eager waiting mode. Once the format
definitions and tools are in place, we
will (among others) want to try the
new possibilities in IETF stream
documents. From a careful engineering
stand point we would like to start
small, and gather experience on
using the new format and tools. There
will be implications on how we review
documents, for instance.

5. Existing I-D submission using text
only will likely stay on for a long time
if not indefinitely, so old methods can
also be used as needed or desired.

Comments appreciated, as always.

Jari Arkko for the IESG

Reading list:

1. The big picture

- - Flanagan, H., "RFC Format Framework",
   http://datatracker.ietf.org/doc/draft-iab-rfc-framework/

2. The underlying vocabulary

- - Hoffman, P., "The 'XML2RFC' version 3 Vocabulary",
    https://datatracker.ietf.org/doc/draft-iab-xml2rfc/

3. The outputs

- - Hildebrand, J. and P. Hoffman, "HyperText Markup
   Language Request For Comments Format”,
   https://datatracker.ietf.org/doc/draft-iab-html-rfc/

- - Flanagan, H., "Requirements for Plain Text RFCs”,
    https://datatracker.ietf.org/doc/draft-iab-rfc-plaintext/

- - Hansen, T., Masinter, L., and M. Hardy, "PDF for
   an RFC Series Output Document Format”,
   https://datatracker.ietf.org/doc/draft-hansen-rfc-use-of-pdf/
   Note that the filename may change to an IAB document soon.

- - Brownlee, N., "SVG Drawings for RFCs: SVG 1.2 RFC",
   https://datatracker.ietf.org/doc/draft-iab-svg-rfc/

4. Generalized requirements

- - Flanagan, H., "The Use of Non-ASCII Characters in RFCs",
   https://www.ietf.org/id/draft-iab-rfc-nonascii-00.pdf

- - Flanagan, H., “CSS Requirements for RFCs”,
   https://datatracker.ietf.org/doc/draft-iab-rfc-css/

5. Workflow and tools (note that the examples draft will
   not become an RFC, but is necessary for the project)

- - Hildebrand, J. and P. Hoffman, "RFC v3 Prep Tool Description",
   https://datatracker.ietf.org/doc/draft-iab-rfcv3-preptool/

- - Hoffman, P. and T. Hansen, "Examples of the ‘XML2RFC'
   Version 2 and 3 Vocabularies”,
   http://datatracker.ietf.org/doc/draft-hoffman-rfcexamples/

6. The Statements of Work

- - http://www.nostrum.com/~rjsparks/rfced/

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 27 Jan 2016 10:52:11 -0500

Nice work!

For folk who don't want to deal with XML2RFC, I have a tool that will
convert between XML, HTML, Markdown and Word formats written in C#. It
mostly works and has been used to write one RFC.

It does not support the new formats yet but it probably will do
shortly after the XML and HTML formats are fixed.

When can we expect that to happen?

---

From: [email-masked]
Date: Thu, 28 Jan 2016 09:17:08 +0800

敖婷  Ting Ao
高级标准预研工程师  Senior Standard Pre-research Engineering
SDN开发部 / 有线研究院  SDN development Department / Wireline R&D 
Insititute

上海市浦东新区碧波路889号
Add: ZTE Corporation, No.889,Bibo Rd.,Zhangjiang Hi-tech Park, Pudong 
District,Shanghai, P.R. China, 201203
T: +86-21-68897642    M: +86 17721209283
E: [email-masked]
www.zte.com.cn

发件人:         IETF Chair <[email-masked]>
收件人:         IETF Announcement List <[email-masked]>, 
抄送:   "Heather Flanagan \(RFC Series Editor\)" <[email-masked]>, 
IETF <[email-masked]>
日期:   2016/01/27 23:32
主题:   RFC format evolution and IETF documents
发件人: "IETF-Announce" <[email-masked]>

Jari Arkko for the IESG

Reading list:

1. The big picture

3. The outputs