Subject: actions related to improving IETF meeting selections

From: IETF Chair <[email-masked]>
Date: Wed, 8 Jun 2016 16:58:19 +0300

The discussion about the Singapore meeting has been difficult for us. The IETF needs a meeting that we are generally happy with. Various past mistakes and new learnings aside, we are now in a situation where no decision in this space will be perfect. We knew that no matter what choice is made, there will be groups of people who feel they are unfairly impacted.

But perhaps the most important things are that, long-term, the community gets to carefully weigh what they expect from meeting locations, that we all learn from more about the various challenges discussed, we are an open organisation for everybody including minorities, and that we improve our processes going forward. It is also crucial that the IETF remains an organisation that can do its technical work, and be open to all of our global participants in a fair manner. And obviously be capable of arranging our operations in the real world, in areas that our participants come from.

What follows is what we are proposing as additional onward work to address the issues highlighted in this discussion:

o   The IAOC as well as members of the community have asked me to charter a working group to continue the discussion of the detailed meeting criteria document (draft-baker-mtgvenue-iaoc-venue-selection-process). All criteria are on the table for discussion. The working group proposal is being reviewed by the IESG, and will be out for community review shortly. A WG meeting in Berlin is planned.

o   Develop a BCP that defines the community-backed, official policy for the overall strategy of geographic meeting distribution (our current strategy is referred to as 1-1-1*). An initial draft for this is in the works.

o   Arrange a special session in Berlin to discuss the role of human rights, visas, and other aspects of international meeting arrangements. We have begun to work to find outside experts in this space who can join a conversation. (If you have suggestions, let us know.)

o   Continue the new practice of informing the community of potential future meeting destinations, and collecting “crowd-sourced” input on their suitability.

o   Commit to a proper, informed process to identify issues that any subgroup (including but not only the LGBTQ community) has with our site selections.

o   Commit to returning to the 1-1-1* meeting model — or what the eventual BCP policy is -- for Asia for the remainder of the decade. For the last decade, we’ve only met there 4 times.

o   Commit to holding all other currently planned meetings as they are, and focusing on making the most appropriate decisions about future meetings, as informed by community input.

o   While we do not believe that we should respond to the current discussions merely with a suggestion of conducting our meeting virtually, it is a clear direction that IETF and other organisations will be using more virtual collaboration tools in the future. The IESG has discussed taking initial steps with regards to bigger virtual meetings. Experiences from this could drive further efforts.

Jari Arkko, IETF Chair

---

From: Sheng Jiang <[email-masked]>
Date: Sun, 12 Jun 2016 02:18:11 +0000

Hi, Jari,

Thanks so much for your efforts on both Singapore meeting and improving future IETF meeting selections. You have done an excellent work on respecting various opinions and making a necessary compromise. 

Regarding to diversity among future IETF meeting selections, there are actually multiple meanings of diversity. But in my opinion, the most important task for IETF organizer should be to get and keep high quality and consistent contributors. Arising the awareness of IETF in wider areas, attracting more diversity people (particularly, if these people would not join the follow-up IETF meetings) are much less important than the convenience for our majority consistent participants. Therefore, the most important diversity should be geography diversity among the current majority consistent participants. Consequently, I strongly support 1+1+1 policy. One potential option is that we may have a set of side/secondary IETF meetings apart from the three main IETF meetings per years. They could be hold out of main areas to serve the other diversity purposes.

Best regards,

Sheng

>-----Original Message-----
>From: ietf [mailto:[email-masked]] On Behalf Of IETF Chair
>Sent: Wednesday, June 08, 2016 9:58 PM
>To: IETF Announcement List
>Cc: [email-masked]; [email-masked] Discussion
>Subject: actions related to improving IETF meeting selections
>
>
>The discussion about the Singapore meeting has been difficult for us. The IETF
>needs a meeting that we are generally happy with. Various past mistakes and
>new learnings aside, we are now in a situation where no decision in this space
>will be perfect. We knew that no matter what choice is made, there will be
>groups of people who feel they are unfairly impacted.
>
>But perhaps the most important things are that, long-term, the community
>gets to carefully weigh what they expect from meeting locations, that we all
>learn from more about the various challenges discussed, we are an open
>organisation for everybody including minorities, and that we improve our
>processes going forward. It is also crucial that the IETF remains an
>organisation that can do its technical work, and be open to all of our global
>participants in a fair manner. And obviously be capable of arranging our
>operations in the real world, in areas that our participants come from.
>
>What follows is what we are proposing as additional onward work to address
>the issues highlighted in this discussion:
>
>o   The IAOC as well as members of the community have asked me to
>charter a working group to continue the discussion of the detailed meeting
>criteria document (draft-baker-mtgvenue-iaoc-venue-selection-process). All
>criteria are on the table for discussion. The working group proposal is being
>reviewed by the IESG, and will be out for community review shortly. A WG
>meeting in Berlin is planned.
>
>o   Develop a BCP that defines the community-backed, official policy for the
>overall strategy of geographic meeting distribution (our current strategy is
>referred to as 1-1-1*). An initial draft for this is in the works.
>
>o   Arrange a special session in Berlin to discuss the role of human rights,
>visas, and other aspects of international meeting arrangements. We have
>begun to work to find outside experts in this space who can join a
>conversation. (If you have suggestions, let us know.)
>
>o   Continue the new practice of informing the community of potential
>future meeting destinations, and collecting “crowd-sourced” input on their
>suitability.
>
>o   Commit to a proper, informed process to identify issues that any
>subgroup (including but not only the LGBTQ community) has with our site
>selections.
>
>o   Commit to returning to the 1-1-1* meeting model — or what the
>eventual BCP policy is -- for Asia for the remainder of the decade. For the last
>decade, we’ve only met there 4 times.
>
>o   Commit to holding all other currently planned meetings as they are, and
>focusing on making the most appropriate decisions about future meetings, as
>informed by community input.
>
>o   While we do not believe that we should respond to the current
>discussions merely with a suggestion of conducting our meeting virtually, it is
>a clear direction that IETF and other organisations will be using more virtual
>collaboration tools in the future. The IESG has discussed taking initial steps
>with regards to bigger virtual meetings. Experiences from this could drive
>further efforts.
>
>Jari Arkko, IETF Chair

---

From: <[email-masked]>
Date: Sun, 12 Jun 2016 15:31:14 +0000 (UTC)

>Thanks so much for your efforts on both Singapore meeting and improving future IETF meeting selections. You have done an excellent work on respecting various opinions and making a >necessary compromise. 

+1 

>Regarding to diversity among future IETF meeting selections, there are actually multiple meanings of diversity. But in my opinion, the most important task for IETF organizer should be to >get and keep high quality and consistent contributors. Arising the awareness of IETF in wider areas, attracting more diversity people (particularly, if these people would not join the follow->up IETF meetings) are much less important than the convenience for our majority consistent participants. Therefore, the most important diversity should be geography diversity among the >current majority consistent participants. Consequently, I strongly support 1+1+1 policy. One potential option is that we may have a set of side/secondary IETF meetings apart from the >three main IETF meetings per years. They could be hold out of main areas to serve the other diversity purposes.
Sheng, I find the idea of "secondary or side" meetings very intriguing.   I think this may be a path for regions who do not have a large set of participants (yet).   I would like to see this idea elaborated upon.   What are your thoughts?
Nalini

---

From: Ted Lemon <[email-masked]>
Date: Sun, 12 Jun 2016 14:06:19 -0400

This is a great idea, but would require a lot of regular IETFers to sign on
and get support for going to those meetings.

On Sun, Jun 12, 2016 at 11:31 AM, <[email-masked]> wrote:

> >Thanks so much for your efforts on both Singapore meeting and improving
> future IETF meeting selections. You have done an excellent work on
> respecting various opinions and making a >necessary compromise.
>
> +1
>
>
>
> >Regarding to diversity among future IETF meeting selections, there are
> actually multiple meanings of diversity. But in my opinion, the most
> important task for IETF organizer should be to >get and keep high quality
> and consistent contributors. Arising the awareness of IETF in wider areas,
> attracting more diversity people (particularly, if these people would not
> join the follow->up IETF meetings) are much less important than the
> convenience for our majority consistent participants. Therefore, the most
> important diversity should be geography diversity among the >current
> majority consistent participants. Consequently, I strongly support 1+1+1
> policy. One potential option is that we may have a set of side/secondary
> IETF meetings apart from the >three main IETF meetings per years. They
> could be hold out of main areas to serve the other diversity purposes.
>
> Sheng, I find the idea of "secondary or side" meetings very intriguing.
> I think this may be a path for regions who do not have a large set of
> participants (yet).   I would like to see this idea elaborated upon.   What
> are your thoughts?
>
> Nalini
>
>

---

From: Melinda Shore <[email-masked]>
Date: Sun, 12 Jun 2016 10:24:32 -0800

On 6/12/16 10:06 AM, Ted Lemon wrote:
> This is a great idea, but would require a lot of regular IETFers to sign
> on and get support for going to those meetings.

I'm not sure it's a great idea.  IETF meetings are working
meetings, not conferences, and I'm not sure that having
additional meetings for people who are not active contributors
without the presence of chairs and document editors is going
to be productive, either in terms of the primary goal of
moving documents along or in terms of a secondary goal
of broadening the participant base.

Melinda

---

From: Ted Lemon <[email-masked]>
Date: Sun, 12 Jun 2016 14:36:35 -0400

Yes, there would have to be work to do.

---

From: <[email-masked]>
Date: Sun, 12 Jun 2016 19:43:19 +0000 (UTC)

>Yes, there would have to be work to do.
Today, there are meetings in various regions for IETF awareness.  At times,  ISOC chapters and /or NOGs are quite involved.   We also have quite a bit of activity at remote hubs (or community hubs) or whatever we are calling them.
I would like to hear from Sheng about what his ideas are for these "secondary" meetings.   Of course, then, we need to be clear about what the goals of such activities are and to coordinate well with other existing activities.
Nalini

On Sun, Jun 12, 2016 at 2:24 PM, Melinda Shore <[email-masked]> wrote:

Melinda

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 13 Jun 2016 01:42:28 +0000

Hi, Nalini, Melinda & Ted,

Although there are meetings in various regions for IETF awareness, they are not really IETF meetings. The secondary meetings in my mind are actually working meetings first. That’s why Ted said it “would require a lot of regular IETFers to sign on and get support for going”. I personally believe it is feasible because the current three meetings per year is actually slowing down many WGs’ pace. It is one of the reasons that IETF’s standardization work is slow. Some 3GPP WGs could meet almost 10 times per year! Of course, not every WG need extra meetings. The requirements from various WGs are different. But it is never discussed! If you asked the WG chairs the question of how many f2f meetings per year are ideal for their WGs, in my guess, over 1/4 WGs would like to meet more than three times.  But WG chairs are lacking of logistics for f2f interim meetings. It is also difficult to get contributors to travel for a single WG interim meetings. But if there are 20 WGs interim meetings together, it may be a different story. I don’t think we will lose the key contributors for those active WGs in such meetings, although there may be less “steady” audience. This may give the chance for both accelerating WG’s work and serving diversity purposes. Also, participants may have more time to discuss new works or more details, giving more relax on the total agenda. The scale of such meetings could be much smaller, I guess, like 300 participants. It would give more flexibility and agility, too.

Best regards,

Sheng

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, June 13, 2016 3:43 AM
To: Ted Lemon; Melinda Shore; Sheng Jiang
Cc: ietf
Subject: Re: actions related to improving IETF meeting selections

Nalini

On Sun, Jun 12, 2016 at 2:24 PM, Melinda Shore <[email-masked]<mailto:[email-masked]>> wrote:

Melinda

---

From: Melinda Shore <[email-masked]>
Date: Sun, 12 Jun 2016 18:06:58 -0800

On 6/12/16 5:42 PM, Sheng Jiang wrote:
> I
> personally believe it is feasible because the current three meetings per
> year is actually slowing down many WGs’ pace.

If so, it's because people are choosing not to progress
work between meetings, where "people" include both chairs
and editors.  By contrast, W3C is able to progress work
rather quickly (er, for the most part) and meets only
once/year.  However, they make heavy use of teleconferences,
collaboration tools, and mailing lists.

 > If you asked the WG chairs the question of how many f2f
> meetings per year are ideal for their WGs, in my guess, over 1/4 WGs
> would like to meet more than three times.

I've chaired a bunch of working groups over the years and never
felt that way, myself.  In a working group I chair currently
our editors rarely show up at face to face meetings and while
we're a lot slower than we'd like to be I'd say that has more
to do with problems that would not be resolved by meeting more
frequently or by having editors at meetings.

It is a little vexing that in many cases we're being asked
to accommodate the needs of people who haven't actively
contributed in the past and who don't show an interest in
actively contributing in the future.

I chaired an ETSI working group (TIPHON Security) a bunch
of years ago and don't think that their working style (nor that
of the ITU-T, or IEEE, or ... ) maps particularly well onto the
IETF, and consequently that it would be inappropriate to force
it.  Also note that ETSI and 3GPP (and W3C) and so on have
designated experts on salary to move work along, and it may
be worth considering the extent to which they're able to move
work forward by paying someone else to do it.

The question of the relevance of IETF standards is inseparable from
the question of their implementation and deployment, I think, and
the economic model underlying our work is quite different from that
motivating the work of the big, traditional telecomm standards
bodies.

Melinda

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 13 Jun 2016 02:37:37 +0000

>and editors.

Yes, but it is given that we do not provide the opportunities. The chairs have to do every logistics by themselves with the risk that only key contributors would like to travel for this single WG interim meeting. Actually, even myself, although I think one more meeting would benefit my WG, I don't want to organize it by myself. But it was IETF organizing a secondary meeting, I certainly would like to give a try.

I have been involved in a few standardization bodies, ITU-T, ETSI, BBF, 3GPP.... I don't think IETF should bring the style from them. But I do feel the IETF three meeting per year is a little bit rigid. And I did hear a lot of complain from various people regarding to the slow progress of IETF standardization.

Sheng

>By contrast, W3C is able to progress work