Subject: www.ietf.org Revamp Update

From: IETF Chair <[email-masked]>
Date: Thu, 16 Jun 2016 12:33:21 -0700

Hi,

Work on a revamped public website for the IETF began last year and is scheduled to be ready for community review in the next few months. Based on user research and current best practices, the new design—which was previewed around IETF 93—includes a number of new features. Final implementation details are being worked out and the goal is to move into production yet this year.

In the meantime, I wanted to share a brief update on the progress from project manager Joe Hildebrand:

https://www.ietf.org/blog/2016/06/www-ietf-org-revamp-update/

Jari Arkko, IETF Chair

---

From: Randal Atkinson <[email-masked]>
Date: Sat, 18 Jun 2016 14:47:06 -0400

Jari,

While the idea of a web site update is fine, the information supplied about the 
new website at the URL in the note posted recently was — oddly — missing
what might be the most important pieces of information for an IETF web site:

	- Will the new web site be fully compliant with applicable IETF and W3C standards ?
       - If yes, will this include, for example, HTML5 compliance ?
       - If yes, how is standards compliance being verified ?

IMHO, we ought not be deploying an IETF web site that is not fully compliant
with appropriate Internet standards, whether our own standards or W3C’s standards.

In specific, I believe IETF ought NOT be deploying a website with proprietary stuff.

Yours,

Ran

---

From: Joe Hildebrand <[email-masked]>
Date: Mon, 20 Jun 2016 14:52:50 -0400

> On Jun 18, 2016, at 2:47 PM, Randal Atkinson <[email-masked]> wrote:
> 
> Jari,
> 

As the project manager for the website revamp:

As Section 7 in the Scope of Work linked from the update blog post (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf) indicates, the new website must be built with HTML5 and other open web standards.  We will be verifying this before accepting delivery from the vendor.

Also, we've been careful to tell them that the site has to work (although perhaps without as many bells and whistles) if JavaScript is disabled in your browser.

Finally, if the community finds places that we've missed for some reason, we will accept bug reports, as usual.

-- 
Joe Hildebrand

---

From: "Tony Hain" <[email-masked]>
Date: Mon, 20 Jun 2016 12:22:26 -0700

What section 7 does not say is "HTTPS access will NOT attempt to deliver unsecured content". I get really annoyed by sites that are lazy and refer to random images that are outside the security scope. Mixed content should be explicitly forbidden in this SOW.

Tony

> -----Original Message-----
> From: ietf [mailto:[email-masked]] On Behalf Of Joe Hildebrand
> Sent: Monday, June 20, 2016 11:53 AM
> To: Randal Atkinson
> Cc: [email-masked]
> Subject: Re: www.ietf.org Revamp Update
> 
> 
> > While the idea of a web site update is fine, the information supplied
> > about the new website at the URL in the note posted recently was —
> > oddly — missing what might be the most important pieces of information
> for an IETF web site:
> >
> > IMHO, we ought not be deploying an IETF web site that is not fully
> > compliant with appropriate Internet standards, whether our own
> standards or W3C’s standards.
> >
> As Section 7 in the Scope of Work linked from the update blog post
> (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf)
> indicates, the new website must be built with HTML5 and other open web
> standards.  We will be verifying this before accepting delivery from the
> vendor.
> 
> Also, we've been careful to tell them that the site has to work (although
> perhaps without as many bells and whistles) if JavaScript is disabled in your
> browser.
>

---

From: Joe Hildebrand <[email-masked]>
Date: Mon, 20 Jun 2016 22:17:05 -0400

> On Jun 20, 2016, at 3:22 PM, Tony Hain <[email-masked]> wrote:
> 

I agree that this would be the correct goal, but we didn't get it into the SOW.  Please file a bug if you see that happening when we have running code, and we'll do the best we can to chase those down where possible.

-- 
Joe Hildebrand