Subject: Gen-ART LC review of draft-ietf-tram-turn-mobility-03

From: Pete Resnick <[email-masked]>
Date: Mon, 8 Aug 2016 12:13:20 -0500

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-tram-turn-mobility-03
Reviewer: Pete Resnick
Review Date: 2016-08-08
IETF LC End Date: 2016-08-11
IESG Telechat date: Unknown

Summary: This draft is basically ready for publication, but has some 
minor issues and nits that should be fixed before publication.

Major issues:

None

Minor issues:

3.1.2 - Change "MUST" to "will" both times in the second paragraph. The 
last sentence of the section I don't understand; it doesn't seem to have 
any interoperability implications, and I don't see why the client can't 
examine the ticket in any way it wants. Either justify the sentence or 
delete it.

3.2.2 - Change "may" to "MAY" in the sixth paragraph. That *is* a 
protocol option being described there.

Nits/editorial comments:

3.1.4 - Change "MAY" to "can" in the second paragraph. I'd also split 
that sentence into two sentences as the first half has nothing to do 
with the second half.

3.2.1 - The last sentence of 3.2.1 is confusing until you read 3.2.2 and 
3.2.3. I would simply delete the sentence. I don't think it adds 
anything.

3.4 - Put the "TBD" in there so that the RFC Editor can update.

4 - Put a note to the RFC Editor here to update sections 3.1.4 and 3.4 
with the error number. That will make sure it gets updated properly.

pr
-- 
Pete Resnick <http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Tue, 9 Aug 2016 04:50:16 +0000

Hi Pete,

Thanks for the review. Please see inline

From: Pete Resnick [mailto:[email-masked]]
Sent: Monday, August 8, 2016 10:43 PM
To: General Area Review Team <[email-masked]>; [email-masked]; [email-masked]; IETF <[email-masked]>
Subject: Gen-ART LC review of draft-ietf-tram-turn-mobility-03

http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq.

Summary: This draft is basically ready for publication, but has some minor issues and nits that should be fixed before publication.

Major issues:

None

Minor issues:

3.1.2 - Change "MUST" to "will" both times in the second paragraph. The last sentence of the section I don't understand; it doesn't seem to have any interoperability implications, and I don't see why the client can't examine the ticket in any way it wants. Either justify the sentence or delete it.

[TR] Even if the client examines the ticket there is no guarantee that it will be able decode its fields. This line is added to suggest that there is no need for the client to examine the ticket.

3.2.2 - Change "may" to "MAY" in the sixth paragraph. That is a protocol option being described there.

[TR] Updated.

Nits/editorial comments:

3.1.4 - Change "MAY" to "can" in the second paragraph. I'd also split that sentence into two sentences as the first half has nothing to do with the second half.

[TR] Changed.

3.2.1 - The last sentence of 3.2.1 is confusing until you read 3.2.2 and 3.2.3. I would simply delete the sentence. I don't think it adds anything.

[TR] Sure, deleted.

[TR] Added.

4 - Put a note to the RFC Editor here to update sections 3.1.4 and 3.4 with the error number. That will make sure it gets updated properly.

[TR] Yes, updated.

-Tiru

pr
--
Pete Resnick

http://www.qualcomm.com/~presnick/<http://www.qualcomm.com/%7Epresnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Pete Resnick <[email-masked]>
Date: Tue, 9 Aug 2016 11:05:57 -0500

Thanks for the response Tiru. Trimming down to the one open issue below; 
everything else looks perfect:

On 8 Aug 2016, at 23:50, Tirumaleswar Reddy (tireddy) wrote:

>> 3.1.2 - Change "MUST" to "will" both times in the second paragraph.

I presume you're OK with those changes?

>> The last sentence of the section I don't understand; it doesn't seem 
>> to have any interoperability implications, and I don't see why the 
>> client can't examine the ticket in any way it wants. Either justify 
>> the sentence or delete it.
>
> [TR] Even if the client examines the ticket there is no guarantee that 
> it will be able decode its fields. This line is added to suggest that 
> there is no need for the client to examine the ticket.

Well, "no need" is very different than "MUST NOT". If you really want to 
keep the sentence (and I still think you could just delete it), I would 
suggest simply changing it to something like: "Note: There is no 
guarantee that the fields in the ticket are going to be decodable to a 
client, and therefore attempts by a client to examine the ticket are 
unlikely to be useful."

pr

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Tue, 9 Aug 2016 16:49:10 +0000

From: Pete Resnick [mailto:[email-masked]]
Sent: Tuesday, August 9, 2016 9:36 PM
To: Tirumaleswar Reddy (tireddy) <[email-masked]>
Cc: General Area Review Team <[email-masked]>; [email-masked]; [email-masked]; IETF <[email-masked]>
Subject: Re: Gen-ART LC review of draft-ietf-tram-turn-mobility-03

Thanks for the response Tiru. Trimming down to the one open issue below; everything else looks perfect:

[TR] Yes.

The last sentence of the section I don't understand; it doesn't seem to have any interoperability implications, and I don't see why the client can't examine the ticket in any way it wants. Either justify the sentence or delete it.

Well, "no need" is very different than "MUST NOT". If you really want to keep the sentence (and I still think you could just delete it), I would suggest simply changing it to something like: "Note: There is no guarantee that the fields in the ticket are going to be decodable to a client, and therefore attempts by a client to examine the ticket are unlikely to be useful."

[TR] Works for me, updated.

-Tiru

pr
--
Pete Resnick http://www.qualcomm.com/~presnick/<http://www.qualcomm.com/%7Epresnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Jari Arkko <[email-masked]>
Date: Thu, 1 Sep 2016 09:17:46 +0300

Pete, Tiru,

Thanks for the reviews & updates. Much appreciated. I have balloted no objection for this document.

Jari