Subject: Re: I-D Action: draft-leiba-rfc2119-update-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Aug 2016 10:44:13 +1200

Hi,

>    o  When these words are not capitalized, they have their normal
>       English meanings; this document has nothing to do with them.

There are, and probably always will be, standards track documents
that do not cite RFC 2119 and do not use upper-case normative
keywords. In those documents, we will find usage of 'should' and
'should not' whose interpretation will remain ambiguous. (Does
'should' mean 'must unless there is a very good reason' or something
less?) I think that ambiguity is worth pointing out. I don't think
'must' and 'may' are ambiguous in that way.

However, that point leads me to another issue:

>    Authors who follow these guidelines should incorporate this phrase
>    near the beginning of their document:

I think that 'should' needs to be 'must'. Otherwise we could in theory
have documents using both 'MUST' and 'must' with no disambiguation.
(This is also a bug in RFC 2119.)

>    To reduce the number of reserved key words, the following key words
>    are deprecated, and no longer have special meanings defined by BCP
>    14:
> 
>    REQUIRED, SHALL, SHALL NOT, RECOMMENDED, NOT RECOMMENDED, OPTIONAL

I will be glad to see the back of SHALL, but I object to deprecating
the adjectives. They are useful - indeed, sometimes required - for
the construction of readable sentences and, for example, tables of
RECOMMENDED and OPTIONAL values.

Regards
   Brian Carpenter

On 10/08/2016 07:55, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words
>         Author          : Barry Leiba
> 	Filename        : draft-leiba-rfc2119-update-00.txt
> 	Pages           : 4
> 	Date            : 2016-08-09
> 
> Abstract:
>    RFC 2119 specifies common key words that may be used in protocol
>    specifications.  This document aims to reduce the ambiguity by
>    clarifying that only UPPERCASE usage of the key words have the
>    defined special meanings, and by deprecating some versions of the key
>    words.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-leiba-rfc2119-update/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-leiba-rfc2119-update-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "C. M. Heard" <[email-masked]>
Date: Wed, 10 Aug 2016 07:59:23 -0700

> RECOMMENDED and OPTIONAL values.

+1 to keeping the adjectives. They are indeed helpful or even necessary
in crafting readable prose.

Mike Heard