Subject: Review of draft-ietf-tram-turn-server-discovery-08

From: Ralph Droms <[email-masked]>
Date: Tue, 9 Aug 2016 17:27:48 -0400

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed by
the IESG for the IETF Chair. Please resolve these comments along with
any other Last Call comments you may receive.

For more information, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-tram-turn-server-discovery-08
Reviewer: Ralph Droms
Review Date: 2016-08-09
IETF LC End Date: 2016-08-11
IESG Telechat date: unknown

Summary:

This draft is on the right track but has open issues, described in the
review.

The draft is well-written and appears to be ready for publication,
except as noted below.

Major issues:

Section 5, DNS Service Discovery, includes more details about DNS
Service Discovery (DNS-SD) than is necessary for this specification.
While it can be useful to repeat some specific details of another
specification for, there is a danger in writing too many details that
may not be entirely in agreement with the published specification.  In
the case of this document, I suggest that section 5 be rewritten to
just refer to DNS Service discovery, with a minimum of explanation.
The example is useful ... although I think some of the details in the
example ought to be changed.  The use of DNS-SD over unicast DNS and
multicast DNS can be mentioned in a sentence somewhere in section 5,
as the use of DNS-SD is otherwise identical.  I would leave out
section 5.1 altogether.

Looking at the IANA "Service Name and Transport Protocol Port Number
Registry"
<www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xhtml>,
I see that TURN is registered as using service name "turn", rather
than "turnserver" as in the example.  Also in the example, the
instance name "example.com" might be problematic, as the instance is
usually just a single label.  In fact, I interpret the text in the
document to describe the instance name as a single label.  It might be
worth experimenting to see how DNS-SD libraries deal with a label like
"example.com", or perhaps simply change instance in the example to
something like "exampleco TURN Server"

Minor issues:

Section 5 mentions the use of a TXT record to carry additional information about the TURN service instance.  Are there any conventions for the name/value pairs carried in the TXT record?  If not, I think there should be a note that any name/value pairs in the TXT record are left to local definition.

Editorial issues:

I suggest using the example.com domain rather than local in the example for clarity.  Perhaps also change the intro sentence for the example:

OLD:
 For example, TURN server advertises the following DNS records :
NEW:
 For example, the following DNS records would be used for a TURN server with instance name "exampleco TURN Server" providing TURN service over UDP on port 5030:

It would help readability if the columns in the DNS records in the example could be lined up; something like (apologies if your mail reader changes the column alignments and if I don't have the quoting right):

_turnserver._udp.local.
PTR	"exampleco TURN Server"._turn._udp.local.

"exampleco TURN Server"._turn._udp.local.
SRV	0 0 5030 example-turn-server.local.

example-turn-server.local.
A	198.51.100.2

example-turn-server.local.
AAAA	2001:db8:8:4::2

Similarly, it would help readability if the list of DNS records for S-NAPTR resolution were formatted in aligned columns.

In section 3, does "on top of" mean "in addition to" or "instead of"?

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Wed, 17 Aug 2016 15:24:19 +0000

Hi Ralph,

Thanks for the review. Please see inline.

> -----Original Message-----
> From: Ralph Droms [mailto:[email-masked]]
> Sent: Wednesday, August 10, 2016 2:58 AM
> To: Review Area [email-masked] Team <[email-masked]>
> Cc: [email-masked]; IETF discussion list
> <[email-masked]>
> Subject: Review of draft-ietf-tram-turn-server-discovery-08
> 
> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for
> the IETF Chair. Please resolve these comments along with any other Last Call
> comments you may receive.
> 
> This draft is on the right track but has open issues, described in the review.
> 
> The draft is well-written and appears to be ready for publication, except as
> noted below.
> 
> Major issues:
> 
> Section 5, DNS Service Discovery, includes more details about DNS Service
> Discovery (DNS-SD) than is necessary for this specification.
> While it can be useful to repeat some specific details of another specification
> for, there is a danger in writing too many details that may not be entirely in
> agreement with the published specification.  In the case of this document, I
> suggest that section 5 be rewritten to just refer to DNS Service discovery, with
> a minimum of explanation.
> The example is useful ... although I think some of the details in the example
> ought to be changed.  The use of DNS-SD over unicast DNS and multicast DNS
> can be mentioned in a sentence somewhere in section 5, as the use of DNS-SD
> is otherwise identical.  I would leave out section 5.1 altogether.
> 
> I see that TURN is registered as using service name "turn", rather than
> "turnserver" as in the example.  Also in the example, the instance name
> "example.com" might be problematic, as the instance is usually just a single
> label.  In fact, I interpret the text in the document to describe the instance
> name as a single label.  It might be worth experimenting to see how DNS-SD
> libraries deal with a label like "example.com", or perhaps simply change
> instance in the example to something like "exampleco TURN Server"

Changed to "exampleco TURN Server" and used service names "turn" and "turns".

> 
> Minor issues:
> 
> Section 5 mentions the use of a TXT record to carry additional information
> about the TURN service instance.  Are there any conventions for the
> name/value pairs carried in the TXT record? 

No conventions.

>  If not, I think there should be a
> note that any name/value pairs in the TXT record are left to local definition.

Okay, added following line:
The TXT record can contain any key/value pairs left to the local definition.

> 
> Editorial issues:
> 
> I suggest using the example.com domain rather than local in the example for
> clarity.  Perhaps also change the intro sentence for the example:
> 
> OLD:
>  For example, the following DNS records would be used for a TURN server with
> instance name "exampleco TURN Server" providing TURN service over UDP on
> port 5030:

Updated.

> 
> 
> It would help readability if the columns in the DNS records in the example
> could be lined up; something like (apologies if your mail reader changes the
> column alignments and if I don't have the quoting right):
> 
> _turnserver._udp.local.
> Similarly, it would help readability if the list of DNS records for S-NAPTR
> resolution were formatted in aligned columns.

Fixed.

> In section 3, does "on top of" mean "in addition to" or "instead of"?

It means "in addition to".

-Tiru

---

From: Ralph Droms <[email-masked]>
Date: Wed, 17 Aug 2016 21:04:26 -0400

Tiru - thanks for advising me of your responses to the points in my review.

Do you and the other authors have any thoughts about my recommendations for section 5?

- Ralph

> On Aug 17, 2016, at 11:24 AM 8/17/16, Tirumaleswar Reddy (tireddy) <[email-masked]> wrote:
> 
> Hi Ralph,
> 
>> From: Ralph Droms [mailto:[email-masked] <mailto:[email-masked]>]
>> To: Review Area [email-masked] <mailto:[email-masked]> Team <[email-masked] <mailto:[email-masked]>>
>> Cc: [email-masked] <mailto:[email-masked]>; IETF discussion list
>> <[email-masked] <mailto:[email-masked]>>
>> I suggest using the example.com <http://example.com/> domain rather than local in the example for

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 18 Aug 2016 05:21:27 +0000

From: Ralph Droms [mailto:[email-masked]]
Sent: Thursday, August 18, 2016 6:34 AM
To: Tirumaleswar Reddy (tireddy) <[email-masked]>
Cc: Review Area [email-masked] Team <[email-masked]>; [email-masked]; IETF discussion list <[email-masked]>
Subject: Re: Review of draft-ietf-tram-turn-server-discovery-08

[TR] Agree with your recommendation, updated Section 5.

-Tiru

- Ralph

On Aug 17, 2016, at 11:24 AM 8/17/16, Tirumaleswar Reddy (tireddy) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Ralph,

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: Wednesday, August 10, 2016 2:58 AM
To: Review Area [email-masked]<mailto:[email-masked]> Team <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; IETF discussion list
<[email-masked]<mailto:[email-masked]>>
Subject: Review of draft-ietf-tram-turn-server-discovery-08

Summary:

Major issues:

Looking at the IANA "Service Name and Transport Protocol Port Number
Registry"
<www.iana.org/assignments/service-names-port-numbers/service-names-<http://www.iana.org/assignments/service-names-port-numbers/service-names->
port-numbers.xhtml>,
I see that TURN is registered as using service name "turn", rather than
"turnserver" as in the example.  Also in the example, the instance name
"example.com<http://example.com>" might be problematic, as the instance is usually just a single
label.  In fact, I interpret the text in the document to describe the instance
name as a single label.  It might be worth experimenting to see how DNS-SD
libraries deal with a label like "example.com<http://example.com>", or perhaps simply change
instance in the example to something like "exampleco TURN Server"

Minor issues:

No conventions.

Editorial issues:

I suggest using the example.com<http://example.com/> domain rather than local in the example for
clarity.  Perhaps also change the intro sentence for the example:

OLD:

Updated.

_turnserver._udp.local.

Fixed.

-Tiru