Subject: Re: Review of draft-ietf-curdle-dnskey-eddsa-02 (Als was: Secdir review of draft-ietf-curdle-dnskey-eddsa-02)

From: Ondřej Surý <[email-masked]>
Date: Mon, 12 Dec 2016 10:38:35 +0100 (CET)

Magnus and Dan,

thanks for the review.

Magnus, you are right, I have removed the first full paragraph
about "security properties" from Security Considerations
from my git version as the security properties of EdDSA
are better described in Normative references anyway.

https://gitlab.labs.nic.cz/labs/ietf/commit/7b52c8e2bbe44042a279a81b960270fdd103d9a2

Dan,

good catches, I fixed the nits in the git:

https://gitlab.labs.nic.cz/labs/ietf/commit/bbfc7ce43fb1f46c91fb7f5de564d907d035aadf

I would be happy to upload next revision after Last Call
is finished or just let the RFC editors to fix it.

Cheers,
--
 Ondřej Surý -- Technical Fellow
 --------------------------------------------
 CZ.NIC, z.s.p.o.    --     Laboratoře CZ.NIC
 Milesovska 5, 130 00 Praha 3, Czech Republic
 mailto:[email-masked]    https://nic.cz/
 --------------------------------------------

----- Original Message -----
> From: "Magnus Nyström" <[email-masked]>
> To: [email-masked], "draft-ietf-curdle-dnskey-eddsa" <[email-masked]>
> Sent: Monday, 12 December, 2016 02:44:18
> Subject: Secdir review of draft-ietf-curdle-dnskey-eddsa-02

> I have reviewed this document as part of the security directorate's
> ongoing effort to review all IETF documents being processed by the
> IESG. These comments were written primarily for the benefit of the
> security area directors. Document editors and WG chairs should treat
> these comments just like any other last call comments.
> 
> This document describes how to use two two specific Edwards Curves
> (Elliptic Curves) in conjunction with DNSSEC, namely ed25519 and
> ed448.
> 
> The only comment I have on this document is that the Security
> Considerations section plainly states, without any reference or proof:
> 
> "Ed25519 and Ed448 offers improved security properties and
> implementation characteristics compared to RSA and ECDSA algorithms"
> 
> I suggest either adding references to proofs of these statements or
> alternatively just remove the sentence (since it doesn't really add
> anything to the memo); the remaining paragraphs in the Security
> Considerations section is what really covers what someone implementing
> the memo should know or be aware of.
> 
> -- Magnus

~~~~

----- Original Message -----
> From: "Dan Romascanu" <[email-masked]>
> To: [email-masked]
> Cc: "draft-ietf-curdle-dnskey-eddsa all" <[email-masked]>, "curdle" <[email-masked]>,
> [email-masked]
> Sent: Sunday, 11 December, 2016 12:21:25
> Subject: Review of draft-ietf-curdle-dnskey-eddsa-02

> Reviewer: Dan Romascanu
> Review result: Ready with Nits
> 
> Summary: Ready, with nits
> 
> I am not an expert in this field, but the document seems to meet its
> goals, it's clear and precise
> 
> Major issues:
> 
> Minor issues:
> 
> Nits/editorial comments:
> 
> 1. Section 4: s/Section5.1.7/Sections 5.1.7/
> 
> 2. Section 8: 'The following entry has been added to
>   the registry' - I may be wrong, but the section seems to define two
> new entries in the registry rather than one

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 12 Dec 2016 11:24:18 +0000

Hi Ondřej,

> is finished or just let the RFC editors to fix it.

Please do upload a new version at the end of last call
with these and any other non-controversial changes.

Thabks,
S.

---

From: Dan Romascanu <[email-masked]>
Date: Mon, 12 Dec 2016 13:34:34 +0200

Hi Ondrej,

Thanks for addressing my comments. The nits can be fixed at any time you
find more convenient before publication.

Regards,

Dan

On Mon, Dec 12, 2016 at 11:38 AM, Ondřej Surý <[email-masked]> wrote:

> > Cc: "draft-ietf-curdle-dnskey-eddsa all" <draft-ietf-curdle-dnskey-
> [email-masked]>, "curdle" <[email-masked]>,
> > [email-masked]

---

From: Ondřej Surý <[email-masked]>
Date: Sat, 17 Dec 2016 08:01:47 +0100 (CET)

Hi all,

the IETF review has ended, so I have uploaded -03 version.

Magnus, Dan,

the -03 version addresses all your comments.

Tim,

I left the irtf documents in Normative as per Stephan's comments.

I believe that Section 8 correctly references IANA registry:
http://www.iana.org/assignments/dns-sec-alg-numbers/dns-sec-alg-numbers.xhtml
by its name.

The paragraph with nit has been removed altogether per Magnus's request.

Thank you all very much for the reviews.

Cheers,

----- Original Message -----
> From: "Ondřej Surý" <[email-masked]>
> To: "Magnus Nyström" <[email-masked]>, "Dan Romascanu" <[email-masked]>
> Cc: "secdir" <[email-masked]>, "draft-ietf-curdle-dnskey-eddsa" <[email-masked]>, "gen-art"
> <[email-masked]>, "ietf" <[email-masked]>, "curdle-chairs" <[email-masked]>, "curdle" <[email-masked]>
> Sent: Monday, 12 December, 2016 10:38:35
> Subject: Re: Review of draft-ietf-curdle-dnskey-eddsa-02 (Als was: Secdir review of draft-ietf-curdle-dnskey-eddsa-02)

>> To: [email-masked], "draft-ietf-curdle-dnskey-eddsa"
>> <[email-masked]>
>> Cc: "draft-ietf-curdle-dnskey-eddsa all"
>> <[email-masked]>, "curdle" <[email-masked]>,
>> [email-masked]

---

From: Dan Romascanu <[email-masked]>
Date: Sat, 17 Dec 2016 09:11:03 +0200

Thank you for addressing my comments.

Regards,

Dan

On Sat, Dec 17, 2016 at 9:01 AM, Ondřej Surý <[email-masked]> wrote:

> > Cc: "secdir" <[email-masked]>, "draft-ietf-curdle-dnskey-eddsa" <
> [email-masked]>, "gen-art"
> > <[email-masked]>, "ietf" <[email-masked]>, "curdle-chairs" <
> [email-masked]>, "curdle" <[email-masked]>
> > Subject: Re: Review of draft-ietf-curdle-dnskey-eddsa-02 (Als was:
> Secdir review of draft-ietf-curdle-dnskey-eddsa-02)
>
> > Magnus and Dan,
> >
> > thanks for the review.
> >

---

From: Magnus Nyström <[email-masked]>
Date: Sat, 17 Dec 2016 09:13:52 -0800

Same here. Thank you!
/M

On Fri, Dec 16, 2016 at 11:11 PM, Dan Romascanu <[email-masked]> wrote:
>> > Cc: "secdir" <[email-masked]>, "draft-ietf-curdle-dnskey-eddsa"
>> > <[email-masked]>, "gen-art"
>> > <[email-masked]>, "ietf" <[email-masked]>, "curdle-chairs"
>> > <[email-masked]>, "curdle" <[email-masked]>

-- 
-- Magnus