Subject: Re: [Gen-art] Last Call Review of draft-ietf-manet-dlep-25

From: Jari Arkko <[email-masked]>
Date: Thu, 15 Dec 2016 11:08:40 +0200

Matt,

Many thanks for this.

Authors, did you have any responses on Matt’s comments?

Also, Matt, I had one question for you:

> 
> * The IANA registries this document establishes are not defined.
> One can deduce the required information and its format, but there
> is no guidance on review process (for example). I urge the authors
> to consult RFC 5226 when revisiting the IANA considerations.

What did you have in mind here? At least the -26 specifies Specification
Required for the registries, and given RFC 5226’s guidance on what that
means, I’m not sure what information is missing. Unless, of course, you
think that there should further expert review guidance. Or is the problem
that the allocation policy is in the table, not in the text, e.g.:

> 13.6.  DLEP Extensions Registrations
> 
> 
>   Upon approval of this document, IANA is requested to create a new
>   DLEP registry, named "Extension Type Values".
> 
>   The following table provides initial registry values and the
>   [RFC5226] defined policies that should apply to the registry:
> 
>               +--------------+----------------------------+
>               | Code         | Description/Policy         |
>               +--------------+----------------------------+
>               | 0            | Reserved                   |
>               | 1            | Credit Windowing [CREDIT]  |
>               | 2-65519      | Specification Required     |
>               | 65520-65534  | Private Use                |
>               | 65535        | Reserved                   |
>               +--------------+----------------------------+
> 
>                       Table 3: DLEP Extension types
> 
> 

Jari

---

From: "Taylor, Rick (External)" <[email-masked]>
Date: Thu, 15 Dec 2016 10:13:38 +0000

Hi Jari,

I have (belatedly) responded to Matt's comments which were on draft-25.  A lot of his points were made by other reviewers and many have been addressed in draft-26 already.

The IANA reviewer gave us good direction to the correct registration entries/format/detail, and I hope we have got them right in the latest draft.

Regards,

Rick Taylor

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: 15 December 2016 09:09
> To: Matt Miller
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Gen-art] Last Call Review of draft-ietf-manet-dlep-25
>
> Matt,
>
> Many thanks for this.
>
> Authors, did you have any responses on Matt's comments?
>
> > One can deduce the required information and its format, but there is
> > no guidance on review process (for example). I urge the authors to
> > consult RFC 5226 when revisiting the IANA considerations.
>
> Required for the registries, and given RFC 5226's guidance on what that
> means, I'm not sure what information is missing. Unless, of course, you think
> that there should further expert review guidance. Or is the problem that the
> allocation policy is in the table, not in the text, e.g.:
>
> This mail has originated outside your organization, either from an external
> partner or the Global Internet.
> Keep this in mind if you answer this message.
>

The information contained within this e-mail and any files attached to this e-mail is private and in addition may include commercially sensitive information. The contents of this e-mail are for the intended recipient only and therefore if you wish to disclose the information contained within this e-mail or attached files, please contact the sender prior to any such disclosure.

If you are not the intended recipient, any disclosure, copying or distribution is prohibited. Please also contact the sender and inform them of the error and delete the e-mail, including any attached files from your system.

Emails to Airbus Defence and Space Limited may be processed, recorded and monitored anywhere in the European Community.

Airbus Defence and Space Limited

Registered Office: Gunnels Wood Road, Stevenage, Hertfordshire, SG1 2AS.
Registered in England and Wales under company number 02449259.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 15 Dec 2016 15:56:01 +0200

Excellent - thanks!

Jari

---

From: Matt Miller <[email-masked]>
Date: Thu, 15 Dec 2016 10:49:42 -0700

Thanks all.  I have not yet reviewed -26 myself, but a quick perusal
makes me think they have been addressed.  As for my comments on the
registries:

Defining the review level within the table did throw me off.  Looking at
it again, I think it would be helpful to separate out the registry
definition from its initial values, to make it clearer what is expected
from somewhat wishing to add to the registry.

I think I was also expecting some more guidance, at least what someone
wishing to add to the registry could expect from the reviewers.

That said, if IANA and the expert reviewers-to-be are happy with this,
then that's good enough for me.

Thanks again,

- m&m

Matt Miller
Cisco Systems, Inc.