Subject: Re: If categories of people are blocked by the U.S., should the IETF respond?

From: S Moonesamy <[email-masked]>
Date: Wed, 01 Feb 2017 05:12:11 -0800

Hi Stephen,
At 05:31 PM 1/29/2017, Stephen Farrell wrote:
>In this case, and as mentioned previously, there is at
>least one aspect that goes beyond mtgvenue, in that those
>leaving from one place to come to a meeting might be
>restricted in returning home. That seems to me to be an
>order of magnitude more problematic than not being allowed
>entry. The "order of magnitude" aspect of that is maybe
>not relevant for IETF discussion, but the "not able to
>contribute since not able to return home" aspect would
>surely be, as would the "not able to travel to *any*
>'foreign' f2f meetings since not able to return home."

At the lower end, it is a visa problem.  The difference between this 
discussion and the one about Singapore is that the latter was not 
related to entry of IETF attendees.  Jari went through the statistics 
to see whether there were IETF attendees from the affected 
countries.  In terms of attendance, the impact is not 
significant.  The IAB appointed a person from RIPE NCC on the 
IAOC.  Based on the message which the person posted to Facebook, I 
guess that the person may not be able to attend the next IETF meeting 
in the U.S.  It is up to the IESG to assess whether the impact should 
be raised from not significant to something else.

>Anyway, and also speaking personally, I do think there
>may be a valid public IETF reaction here, in addition to
>mtgvenue considerations, which is that we, as with any
>scientific or technical organisation with participants
>welcome from all over the globe, depend on the rule of
>law as it relates to travel being somewhat rational and
>relatively stable. (*)
>
>I think the ACM text could be quite close to something
>on which we could garner IETF consensus as it mostly
>says just the above.

My preference is for the public IETF reaction to be based on open 
discussion instead of a discussion behind closed doors.  I don't 
think that IETF Consensus should be a matter of convenience.

>And yes, you may well be right that there will be more
>pressing matters on which we may need to consider comment
>in future. Personally, I think I'd argue that even if that's
>the case (which we all hope won't turn out true but fear
>might) then we'll be better off having had some discussion
>ahead of time as to where we do or do not have IETF consensus
>for relevant comment being within our scope.

I scanned the list quickly and I only found two IESG members, the 
IETF Chair and you, commenting on the issue.  Do the other IESG 
members have an opinion about the topic?  I'll Cc them to find out.

There was a comment a word which is fashionable nowadays [1].  That 
word sounds hollow given the silence of the persons who have been 
using that word.

Regards,
S. Moonesamy

1. https://www.ietf.org/mail-archive/web/ietf/current/msg100833.html

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 1 Feb 2017 13:44:23 +0000

Hiya,

On 01/02/17 13:12, S Moonesamy wrote:
> 
> I scanned the list quickly and I only found two IESG members, the IETF
> Chair and you, commenting on the issue.  Do the other IESG members have
> an opinion about the topic?  I'll Cc them to find out.

I can help you there. The IESG and IAB (and I'm told the IAOC
and meetings ctte) have been actively discussing all of this.
I'm on one thread between IAB and IESG that has 84 messages in
total (though a good few of those are duplicates in my crappy
foldering scheme;-). And I think this topic may be on the agenda
for an upcoming IAB call and it is on the agenda for an IESG
call tomorrow. If something concrete results from those calls
it'll likely take at least a few days to be visible to the
community. Or maybe we'll need a bit longer. (That's another
reason why it was good that Jari/Andrew/Leslie posted that
blog, and yes they'd gotten some feedback from I* folks
before doing so.)

So while of course I* folks may respond to you if they've
stuff to say, I don't think there's much need for a slew of
"yeah we're aware of that" mails. But it is the case that quite
a few IESG/IAB folks have been actively engaged on this.

Cheers,
S.

---

From: Tim Chown <[email-masked]>
Date: Wed, 1 Feb 2017 15:27:55 +0000

Hi,

> a few IESG/IAB folks have been actively engaged on this.

It seems the person who is being officially appointed as IAB’s liaison the the IAOC will now not be able to attend the Chicago IETF:

https://motherboard.vice.com/en_us/article/icann-trump-travel-ban-internet <https://motherboard.vice.com/en_us/article/icann-trump-travel-ban-internet>

(apologies if this has been mentioned already - so many emails on this important topic - but I also saw this directly on Facebook from the volume of shares on the post by people I trust, so I assume it’s genuine)

Tim

---

From: Jari Arkko <[email-masked]>
Date: Wed, 1 Feb 2017 23:51:54 +0100

> I scanned the list quickly and I only found two IESG members, the IETF Chair and you, commenting on the issue.  Do the other IESG members have an opinion about the topic?

I think I may have discussed the topic by now with every person on the IESG, IAB, and IAOC. I can assure you that they care deeply about the topic :-)

Jari

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Thu, 9 Feb 2017 11:26:06 +0100

Hi Jari,

see comments below...

Am 30.01.2017 um 20:39 schrieb Jari Arkko:
> I wanted to update people a bit on effects and numbers.
> 
> Adam had given earlier in this thread a list of affected
> people from past meetings. I run my own script on the
> attendee data though, and (I think) took into account
> who was actually on site. Out of the seven countries
> on the list, we’ve not had a single attendee on site from
> the beginning of the full records at IETF #80.
> 
> Obviously, that doesn’t make it right. Also,
> the registration data is still based on the country or
> region that people given when they register. And
> you can only enter one value.
> 
> I’m aware of at least two people (Kaveh and Naeem)
> who have dual citizenships for instance, and they are
> sadly affected. There’s likely some more. If you are
> affected and planning to attend future IETF meetings,
> drop me an e-mail.

The collateral damage and impact of current US policy on
immigration is probably broader than just counting the people
who are obviously affected by any ban.
I originally planned to attend the meeting in Chicago
and normally I'm always looking forward to visit the US.
Though I'm not affected by my citizenship (yet), I'm
refraining from attending this time. Why?
I'm deeply concerned about the current practices during
immigration:
http://www.cnbc.com/2017/02/08/us-visitors-may-have-to-hand-over-social-media-passwords-dhs.html

"We want to get on their social media, with passwords: What do you do,
what do you say?" he [John Kelly] told the House Homeland Security
Committee. "If they don't want to cooperate then you don't come in."

So just flying several hours across the ocean and then get denied on
entry, because one of your friends probably posted some US politics
criticism that the immigration officer didn't like is a risk that I
don't need this time.
Moreover, if someone gets full control over a social media account
he/she can also *write* - this is ridiculous. [*]
I refuse this highly privacy invading practice.

More stuff like this:
http://www.cbc.ca/news/canada/montreal/canadian-woman-turned-away-from-u-s-border-after-questions-about-religion-trump-1.3972019

https://www.aclu.org/blog/speak-freely/flying-home-abroad-border-agent-stopped-and-questioned-me-about-my-work-aclu

I really like to support the IETF by also physically attending the
meetings if possible, but under these circumstances I refrain from
doing so.

Regards,
 Roland

[*] it's clear that some "agencies" already have that access,
but this is even another dimension now...