Subject: Side meetings experiment at IETF 99

From: Suresh Krishnan <[email-masked]>
Date: Fri, 26 May 2017 16:24:32 -0400

Hi all,
  The IESG has discussed how to improve the path for potential new topics to be discussed transparently in the IETF community.  For some cross-area topics, it is quite useful to have active conversation among a group of people to work on defining the potential work and how it interacts with existing efforts.  As the IETF week is quite busy, it can be a challenge to arrange these side-meetings to avoid conflicts.  To facilitate the scheduling of these conversational side-meetings, the IESG has decided to provide a meeting room at IETF 99 in Prague for around 30 people, with a U-shaped table, that will be available for first-come first-served (FCFS) signup online as soon as the final IETF meeting agenda is published.  This experiment will be conducted for IETF 99 in Prague and will replace AD approval for rooms for side-meetings for potential new topics. Proponents of potential new topics are reminded that the BoF deadline is June 2; this includes non-WG forming BoFs.  The on-site signup FCFS room (seats about 16) will continue to be available at IETF 99.

Thanks
Suresh
(on behalf of the IESG)

---

From: Yoav Nir <[email-masked]>
Date: Fri, 26 May 2017 23:34:02 +0300

Hi, Suresh.

How is this experiment different from the sign-up room that has been available for the last several meetings with a sign-up sheet by the door?

I mean, other than making the sign-up online.

Will a sign-up room still be available, or is this experiment replacing that?

Thanks

Yoav

> On 26 May 2017, at 23:24, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi all,

---

From: Alia Atlas <[email-masked]>
Date: Fri, 26 May 2017 17:31:15 -0400

Yoav,

As indicated in Suresh's email, the existing on-site FCFS room that holds
around 16 people will continue to be
available.  There will also be a room that holds about 30 people, in a
U-shape, that will be available for sign-ups
a couple weeks before IETF (when the IETF agenda comes out).

Does that help clarify?

Regards,
Alia

On Fri, May 26, 2017 at 4:34 PM, Yoav Nir <[email-masked]> wrote:

> Hi, Suresh.
>
> How is this experiment different from the sign-up room that has been
> available for the last several meetings with a sign-up sheet by the door?
>
> >  The IESG has discussed how to improve the path for potential new topics
> to be discussed transparently in the IETF community.  For some cross-area
> topics, it is quite useful to have active conversation among a group of
> people to work on defining the potential work and how it interacts with
> existing efforts.  As the IETF week is quite busy, it can be a challenge to
> arrange these side-meetings to avoid conflicts.  To facilitate the
> scheduling of these conversational side-meetings, the IESG has decided to
> provide a meeting room at IETF 99 in Prague for around 30 people, with a
> U-shaped table, that will be available for first-come first-served (FCFS)
> signup online as soon as the final IETF meeting agenda is published.  This
> experiment will be conducted for IETF 99 in Prague and will replace AD
> approval for rooms for side-meetings for potential new topics. Proponents
> of potential new topics are reminded that the BoF deadline is June 2; this
> includes non-WG forming BoFs.  The on-site signup FCFS room (seats about
> 16) will continue to be available at IETF 99.
> >
> > Thanks
> > Suresh
> > (on behalf of the IESG)
> >
>
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 26 May 2017 22:43:52 -0400

--On Friday, May 26, 2017 17:31 -0400 Alia Atlas
<[email-masked]> wrote:

> Yoav,
> 
> As indicated in Suresh's email, the existing on-site FCFS room
> that holds around 16 people will continue to be
> available.  There will also be a room that holds about 30
> people, in a U-shape, that will be available for sign-ups

It does, but let me note three things for whatever they might be
worth:

(1) <rant> Suresh's description of these informal meetings match
reasonably closely something we did in the distant past.  It was
calls a "BOF".  Over the years, that concept of a BOF as a
relatively informal session for discussion of new ideas and
other things that were not ready for WG charters, morphed into
very formal arrangements requiring formal proposals more than
six weeks in advance of IETF meetings and approval by the IESG
and advice from the IAB.   People dealt with that problem with
formally organized Bar BOFs, a combination that would have been
considered an oxymoron when BOFs were more informal gatherings,
which led to requests for meeting rooms for side meetings and
now sign-up arrangements for those meeting rooms.</rant>  

(2) I believe there was at least one "informal side meeting" in
Chicago that wanted video remote participation arrangements, so
let me ask the question in advance: will this room be set up for
Meetecho and, if not, why not?   Is it time for the IESG to
rethink how we do this and why we seem to need to move in
directions of more and more Procedures, rather than just walking
across (or down) slippery slopes? 

(3) For those who are concerned about where we meet and what the
constraints are on locations, it may be worth noting that, for
at least some facilities, the number of small to medium-sized
meeting rooms we now require for one or two official
side-meeting spaces, plus rooms for IESG, IAB, Nomcom, IAD,
IOAC, ISOC, Secretariat work space, etc., may be as much of a
constraint as spaces for parallel WG sessions.

Grumpily,
   john

---

From: Melinda Shore <[email-masked]>
Date: Fri, 26 May 2017 19:16:20 -0800

> now sign-up arrangements for those meeting rooms.</rant>  

I agree with all of this, although I think it's very easy to
move from less structure to more structure and extremely difficult
to move from more structure to less structure.  This weighty
process stuff was put in place to solve some problem, and I
think (but am not completely sure) that that problem is related
to resource contention and shortages, where "resource" is probably
some combination of time/attention of the I*, meeting rooms,
etc.  But, of course, the problem of how to have relatively
unstructured but productive interactions hasn't gone away, so
we keep adding more, er, "stuff" to the process of finding ways
to talk with each other.  And then the culture has changed as
well, with increasing participation from people whose job it
is to go to standards meetings bringing in process expectations
from organizations with more formal structures.

I'll add that it's kind of weird, at least to me, to say
that people will get supported resources to brainstorm together
informally but only if they grab that resource first.

It would be nice to find some way to strip away some of the
weight in our processes.  I'm still intrigued by the IRSG
experiment with letting groups meet for a year and seeing what
they come up with, then axing them if the work isn't up to
snuff, although that may not translate well to the broader
IETF organization.  In the meantime, over the past few years
I've increasingly found that the best place to grab some
informal chat and whiteboarding time to work through some ideas
at meetings is the hackathon (which is, of course, not its
intent, but there we are anyway).

Melinda

---

From: Lloyd Wood <[email-masked]>
Date: Sat, 27 May 2017 14:06:11 +0000 (UTC)

It's interesting watching the ongoing ossification of the
IETF and its workflow process.

RFCs were originally actual requests for comments.
(What was the first internet-draft requesting comments?)

Workgroups begat BOFs to possibly lead to workgroups.
BOFs became formalised to beget Bar BOFs once the BOF
process was formalised.

I was half-expecting bar seating reservations and waitlists,
with applications for bar discussions to be accepted by

a new ad-hoc committee, leading to Bar Queue Grouping
Formaulation discussions for Bar BOF applications...
And now we have side meetings? Bar, humbug.

Lloyd Wood [email-masked] http://about.me/lloydwood 

________________________________
From: Suresh Krishnan <[email-masked]>
To: IETF Discussion <[email-masked]> 
Cc: IESG <[email-masked]>
Sent: Saturday, 27 May 2017, 6:25
Subject: Side meetings experiment at IETF 99

Hi all,

Thanks

Suresh

(on behalf of the IESG)

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 28 May 2017 13:00:13 -0400

Hi, Lloyd,

On May 27, 2017 09:06, "Lloyd Wood" <[email-masked]> wrote:

If by "now", you mean "since 2012", yes.

https://datatracker.ietf.org/doc/rfc6771/ (first draft in 2010) was written
in response to a series of barless bar bofs. One of the side effects of
having them called "bar bofs" was that they were easily confused with
actual BoFs, especially when they were held in the same meeting rooms as
actual BoFs, and looked indistingushable from actual BoFs. So, the
half-decade-ago guidance was to call them something else, hence "side
meetings".

I can't speak to why other IESG members thought this was a reasonable
experiment, but the reason I supported this experiment was to give the
community more tools to have the kind of organizational side meetings I
hope BoF proponents have - with Occam's Razor being whether the desired
outcome is

- the proponents agree on what to ask the community for (so, side meeting),
or

- the community agrees that a working group should be chartered (so, BoF).

And it's always appropriate to point out that if this all sounds like
organizational claptrap, there is no requirement to have a side meeting
before requesting a BoF, AND there's no requirement to have a BoF before
requesting approval for a working group charter, so you can safely ignore
ALL of it ;-)

Please, enjoy your day.

Spencer, speaking as only 1/15th of the currently serving ADs, but one who
has chartered working groups without a BoF ...

Hi all,

Thanks

Suresh

(on behalf of the IESG)