Subject: Opsdir last call review of draft-ietf-curdle-cms-ecdh-new-curves-07

From: Stefan Winter <[email-masked]>
Date: Tue, 23 May 2017 02:29:20 -0700

Reviewer: Stefan Winter
Review result: Has Nits

Nits: 

* 2.1 starts with "...  based on a one-way hash function described in
ANS X9.63 [X963]." s/ANS/ANSI/

* Chapter 7 defines six OIDs (secg-scheme 11 1...3 and smime-alg
TBD1...3) and also includes the base OIDs under which these new OIDs
are attached (secg-scheme and smime-alg). Those two are not defined in
this document, but the text in chapter 7 suggests so.
Maybe it would be a bit clearer if the text stated explicitly which of
the OIDs in the chapter are NEW, and which ones already exist and are
provided for reference/context.

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 May 2017 15:34:29 -0400

> On May 23, 2017, at 5:29 AM, Stefan Winter <[email-masked]> wrote:
> 
> Reviewer: Stefan Winter
> Review result: Has Nits
> 
> Nits: 
> 

The American National Standards Institue (ANSI) is an organization.  See https://www.ansi.org/ <https://www.ansi.org/>.

American National Standards (ASN) are documents.  In this case, ANS X9.63 is being referenced.

I will expand ANS to American National Standard to avoid future confusion.

> this document, but the text in chapter 7 suggests so.

Section 7 includes:

      secg-scheme OBJECT IDENTIFIER ::= {
        iso(1) identified-organization(3) certicom(132) schemes(1) }

which is followed by 3 OIDs assigned in that arc.

Section 7 also includes:

      smime-alg OBJECT IDENTIFIER ::= {
         iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1)
         pkcs-9(9) smime(16) alg(3) }

which is followed by three TBD OID values that need to be assigned by IANA once the document is approved.

> provided for reference/context.

Once IANA makes the three assignments, all of the OID values will appear in the RFC.

Russ