Subject: IPv10, KRP, and RRP IDs Removal.

From: Khaled Omar <[email-masked]>
Date: Mon, 22 May 2017 22:55:02 +0000

Hi Jasmine,

As I'm the only author of the following IDs:

1)      Internet Protocol version 10 (IPv10): https://datatracker.ietf.org/doc/draft-omar-ipv10/

2)      KHALED Routing Protocol (KRP): https://datatracker.ietf.org/doc/draft-omar-krp/

3)      Regional Routing Protocol (RRP): https://datatracker.ietf.org/doc/draft-omar-rrp/

Please remove them all from the ietf database or repository.

If the ideas explained on these drafts will be used, discussed or published by the ietf, legal actions will be taken.

Regards,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Mon, 22 May 2017 23:09:11 +0000

I'm the only author of the listed IDs and they are submitted individually, I made this removal request and these IDs must not be stored on the ietf database anymore and the ietf representation must not exist after the request date and time which is 23rd of May, 2017 at 1:00 PM GMT+02:00.

-----Original Message-----
From: Ole Jacobsen [mailto:[email-masked]] 
Sent: Tuesday, May 23, 2017 1:02 AM
To: Khaled Omar
Subject: Re: IPv10, KRP, and RRP IDs Removal.

You really have no idea how the IETF works, do you?

On Mon, 22 May 2017, Khaled Omar wrote:

> 1) Internet Protocol version 10 (IPv10): 
> https://datatracker.ietf.org/doc/draft-omar-ipv10/
> 
> 
> 2) KHALED Routing Protocol (KRP): 
> https://datatracker.ietf.org/doc/draft-omar-krp/
> 
> 
> 3) Regional Routing Protocol (RRP): 
> https://datatracker.ietf.org/doc/draft-omar-rrp/
> 
> 
> If the ideas explained on these drafts will be used, discussed or 
> published by the ietf, legal actions will be taken.
> 
> Regards,
> 
> Khaled Omar
>

---

From: Alexa Morris <[email-masked]>
Date: Mon, 22 May 2017 20:27:18 -0400

Khaled,

The IESG has published a statement on this topic. Please see "IESG Statement on Removal of an Internet-Draft from the IETF Web Site" at https://www.ietf.org/iesg/statement/removal-of-an-internet-draft.html, which explains that IESG consensus is required in order to remove an Internet Draft from the I-D Repository.

I have forwarded your email to the IESG for their review. Please be patient as it will take at least several days for them to review and respond to this request. 

Regards,
Alexa

>> published by the ietf, legal actions will be taken.

----------
Alexa Morris / Executive Director / IETF
+1.510.492.4001
Email: [email-masked]

---

From: Khaled Omar <[email-masked]>
Date: Tue, 23 May 2017 00:54:04 +0000

As mentioned in the provided link:

"Internet-Drafts have no formal status, and are subject to change or removal at any time."

> which explains that IESG consensus is required in order to remove an Internet Draft from the I-D Repository.

>From today's date till reaching this consensus for removal, these IDs shouldn't be discussed or published by the ietf on any meeting or any official event as the contents are not representing the ietf anymore after this date.

I'm waiting for the IESG response ... I hope they can make a decision soon.

"When an I-D is removed from the Public I-D Archive, a copy will be kept in a location accessible by the IETF Secretariat."

This of course doesn't gives the ietf the right of making any usage of these I-Ds after its removal.

-----Original Message-----
From: Alexa Morris [mailto:[email-masked]] 
Sent: Tuesday, May 23, 2017 2:27 AM
To: Khaled Omar
Cc: Ole J. Jacobsen; [email-masked]
Subject: Re: IPv10, KRP, and RRP IDs Removal.

Khaled,

Regards,
Alexa

----------

---

From: Michael StJohns <[email-masked]>
Date: Mon, 22 May 2017 21:05:05 -0400

> I'm the only author of the listed IDs and they are submitted individually, I made this removal request and these IDs must not be stored on the ietf database anymore and the ietf representation must…

Khaled - upon submitting these IDs you included the standard IETF 
Internet Draft Boiler plate for copyright and licensing.  By doing so, 
you granted the IETF process an unlimited, irrevocable paid up license 
to publish, translate and make derivative works  (and others)  of those 
submissions (see http://trustee.ietf.org/license-info, Trust Legal 
Provisions 5.0 at 2(b) and 3(a).

I am not a lawyer, but removal of the IDs from the ID repository is 
unlikely approaching zero to void the grant of rights you made.  Any 
legal action you take to force the removal is most likely to fail. Your 
specific language of  "If the ideas explained on these drafts will be 
used, discussed or published by the ietf, legal actions will be taken." 
is in conflict with your grant of rights.

  Hence Ole's comment.

Mike

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 23 May 2017 00:00:00 -0500

Dear Khaled,

Speaking as sergeant-at-arms,

You were recently placed under a temporary suspension of posting
rights to this list [1], a message that suggested you use that
time to read about the process of submitting and discussing drafts
at the IETF.  It seems that you have not taken advantage of the
opportunity to do so, as you persist in using an overly broad
recipient list when corresponding with the address used for draft
submission, and are attempting to block discussion of technical
issues on a list reserved for such discussions of technical issues.

With my authority as sergeant-at-arms under RFC 3004, I am forced to
request that the secretariat apply an additional restriction of your
posting rights for the period of 60 days, starting immediately.

If you do decide to bring new work to the IETF in the future, we
will expect that you and keep traffic on the IETF mailing
lists focused on discussion of technical issues and in the
appropriate venue(s).

-Ben Kaduk

[1] https://www.ietf.org/mail-archive/web/ietf/current/msg102743.html

---

From: Khaled Omar <[email-masked]>
Date: Tue, 23 May 2017 11:55:06 +0000

I don't care, once IDs will be removed, I will unsubscribe and will not submit anything here again.

-------- Original Message --------
Subject: Re: IPv10, KRP, and RRP IDs Removal.
From: Benjamin Kaduk
To: Khaled Omar ,[email-masked]
CC: [email-masked]

Dear Khaled,

-Ben Kaduk

---

From: [email-masked]
Date: Tue, 23 May 2017 08:43:14 -0400 (EDT)

note well... i lol'd.

On Tue, 23 May 2017, Khaled Omar wrote:

>       [1]
>       https://www.ietf.org/mail-archive/web/ietf/current/msg102743.html
>
>       > If the ideas explained on these drafts will be used, discussed
>       or published by the ietf, legal actions will be taken.
>       >
>       > Regards,
>       >
>       > Khaled Omar
> 
> 
>

---

From: Khaled Omar <[email-masked]>
Date: Tue, 23 May 2017 13:28:23 +0000

This is a serious official request, if it means nothing for you, stop replying.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, May 23, 2017 2:43 PM
To: Khaled Omar
Cc: Benjamin Kaduk; ietf
Subject: Re: IPv10, KRP, and RRP IDs Removal.

note well... i lol'd.

---

From: Khaled Omar <[email-masked]>
Date: Tue, 23 May 2017 13:45:32 +0000

-----Original Message-----
From: Khaled Omar 
Sent: Tuesday, May 23, 2017 3:45 PM
To: 'Paul Wouters'
Subject: RE: IPv10, KRP, and RRP IDs Removal.

> Your ideas will never spread if you don't know how to convey them to people. Blaming people to be unwilling to hear you, and telling others to be quiet if they are critical of your ideas only harms your ideas further.

Leave this only to me, I though the ietf can make a progress with any of these IDs, but they did not, so it is useless.

> I wish you luck contemplating new ideas and new ways of cooperation.

Thanks, there are many ideas and can be represented anywhere.

-----Original Message-----
From: Paul Wouters [mailto:[email-masked]]
Sent: Tuesday, May 23, 2017 3:36 PM
To: Khaled Omar
Subject: RE: IPv10, KRP, and RRP IDs Removal.

> This is a serious official request, if it means nothing for you, stop replying.

Your behaviour is wrong. It violates the rules of our community repeatedly. Which has triggered these kind of responses to you because you ignored many unofficial and a few official warnings.

Your ideas will never spread if you don't know how to convey them to people. Blaming people to be unwilling to hear you, and telling others to be quiet if they are critical of your ideas only harms your ideas further.

I wish you luck contemplating new ideas and new ways of cooperation.

Paul

---

From: Lloyd Wood <[email-masked]>
Date: Fri, 26 May 2017 01:02:28 +0000 (UTC)

https://www.ietf.org/mail-archive/web/ietf/current/threads.html#102743

I see in this rather contentious KRP thread that the IETF mail web archive has several 'Message not available' in place ofmissing messages.
What's happening there?
thanks Lloyd Wood [email-masked] http://about.me/lloydwood

---

From: Mark Andrews <[email-masked]>
Date: Fri, 26 May 2017 11:21:12 +1000

In message <[email-masked]>, Lloyd Wood writes:
> I see in this rather contentious KRP thread that the IETF mail web
> archive has several 'Message not available' in place ofmissing messages.
> What's happening there?

There were replies to private messages that were made public by
Khaled Omar.  The missing messages are those private messages, the
presence of which is visible in the References headers.

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Alexa Morris <[email-masked]>
Date: Fri, 26 May 2017 08:03:17 -0700

Khaled,

The IESG has reviewed your request and the drafts will not be removed. Their response directly below:

---------
Alexa,

The drafts should not be removed. The IESG has not identified any unusual circumstances (e.g., mistaken claims of authorship or allegations of draft content violating the law) that warrant removal of these drafts.

Regards,
The IESG

--------

----------