Subject: Revamp of the www.ietf.org website - next steps

From: Russ Housley <[email-masked]>
Date: Fri, 4 Aug 2017 11:57:32 -0400

Many thanks to everyone who took time to review  the beta.ietf.org website and provide comments. Based on feedback received, there seem to be a few items requiring attention before moving the revamped public-facing website to production:

A. Provide a landing page dedicated to current IETF participants

That page will include links to:
 - items on the left-side at www.ietf.org (or a subset thereof)
 - information about the next IETF meeting 
 - links to functions at datatracker.ietf.org 

Ideally this would also be:
 - viewable in a single screen on a desktop/laptop display
 -  reachable via a short, memorable URL without images

A draft is currently posted at https://beta.ietf.org/links/

This page can be updated further based on input from the community. There were also some suggestions received that revisions to datatracker.ietf.org might meet this need. While that is out of scope for this project, suggestions have been noted by the tools team.  If you frequently use something that is missing, please let us know.

B. Ensure WCAG 2.0 compliance

This is a requirement of the SOW (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf) and we are working with the website developer to ensure it is implemented. The baseline goal is to improve upon the status of the current www.ietf.org site. Furthermore, improving accessibility will continue to be an area of focus for the revamped website.

C. Conduct review with other key audiences, especially potential participants and non-participants

Based on the project SOW and the results of initial research (https://iaoc.ietf.org/documents/Torchbox_ETFUserresearch.pdf), additional interviews with members of the key audiences will be conducted to gather input. The results of those interviews will be incorporated into the project via issues noted at: https://github.com/ietf/www.ietf.org/issues  

D. Improve data use and load times

Load time and data usage was noted as being higher than the current www.ietf.org site. The expectation is that load times will improve as the beta site moves to production and is deployed on the CDN used by www.ietf.org. In addition, content elements such as images will be adjusted to improve performance. In particular, some of the potential participants and non-participants reviewers will be in locations with less robust connectivity and their input on this aspect of the revamped site will be sought out. This is an aspect called out in the SOW and will have ongoing attention.

Over the next few weeks, the project team will be working through these and some other issues, such as filling out content and moving to the the most current version of the open source Wagtail Content Management System. There will be ongoing efforts to improve the revamped site, so your ongoing input is encouraged. Feedback can be sent to [email-masked] or issues can be raised at:

   https://github.com/ietf/www.ietf.org/issues

Thanks again to all those who have provided input. I expect to be in touch again as we move the revamped site to production.

Sincerely,
 Russ Housley
 IETF Website Revamp Project Manager

---

From: Tim Chown <[email-masked]>
Date: Fri, 4 Aug 2017 17:34:45 +0100

Hi,

> On 4 Aug 2017, at 16:57, Russ Housley <[email-masked]> wrote:
> 
> 

Having a direct and short URL to the ‘participants’ page’ will be welcome.

But as it stands, the beta links page is difficult to parse. It would be easier to parse were it laid out more like this style - https://www.ietf.org/wg/chairs-page.html.

> This page can be updated further based on input from the community. There were also some suggestions received that revisions to datatracker.ietf.org might meet this need. While that is out of scope…

The main site and the datatracker site take different perspective on certain (important) areas, such as past and next meeting info. Both are useful.  Witness https://www.ietf.org/meeting/100/index.html and https://datatracker.ietf.org/meeting/upcoming.

I’m expecting with the revamp that I would rarely visit www.ietf.org, rather I would visit the new ‘links’ URL and the datatracker, where now I visit www.ietf.org and the datatracker.  I would point people interested in finding out more about the IETF to www.ietf.org.

I’m very happy with the datatracker site.  New features like support for managing and submitting draft reviews are really nice.

> This is a requirement of the SOW (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf) and we are working with the website developer to ensure it is implemented. The baseline goal i…

As someone with contrast issues, I don’t think https://beta.ietf.org/links/ would be compliant; it’s light blue on light grey.  There’s no need for the text to be that light, or there to be a background ‘colour’.

Thanks,
Tim

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 5 Aug 2017 08:48:51 +1200

Russ,
On 05/08/2017 03:57, Russ Housley wrote:
... 
> A draft is currently posted at https://beta.ietf.org/links/

Thanks for this. A few comments:

1. I agree with Tim that the visual style isn't ideal. There isn't really enough
contrast. I hope the current fashion for pale print over a pale background will
soon go away. (This applies to the whole beta site, of course. Needs to be legible
in direct sunlight :-)

2. A few bits of content that I use fairly often are missing:

Under Internet-Drafts: Guidelines | Checklist
Contact the IETF (important things like [email-masked])

3. There's a bar at the bottom with "RFC Editor IANA IAB" etc.
That's fine except it's so far down that I completely missed it
and was most of the way through typing a complaint that it wasn't there
until I happened to find it.

4. The links on that bar to "Secretariat" and "ISOC" seem to be advertising.
I think they need to go first to little "About" pages that explain the
roles of AMS and ISOC w.r.t. the IETF, then the links to AMS and ISOC.

Regards
     Brian

---

From: "Scott O. Bradner" <[email-masked]>
Date: Fri, 4 Aug 2017 17:00:20 -0400

I trust that as many of the existing URLs as possible will continue to work
(e.g., https://datatracker.ietf.org/ipr/search/)

on the links page - it would be good to include the contact section

Scott

> On Aug 4, 2017, at 11:57 AM, Russ Housley <[email-masked]> wrote:
> 
>

---

From: Pat Thaler <[email-masked]>
Date: Fri, 4 Aug 2017 14:27:47 -0700

I also prefer the style on: https://www.ietf.org/wg/chairs-page.html. for a
links page

The low contrast tone-on-tone is hard to read and the two column
arrangement with just one to three links per column line makes it easier to
select the link.

On Fri, Aug 4, 2017 at 9:34 AM, Tim Chown <[email-masked]> wrote:

> > Many thanks to everyone who took time to review  the beta.ietf.org
> website and provide comments. Based on feedback received, there seem to be
> a few items requiring attention before moving the revamped public-facing
> website to production:
> >
> But as it stands, the beta links page is difficult to parse. It would be
> easier to parse were it laid out more like this style -
> https://www.ietf.org/wg/chairs-page.html.
>
> > This page can be updated further based on input from the community.
> There were also some suggestions received that revisions to
> datatracker.ietf.org might meet this need. While that is out of scope for
> this project, suggestions have been noted by the tools team.  If you
> frequently use something that is missing, please let us know.
>
> The main site and the datatracker site take different perspective on
> certain (important) areas, such as past and next meeting info. Both are
> useful.  Witness https://www.ietf.org/meeting/100/index.html and
> https://datatracker.ietf.org/meeting/upcoming.
>
> I’m expecting with the revamp that I would rarely visit www.ietf.org,
> rather I would visit the new ‘links’ URL and the datatracker, where now I
> visit www.ietf.org and the datatracker.  I would point people interested
> in finding out more about the IETF to www.ietf.org.
>
> I’m very happy with the datatracker site.  New features like support for
> managing and submitting draft reviews are really nice.
>
> > This is a requirement of the SOW (https://iaoc.ietf.org/
> documents/IETF-Website-SOW-20140604-Final.pdf) and we are working with
> the website developer to ensure it is implemented. The baseline goal is to
> improve upon the status of the current www.ietf.org site. Furthermore,
> improving accessibility will continue to be an area of focus for the
> revamped website.
>
> As someone with contrast issues, I don’t think
> https://beta.ietf.org/links/ would be compliant; it’s light blue on light
> grey.  There’s no need for the text to be that light, or there to be a
> background ‘colour’.
>
> Thanks,
> Tim
>
> > Based on the project SOW and the results of initial research (
> https://iaoc.ietf.org/documents/Torchbox_ETFUserresearch.pdf), additional
> interviews with members of the key audiences will be conducted to gather
> input. The results of those interviews will be incorporated into the
> project via issues noted at: https://github.com/ietf/www.ietf.org/issues
> >
> > Load time and data usage was noted as being higher than the current
> www.ietf.org site. The expectation is that load times will improve as the
> beta site moves to production and is deployed on the CDN used by
> www.ietf.org. In addition, content elements such as images will be
> adjusted to improve performance. In particular, some of the potential
> participants and non-participants reviewers will be in locations with less
> robust connectivity and their input on this aspect of the revamped site
> will be sought out. This is an aspect called out in the SOW and will have
> ongoing attention.
> >
> > Over the next few weeks, the project team will be working through these
> and some other issues, such as filling out content and moving to the the
> most current version of the open source Wagtail Content Management System.
> There will be ongoing efforts to improve the revamped site, so your ongoing
> input is encouraged. Feedback can be sent to [email-masked] or issues
> can be raised at:
> >
> > Thanks again to all those who have provided input. I expect to be in
> touch again as we move the revamped site to production.
> >
> > Sincerely,
> > Russ Housley

---

From: Stewart Bryant <[email-masked]>
Date: Sat, 5 Aug 2017 11:57:10 +0100

+1

Stewart

On 04/08/2017 22:27, Pat Thaler wrote:
> I also prefer the style on: https://www.ietf.org/wg/chairs-page.html 
> <https://www.ietf.org/wg/chairs-page.html>. for a links page
>
> arrangement with just one to three links per column line makes it 
> easier to select the link.
>
> On Fri, Aug 4, 2017 at 9:34 AM, Tim Chown <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     > On 4 Aug 2017, at 16:57, Russ Housley <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     >
>     > Many thanks to everyone who took time to review the
>     beta.ietf.org <http://beta.ietf.org> website and provide comments.
>     Based on feedback received, there seem to be a few items requiring
>     attention before moving the revamped public-facing website to
>     production:
>     >
>     > - items on the left-side at www.ietf.org <http://www.ietf.org>
>     (or a subset thereof)
>     <http://datatracker.ietf.org>
>     >
>     But as it stands, the beta links page is difficult to parse. It
>     would be easier to parse were it laid out more like this style -
>     https://www.ietf.org/wg/chairs-page.html
>     <https://www.ietf.org/wg/chairs-page.html>.
>
>     > This page can be updated further based on input from the
>     community. There were also some suggestions received that
>     revisions to datatracker.ietf.org <http://datatracker.ietf.org>
>     might meet this need. While that is out of scope for this project,
>     suggestions have been noted by the tools team.  If you frequently
>     use something that is missing, please let us know.
>
>     The main site and the datatracker site take different perspective
>     on certain (important) areas, such as past and next meeting info.
>     Both are useful.  Witness
>     https://www.ietf.org/meeting/100/index.html
>     <https://www.ietf.org/meeting/100/index.html> and
>     https://datatracker.ietf.org/meeting/upcoming
>     <https://datatracker.ietf.org/meeting/upcoming>.
>
>     I’m expecting with the revamp that I would rarely visit
>     www.ietf.org <http://www.ietf.org>, rather I would visit the new
>     ‘links’ URL and the datatracker, where now I visit www.ietf.org
>     <http://www.ietf.org> and the datatracker.  I would point people
>     interested in finding out more about the IETF to www.ietf.org
>     <http://www.ietf.org>.
>
>     I’m very happy with the datatracker site.  New features like
>     support for managing and submitting draft reviews are really nice.
>
>     > This is a requirement of the SOW
>     (https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf
>     <https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf>)
>     and we are working with the website developer to ensure it is
>     implemented. The baseline goal is to improve upon the status of
>     the current www.ietf.org <http://www.ietf.org> site. Furthermore,
>     improving accessibility will continue to be an area of focus for
>     the revamped website.
>
>     https://beta.ietf.org/links/ would be compliant; it’s light blue
>     on light grey. There’s no need for the text to be that light, or
>     there to be a background ‘colour’.
>
>     Thanks,
>     Tim
>
>     > Based on the project SOW and the results of initial research
>     (https://iaoc.ietf.org/documents/Torchbox_ETFUserresearch.pdf
>     <https://iaoc.ietf.org/documents/Torchbox_ETFUserresearch.pdf>),
>     additional interviews with members of the key audiences will be
>     conducted to gather input. The results of those interviews will be
>     incorporated into the project via issues noted at:
>     <https://github.com/ietf/www.ietf.org/issues>
>     >
>     > Load time and data usage was noted as being higher than the
>     current www.ietf.org <http://www.ietf.org> site. The expectation
>     is that load times will improve as the beta site moves to
>     production and is deployed on the CDN used by www.ietf.org
>     <http://www.ietf.org>. In addition, content elements such as
>     images will be adjusted to improve performance. In particular,
>     some of the potential participants and non-participants reviewers
>     will be in locations with less robust connectivity and their input
>     on this aspect of the revamped site will be sought out. This is an
>     aspect called out in the SOW and will have ongoing attention.
>     >
>     > Over the next few weeks, the project team will be working
>     through these and some other issues, such as filling out content
>     and moving to the the most current version of the open source
>     Wagtail Content Management System. There will be ongoing efforts
>     to improve the revamped site, so your ongoing input is encouraged.
>     Feedback can be sent to [email-masked]
>     <mailto:[email-masked]> or issues can be raised at:
>     >
>     <https://github.com/ietf/www.ietf.org/issues>
>     >
>     > Thanks again to all those who have provided input. I expect to
>     be in touch again as we move the revamped site to production.
>     >
>     > Sincerely,
>     > Russ Housley

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sat, 5 Aug 2017 12:49:17 -0400

I also agree. Just because you CAN update web pages to make them looks more
“modern” or “stylish” doesn’t mean that you SHOULD …

Cheers,
Andy

On Sat, Aug 5, 2017 at 6:57 AM, Stewart Bryant <[email-masked]>
wrote:

> I also prefer the style on: https://www.ietf.org/wg/chairs-page.html. for
> a links page
>
>> datatracker.ietf.org might meet this need. While that is out of scope
>> for this project, suggestions have been noted by the tools team.  If you
>> > This is a requirement of the SOW (https://iaoc.ietf.org/documen
>> ts/IETF-Website-SOW-20140604-Final.pdf) and we are working with the
>> website developer to ensure it is implemented. The baseline goal is to
>> https://beta.ietf.org/links/ would be compliant; it’s light blue on
>> light grey.  There’s no need for the text to be that light, or there to be
>> a background ‘colour’.
>>
>> Thanks,
>> Tim
>>
>> https://iaoc.ietf.org/documents/Torchbox_ETFUserresearch.pdf),
>> additional interviews with members of the key audiences will be conducted
>> to gather input. The results of those interviews will be incorporated into
>> the project via issues noted at: https://github.com/ietf/www.ie
>> tf.org/issues
>> >
>> www.ietf.org site. The expectation is that load times will improve as
>> the beta site moves to production and is deployed on the CDN used by
>> input is encouraged. Feedback can be sent to [email-masked] or
>> issues can be raised at:
>> >