Subject: Genart last call review of draft-ietf-tsvwg-sctp-ndata-12

From: Stewart Bryant <[email-masked]>
Date: Mon, 14 Aug 2017 13:02:22 -0700

Reviewer: Stewart Bryant
Review result: Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-tsvwg-sctp-ndata-12
Reviewer: Stewart Bryant
Review Date: 2017-08-14
IETF LC End Date: 2017-08-25
IESG Telechat date: Not scheduled for a telechat

Summary: This is a well written draft and is ready for publication.

Major issues: None

Minor issues: None

Nits/editorial comments:

You repeat the text:

"A message is considered in flight, if at least  on of its I-DATA chunks is not
acknowledged in a non-renegable way"  in two consecutive sections, maybe a
common definition could be used.

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 25 Aug 2017 12:53:52 +0200

> On 14. Aug 2017, at 22:02, Stewart Bryant <[email-masked]> wrote:
> 
> Reviewer: Stewart Bryant
> Review result: Ready
> 
Hi Stewart,

thanks for your review. See my comment in-line.

Best regards
Michael
> common definition could be used.
The first text covers "Message in flight", the second covers "Fragment in flight".
What is duplicated is the text (i.e. acknowledged by the cumulative TSN Ack) for
explaining "acknowledged in a non-renegable way". Giving the explanation only once
improves readability, I guess.

Best regards
Michael

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 25 Aug 2017 12:28:24 +0100

Hi Michael

Sorry I misread the text.

The text is fine as it is, and I leave it to you to see if there is an 
improvement with a common definition.

I am correcting the review.

- Stewart

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 25 Aug 2017 13:50:31 +0200

> On 25. Aug 2017, at 13:28, Stewart Bryant <[email-masked]> wrote:
> 
> Hi Michael
> 
> The text is fine as it is, and I leave it to you to see if there is an improvement with a common definition.
I think the change
https://github.com/sctplab/sctp-idata/commit/768dac9acbeff654ecea782bf682392fad4d4709
makes the text more readable.
> I am correcting the review.
Thanks for the quick feedback!

Best regards
Michael