Subject: Re: normative references to IANA registries

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Aug 2017 09:32:11 +0200

On Aug 1, 2017, at 02:45, Michael Richardson <[email-masked]> wrote:
> 
> 
> Carsten Bormann <[email-masked]> wrote:
>>> So I wonder out loud: shouldn't all of the IANA registries have clear
>>> reference files that could be normatively referenced?
> 
>> Try referencing, say, {{!IANA.cbor-tags}} — it just works :-)
> 
> wow. I'm sure it's documented in some place so obvious I can't see it.

https://xml2rfc.tools.ietf.org/ is the place that talks about bibxml8 references.
kramdown-rfc is just mapping all the IANA.* references to bibxml8, as in

https://xml2rfc.tools.ietf.org/public/rfc/bibxml8/reference.IANA.cbor-tags.xml

> Is the "cbor-tags" part the last part of the IANA registry URL?

Apparently.

bibxml8/index.cgi:

    if ($IANAref =~ m(^/?reference.IANA[.]([^/]+)[.](xml|kramdown)$)) {
	my $IANAref = $1;
…
	    my $a = get("http://www.iana.org/assignments/$IANAref/“);

kramdown-rfc is, somewhat ironically maybe, using the xml version then :-) (getting the kramdown [really: YAML] version isn't even implemented at xml2rfc.ietf.org, but there is no need to).

Grüße, Carsten

---

From: Alia Atlas <[email-masked]>
Date: Tue, 1 Aug 2017 09:00:47 -0400

Carsten,

On Tue, Aug 1, 2017 at 3:32 AM, Carsten Bormann <[email-masked]> wrote:

> kramdown-rfc is, somewhat ironically maybe, using the xml version then :-)
> (getting the kramdown [really: YAML] version isn't even implemented at
> xml2rfc.ietf.org, but there is no need to).
>

It would be very helpful to  have the kramdown version at xml2rfc.ietf.org.
Simply going to github (https://github.com/cabo/kramdown-rfc2629)  to
download and run the kramdown converter to xml doesn't work trivially on a
Windows machine.  I go to
http://xml2rfc.tools.ietf.org/experimental.html#kramdown to run it.

Since this is the only time that I use kramdown (or any markdown language),
it would be quite helpful to
also have a pointer to the syntax to use.  I end up googling and looking at
random kramdown documentation
and hoping.  The error-checking is also a bit frustrating - I had an extra
space in front of a - for separating
the authors and the document failed to convert at all with no error.  Not
being familiar enough with kramdown,
it was completely non-obvious.

Regardless of the above digression, kramdown-rfc is really awesome and
makes it much easier to write drafts!
I've converted over to doing so.  I really think that a bit more visibility
- including on the xml2rfc.ietf.org page - with a pointer or two - would
speed interest and adoption.

Thank you for your work on this!
Alia

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Tue, 1 Aug 2017 19:27:37 +0000

Alia,

> I really think that a bit more visibility - including on the xml2rfc.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=V8I5iVb8w2bZHOeCYV_CvuSlB2p2_f4ggz_rXpod4Uo&e=> page - with a pointer or two - would speed interest and adoption.

Care to contribute text? (Gosh, almost like working on an I-D. :-) )

                Tony Hansen

From: ietf <[email-masked]> on behalf of Alia Atlas <[email-masked]>
Date: Tuesday, August 1, 2017 at 9:01 AM
To: Carsten Bormann <[email-masked]>
Cc: Michael Richardson <[email-masked]>, IETF Discussion Mailing List <[email-masked]>
Subject: Re: normative references to IANA registries

Carsten,

On Tue, Aug 1, 2017 at 3:32 AM, Carsten Bormann <[email-masked]<mailto:[email-masked]>> wrote:
On Aug 1, 2017, at 02:45, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:
>
>
> Carsten Bormann <[email-masked]<mailto:[email-masked]>> wrote:

https://xml2rfc.tools.ietf.org/<https://urldefense.proofpoint.com/v2/url?u=https-3A__xml2rfc.tools.ietf.org_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=tZ2bQACgkgw1mhoZNOwNrxV7yQr3goPfpjni_ZMvbYg&e=> is the place that talks about bibxml8 references.
kramdown-rfc is just mapping all the IANA.* references to bibxml8, as in

https://xml2rfc.tools.ietf.org/public/rfc/bibxml8/reference.IANA.cbor-tags.xml<https://urldefense.proofpoint.com/v2/url?u=https-3A__xml2rfc.tools.ietf.org_public_rfc_bibxml8_reference.IANA.cbor-2Dtags.xml&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=RjSeuRKPVOXuXPDhcEPx7kZCfq6aoOtDA9T5l4CPIpc&e=>

Apparently.

bibxml8/index.cgi:

    if ($IANAref =~ m(^/?reference.IANA[.]([^/]+)[.](xml|kramdown)$)) {
        my $IANAref = $1;
…
            my $a = get("http://www.iana.org/assignments/$IANAref/<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.iana.org_assignments_-24IANAref_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=yyrIWYIS6O1dAeaAvV-MbRo2c0BeHdk0tSg5JUJ4-sE&e=>“);

kramdown-rfc is, somewhat ironically maybe, using the xml version then :-) (getting the kramdown [really: YAML] version isn't even implemented at xml2rfc.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=V8I5iVb8w2bZHOeCYV_CvuSlB2p2_f4ggz_rXpod4Uo&e=>, but there is no need to).

It would be very helpful to  have the kramdown version at xml2rfc.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=V8I5iVb8w2bZHOeCYV_CvuSlB2p2_f4ggz_rXpod4Uo&e=>.
Simply going to github (https://github.com/cabo/kramdown-rfc2629<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_cabo_kramdown-2Drfc2629&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=AAYe_rSSnio9T9T0HkiO0XV_DL9kxjJ2rDLyyu0bjZw&e=>)  to download and run the kramdown converter to xml doesn't work trivially on a Windows machine.  I go to http://xml2rfc.tools.ietf.org/experimental.html#kramdown<https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.tools.ietf.org_experimental.html-23kramdown&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=K4sCwhG_wwTF27IKvxRuaOLywos4xmY9yQZg7wLYY5U&e=> to run it.

Since this is the only time that I use kramdown (or any markdown language), it would be quite helpful to
also have a pointer to the syntax to use.  I end up googling and looking at random kramdown documentation
and hoping.  The error-checking is also a bit frustrating - I had an extra space in front of a - for separating
the authors and the document failed to convert at all with no error.  Not being familiar enough with kramdown,
it was completely non-obvious.

Regardless of the above digression, kramdown-rfc is really awesome and makes it much easier to write drafts!
I've converted over to doing so.  I really think that a bit more visibility - including on the xml2rfc.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=V8I5iVb8w2bZHOeCYV_CvuSlB2p2_f4ggz_rXpod4Uo&e=> page - with a pointer or two - would speed interest and adoption.

---

From: Alia Atlas <[email-masked]>
Date: Tue, 1 Aug 2017 15:31:22 -0400

Tony,

On Tue, Aug 1, 2017 at 3:27 PM, HANSEN, TONY L <[email-masked]> wrote:

> Alia,
>
>
>
> > I really think that a bit more visibility - including on the
> xml2rfc.ietf.org
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=V8I5iVb8w2bZHOeCYV_CvuSlB2p2_f4ggz_rXpod4Uo&e=>
> page - with a pointer or two - would speed interest and adoption.
>
>
>
Sure - but as part of a group.  I can't tell folks - look here for details
on markdown without knowing it is what is implemented.  It'd be nice to be
able to see and retrieve markdown versions of drafts - if available - but
that's a datatracker/tools team effort.
I put some energy into encouraging at least a wiki with best practices,
including for this, a couple years ago but my arm-twisting foo wasn't
strong/good enough then.

Regards,
Alia

>
>                 Tony Hansen
>
>
>
> *From: *ietf <[email-masked]> on behalf of Alia Atlas <
> [email-masked]>
> *Date: *Tuesday, August 1, 2017 at 9:01 AM
> *To: *Carsten Bormann <[email-masked]>
> *Cc: *Michael Richardson <[email-masked]>, IETF Discussion Mailing
> List <[email-masked]>
> *Subject: *Re: normative references to IANA registries
>
>
>
> Carsten,
>
>
>
> https://xml2rfc.tools.ietf.org/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__xml2rfc.tools.ietf.org_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=tZ2bQACgkgw1mhoZNOwNrxV7yQr3goPfpjni_ZMvbYg&e=>
> is the place that talks about bibxml8 references.
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__xml2rfc.tools.ietf.org_public_rfc_bibxml8_reference.IANA.cbor-2Dtags.xml&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=RjSeuRKPVOXuXPDhcEPx7kZCfq6aoOtDA9T5l4CPIpc&e=>
>
>             my $a = get("http://www.iana.org/assignments/$IANAref/
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.iana.org_assignments_-24IANAref_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=yyrIWYIS6O1dAeaAvV-MbRo2c0BeHdk0tSg5JUJ4-sE&e=>
> “);
>
> xml2rfc.ietf.org
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=V8I5iVb8w2bZHOeCYV_CvuSlB2p2_f4ggz_rXpod4Uo&e=>,
> but there is no need to).
>
>
>
> It would be very helpful to  have the kramdown version at xml2rfc.ietf.org
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=V8I5iVb8w2bZHOeCYV_CvuSlB2p2_f4ggz_rXpod4Uo&e=>
> .
>
> Simply going to github (https://github.com/cabo/kramdown-rfc2629
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_cabo_kramdown-2Drfc2629&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=AAYe_rSSnio9T9T0HkiO0XV_DL9kxjJ2rDLyyu0bjZw&e=>)
> to download and run the kramdown converter to xml doesn't work trivially on
> a Windows machine.  I go to http://xml2rfc.tools.ietf.org/
> experimental.html#kramdown
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.tools.ietf.org_experimental.html-23kramdown&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=K4sCwhG_wwTF27IKvxRuaOLywos4xmY9yQZg7wLYY5U&e=>
> to run it.
>
>
>
> I've converted over to doing so.  I really think that a bit more
> visibility - including on the xml2rfc.ietf.org
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__xml2rfc.ietf.org&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=UaIfhDC455biB86xSLn090rOYdsuhuDNxQbRjTasgl0&s=V8I5iVb8w2bZHOeCYV_CvuSlB2p2_f4ggz_rXpod4Uo&e=>
> page - with a pointer or two - would speed interest and adoption.
>
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Aug 2017 21:32:40 +0200

> Care to contribute text? (Gosh, almost like working on an I-D. :-) )

I have this project of coming up with an I-D describing kramdown-rfc.
I even have a TOC and a collaborator lined up.
Now just for some time to actually do the work...
Somehow the normative stuff always gets precedence.

Grüße, Carsten

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 2 Aug 2017 05:48:27 +1000

That would be great -- I'd be happy to help review, make pull requests, etc.

kramdown-rfc is magical.

> On 2 Aug 2017, at 5:32 am, Carsten Bormann <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Gmail <[email-masked]>
Date: Wed, 2 Aug 2017 00:01:12 +0100

Sent from my iPad

> On 1 Aug 2017, at 20:31, Alia Atlas <[email-masked]> wrote:
> 
>   It'd be nice to be able to see and retrieve markdown versions of drafts - if available - but that's a datatracker/tools team effort.

Yes, please, please, please can we have that, or better an opaque type so that we can save the original in the format of the day.

-Stewart

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 2 Aug 2017 01:12:58 +0000

Alternatively, can you be more specific on what types of information you’re looking for?

For example, give me the Q part of an FAQ.

                Tony

From: Alia Atlas <[email-masked]>
Date: Tuesday, August 1, 2017 at 3:31 PM
To: "HANSEN, TONY L" <[email-masked]>
Cc: IETF Discussion Mailing List <[email-masked]>, Carsten Bormann <[email-masked]>
Subject: Re: normative references to IANA registries

Tony,

On Tue, Aug 1, 2017 at 3:27 PM, HANSEN, TONY L <[email-masked]<mailto:[email-masked]>> wrote:
Alia,

Sure - but as part of a group.  I can't tell folks - look here for details on markdown without knowing it is what is implemented.  It'd be nice to be able to see and retrieve markdown versions of drafts - if available - but that's a datatracker/tools team effort.
I put some energy into encouraging at least a wiki with best practices, including for this, a couple years ago but my arm-twisting foo wasn't strong/good enough then.

Regards,
Alia

                Tony Hansen

From: ietf <[email-masked]<mailto:[email-masked]>> on behalf of Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, August 1, 2017 at 9:01 AM
To: Carsten Bormann <[email-masked]<mailto:[email-masked]>>
Cc: Michael Richardson <[email-masked]<mailto:[email-masked]>>, IETF Discussion Mailing List <[email-masked]<mailto:[email-masked]>>
Subject: Re: normative references to IANA registries

Carsten,

Apparently.

bibxml8/index.cgi: