Subject: Re: [homenet] Last Call: <draft-ietf-homenet-dot-12.txt> (Special Use Domain 'home.arpa.') to Proposed Standard

From: S Moonesamy <[email-masked]>
Date: Wed, 16 Aug 2017 10:10:32 -0700

Hello,
At 07:16 AM 8/11/2017, The IESG wrote:
>The IESG has received a request from the Home Networking WG (homenet) to
>consider the following document: - 'Special Use Domain 'home.arpa.''
>   <draft-ietf-homenet-dot-12.txt> as Proposed Standard
>
>The IESG plans to make a decision in the next few weeks, and solicits final
>comments on this action. Please send substantive comments to the
>[email-masked] mailing lists by 2017-08-25. Exceptionally, comments may be

I took a quick look at draft-ietf-homenet-dot-12.

In Section 4:

   "So for example a query for the NS record for 'home.arpa.'  MUST
    NOT result in that query being forwarded to an upstream cache nor
    to the authoritative DNS server for '.arpa.'."

As the sentence provides an example, the usage of the RFC 2119 
keyword is incorrect.  The "MUST result in whatever queries are 
necessary" seems like specifying by example.

Regards,
S. Moonesamy

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Aug 2017 13:47:48 -0400

El 16 ag 2017, a les 13:10, S Moonesamy <[email-masked]> va escriure:
> As the sentence provides an example, the usage of the RFC 2119 keyword is incorrect.  The "MUST result in whatever queries are necessary" seems like specifying by example.

I believe the text is correct.   A query for the NS record is required not to be forwarded by recursive resolvers.   There is actually a mistake in the previous paragraph, though—"caching resolvers" should be recursive resolvers.

Anyway, can you explain why you think the text is wrong?   Did it not make clear that queries were not to be forwarded, or is there something I'm missing where it contradicts itself?

---

From: S Moonesamy <[email-masked]>
Date: Wed, 16 Aug 2017 11:06:34 -0700

Hi Ted,
At 10:47 AM 8/16/2017, Ted Lemon wrote:
>I believe the text is correct.   A query for the 
>NS record is required not to be forwarded by 
>recursive resolvers.   There is actually a 
>mistake in the previous paragraph, 
>though—"cacching resolvers" should be recursive resolvers.
>
>Anyway, can you explain why you think the text 
>is wrong?   Did it not make clear that queries 
>were not to be forwarded, or is there something 
>I'm missing where it contradicts itself?

In Section 4, second paragraph in Item 4, there 
is a requirement not to forward with one 
exception, "a query for a DS record when the DO 
bit".  The next paragraph then goes on to provide 
an example of a query and states the requirement 
again.  It is not about whether the text does not 
make it clear or that there is a contradiction; 
it would be better to drop the "MUST" in that 
(third) paragraph as it is a restatement of the 
requirement in the second paragraph.

Regards,
S. Moonesamy

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 Aug 2017 14:20:03 -0400

El 16 ag 2017, a les 14:06, S Moonesamy <[email-masked]> va escriure:
> In Section 4, second paragraph in Item 4, there is a requirement not to forward with one exception, "a query for a DS record when the DO bit".  The next paragraph then goes on to provide an example of a query and states the requirement again.  It is not about whether the text does not make it clear or that there is a contradiction; it would be better to drop the "MUST" in that (third) paragraph as it is a restatement of the requirement in the second paragraph.

Ah.   While I have sympathy for the motivation to be parsimonious with normative language, I don't see a clean way to fix this.   If the ADs consider it important, perhaps they will suggest text.