Subject: Re: [ippm] I-D Action: draft-ietf-ippm-twamp-yang-09.txt

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 23 Apr 2018 09:54:23 -0700

Tom/Pete,

We believe this version of the draft addresses your comments.

Thanks.

> On Apr 23, 2018, at 9:48 AM, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IP Performance Measurement WG of the IETF.
> 
>        Title           : Two-Way Active Measurement Protocol (TWAMP) Data Model
>        Authors         : Ruth Civil
>                          Al Morton
>                          Reshad Rahman
>                          Mahesh Jethanandani
>                          Kostas Pentikousis
> 	Filename        : draft-ietf-ippm-twamp-yang-09.txt
> 	Pages           : 68
> 	Date            : 2018-04-23
> 
> Abstract:
>   This document specifies a data model for client and server
>   implementations of the Two-Way Active Measurement Protocol (TWAMP).
>   The document defines the TWAMP data model through Unified Modeling
>   Language (UML) class diagrams and formally specifies it using YANG.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-ippm-twamp-yang-09
> https://datatracker.ietf.org/doc/html/draft-ietf-ippm-twamp-yang-09
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-twamp-yang-09
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

Mahesh Jethanandani
[email-masked]

---

From: Pete Resnick <[email-masked]>
Date: Mon, 23 Apr 2018 12:05:36 -0500

Thanks Mahesh. Looks great.

pr

---

From: "tom p." <[email-masked]>
Date: Tue, 24 Apr 2018 11:21:09 +0100

Mahesh

Almost

You ask the RFC Editor to
"replace  reference to RFC XXXX, and draft-ietf-port-twamp-test "

I think that you mean
draft-ietf-ippm-port-twamp-test

I said that I was still thinking about secret-key and still am; I am
unsure what secret-key should look like.

There are two rival models for keystore.  RTGWG have produced RFC8177
which has

choice key-string-style {
...
     case keystring {
..
                   type string;
                   description  "Key string in ASCII format.";

     case hexadecimal {
..
                   type yang:hex-string;
                   description "Key in hexadecimal string format.

The NETCONF WG have produced a number of I-D, such as
draft-ietf-netconf-keystore, all of which have keys of type binary.

A YANG string, as this I-D currently references, limits the character
set of string which I do not think works without a binary or hex-string
alternative.

I note that
 draft-mirsky-ippm-twamp-light-yang
went for a keychain-ref while

draft-ietf-ospf-yang
has
 case auth-trailer-key {
...
               type string;
               description  "Key string in ASCII format.";
 without a hexadecimal alterntive which would seem to have limited
entropy.

Perhaps binary, as you had it originally, is best but I do think that
the IETF is confused, or conflicted, here.

Tom Petch

----- Original Message -----
From: "Mahesh Jethanandani" <[email-masked]>
To: "tom p." <[email-masked]>; "Pete Resnick"
<[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Monday, April 23, 2018 5:54 PM

Tom/Pete,

Thanks.

Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Sun, 29 Apr 2018 12:37:44 -0700

> On Apr 24, 2018, at 3:21 AM, tom p. <[email-masked]> wrote:
> 
> Mahesh
> 
> Almost
> 

Fixed.

> the IETF is confused, or conflicted, here.

I am reverting it back to binary.

Mahesh Jethanandani
[email-masked]