Subject: RE: Rtgdir last call review of draft-ietf-detnet-problem-statement-06

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 1 Oct 2018 07:26:36 +0000

Hello Ines

Many thanks for your review. 

I see this recurring point of adding references to the other detnet documents; I'm happy to follow this advice, noting though that these are forward pointers since the problem statement comes first. 

Please see below:
 
> I believe the draft is technically good. This document is well written and clear to
> understand.
> 
> The document describes the needs in various industries to establish multi-hop
> paths for characterized flows with deterministic properties.
> 
> This document is basically ready for publication, but I have some minor
> questions that should be considered prior to being submitted to the IESG.
> 
> Comments:
> 
> 1)- In section 1 you mention: "....a new model must be proposed to integrate
> determinism in IT technology..." Do you think it is useful to mention draft-ietf-
> detnet-architecture as a starting point for the model?
> 
[PT>] what about:
"
      Forward note: The <xref target='I-D.ietf-detnet-architecture'>
      DetNet Architecture</xref> is the document produced by the DetNet WG to 
      describe that model.
"

> 2)- In Section 1: "the model should not compromise the ability of a network to
> keep carrying the sorts of traffic that is already carried today in conjunction
> with new, more deterministic flows.", and in Section 2 "The goals of
> Deterministic Networking (DetNet) are .... and to support both these new
> applications, and existing packet network applications, over the same physical
> network." Those sentences seems to be related with Interoperability, but
> Interoperability is not explicitly mentioned in the document. Do you think that it
> should be?
[PT>] Can we add after the latter sentence:

"
In other words, a Deterministic Network is backwards compatible with - capable
of transporting - statistically multiplexed traffic while preserving the
properties of the accepted deterministic flows.
"

> 
> 3)- In Section 2: "Multiple methods to schedule, shape, limit, and otherwise
> control the transmission of critical packets at each hop through the network
> data plane;" Do you think that it would be good to add something like: "Detnet
> is working on IP Data Plane Encapsulation [ref.] and on MPLS Data Plane
> Encapsulation [ref]?"
[PT>] I'm not too inclined because this sentence is about a lot more than DP 
encoding, ad because this is really fast forwarding a lot.

> 
> 4)- In Section 2: "Robust defenses against misbehaving hosts, routers, or
> bridges,both in the data and control planes...." Do you think that it would be
> good to add here or in the security considerations section (maybe better) a
> reference to draft-ietf-detnet-security?
> 
[PT>] You're right, that fit in both places.

> Nits:
> 
> It would be nice to expand DetNet in Section 1, since it is the first time that it is
> mentioned.
> 
[PT>] done

Many Thanks, Ines : )

Pascal

---

From: Ines Robles <[email-masked]>
Date: Mon, 1 Oct 2018 15:05:07 +0300

Hi Pascal,

Thank you for your reply. I agree with your suggestions.

Cheers,

Ines.

On Mon, Oct 1, 2018 at 10:26 AM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> I see this recurring point of adding references to the other detnet
> documents; I'm happy to follow this advice, noting though that these are
> forward pointers since the problem statement comes first.
>
> Please see below:
>