Subject: Re: [Tzdist-bis] Opsdir last call review of draft-murchison-tzdist-tzif-14

From: Eliot Lear <[email-masked]>
Date: Mon, 1 Oct 2018 09:45:15 +0200

Hi there...

On 29.09.18 03:12, Qin Wu wrote:
> Hi, Paul:
> -----邮件原件-----
> 发件人: Paul Eggert [mailto:[email-masked]] 
> 发送时间: 2018年9月29日 1:50
> 收件人: Qin Wu; [email-masked]
> 抄送: [email-masked]; [email-masked]; Ken Murchison; [email-masked]
> 主题: Re: Opsdir last call review of draft-murchison-tzdist-tzif-14
>
> Qin Wu wrote:
>
>> [Qin]: I can understand 8-octets accommodate 1-octet record, but How does 8-octets data block accommodate 12-octet record, I can not understand.
> The draft does not say that data block sizes are multiples of 8 octets, and indeed they need not be multiples of 8 octets. Data blocks are merely concatenations of octets, with no padding or alignment. If a field requires only
> 1 octet, exactly 1 octet is appended to a data block. If it requires 8 octets, exactly 8 octets are appended to the data block. If it requires 12 octets, exactly 12 octets are appended to the data block. So it doesn't matter how many octets a field requires: whatever number that is, that's the number of octets that appear in the resulting data block.
>
> [Qin]:12 octets are appended into the same 8-octet data block? I assume 1000 octets can be appended into that 8-octet data block. It looks you are using some kind of compression algorithm.

Each data block is constructed in a way described by the header block. 
The header indicates the number of transitions, and the nature of those
transitions, as well as leap second information.  The block size will
vary based on the version being used (1, 2, or 3).

With this in mind, can you please restate your question.  We're not
following your concern.

Eliot

---

From: Qin Wu <[email-masked]>
Date: Tue, 2 Oct 2018 04:06:58 +0000

I concerns with the header length and data block size, the header size is 44 bytes, but author clarifies it is 32 bit length.
Header for 32 bit transitions, it clear indicate one header comprise multiple transitions, each transitions length may be different.
but author seems to believe header is just 32 bit, which make me confuse.
Anyway it is not a big issue.

-Qin
-----邮件原件-----
发件人: Eliot Lear [mailto:[email-masked]] 
发送时间: 2018年10月1日 15:45
收件人: Qin Wu <[email-masked]>; Paul Eggert <[email-masked]>; [email-masked]
抄送: [email-masked]; Ken Murchison <[email-masked]>; [email-masked]; [email-masked]
主题: Re: [Tzdist-bis] Opsdir last call review of draft-murchison-tzdist-tzif-14

Hi there...

On 29.09.18 03:12, Qin Wu wrote:
> The draft does not say that data block sizes are multiples of 8 
> octets, and indeed they need not be multiples of 8 octets. Data blocks 
> are merely concatenations of octets, with no padding or alignment. If 
> a field requires only

Each data block is constructed in a way described by the header block. The header indicates the number of transitions, and the nature of those transitions, as well as leap second information.  The block size will vary based on the version being used (1, 2, or 3).

With this in mind, can you please restate your question.  We're not following your concern.

Eliot