Subject: Re: Last Call: <draft-ietf-iasa2-trust-update-00.txt> (Update to the Selection of Trustees for the IETF Trust) to Best Current Practice

From: Alissa Cooper <[email-masked]>
Date: Tue, 2 Oct 2018 16:38:57 -0400

I’ve heard this there is a little confusion about the timeline for appointments if this document is approved soon and the current NomCom is asked to seat trustees, so I’d like to suggest the following clarification:

OLD 
The terms of the appointed trustees from IETF NomCom shall be three years.  The initial selection shall be one, two, and three year terms in order to initially stagger the terms and thus miminize potential annual Trustee turnover.  The other appointments by the IESG and the ISOC Board of Trustees shall be two year terms, with the initial terms being one and two years, respectively.

NEW 
The terms of the appointed trustees from IETF NomCom shall be three years.  The initial selection shall be one, two, and three year terms in order to initially stagger the terms and thus miminize potential annual Trustee turnover.  The other appointments by the IESG and the ISOC Board of Trustees shall be two year terms, with the initial terms being one and two years, respectively. The term lengths of initial appointees should be measured from the First IETF of the year in which they are seated even if they are appointed after the First IETF of the year.

Alissa

> On Sep 21, 2018, at 5:18 PM, The IESG <[email-masked]> wrote:
> 
> 
> The IESG has received a request from the IETF Administrative Support Activity
> 2 WG (iasa2) to consider the following document: - 'Update to the Selection
> of Trustees for the IETF Trust'
>  <draft-ietf-iasa2-trust-update-00.txt> as Best Current Practice
> 
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2018-10-05. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the beginning of
> the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>   This memo updates the selection of trustees for the IETF Trust.
>   Previously, the Internet Administrative Oversight Committee (IAOC)
>   members also acted as trustees but the IAOC has been eliminated as
>   part of an update of the structure of the Internet Administrative
>   Support Activity (IASA).  This memo specifies that the trustees shall
>   be selected separately.
> 
>   This memo updates RFCs 4071 and 4371 with regards to the selection of
>   trustees.  All other aspects of the IETF Trust remain as they are
>   today.
> 
> 
> 
> 
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-ietf-iasa2-trust-update/
> 
> IESG discussion can be tracked via
> https://datatracker.ietf.org/doc/draft-ietf-iasa2-trust-update/ballot/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
> 
> 
>

---

From: Scott Mansfield <[email-masked]>
Date: Tue, 2 Oct 2018 20:48:08 +0000

So I interpret this to say...

The NomCom will put forward three candidates.  For this year, the NomCom will put forward one candidate for a one year term, one candidate for a two year team, and one candidate for a three year term.  

 Next year’s NomCom will have one slot to fill.

Is that right?

Thanks.

Sent from my iPhone

> On Oct 2, 2018, at 16:38, Alissa Cooper <[email-masked]> wrote:
> 
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20

---

From: Jari Arkko <[email-masked]>
Date: Tue, 2 Oct 2018 23:30:10 +0200

> The terms of the appointed trustees from IETF NomCom shall be three years.  The initial selection shall be one, two, and three year terms in order to initially stagger the terms and thus miminize p…

Sounds reasonable, and definitely clearer. Thanks.

Jari

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 2 Oct 2018 19:39:17 -0400

> On Oct 2, 2018, at 4:48 PM, Scott Mansfield <[email-masked]> wrote:
> 

That is my reading of the draft. And my suggested clarification further explains that the three appointments by this year’s nomcom need not be completed by IETF 104, and if they are not then the appointees will serve a little less than 3, 2, and 1 years, respectively. That also would apply to the the other two initial appointments.

Alissa

---

From: "John Levine" <[email-masked]>
Date: 2 Oct 2018 19:52:15 -0400

>OLD 
>The terms of the appointed trustees from IETF NomCom shall be three years.  The initial selection shall be one, two, and three year terms in order to
>initially stagger the terms and thus miminize potential annual Trustee turnover.  The other appointments by the IESG and the ISOC Board of Trustees
>shall be two year terms, with the initial terms being one and two years, respectively.
>
>NEW 
>The terms of the appointed trustees from IETF NomCom shall be three years.  The initial selection shall be one, two, and three year terms in order to
>initially stagger the terms and thus miminize potential annual Trustee turnover.  The other appointments by the IESG and the ISOC Board of Trustees
>shall be two year terms, with the initial terms being one and two years, respectively. The term lengths of initial appointees should be measured from
>the First IETF of the year in which they are seated even if they are appointed after the First IETF of the year.

This seems overspecified, and I'd rather leave the language alone.

I presume the goal is that the nomcom shouldn't have to replace all
three of its people at the same time, which the old text handles.  The
two year terms of the nomcom and ISOC are already deliberately out of
sync with the nomcom.  Theoretically if the nomcom and ISOC both
decide to pick someone new the same year there might be two new
people, and possibly one new from nomcom if they don't reappoint an
incumbent, but that doesn't seem to be all that likely nor a big
issue.  There will still be at least two continuing truetees and
almost certainly more.

In practice, people have often resigned from the IAOC mid-term when
their jobs change, so no matter what the rules say, we're going to
have trustees appointed at random times.

R's,
John

---

From: Scott Mansfield <[email-masked]>
Date: Wed, 3 Oct 2018 00:06:25 +0000

Thanks for the affirmation of the staggering point and clarification that the new paragraph allows a schedule that completes after IETF 104.  

Depending on the timing, it may be possible to align with the LLC timing, but I will wait for the official guidance.

Thanks,
-scott.
Sent from my iPhone

> On Oct 2, 2018, at 19:39, Alissa Cooper <[email-masked]> wrote:
> 
> 
>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 5 Oct 2018 19:36:41 +0300

Adrian,

Many thanks for your perceptive review.

I have adopted your suggestions in my copy of the draft.

One follow-up below:

> Section 2
> 
>   IETF rules regarding recalls and other NomCom-related processes
>   continue to apply [RFC7437].
> 
> Pedantic, but you can't quite get away with this because the NomCom
> processes in 7437 did not apply to pure IETF Trust appointments.
> 
> How about...
> 
>   The processes regarding NomCom appointments and recalls of Trustees
>   for the IETF Trust follow those described in [RFC7437].

That’s much better, and this was an important catch.

> Does this mean this document updates 7437?

I think not, because this document uses 7437… would be happy to hear if people think otherwise.

Jari

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 5 Oct 2018 17:59:18 +0100

Hi Jari,

> I think not, because this document uses 7437… would be happy to hear if people

Happy to go with that.

Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 7 Oct 2018 11:11:37 +0100

Jari,
Thanks for the new version.
I checked, and you seem to have captured all my points.

Best,
Adrian

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: 05 October 2018 17:37
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; draft-ietf-iasa2-trust-
> [email-masked]
> Subject: Re: Last Call: <draft-ietf-iasa2-trust-update-00.txt> (Update to the
> Selection of Trustees for the IETF Trust) to Best Current Practice
> 
> Adrian,
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 10 Oct 2018 15:04:40 +0000

Sounds good. And FWIW, we are soon working on an update/replacement of RFC 7437.

On 10/7/18, 6:11 AM, "Adrian Farrel" <[email-masked]> wrote:

    Jari,
    
    Best,
    Adrian

---

From: "Pete Resnick" <[email-masked]>
Date: Thu, 25 Oct 2018 13:15:11 -0500

Section 2 says that NomCom-appointed Trustees can be recalled according 
to 7437 (presumably bis). Can the IESG-appointed and ISOC-BoT-appointed 
Trustees be recalled or otherwise removed as Trustees? If so, by what 
mechanism? I don't have any opinion on what the mechanism should be 
(e.g., the appointing body can simply say, "You're fired", or the 7437 
process could be used, or ...), but I do think there needs to be some 
mechanism specified for removing them if necessary.

pr

---

From: "Pete Resnick" <[email-masked]>
Date: Thu, 25 Oct 2018 13:18:42 -0500

On 25 Oct 2018, at 13:15, Pete Resnick wrote:

> Section 2 says that NomCom-appointed Trustees can be recalled 
> according to 7437 (presumably bis). Can the IESG-appointed and 
> ISOC-BoT-appointed Trustees be recalled or otherwise removed as 
> Trustees? If so, by what mechanism? I don't have any opinion on what 
> the mechanism should be (e.g., the appointing body can simply say, 
> "You're fired", or the 7437 process could be used, or ...), but I do 
> think there needs to be some mechanism specified for removing them if 
> necessary.

My apologies; I see this has already been resolved.

pr