Subject: Opsdir last call review of draft-ietf-dmarc-rfc7601bis-03

From: Linda Dunbar <[email-masked]>
Date: Wed, 31 Oct 2018 10:49:37 -0700

Reviewer: Linda Dunbar
Review result: Ready

I have been assigned to review draft-ietf-dmarc-rfc7601bis-03 on behalf of the
ops directorate.  This document specifies a message header field called
Authentication-Results for use with electronic mail messages to indicate the
results of message authentication efforts.

The document is written very clear. The only question I have is if the
mechanism described in the document are actually used by popular mail-server,
such as Microsoft Outlook?

Thank you,

Linda Dunbar

---

From: "John Levine" <[email-masked]>
Date: 31 Oct 2018 14:09:01 -0400

>such as Microsoft Outlook?

Gmail, Yahoo, and AOL all add Authentication-Results headers to incoming mail.

Outlook is a mail client.  Dunno what their Exchange servers do.

R's,
John

---

From: Dave Crocker <[email-masked]>
Date: Wed, 31 Oct 2018 11:19:07 -0700

> Gmail, Yahoo, and AOL all add Authentication-Results headers to incoming mail.

As does open-source MTA software, apparently including sendmail.

My copy of John's response contained:

   > Authentication-Results: simon.songbird.com; dkim=pass
>  reason="1024-bit key; unprotected key"
>  header.d=ietf.org header.i=@ietf.org header.b=zbjsA0UV;
>  dkim-adsp=none (unprotected policy); dkim-atps=neutral

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 31 Oct 2018 18:51:38 +0000

John, 

Thank you very much for the explanation. Is there any way to find out if my mail server support the Authentication-Results message header? 

Linda

-----Original Message-----
From: John Levine [mailto:[email-masked]] 
Sent: Wednesday, October 31, 2018 1:09 PM
To: [email-masked]
Cc: Linda Dunbar <[email-masked]>
Subject: Re: [dmarc-ietf] Opsdir last call review of draft-ietf-dmarc-rfc7601bis-03

In article <[email-masked]> you write:
>Reviewer: Linda Dunbar
>Review result: Ready
>
>I have been assigned to review draft-ietf-dmarc-rfc7601bis-03 on behalf 
>of the ops directorate.  This document specifies a message header field 
>called Authentication-Results for use with electronic mail messages to 
>indicate the results of message authentication efforts.
>
>mechanism described in the document are actually used by popular 
>mail-server, such as Microsoft Outlook?

R's,
John

---

From: "John R Levine" <[email-masked]>
Date: 31 Oct 2018 15:38:05 -0400

> Thank you very much for the explanation. Is there any way to find out if my mail server support the Authentication-Results message header?

Tell your mail program to show you the headers of this message and see if 
your mail system added Authentication-Results.

> Outlook is a mail client.  Dunno what their Exchange servers do.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly