Subject: remote participation

From: Sandra Murphy <[email-masked]>
Date: Wed, 7 Nov 2018 08:29:46 -0500

Remote participation is hard even in the ideal.  I’ve run into cases recently when it was harder than it needed to be.

Last IETF, I was trying to listen in and ask questions remotely - I found that many wg did not have anyone assigned the role of transferring questions to the mike.  And even if there was a person assigned, the remote latency meant that “any questions” asked in the room, followed 2 seconds later by “no?  ok, on to next topic” did not leave enough time for remote questions to appear.

This IETF, there was no one assigned in the plenary to relay questions from the meetecho chat /jabber room to the mic.

Is real-time remote participation a goal?  Is it supposed to be supported enough that it is effective participation? Or is it just for those who are passive observers?

—Sandy

---

From: Simon Pietro Romano <[email-masked]>
Date: Thu, 8 Nov 2018 01:26:07 +0700

Hello Sandra,

a couple of comments in-line.

> Last IETF, I was trying to listen in and ask questions remotely - I found that many wg did not have anyone assigned the role of transferring questions to the mike.  And even if there was a person a…

A feasible approach to removing such a latency is indeed represented by the use of the Meetecho virtual queue. In this way, remote participants can in fact directly inject (in a chair-moderated fashion) their audio (and video, if desired) into the conference room, with no need for any “jabber relay”.

> This IETF, there was no one assigned in the plenary to relay questions from the meetecho chat /jabber room to the mic.

That was unfortunate, indeed.

The Meetecho queue might have done the trick also in this case, by the way. Remote participants requests get collected in the virtual queue, which is projected at all times inside the conference room, both on secondary screens and on a dedicated laptop on the chairs’ desk.

> Is real-time remote participation a goal?  Is it supposed to be supported enough that it is effective participation? Or is it just for those who are passive observers?

I might be biased,  but my feeling is that we, as a community, have devoted huge efforts in the past years to improve the “quality” of the remote participation experience, by tackling the issue both from the cultural and the technological perspective. Things can (and must) always be improved, obviously. And a lot of work is still to be done. Though, I do believe we have made giant steps towards the final target of what Ray Pelletier used to call the “being there” experience.

My 2 cents,

Simon

                     				            _\\|//_
                           				   ( O-O )
      ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
       ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

> Il giorno 07 nov 2018, alle ore 20:29, Sandra Murphy <[email-masked]> ha scritto:
>

---

From: Sandra Murphy <[email-masked]>
Date: Wed, 7 Nov 2018 14:46:04 -0500

Overall comment.  Meetecho is a wonderful marvelous tool, the staff is fantastically helpful, all quite an uptick from the jabber+audio experience of long ago IETFs.  Long life to them!

But.

Are we mandating the use of meetecho for remote participation?  Are those who still use jabber+audio just out of luck?  

About 

> A feasible approach to removing such a latency is indeed represented by the use of the Meetecho virtual queue. In this way, remote participants can in fact directly inject (in a chair-moderated fas…

In what way does the virtual queue counteract the time it takes for the “any questions” to reach my platform before the “no?  ok, on to next topic” occurs in the meeting room?

’T’would indeed be great to inject my audio and maybe video into the room.  Save me the typing which always takes me much too long.

But.

See overall comment on jabber+audio.

Not all people are remotely participating in situations where they can speak out loud.  What, no one has ever been sitting in one wg, with one ear and a jabber window devoted to the wg in another room?

> The Meetecho queue might have done the trick also in this case, by the way.

The chair who did not see the jabber/chat room might just as easily not seen the virtual queue.  Gotta have somebody in the room to be looking, whether it is looking for the “MIC <comment>” in the jabber room or looking for the "virtual queue, which is projected at all times”. Whether that’s one somebody with an assigned role or a community effort.

(I await education of a current tool feature that puts the audio from the virtual queue directly into the room at some deliberate point without human direction.  But you did say "in a chair-moderated fashion”.)

> I might be biased,  but my feeling is that we, as a community, have devoted huge efforts in the past years to improve the “quality” of the remote participation experience

I repeat my first enthusiastic gratitude to the work that has been done.  I agree with the improvement wholeheartedly.  

But.

Humans, AFAIK, still have a determining factor in making the remote participation work well.

—Sandy

(wrt jabber+audio vs meetecho.  I’ll just presume that Meetecho’s excellence extends to support for audio/visual disabilities; seems a real safe presumption.)

> On Nov 7, 2018, at 1:26 PM, Simon Pietro Romano <[email-masked]> wrote:
> 
> Hello Sandra,
>

---

From: John C Klensin <[email-masked]>
Date: Wed, 07 Nov 2018 15:39:53 -0500

--On Wednesday, November 7, 2018 14:46 -0500 Sandra Murphy
<[email-masked]> wrote:

> Overall comment.  Meetecho is a wonderful marvelous tool, the
> staff is fantastically helpful, all quite an uptick from the
> jabber+audio experience of long ago IETFs.  Long life to them!

Strongly agree.  I'm afraid I haven't been saying that often
enough lately and apologize for not doing so.  I also think we
have reached the point were the vast majority of the problems we
have "with Meetecho" are IETF participant issues involving
training, lack of attention, etc.

> But.
> 
> Are we mandating the use of meetecho for remote participation?
> Are those who still use jabber+audio just out of luck?  

I hope not.  At the same time, I see a difference between
relatively passive remote participation in which someone
observes, tracks documents, participates on the mailing list,
makes an occasional comment in a WG meeting, etc., and really
active participation in which someone might be editing WG
documents, taking one leadership roles such as WG co-chair or
secretary, participating in complex directorate discussions, and
so on.   If we needed to require that someone either be f2f or
have enough technology and technology available to run Meetecho,
I, at least, wouldn't be enthused but wouldn't lose a lot of
sleep over it either.
 
> About 
> 
>> A feasible approach to removing such a latency is indeed
>> represented by the use of the Meetecho virtual queue. In this
>> way, remote participants can in fact directly inject (in a
>> chair-moderated fashion) their audio (and video, if desired)
>> into the conference room, with no need for any "jabber
>> relay".
> 
> In what way does the virtual queue counteract the time it
> takes for the "any questions" to reach my platform before
> the "no?  ok, on to next topic" occurs in the meeting room?

Simon may have a different answer, but what I'm noticed is that
it takes me a while to compose a question that will be coherent
and clear enough when read at the microphone by someone else and
possibly out of sequence with the conversation.   By contrast, I
can click on the "put me in queue" icon in real time and finish
composing my question the same way I do when I get in the mic
line, i.e., while waiting to get to the front of the queue.  As
with standing in the physical line, if I change my mind about
saying something before I get to the front of the queue, it is
easy for me to get out of line sit down (physically or
virtually).

> 'T'would indeed be great to inject my audio and maybe
> video into the room.  Save me the typing which always takes me
> much too long.

And that is exactly the point above.   The Jabber input
mechanism is much more suited for quick comments than for
detailed ones and far too ponderous for anything resembling a
bac-and-forth discussion (which I've had using Meetecho
facilities)
 
> Not all people are remotely participating in situations where
> they can speak out loud.  What, no one has ever been sitting
> in one wg, with one ear and a jabber window devoted to the wg
> in another room?

See above.  And, having done that, if I conclude that I need to
actively participate in a discussion in a different WG, I get up
and change rooms.

> The chair who did not see the jabber/chat room might just as
> easily not seen the virtual queue.  Gotta have somebody in the
> room to be looking, whether it is looking for the "MIC
> <comment>" in the jabber room or looking for the "virtual
> queue, which is projected at all times". 

Unless one has an alert mechanism that is capable of getting
increasingly intrusive and obnoxious if it were ignored... just
as someone in an in-room mic queue has options other than
standing their passively if not recognized.  We would hope those
options would never be used, but I've been around long enough to
see a few of them and you probably have too.

> Whether that's
> one somebody with an assigned role or a community effort.
> 
> (I await education of a current tool feature that puts the
> audio from the virtual queue directly into the room at some
> deliberate point without human direction.  But you did say "in
> a chair-moderated fashion".)

In-room microphone queues are also chair-moderated.   I'd be
really happy if we could get to parity.

>> I might be biased,  but my feeling is that we, as a
>> community, have devoted huge efforts in the past years to
>> improve the "quality" of the remote participation
>> experience
> 
> I repeat my first enthusiastic gratitude to the work that has
> been done.  I agree with the improvement wholeheartedly.  
> 
> But.
> 

Again, I see most of the issues at this point as having to do
with effective meeting management that gives adequate
consideration to remote participants and fairness toward them,
not deficiencies in Meetecho.

     john

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 8 Nov 2018 07:23:06 +0700

Hi Sandy,

> On Nov 7, 2018, at 8:29 PM, Sandra Murphy <[email-masked]> wrote:
> 

This seems like another area where a refresh of WG chairs training is in order. I’ll work on that with the EDU team and my fellow ADs who have been running chair training. 

I suspect that as the MeetEcho service quality has become so good (in general) and more participants have become accustomed to it, the jabber channel has fallen back in people’s consciousnesses. That certainly seems to be what has happened to me.

> This IETF, there was no one assigned in the plenary to relay questions from the meetecho chat /jabber room to the mic.

This was completely my fault for forgetting. As mentioned to SM, I’ve set a reminder for myself to ensure it doesn’t happen next time.

I was furtively glancing at the MeetEcho queue throughout the plenary to see if there were remote participants in queue, but obviously that does not solve this problem.

> Is real-time remote participation a goal?  Is it supposed to be supported enough that it is effective participation? Or is it just for those who are passive observers?

The goal is certainly for remote participation to be effective, which relies on a combination of technology and human factors. It’s clear that we have work to do on the latter (myself included) while we’ve been lucky to have a high-quality service for the former.

Apologies,
Alissa

---

From: Simon Pietro Romano <[email-masked]>
Date: Thu, 8 Nov 2018 08:58:57 +0700

Hello again John and Sandra,

a few additional comments in-line.

> easy for me to get out of line sit down (physically or

I haver no better answer, indeed. You did read my mind.

> bac-and-forth discussion (which I've had using Meetecho

Agreed.

> really happy if we could get to parity.

I could not agree more on that, since “moderation” has been our kink for a while.
See https://ieeexplore.ieee.org/document/7081100 <https://ieeexplore.ieee.org/document/7081100> to get a sense of what I’m saying (and sorry about the self-citation!).

Thanks again for your precious feedbacks,

Simon

                     				            _\\|//_
                           				   ( O-O )

---

From: Ted Lemon <[email-masked]>
Date: Thu, 8 Nov 2018 09:27:12 +0700

Is this a paper you can share with us without requiring us to sign into the
IEEE web site?

On Thu, Nov 8, 2018 at 8:59 AM Simon Pietro Romano <[email-masked]>
wrote:

> See https://ieeexplore.ieee.org/document/7081100 to get a sense of what
> I’m saying (and sorry about the self-citation!).
>

---

From: Simon Pietro Romano <[email-masked]>
Date: Thu, 8 Nov 2018 09:45:17 +0700

> Is this a paper you can share with us without requiring us to sign into the IEEE web site?

Not the copyrighted version. You can find a pre-print here:

https://bit.ly/2ARJRWZ <https://bit.ly/2ARJRWZ>

Cheers,

Simon

                     				            _\\|//_
                           				   ( O-O )

> Il giorno 08 nov 2018, alle ore 09:27, Ted Lemon <[email-masked]> ha scritto:
> 
> Is this a paper you can share with us without requiring us to sign into the IEEE web site?
> 
> On Thu, Nov 8, 2018 at 8:59 AM Simon Pietro Romano <[email-masked] <mailto:[email-masked]>> wrote:
>                                            e-mail: [email-masked] <mailto:[email-masked]>
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 12 Nov 2018 19:30:00 -0600

Just to drill down on one point ...

> I, at least, wouldn't be enthused but wouldn't lose a lot of

For several years, I carried a Chromebook to IETF meetings, and this was
long enough ago that I couldn't run an Android client on my Chromebook
(which works now), much less something like Pidgin (which should work as
soon as I get my Chromebook sorted for Unix, and I don't think that's far
in the future).

So I was really aware that Meetecho  provides the jabber room in a separate
window - that's usually how I accessed the Jabber room.

Given that, plus Meetecho using HTML5 for video, etc., what kind of use
case are we talking about, where someone can use the audio stream plus a
jabber client, but can't use Meetecho?

I'm willing to believe this is a real constraint, I'm just trying to
understand what problem we're solving, and if the answer is "we've got most
or all of the technology we need to solve these real problems for remote
participants without retraining humans, which can improve things but not to
the point of perfection", that would be helpful to know.

Spencer

---

From: Ted Lemon <[email-masked]>
Date: Mon, 12 Nov 2018 20:41:42 -0500

Several people have pointed out that they weren't able to access the
Meetecho Jabber, and also that the way it handles names isn't ideal.   I
wasn't able to access it because I didn't have an access code handy and
didn't want to register for remote access when not remote.
 XMPP-over-Websocket?

On Mon, Nov 12, 2018 at 8:30 PM Spencer Dawkins at IETF <
[email-masked]> wrote:

> in the future)..
> So I was really aware that Meetecho  provides the jabber room in a
> separate window - that's usually how I accessed the Jabber room.
>

---

From: Mark Andrews <[email-masked]>
Date: Tue, 13 Nov 2018 12:49:49 +1100

The meetecho login screen has a “forgotten my registration” button so it
should be possible to get in provided you have access to your email account.

> On 13 Nov 2018, at 12:41 pm, Ted Lemon <[email-masked]> wrote:
> 
> Several people have pointed out that they weren't able to access the Meetecho Jabber, and also that the way it handles names isn't ideal.   I wasn't able to access it because I didn't have an access code handy and didn't want to register for remote access when not remote.   XMPP-over-Websocket?

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742              INTERNET: [email-masked]

---

From: Alessandro Amirante <[email-masked]>
Date: Tue, 13 Nov 2018 10:05:32 +0100

Il 13/11/18 02:41, Ted Lemon ha scritto:
>  Meetecho Jabber, 
There's no Meetecho Jabber room. Meetecho relays the IETF official 
jabber channels (e.g., [email-masked]).
We have not been reported of people having problems accessing Meetecho 
during the last meeting. If you know such people, Ted, can you please 
ask them to get in touch with us so we can see what happened and sort it 
out?

> and also that the way it handles names isn't ideal.

I'm not sure I get what you mean by "handling names", but please address 
any feedback to the Meetecho team. The IETF remote participation 
platform has improved a lot over the years thanks to the precious 
feedback received by the IETF community. All feedback we receive is 
taken into consideration for the upcoming meetings.

>  I wasn't able to access it because I didn't have an access code
> handy and didn't want to register for remote access when not remote.

As I already said in another thread, all information you need is your 
name and your Registration ID, which is also printed on your badge if 
you're on-site.

Alessandro

>  XMPP-over-Websocket?
> 
> On Mon, Nov 12, 2018 at 8:30 PM Spencer Dawkins at IETF 
> <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
> On Wed, Nov 7, 2018 at 2:40 PM John C Klensin <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
> 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Are we mandating the use of meetecho for remote participation? Are
>> those who still use jabber+audio just out of luck?
> 
> I hope not.  At the same time, I see a difference between relatively
> passive remote participation in which someone observes, tracks
> documents, participates on the mailing list, makes an occasional
> comment in a WG meeting, etc., and really active participation in
> which someone might be editing WG documents, taking one leadership
> roles such as WG co-chair or secretary, participating in complex
> directorate discussions, and so on.   If we needed to require that
> someone either be f2f or have enough technology and technology
> available to run Meetecho, I, at least, wouldn't be enthused but
> wouldn't lose a lot of sleep over it either.
> 
> 
> For several years, I carried a Chromebook to IETF meetings, and this 
> was long enough ago that I couldn't run an Android client on my 
> Chromebook (which works now), much less something like Pidgin (which 
> should work as soon as I get my Chromebook sorted for Unix, and I 
> don't think that's far in the future)...
> 
> Given that, plus Meetecho using HTML5 for video, etc., what kind of 
> use case are we talking about, where someone can use the audio stream
> plus a jabber client, but can't use Meetecho?
> 
> understand what problem we're solving, and if the answer is "we've 
> got most or all of the technology we need to solve these real 
> problems for remote participants without retraining humans, which can
> improve things but not to the point of perfection", that would be
> helpful to know.
> 
> Spencer
> 

-- 
Ing. Alessandro Amirante, Ph.D.

Meetecho S.r.l.
www.meetecho.com

Via Riviera di Chiaia 124
80122 Napoli, Italy

Mobile: +39 329 6178743
E-mail: [email-masked]