Subject: The Friday Experiment

From: "Andrew G. Malis" <[email-masked]>
Date: Sat, 10 Nov 2018 16:14:45 +0700

I would like to start a discussion on the Friday experiment. I, for one,
thought that it was a resounding failure. Based on the room reservations in
the meeting wiki, there were 8 rooms available on Friday, but only 5 side
meetings, most of which were for only an hour or two, which was a huge
underutilization of the resources that the IETF was paying for.

The experiment also had at least two detrimental effects on the IETF agenda:

- Many WGs had less time than was needed to address the topics or drafts
that needed discussion

- There were a number of unfortunate conficts, expecially in the Routing
area.

My personal hope is that this experiment will not be repeated, and we go
back to our previous meeting agenda.

Cheers,
Andy

---

From: Stewart Bryant <[email-masked]>
Date: Sat, 10 Nov 2018 09:22:09 +0000

On 10/11/2018 09:14, Andrew G. Malis wrote:
> I would like to start a discussion on the Friday experiment. I, for 
> one, thought that it was a resounding failure. Based on the room 
> reservations in the meeting wiki, there were 8 rooms available on 
> Friday, but only 5 side meetings, most of which were for only an hour 
> or two, which was a huge underutilization of the resources that the 
> IETF was paying for.
>
> - Many WGs had less time than was needed to address the topics or 
> drafts that needed discussion
>
> - There were a number of unfortunate conficts, expecially in the 
> Routing area.
>
> My personal hope is that this experiment will not be repeated, and we 
> go back to our previous meeting agenda.
>
> Cheers,
> Andy
>

+100

In addition there will have been wasted money on room bookings by people 
that anticipated productive work on Friday.

Furthermore we know where that ends. Thursday becomes the new Friday. We 
get WGs reluctant to meet on Thursday afternoon, and fewer people 
available to contribute after Thursday lunch time, so we end up loosing 
a full day not a partial day. We then get even more meeting clashes...

Thanks for starting the thread

Stewart

---

From: Leif Johansson <[email-masked]>
Date: Sat, 10 Nov 2018 11:09:58 +0100

> 
> My personal hope is that this experiment will not be repeated, and we go back to our previous meeting agenda.
> 

Agree!

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 10 Nov 2018 17:10:53 +0700

It worked for us (T2TRG).

But then we pretty aggressively went for making it work; planning started long before IETF102.

Limited support for remote presentations could have been a showstopper, but wasn’t for us.

The scheduling was weird: We were luckily able to incorporate a competing side meeting as one of our breakouts.  
We were just lucky here that other side meetings did not happen.

I have no idea why we had to stop on 13:20 (again, this happened to work for us, but that is another coincidence).

Summarizing, I don’t think all this luck can be repeated; the assumption of the experiment seems to have been that the entire IETF neatly splits into side meetings that can be scheduled as ships in the dark.

I really like the idea of having some space for more in-depth work, but it will need to become first-class, both wrt support and wrt scheduling.

(For Prague, we are now thinking about starting on Wednesday in the week before the IETF.  Can we have rooms for that?)

Grüße, Carsten

> On Nov 10, 2018, at 16:14, Andrew G. Malis <[email-masked]> wrote:
> 
> I would like to start a discussion on the Friday experiment. I, for one, thought that it was a resounding failure. Based on the room reservations in the meeting wiki, there were 8 rooms available on Friday, but only 5 side meetings, most of which were for only an hour or two, which was a huge underutilization of the resources that the IETF was paying for. 
> 
> - Many WGs had less time than was needed to address the topics or drafts that needed discussion
> 
> - There were a number of unfortunate conficts, expecially in the Routing area.
>

---

From: Job Snijders <[email-masked]>
Date: Sat, 10 Nov 2018 11:18:31 +0100

Dear all,

I actually liked the approach and would like to encourage the IESG to
repeat the experiment a few more times.

Between the normal work week (the week before IETF), traveling to IETF, the
hackathon, IEPG, and the IETF meeting itself you’ll easily end up being
busy for 12 days in a row. This is not healthy - we owe it to ourselves to
foster an environment that encourages rest as much as it encourages working
together.

Making the Friday optional (like at IETF103) increases the chances of
people getting home for a full weekend of downtime.

I see no risk of “the Thursday becoming the new Friday”, to me the slippery
slope argument makes no sense without supporting data.

Kind regards,

Job

---

From: Kathleen Moriarty <[email-masked]>
Date: Sat, 10 Nov 2018 07:47:16 -0500

Hello,

I was disappointed by the number of overlapping sessions for security and having to choose between working group sessions that I would have liked to attend.  This did impact some working groups that suffered from light attendance that included having less regular participants.

When I asked about this, I was told the same number of slots were available, so it was a conflict resolution issue.  Perhaps we need to extend the number of slots when Friday is added back to help with conflicts.

I will have to read the minutes or watch recorded sessions for a few meetings that I was interested to attend.

Best regards,
Kathleen 

Sent from my mobile device

> On Nov 10, 2018, at 5:18 AM, Job Snijders <[email-masked]> wrote:
> 
> Dear all,
> 
> I actually liked the approach and would like to encourage the IESG to repeat the experiment a few more times.
> 
> Between the normal work week (the week before IETF), traveling to IETF, the hackathon, IEPG, and the IETF meeting itself you’ll easily end up being busy for 12 days in a row. This is not healthy - we owe it to ourselves to foster an environment that encourages rest as much as it encourages working together.
> 
> Making the Friday optional (like at IETF103) increases the chances of people getting home for a full weekend of downtime..
> 
> I see no risk of “the Thursday becoming the new Friday”, to me the slippery slope argument makes no sense without supporting data.
> 
> Kind regards,
> 
> Job

---

From: Bob Hinden <[email-masked]>
Date: Sat, 10 Nov 2018 23:07:02 +0900

> On Nov 10, 2018, at 6:14 PM, Andrew G. Malis <[email-masked]> wrote:
> 

I agree for the reasons Andy stated.   We had the same issue in 6man (not enough time).  We did schedule a meeting on Friday on one topic, but that could have easily been done during the week in the lounge.

Bob

---

From: Alissa Cooper <[email-masked]>
Date: Sat, 10 Nov 2018 22:07:25 +0700

Thanks for starting the thread, Andy. And thanks all for the feedback! Keep it coming. The IESG will be sending a note around in a few days about start/end days and times for IETF 104 and will be following up with more detailed agenda plans a bit later after we have a chance to collect more feedback.

People are also welcome to send feedback to [email-masked] as you prefer.

Alissa

> On Nov 10, 2018, at 4:14 PM, Andrew G. Malis <[email-masked]> wrote:
>

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 10 Nov 2018 15:19:17 +0000

On 10/11/2018 09:14, Andrew G. Malis wrote:
> thought that it was a resounding failure. 

Agreed.

> back to our previous meeting agenda.

I'd encourage the IESG to consider a similar approach but
never on the last day of the meeting. My suggestion is to
have one or more of Tue/Wed/Thu mornings with no (or few)
WG sessions scheduled.

Cheers,
S.

PS: As a data point, I booked a flight home departing on
Friday morning. That precluded taking part in Friday fun.
Given the probabilities, I'd pick being home over maybe
having a good Friday meeting every time.

---

From: Ted Lemon <[email-masked]>
Date: Sat, 10 Nov 2018 12:33:52 -0500

I also flew home Friday morning.   Interestingly, some of my colleagues
actually did plan to use Friday, and this turns out to have been (arguably)
a mistake, although I'm really glad to be home.   I think that what we
should do is to have the experiment mid-week, not at the end of the week,
and to make Friday a regular meeting day, not a special day that ends early.

As for the conflicts, yes, they were really, really bad.   I wonder if
people would be willing to participate in a poll about this, for the
purposes of data collection.   The basic idea would be to just make a list
of all the slots for IETF 103, and all the meetings in the slots, and then,
for each meeting, have people check "attended," "needed to attend but
couldn't," "would have attended but couldn't," "might have attended" or
"wouldn't have attended".   And then crunch the numbers to see how close to
optimal we came.

Right now the way conflict resolution is done is totally unscientific, and
seems to have more to do with AD availability than effective use of meeting
time by other participants.   I think that prioritizing for AD availability
is not a bad thing to do, but in principle ADs aren't doing work in these
meetings—they're there as moderators (which *is* work, to be sure, but not
what I mean).   Moderating isn't a bad thing, but it shouldn't be
prioritized over doing work.   In principle working group chairs are
supposed to be know what they are doing and do it; if they are not, that's
actually a problem.   Requiring ADs to attend every working group meeting
for working groups they're responsible for sounds really good from a
management checking-of-boxes perspective, but I'm not convinced that it's
actually the best use of AD time.

---

From: Job Snijders <[email-masked]>
Date: Sat, 10 Nov 2018 18:41:47 +0100

Dear Ted,

On Sat, Nov 10, 2018 at 6:34 PM Ted Lemon <[email-masked]> wrote:
> I think that what we should do is to have the experiment mid-week, not at the end of the week, and to make Friday a regular meeting day, not a special day that ends early.

Can you elaborate on /why/ a mid-week day is more suitable in your
opinion than the Friday or Monday?

In my mind doing this at the beginning (or preferably the end) of the
week creates opportunity to optionally reduce the total duration of a
trip, whereas planning such experiments in the middle of the week
basically forces everyone to be around, even if they don't have a need
to do so during given IETF meeting.

Kind regards,

Job

---

From: Mikael Abrahamsson <[email-masked]>
Date: Sat, 10 Nov 2018 18:49:21 +0100 (CET)

On Sat, 10 Nov 2018, Ted Lemon wrote:

> and to make Friday a regular meeting day, not a special day that ends early..

I booked my travels in August and wasn't aware of this "experiment" until 
it was too late. Now, with the 6man side-meeting on friday I am happy I 
was there, I got a few hours friday afternoon for things I wanted to do in 
Bangkok and then took a midnight flight home.

A lot of flights leave Bangkok around midnight, at least Europe-bound. In 
other cities it seems long distance flights leave more spread out. I think 
this might be something that should be taken into account when it comes to 
deciding how to schedule Fridays for meetings.

It felt I had more conflcits this week compared to earlier meetings. I 
attend lots of different meetings, transport, internet area, 
netconf/netmod. I was quite surprised by the "oh, nobody would ever want 
to attend multicast and IPv6 standardisation so that's fine to schedule 
at the same time" conflict this time around. I typically have conflicts, 
but it felt this meeting was worse than average.

I also felt several sessions I attended were quite rushed and there wasn't 
enough time for discussions and presentations.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Sat, 10 Nov 2018 13:00:31 -0500

If the goal is to decrease the duration of the trip, we should just have
that as a goal and not pretend it's something else.   If the goal is to
provide opportunities for unstructured collaboration, then we should make
that the goal.   One thing we could do would be to make it a "hackathon"
day, and have one less "hackathon" day on the weekend, for example.   This
would enable both unstructured meeting and hackathoning.   But what we
should not do is have Heisenfreitag, where we don't know who is meeting
until the wave function collapses.

On Sat, Nov 10, 2018 at 12:42 PM Job Snijders <[email-masked]> wrote:

> > I think that what we should do is to have the experiment mid-week, not
> at the end of the week, and to make Friday a regular meeting day, not a
> special day that ends early.
>

---

From: John C Klensin <[email-masked]>
Date: Sat, 10 Nov 2018 13:08:03 -0500

--On Saturday, November 10, 2018 11:18 +0100 Job Snijders
<[email-masked]> wrote:

> Making the Friday optional (like at IETF103) increases the
> chances of people getting home for a full weekend of downtime.
> 
> I see no risk of "the Thursday becoming the new Friday",
> to me the slippery slope argument makes no sense without
> supporting data.

Actually, Jeb, there is supporting data although you could
reasonably argue that it is too old, and things have changed
enough, to make it of little or no use (see below).

Once upon a time, IETF was a four day activity plus a few
ancillary meetings Sunday afternoon.  No Saturdays and, except
for the IAB, IESG, Secretariat Staff, and NOC volunteers, no
Sunday mornings or early Sunday afternoons.  And we wrapped up
at the end of the day on Thursday.  Logistics (e.g., airline
schedules) might require people to stay around until Friday
morning but, again with the exception of IAB and IESG
post-meeting retrospectives, most people expected to be out as
early as possible on Friday.  There was some "get out of
Thursday" attrition, but, at least IMO, not nearly as much as
one would expect from observations of how many people are around
on Friday and how many WGs prefer to avoid Friday meetings.

We also ran fewer parallel sessions -- I recall five, which the
Bangkok agenda seems to show seven or eight in many slots.
With careful planning, that reduces the number of people who are
forced into "two places at once" situations.  And some people
thought we still had too many WGs.   FWIW, a requirement for
fewer parallel meeting rooms expands our choice of venues and
might lower costs a bit.

>From one point of view, and especially as evidence mounts that
in-depth cross-area review is becoming less effective, this is a
choice between doing a lot of things and doing a smaller number
of things well.

Things have changed.  The IETF has gotten bigger in terms of
participants.  However, perhaps more important, I believe we
have ended up with fewer really active participants per WG
(perhaps because the people who do the work are spread too
thin).   We have definitely gotten less selective about the
threshold for forming a WG and the conditions needed to get a
meeting slot or two and have put more stress on meetings and
less on mailing lists (a count of interim meetings is fairly
strong evidence of the latter).  

I'm not certain that more selectivity, fewer WGs, fewer ADs,
etc., would be an improvement whether it led to shorter meetings
or not and am not advocating it at the moment, but it would
probably be clear that we are making choices more complex than
how many days we meet and that those choices have consequences.

     john

---

From: Ted Lemon <[email-masked]>
Date: Sat, 10 Nov 2018 13:10:09 -0500

BTW, one thing to say about "rushed agendas" is that they are as likely to
be the result of poor planning as lack of time.   Some IETF working groups
are very productive, and for those working groups, limited agenda time
could in principle be a problem.   However, these same IETF working groups
could probably just have more virtual interims and achieve the same result,
or possibly a better result, because interims do not discriminate against
people who are not able to attend in person.   Two hours of really good
in-person discussion during an in-person meeting might be quite valuable to
such a group.

Then there are groups where the chairs don't really know in advance what
the hot topics are.   Why not?   Either because of sporadic participation,
or poor planning, or because the working group is a "where we get things of
class X done" group and not a "we're trying to do X" group.   In both of
these cases, the right approach is to put a little more effort into
deciding how to best use the agenda time.   The algorithm should not be "we
have 90 minutes, and we have 9 presentations, so that's 10 minutes per
presentation."   It should start with "what work will we feel perfectly
okay about if we don't get to it?"   Okay, that gets *zero* time on the
agenda until other work is complete.   We do not need to schedule a second
meeting slot for it.   Then there's "what work would we feel really bad
about if we didn't get to it?"   If the answer is "none," then the working
group should not meet.   If the answer is "everything that's left," then
maybe you have a problem, but I don't think that's a likely thing.

So then the working group can maybe focus on the stuff that's an absolute
priority, and spend remaining time on the "nice to have" stuff, and
completely blow off the "not important" stuff.   That might be
disappointing for the people whose stuff doesn't seem important to the WG.
 That's okay.   Consider that the cost per ten minutes of agenda time is
about $24,000 US.   Think about that seriously.   Does your topic really
need ten minutes of working group time?

---

From: "Paul Hoffman" <[email-masked]>
Date: Sat, 10 Nov 2018 12:20:52 -0800

I was one of the first to schedule a side-meeting on Friday, and I 
immediately got a few people saying "but I already scheduled to leave 
Thursday night because I assumed nothing would be happening on Friday". 
I scheduled a second side-meeting on the same topic on Wednesday. The 
Wednesday meeting had 35ish people, the Friday had below 20.

But I also note that very few side meetings were on the schedule for 
Friday, which to me says that maybe optimizing for side-meetings was 
overkill. A different idea is to have three rooms for side-meetings 
during the week because there was contention for the two in some slots.

--Paul Hoffman

---

From: Jared Mauch <[email-masked]>
Date: Sat, 10 Nov 2018 17:03:33 -0500

> On Nov 10, 2018, at 3:20 PM, Paul Hoffman <[email-masked]> wrote:
> 
> I was one of the first to schedule a side-meeting on Friday, and I immediately got a few people saying "but I already scheduled to leave Thursday night because I assumed nothing would be happening on Friday". I scheduled a second side-meeting on the same topic on Wednesday. The Wednesday meeting had 35ish people, the Friday had below 20.
> 
> But I also note that very few side meetings were on the schedule for Friday, which to me says that maybe optimizing for side-meetings was overkill. A different idea is to have three rooms for side-meetings during the week because there was contention for the two in some slots.

I ended up shortening my stay by ~22 hours and arrived home ~24h earlier as a result due to the flight schedules.

I didn’t have as many overlapping items as usual this time, but I think that’s due to some of the WGs being more aggressive about holding interims.

It also felt like attendance was down (but I haven’t done the obvious and check the registration numbers).

I did like the venue, it worked well.  Plenty of food choices nearby and once I realized the shortcut to the train station via the park life was good.

I think the fact that there are 11pm/1am flights leaving BKK for where I live made things much better even if it was a full day Friday.  I wish there were later flights to the US from Europe.  I often end up leaving Prague 6am on Friday to get a connection home.  I think this speaks more to BKK as a location we should revisit regardless of what happens with Fridays.

- Jared

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 11 Nov 2018 05:21:22 +0700

On Nov 11, 2018, at 01:00, Ted Lemon <[email-masked]> wrote:
> 
>  have one less “hackathon" day on the weekend, for example.  

Wrong direction (for our community).  The 1.5 day hackathon is already too short (one factor may be that we are schlepping hardware around and that takes some time to calibrate before everyone can get productive); we need more of that time, not less.

> Heisenfreitag, 

Thank you! We now have a word for what happened this time…

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 11 Nov 2018 05:41:43 +0700

On Nov 11, 2018, at 01:08, John C Klensin <[email-masked]> wrote:
> 
> fewer really active participants per WG

The tendency to spin up more WGs with a narrower focus leads us to have to go to more WG meetings.

When I started with IETF, I needed to go to, say, mmusic and avt, and everything else was cross-area review (and the odd RG).
Today there are about 10 must-go WGs for me and about that many that I would want to go to but often can’t (see my regular eclectic agenda).

mmusic and avt were “big” WGs until they were split up and spawned WGs like ice.  I haven’t followed that area of work too much recently, but in our community we already have a hard time avoiding to spend WG time on the subject of which of the many WGs to choose from some effort should go to.

(This is not a complaint, and it is not calling for immediate action; I just want to point out that the pendulum for some subject areas is on the side of fragmentation.  Of course there are also still the catch-all, gong show WGs like 6man.)

And yes, interims help us a lot to relieve the pressure on physical meetings; I seem to like the bi-weekly one-hour interims started by cbor.  But it is still extremely productive to have everyone convening in one physical space for a week.  And it is important to have space for new work in that time, too.

Grüße, Carsten

---

From: Loa Andersson <[email-masked]>
Date: Sun, 11 Nov 2018 14:09:56 +0800

HI,

This time there were at least three times when there were two or three
working groups colliding, for me that meant that out of 7 working groups
I could only attend 3.

13:50-15:50	Monday Afternoon session I

7 Meeting 2       rtg   bess	BGP Enabled ServiceS	
3 Boromphimarn 4  rtg	pce	Path Computation Element

9:00-11:00	Wednesday Morning session I

3 Boromphimarn 3  rtg	bier	Bit Indexed Explicit Replication	
3 Boromphimarn 4  rtg	ccamp	Common Control and Measurement Plane	
2 Chitlada 2      rtg	spring	Source Packet Routing in Networking	

13:50-15:50	Thursday Afternoon session I

2 Chitlada 2      rtg	detnet	Deterministic Networking	
2 Chitlada 3      rtg	sfc	Service Function Chaining

I'm not entirely clear over how much this has to do with the "Friday
Experiment", but anyhow I hope that that experiment is history now.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Michael Richardson <[email-masked]>
Date: Sun, 11 Nov 2018 13:41:56 -0500

Job Snijders <[email-masked]> wrote:
    > people getting home for a full weekend of downtime..

    > I see no risk of “the Thursday becoming the new Friday”, to me the
    > slippery slope argument makes no sense without supporting data.

+1

Friday meetings can be effective if groups decide well enough ahead of time
that they want to do so, and need 3-4+ hours of meeting time.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Sun, 11 Nov 2018 13:43:47 -0500

Kathleen Moriarty <[email-masked]> wrote:
    > I was disappointed by the number of overlapping sessions for security
    > and having to choose between working group sessions that I would have
    > liked to attend.  This did impact some working groups that suffered
    > from light attendance that included having less regular participants.

I had a similar number of conflicts this past week as previous IETFs.
Typically this is at least four significant conflicts, and 4 or 5
conflicts where I'd like to know what is going on some new group
(i.e. wugh), but I can't because I have to be elsewhere.

We need to reduce the number of WGs as well.

---

From: Yoav Nir <[email-masked]>
Date: Sun, 11 Nov 2018 21:08:17 +0200

> On 11 Nov 2018, at 20:41, Michael Richardson <[email-masked]> wrote:
> 
> 

Groups don’t decide anything. If 1-2 key contributors decide that since nothing is happening at the IETF on Friday they’re going home, then you can’t do it on Friday.  If they had stayed at home they might join remotely (assuming that was available) but since they are traveling, they just can’t participate. 

I think this experiment has failed. I suppose it’s possible that given 1-2 more times the community will manage to make it work, but if it’s repeated in 104, I just don’t see the point of planning to stay on Friday.  At least not for doing work.

Yoav

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 12 Nov 2018 08:29:50 +1300

> We need to reduce the number of WGs as well.

One of the IETF natural constants that I have never properly understood
is that the number of WGs ~= 120 over many years. But just to quote
from my public input to NomCom (draft-carpenter-community-leaders):

   We expect the leaders not to work too hard.  The IESG in particular
   works just as hard as it makes itself work.  More precisely, today's
   IESG defines the work load for its successors, by approving WG
   charters.  If fewer WGs are approved or renewed today, there will be
   fewer drafts to process in two years' time.  We expect the IESG to
   say "no" quite often.  In the case of BOFs and workshops, we also
   expect the IAB to recommend "no" quite often.  Of course, the "no"
   should be clearly explained, and rooted in community consensus and
   technical evaluations
 
If we as a community don't get better at saying "no" this problem
will never go away.

    Brian

---

From: Jared Mauch <[email-masked]>
Date: Sun, 11 Nov 2018 15:10:24 -0500

> On Nov 11, 2018, at 2:29 PM, Brian E Carpenter <[email-masked]> wrote:
> 

I can think of a few WGs that are well intentioned but should likely
just go away or be merged.  Some examples, tictoc should be merged with NTP
or just become the time-wg or something similar.  Captive portal is a
problem I care about as a traveller because the variety of interactions
with the hotels/airplanes/airports is all different and should be standard
but different ones have different reasons for working the way they do and
I do not expect them to standardize this to be honest.  There’s no value
for them to interact with the IETF.

From attending homenet this week there may be some things of value to come
out of it, but as most people don’t have significant options nor do they
_want_ to have this complexity in their home network (they just want to consume
the internet, not orchestrate it all) it seems like perhaps a problem of
consuming space because you can, not because it’s a good idea.

There’s also some significant issues with the overlap and lack of interest
between areas such as from network operator things like GROW and transport
area changes.  Due to application and transport layer problems many operators
have deployed mitigations to keep their networks functioning.  The transport area
folks are very dismissive of the reasons the operators have done this in some
of the side conversations I’ve had and I fear the gap within the IETF
and fortress walls will be built taller vs talking amongst ourselves better.

We don’t have infinite time to review each others work and I suspect that most
folks are interested in this but honestly don’t have the time/resources to read
all the work that comes up for IETF LC.  I certainly don’t, nor do I expect most
other people will either.

- Jared

---

From: Lars Eggert <[email-masked]>
Date: Mon, 12 Nov 2018 14:30:44 +0200

Hi,

> having a good Friday meeting every time.

same here. The meeting is long enough already, since it now effectively starts on Saturday (thanks to the hackathon, which I find very useful and will attend).

Add to that that side meetings that I might have stuck around for (the joint datacenter meeting with the IEEE) decided to not even use the opportunity and instead decided to meet on Sunday...

Lars

---

From: Russ Housley <[email-masked]>
Date: Mon, 12 Nov 2018 07:39:24 -0500

> Add to that that side meetings that I might have stuck around for (the joint datacenter meeting with the IEEE) decided to not even use the opportunity and instead decided to meet on Sunday...

Joint activities with IEEE 802 were scheduled before the IESG announced the Friday experiment.  Anyway, even if it was known, the point was to use the weekend between the IETF and IEEE 802 meetings to allow participates in both communities to collaborate.

Russ

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 12 Nov 2018 21:03:32 +0800

Lars,

The datacenter session was on Saturday and well worth staying for.

All of the slides are online at
https://1.ieee802.org/802-nendica/802-ietf-workshop-data-center-bangkok/ if
you would like to download them.

Cheers,
Andy

On Mon, Nov 12, 2018 at 8:40 PM Russ Housley <[email-masked]> wrote:

> Lars:
>
>
> Add to that that side meetings that I might have stuck around for (the
> joint datacenter meeting with the IEEE) decided to not even use the
> opportunity and instead decided to meet on Sunday...
>
>
> Joint activities with IEEE 802 were scheduled before the IESG announced
> the Friday experiment.  Anyway, even if it was known, the point was to use
> the weekend between the IETF and IEEE 802 meetings to allow participates in
> both communities to collaborate.
>
> Russ
>
>

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 12 Nov 2018 14:03:51 +0100

+1

As one of the few in this thread who seemed to have actually stayed 
through Friday (after 10 days in Asia BTW) and attended some of these 
meetings, I wouldn’t call the experiment a failure.

It required some coordination between groups, resulting in a nice stream 
of discussion of new ideas in a reasonably well-scoped context. Not sure 
we would have achieved that just on the side of the normal schedule.

I agree that Friday may not be the best day.

On that topic: Since we are now starting on Saturday (which seems to be 
useful), the IETF is often killing two weekends for at least some of us. 
With different company policies for (not) compensating for 
weekend-travel/work, this could be a problem from a family-friendliness 
perspective.

Have we considered to have the meetings go from Wed to Wed (or Thurs to 
Thurs)? It would allow people to avoid weekend travel (plus shift the 
flights to less popular days, thus reducing cost and increasing upgrade 
probabilities).

Surely, we will soon find reasons to fill the Mondays/Tuesdays before 
and the days after, but maybe still worth considering…

Cheers,
Dirk

---

From: Yoav Nir <[email-masked]>
Date: Mon, 12 Nov 2018 22:38:09 +0200

> On 12 Nov 2018, at 15:03, Dirk Kutscher <[email-masked]> wrote:
> 
> On that topic: Since we are now starting on Saturday (which seems to be useful), the IETF is often killing two weekends for at least some of us. With different company policies for (not) compensating for weekend-travel/work, this could be a problem from a family-friendliness perspective.
> 
> Have we considered to have the meetings go from Wed to Wed (or Thurs to Thurs)? It would allow people to avoid weekend travel (plus shift the flights to less popular days, thus reducing cost and increasing upgrade probabilities).

That would make the meeting less work-friendly.

To get to the meeting Wednesday morning, you would need to miss at least part of Tuesday if the meeting is in your region, and probably all of Tuesday and maybe even Monday. So that week is gone. On the following week, you might be able to make it to work on Thursday if the meeting is in your region, but only on Friday otherwise. 

So this proposal kills two weeks at work, making it less likely for us corporate folks to be able to attend.

Yoav

---

From: Mary B <[email-masked]>
Date: Mon, 12 Nov 2018 15:07:43 -0600

I also think this (Wed-Wed) would be much less friendly to newcomers that
aren't yet active in a lot of WGs.   It's not a majority of participants
that attend Sat-Fri right now, is it (realizing of course that some venues
do require already leaving mid-week to be available for Sunday am
meetings).

Mary.

On Mon, Nov 12, 2018 at 2:38 PM Yoav Nir <[email-masked]> wrote:

> To get to the meeting Wednesday morning, you would need to miss at least
> part of Tuesday if the meeting is in your region, and probably all of
> Tuesday and maybe even Monday. So that week is gone. On the following week,
> you might be able to make it to work on Thursday if the meeting is in your
> region, but only on Friday otherwise.
>

---

From: "Aaron Falk" <[email-masked]>
Date: Mon, 12 Nov 2018 16:45:19 -0500

On 10 Nov 2018, at 4:14, Andrew G. Malis wrote:

> one, thought that it was a resounding failure.

Thanks, Andy.  I had meant to bring this up at the plenary but this is 
better.  I spent Friday sleeping and sightseeing, which was nice but I'd 
rather have had an extra 60 minutes for my working group.  IMO, an 
already small IETF lost critical mass for friday and it wasn't 
successful.

Nevertheless, I do agree we should continue to keep an open mind and 
experiment with tweaks to the meeting format.  For myself, I'd have 
spoken against this beforehand given the opportunity.  Perhaps poll 
testing some ideas would be helpful to the folks doing the planning.

This discussion prods me to share some additional thoughts. There seems 
to be a growing consensus that online tools are making virtual interims 
quite productive, especially for groups that are already on-track.  
TAPS, eg, has had two quite useful interims.  I can envision a future 
where we might make virtual meetings our primary real-time venue 
(happily relaxing the conflict constraints) and use the f2f meetings for 
a smaller number of less settled topics: BoFs, plenary discussion, 
information sharing (like DISPATCH, TSVAREA, or SAAG), or cross-domain 
(like QUIC or TLS) discussions.  I think it would be a good thing if we 
could find a way to reduce the number of tracks to get a bit more 
'shared state' in the community.  Maybe a fantasy...

--aaron

---

From: Melinda Shore <[email-masked]>
Date: Mon, 12 Nov 2018 16:33:20 -0900

On 11/12/18 12:45 PM, Aaron Falk wrote:
> already small IETF lost critical mass for friday and it wasn't successful.

Right.  I really appreciated having more unstructured time
during the meeting, but it was clearly the case that many
people felt that the meeting ended on Thursday and consequently
left early.  (Also, ob-anecdotes-are-not-data but I had fewer
conflicts than usual, although I was also busier than usual).
I hope that there's support for trying again, with either a
mid-week day set aside for unstructured time, or some session
slots left unscheduled.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 13 Nov 2018 01:47:37 +0000

> mid-week day set aside for unstructured time, or some session

Me too.

Two suggestions:

1) IESG create a wiki page the community can muck about
with to outline various suggestions and who likes which.
IESG pick whatever they think is worth trying whenever
they wanna try something.

and/or

2) Hackathon runs Sun-Wed, mornings only. Sunday otherwise
as-is. No WG sessions in the mornings Mon-Wed. WG sessions
in the afternoons Mon-Wed as usual. Thurs, all WG sessions
and plenary stuff. We reduce the number of WGs meeting in
parallel - not sure how much. Everyone gets to go home on
Friday ('less they've organised something else themselves.)
Network goes away Friday lunchtime(ish).

Cheers,
S.

PS: I prefer #2, and not least because I could stay in
bed longer - I'd also support any variations on #2 that
maintain that property:-)

---

From: Lou Berger <[email-masked]>
Date: Tue, 13 Nov 2018 08:58:04 +0700

I think it would be good to understand how/if the experiment influenced 
attendance.

I know there is a good community discussion that can/should be had on 
why attendance was so low in Bangkok, and that how the experiment may or 
may not have contributed to this is just part of that discussion.

Even though we don't have a BCP on ietf meeting week structure, I'd 
still be interested in hearing why BCP93 wasn't used for the process 
experiment. Had it been, we would have a better idea of what metrics 
should be collected and would be used to gauge success of this experiment.

Lou

FWIW my personal feeling is that IETFs are a huge investment of time and 
resources, and shortening our face-to-face time diminishes the "ROI" on 
attendance.  Informal meeting time *is* very important, but parallel 
side/informal meetings have always taken place and won't/don't benefit 
from a dedicated day to warrant impacting formal meeting time.

If the meeting is too long for the hackathon+ietf attendees, I 
personally would love to see an experiment that runs the hackaton all 
week in parallel with the meetings -- and do a  hackathon 'prize' award 
in the IETF plenary.

---

From: Paul Wouters <[email-masked]>
Date: Tue, 13 Nov 2018 09:14:47 +0700

> On Nov 13, 2018, at 08:58, Lou Berger <[email-masked]> wrote:
> 
>  and do a  hackathon 'prize' award in the IETF plenary.

I dislike the “competition” part of the hackathon. The goal is to write running code. One group is not “better” than another. I wish it would stop running a “competition” and stop announcing “winners”.

Paul

---

From: Ted Lemon <[email-masked]>
Date: Mon, 12 Nov 2018 21:49:58 -0500

Yup. The announcements in general are pretty distracting.

On Mon, Nov 12, 2018 at 9:15 PM Paul Wouters <[email-masked]> wrote:

> I dislike the “competition” part of the hackathon. The goal is to write
> running code. One group is not “better” than another. I wish it would stop
> running a “competition” and stop announcing “winners”.
>
> Paul
>

---

From: Lou Berger <[email-masked]>
Date: Tue, 13 Nov 2018 11:31:41 +0700

funny - I'd go the other way -- (cash or meeting fee credit) prize for 
hackaton or codesprint opensource work that benefits the IETF or its 
protocols, together with 10 minute presentation showcasing the work at 
the plenary.

On 11/13/2018 9:49 AM, Ted Lemon wrote:
> On Mon, Nov 12, 2018 at 9:15 PM Paul Wouters <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>
>     > On Nov 13, 2018, at 08:58, Lou Berger <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     I dislike the “competition” part of the hackathon. The goal is to
>     write running code. One group is not “better” than another. I wish
>     it would stop running a “competition” and stop announcing “winners”.
>
>     Paul
>

---

From: Paul Wouters <[email-masked]>
Date: Mon, 12 Nov 2018 23:34:44 -0500 (EST)

On Tue, 13 Nov 2018, Lou Berger wrote:

> protocols, together with 10 minute presentation showcasing the work at the 
> plenary.

You quickly run into "let's not let [TLS|DNS] win again" kind of
workarounds. Also, I've done various interop tests with proprietary
implementations, but don't think we should give money to Big Vendors
for winning :)

Paul

---

From: Lou Berger <[email-masked]>
Date: Tue, 13 Nov 2018 12:03:26 +0700

> implementations, but don't think we should give money to Big Vendors

couldn't agree more and is exactly why I added opensource as a caveat.

---

From: Lars Eggert <[email-masked]>
Date: Tue, 13 Nov 2018 08:38:03 +0200

> Yup. The announcements in general are pretty distracting.

Fully agreed. Basically, they kill over an hour of otherwise productive time.

If there have to be announcements, maybe only let those projects speak for whom it's their first time, or for whom the selection panel has decided that they have something other to share that is worthwhile the disruption.

Or we could all just stop uploading reports :-)

Lars

> 
> On Mon, Nov 12, 2018 at 9:15 PM Paul Wouters <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> > On Nov 13, 2018, at 08:58, Lou Berger <[email-masked] <mailto:[email-masked]>> wrote:
> >

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Nov 2018 17:48:54 +1100

> Fully agreed. Basically, they kill over an hour of otherwise productive time.

Same.  I appreciate that it is necessary to thank sponsors and the
like, but these overheads could be greatly reduced or eliminated.

Why can't they all be like the Cisco host talk at the plenary?

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 13 Nov 2018 13:55:09 +0700

+1 to let's not do presentations at the end of the hackathon.  If we want
to thank sponsors, there could be a no-audio presentation that runs in a
loop for a couple of hours on Sunday afternoon.

I will take a moment to thank the organizers for the excellent arrangements
in Bangkok.  The meals/snacks/drinks options alone were spectacular.

---

From: "Valery Smyslov" <[email-masked]>
Date: Tue, 13 Nov 2018 11:11:32 +0300

> > My personal hope is that this experiment will not be repeated, and we go back to our previous meeting

Me too. In Bangkok there were more agenda conflicts than usual (up to three parallel sessions in SEC area),
I believe it was due to the experiment. And for me (as for many others) the Friday has become
an unexpected vacation day.

Regards,
Valery.

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 13 Nov 2018 15:34:29 +0700

FWIW, I liked having the IETF be a day shorter. I usually end up flying out
on Saturday after IETF, which eats into two weekends since I'm also at the
hackathon the weekend before. With the shorter IETF, I can fly out on
Friday and not lose two weekends. I travel a fair bit (as plenty of us do),
and I and my family are grateful to not have me be on the road for another
half-weekend.

I don't think the agenda conflicts are necessarily due to the shorter IETF,
though I imagine that the likelihood is probably higher. I've had terrible
conflicts in past IETFs. It just happens sometimes.

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 13 Nov 2018 06:29:08 -0800

+1 on the presentations and competition aspect. I also don't think we need
the "here is how to find a team" stuff...

-Ekr

On Mon, Nov 12, 2018 at 10:55 PM Jana Iyengar <[email-masked]> wrote:

> I will take a moment to thank the organizers for the excellent
> arrangements in Bangkok.  The meals/snacks/drinks options alone were
> spectacular.
>

---

From: Job Snijders <[email-masked]>
Date: Tue, 13 Nov 2018 15:52:41 +0100

On Tue, Nov 13, 2018 at 09:14:47AM +0700, Paul Wouters wrote:
> write running code. One group is not “better” than another. I wish it
> would stop running a “competition” and stop announcing “winners”.

I agree, "Hackathons" shouldn't be viewed as a competition. People work
on different projects and all of the projects are to the benefit of us
all. It makes no sense to view it in context of 'winning' - how can DNS
and TLS compete? We need both.

    https://hackathon.guide/

Kind regards,

Job

---

From: Randy Bush <[email-masked]>
Date: Wed, 14 Nov 2018 12:14:04 +0900

> Joint activities with IEEE 802 were scheduled before the IESG
> announced the Friday experiment.  Anyway, even if it was known, the
> point was to use the weekend between the IETF and IEEE 802 meetings to
> allow participates in both communities to collaborate.

the ieee/ietf thing worked for me.  friday holiday did not.

randy

---

From: Russ Housley <[email-masked]>
Date: Tue, 13 Nov 2018 22:21:15 -0500

> allow participates in both communities to collaborate.

I stayed for the IEEE 802 meeting.  I got a lot of positive feedback for the weekend sessions.  Many are saying that the two should be back-to-back every two or three years to keep the collaboration and coordination going.

Russ

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 14 Nov 2018 11:26:07 +0800

Meeting jointly on Saturday and Sunday with the IEEE worked great, IMHO.
Both meetings were useful and productive, and Randy gave an entertaining
talk! :-) I hope we have the chance to do something like this again in the
future.

Cheers,
Andy

> the ieee/ietf thing worked for me.  friday holiday did not.
Sent from my iPhone, please excuse autocorrects

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 14 Nov 2018 13:01:06 +0000

+1
(As others are saying, talks/opportunity to share perspectives directly at mike vs. formal liaisons was great. We should consider other groups too - 3GPP, Openfoo, ...)

Sent from my iPhone

---

From: Michael Richardson <[email-masked]>
Date: Wed, 14 Nov 2018 09:30:32 -0500

> I stayed for the IEEE 802 meeting.  I got a lot of positive feedback
    > for the weekend sessions.  Many are saying that the two should be
    > back-to-back every two or three years to keep the collaboration and
    > coordination going.

That's a great idea, but if we do this, then we need to move the Hackathon
into the intervening weekend, and basically move everything towards the end
of the week.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Dr. Pala" <[email-masked]>
Date: Wed, 14 Nov 2018 06:47:41 -0700

+1

On top of what Kathleen, I also want to add that reading the notes and/or watching the video (which is a great resource) does not allow you to participate in the discussion and provide your humming :-)

Cheers,
Max

> On Nov 10, 2018, at 8:47 PM, Kathleen Moriarty <[email-masked]> wrote:
> 
> Hello,
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 14 Nov 2018 16:57:57 +0100

> into the intervening weekend, and basically move everything towards the end

I don’t understand — for those who want to go both to hackathon and the IEEE joint meetings, this is a non-starter, and for both those that do and those that don’t, the arrangement in Bangkok was perfect.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Wed, 14 Nov 2018 11:10:51 -0500

> I don’t understand — for those who want to go both to hackathon and the
    > IEEE joint meetings, this is a non-starter, and for both those that do
    > and those that don’t, the arrangement in Bangkok was perfect.

It's just too long to be away, and fails to bring the IEEE people
into the Hackathon.

Imagine we moved the Hackathon to Thursday starting at 5pm (to 9pm)
[because it as you said, it takes a bunch of time just to setup], all of
Friday, and then into Saturday. (and maybe even Sunday).

The Hackathon doesn't have to be *contiguous* for everyone, and one can
wander off to 3-4hr joint meetings easily in my opinion.

{I acknowledge that there is great value in having the Hackathon before the
IETF WG meetings}

Another idea is to have IEEE followed by Hackathon followed by IETF.
That might make both of us happy?

---

From: Victor Kuarsingh <[email-masked]>
Date: Wed, 14 Nov 2018 11:14:28 -0500

I found the experiment to be valuable - we did learn a few things.
Since perfection is not the goal, I think trying to understand how we
would function with a reduction to four main days was worthwhile.
That said, it appears the downsides (we seem to not deal well with the
compressed schedule well) may outweigh the upsides.

My personal opinion is that the main goal of the face-to-face meetings
is to meet face-to-face.  So attempting to knock off a day seems to
not be worthwhile if it means we risk significant overlap and
conflicts for the days we are at the IETF.    I guess for those who
don't want to be away from home too long, we just need to accept that
it's not going to be prefect.   I know other organizations seem to
often have some flex to end early to allow folks to get home before
the weekend starts, but sacrificing the main point of getting together
(to get work done) - does not seem to be the right compromise.

regards,

Victor K

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 14 Nov 2018 10:20:50 -0600

> (to get work done) - does not seem to be the right compromise.
+1 for returning to the previous timing and also not changing it at all.

Behcet

---

From: <[email-masked]>
Date: Thu, 15 Nov 2018 13:21:48 +0000

Hi Andy,

thanks for bringing this up. I also had a bunch of conflicts (more than usual) due to the new agenda. I think we were also lucky due to the fact that many people had flights late in the evening or close to midnight and were able to attend the whole Thursday. But this depends on the location; with a location were most of the flights are leaving during the day I see the risk that people will leave on Thursday around noon which is probably not what we want. Also with the 2.5h slots disappearing the chairs have the choice either to reduce the time to a 2h slot or to allocate 3h (in the first case you lose 30 minutes of discussion time; in the second case you might steal 30 minutes from another WG).  I am also in favor of going back to the old agenda style.

Regards

Nic

Von: ietf <[email-masked]> Im Auftrag von Andrew G. Malis
Gesendet: Samstag, 10. November 2018 10:15
An: IETF Discussion <[email-masked]>
Betreff: The Friday Experiment

Cheers,
Andy

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 19 Nov 2018 22:17:04 +0000

Thanks for the feedback on the hackathon. I commented on the competition part in another thread.

As for finding a team and project presentations, we did away with the project specific presentations/pitches at the beginning of the hackathon and replaced with the use of the wiki. This reduced the amount of time spent at the beginning of the hackathon considerably. At IETF 102 and 103, we announced each time and had them raise their hand to show where they were. This took a few minutes at most. Are you saying this is not helpful?

The entire kickoff presentation took roughly 15 minutes. For many people, this was probably not a great use of their time. However, keep in mind that we had 80 people at the hackathon for whom this was their first IETF meeting, and over 120 for which this was their first IETF hackathon. I hope and expect it was a helpful for them.

At the end of the hackathon, we had 3-minute presentations by all teams that wished to share a summary of what they did. This is entirely optional, yet most teams chose to do it. It took about 90 minutes, which is admittedly a long time. At IETF 101, I proposed not having these presentations, but when I polled the room the vast majority of participants raised their hands in favor of having them. These presentations are a way to record and share what was accomplished and learned at the hackathon. I believe this is valuable, even if not every presentation is of interest to everyone in attendance.

Cheers,
Charles

From: ietf <[email-masked]> on behalf of Eric Rescorla <[email-masked]>
Date: Tuesday, November 13, 2018 at 6:30 AM
To: Jana Iyengar <[email-masked]>
Cc: Paul Wouters <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Hackathon (was: Re: The Friday Experiment)

+1 on the presentations and competition aspect. I also don't think we need the "here is how to find a team" stuff....

-Ekr

On Mon, Nov 12, 2018 at 10:55 PM Jana Iyengar <[email-masked]<mailto:[email-masked]>> wrote:
+1 to let's not do presentations at the end of the hackathon.  If we want to thank sponsors, there could be a no-audio presentation that runs in a loop for a couple of hours on Sunday afternoon.

I will take a moment to thank the organizers for the excellent arrangements in Bangkok.  The meals/snacks/drinks options alone were spectacular.

On Tue, Nov 13, 2018 at 1:49 PM Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:
On Tue, Nov 13, 2018 at 5:38 PM Lars Eggert <[email-masked]<mailto:[email-masked]>> wrote:
> On 2018-11-13, at 4:49, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

---

From: Paul Wouters <[email-masked]>
Date: Tue, 20 Nov 2018 09:09:22 +0700

> On Nov 20, 2018, at 05:17, Charles Eckel (eckelcu) <[email-masked]> wrote:
>  
>  At IETF 102 and 103, we announced each time and had them raise their hand to show where they were. This took a few minutes at most. Are you saying this is not helpful?

It is especially for Newcomer’s I guess. But also nice to know what is happening. Although I don’t think I have ever been at the start of a hackathon to see these.

> 
>  At the end of the hackathon, we had 3-minute presentations by all teams that wished to share a summary of what they did. This is entirely optional, yet most teams chose to do it. It took about 90 minutes, which is admittedly a long time.

There were 30 teams?

An idea would be to have a max of three slides. What is the project worked on in 1 slide, what was the goal, what was achieved.

> At IETF 101, I proposed not having these presentations, but when I polled the room the vast majority of participants raised their hands in favor of having them. These presentations are a way to record and share what was accomplished and learned at the hackathon. I believe this is valuable, even if not every presentation is of interest to everyone in attendance.

Yes I agree. My earlier comments was only about disliking the contest. I do like the short presentations.

Paul

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 20 Nov 2018 15:10:51 +0000

From: Paul Wouters <[email-masked]>
Date: Monday, November 19, 2018 at 6:11 PM
To: Charles Eckel <[email-masked]>
Cc: Eric Rescorla <[email-masked]>, Jana Iyengar <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Hackathon (was: Re: The Friday Experiment)

On Nov 20, 2018, at 05:17, Charles Eckel (eckelcu) <[email-masked]<mailto:[email-masked]>> wrote:

There were 30 teams?

Yes, about 25 or which presented. Each had 3 minutes and generally presented what you suggest here. Transitions between teams makes a bit of time as well.

Great, and thanks for sharing your thoughts. The hackathon continues to evolve as it grows. Constructive feedback and suggested improvements are welcome and valued.

Cheers,
Charles

Paul

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 20 Nov 2018 12:39:01 -0500

On Tue, Nov 20, 2018 at 10:11 AM Charles Eckel (eckelcu) <[email-masked]>
wrote:

>
>
> *From: *Paul Wouters <[email-masked]>
> *Date: *Monday, November 19, 2018 at 6:11 PM
> *To: *Charles Eckel <[email-masked]>
> *Cc: *Eric Rescorla <[email-masked]>, Jana Iyengar <[email-masked]>, "
> [email-masked]" <[email-masked]>
> *Subject: *Re: Hackathon (was: Re: The Friday Experiment)
>
>
>
>
>
>
>  At IETF 102 and 103, we announced each time and had them raise their hand
> to show where they were. This took a few minutes at most. Are you saying
> this is not helpful?
>
>
>
> It is especially for Newcomer’s I guess. But also nice to know what is
> happening. Although I don’t think I have ever been at the start of a
> hackathon to see these.
>
>
>
>
>
>  At the end of the hackathon, we had 3-minute presentations by all teams
> that wished to share a summary of what they did. This is entirely optional,
> yet most teams chose to do it. It took about 90 minutes, which is
> admittedly a long time.
>
>
>
> There were 30 teams?
>
>
>
> An idea would be to have a max of three slides. What is the project worked
> on in 1 slide, what was the goal, what was achieved.
>
>
>
> Yes, about 25 or which presented. Each had 3 minutes and generally
> presented what you suggest here. Transitions between teams makes a bit of
> time as well.
>
> At IETF 101, I proposed not having these presentations, but when I polled
> the room the vast majority of participants raised their hands in favor of
> having them. These presentations are a way to record and share what was
> accomplished and learned at the hackathon. I believe this is valuable, even
> if not every presentation is of interest to everyone in attendance.
>
>
>
> Great, and thanks for sharing your thoughts. The hackathon continues to
> evolve as it grows. Constructive feedback and suggested improvements are
> welcome and valued.
>

I have gone in toward the end just to see some of the presentations so I
would know what WGs were implementing or testing for the ones I was
interested in seeing.  I can see the point that 90 minutes is long, but
there is some value in it.

Best regards,
Kathleen

-- 

Best regards,
Kathleen

---

From: Ted Lemon <[email-masked]>
Date: Tue, 20 Nov 2018 17:23:47 -0500

> there is some value in it.

I agree that there's value in it, but not that it needs to be compulsory in
the sense that it is now.   I suggested to Charles privately that it might
make sense to do it during the hackdemo happy hour, because then it
wouldn't cut into hackathon time, people who really aren't interested could
give it a miss, and it would probably draw people like you who just want to
see what happened and how it went.