Subject: Re: [dmarc-ietf] Last Call: <draft-ietf-dmarc-rfc7601bis-03.txt> (Message Header Field for Indicating Message Authentication Status) to Proposed Standard

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sat, 3 Nov 2018 13:44:39 +0900

On Sat, Oct 27, 2018 at 2:19 AM Scott Kitterman <[email-masked]> wrote:

> As written, is it appropriate for this draft to obsolete RFC 7601?  Should
> it
> update it instead?
>
> In the Email Authentication Parameters registry [1] there are 63
> parameters
> that use RFC 7601 as the reference for their definition.  They are not
> replicated in this document.
>
> As it stands, that would result in the registry using a historic document
> for
> definitions in an active registry.  Is that OK?
>
> Assuming it's not (because if it is, then there's no issue to discuss),
> there
> are two solutions I can suggest:
>
> 1.  Change this draft to update RFC 7601 rather than obsolete it.
> 2.  Add the missing parameters from RFC 7601 to this draft and update the
> registry entries to use it as the reference.
>
> I think the former is easier and the latter a bit cleaner for implementers
> to
> have fewer documents to sort through.  I don't have an opinion on which
> would
> be better.
>

Yeah, good catch.

I'm inclined to change this to "updates" rather than "obsoletes".  It's
otherwise a lot of stuff to copy over just for the sake of making keeping
this as an omnibus document.  I'll do that unless someone makes an argument
for the other choice.

Are there any registry entries you think that should reference both
documents?  IANA lets us do that for registrations for which an implementer
should be pointed to more than one reference.

-MSK

---

From: Scott Kitterman <[email-masked]>
Date: Sat, 03 Nov 2018 05:18:19 +0000

>should be pointed to more than one reference.

I don't think so.

Scott K

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 15 Nov 2018 03:44:10 +0000

On November 3, 2018 5:18:19 AM UTC, Scott Kitterman <[email-masked]> wrote:
>>> 2.  Add the missing parameters from RFC 7601 to this draft and
>update
>>the

For avoidance of doubt, draft-ietf-dmarc-rfc7601bis-04 has been posted.  It resolves my concern.

Scott K