Subject: [Ila] Fwd: New Version Notification for draft-herbert-ila-motivation-00.txt

From: Tom Herbert <[email-masked]>
Date: Mon, 22 Jan 2018 14:16:47 -0800

Hello,

I've posted a draft for problem areas, motivation, and use cases of
ILA. Please take a look. For the use cases, there are currently just
placeholders to add content. If you would like to contribute please
let me know!

Tom

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Mon, Jan 22, 2018 at 2:13 PM
Subject: New Version Notification for draft-herbert-ila-motivation-00.txt
To: Tom Herbert <[email-masked]>

A new version of I-D, draft-herbert-ila-motivation-00.txt
has been successfully submitted by Tom Herbert and posted to the
IETF repository.

Name:           draft-herbert-ila-motivation
Revision:       00
Title:          Identifier Locator Addressing: Problem areas,
Motivation, and Use Cases
Document date:  2018-01-22
Group:          Individual Submission
Pages:          17
URL:
https://www.ietf.org/internet-drafts/draft-herbert-ila-motivation-00.txt
Status:         https://datatracker.ietf.org/doc/draft-herbert-ila-motivation/
Htmlized:       https://tools.ietf.org/html/draft-herbert-ila-motivation-00
Htmlized:
https://datatracker.ietf.org/doc/html/draft-herbert-ila-motivation-00

Abstract:
   This document describes the problems, motivation, and use cases for
   Identifier-Locator Addressing.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Wed, 24 Jan 2018 20:27:59 +0000

Tom:

There are other documents in IETF that can be used as basis for use cases in your document.

The ICN for 5G I-D has mobility use cases . They are applicable for ILA as well.
https://tools.ietf.org/html/draft-ravi-icnrg-5gc-icn-00
 
Regarding Network Function virtualization, here is one I-D that has a good description of 
5G services based architecture even though it is focused on YANG models.
https://tools.ietf.org/html/draft-chin-nfvrg-cloud-5g-core-structure-yang-00

This document provides the ETSI NFV framework. 
https://www.ietf.org/id/draft-irtf-nfvrg-gaps-network-virtualization-08.txt

The network functions in 3GPP architecture will be implemented as VNFs and could consist of several
VNF components (VNFCs) that could be implemented at VMs or containers. This is the use case for 
VM/container mobility relevant to ILA.

Kalyani

-----Original Message-----
From: ila [mailto:[email-masked]] On Behalf Of Tom Herbert
Sent: Monday, January 22, 2018 5:17 PM
To: [email-masked]
Subject: [E] [Ila] Fwd: New Version Notification for draft-herbert-ila-motivation-00.txt

Hello,

I've posted a draft for problem areas, motivation, and use cases of ILA. Please take a look. For the use cases, there are currently just placeholders to add content. If you would like to contribute please let me know!

Tom

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Mon, Jan 22, 2018 at 2:13 PM
Subject: New Version Notification for draft-herbert-ila-motivation-00.txt
To: Tom Herbert <[email-masked]>

A new version of I-D, draft-herbert-ila-motivation-00.txt
has been successfully submitted by Tom Herbert and posted to the IETF repository.

Name:           draft-herbert-ila-motivation
Revision:       00
Title:          Identifier Locator Addressing: Problem areas,
Motivation, and Use Cases
Document date:  2018-01-22
Group:          Individual Submission
Pages:          17
URL:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_internet-2Ddrafts_draft-2Dherbert-2Dila-2Dmotivation-2D00.txt&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-F864AK6wkXjJpYYA7n3ho_M&s=CtggSNAD63b34w8Fiik4Iy2PJKinTg_4_j5SgoIVZNE&e=
Status:         https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dherbert-2Dila-2Dmotivation_&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-F864AK6wkXjJpYYA7n3ho_M&s=a46zGiTnUWsEjoLPgmowM6oxqEvc72EheFJ95NVZoX0&e=
Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dherbert-2Dila-2Dmotivation-2D00&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-F864AK6wkXjJpYYA7n3ho_M&s=ulaeasv1BEkZKjhMbRrNfmfc0OeASvASVtLuGHJauBY&e=
Htmlized:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dherbert-2Dila-2Dmotivation-2D00&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-F864AK6wkXjJpYYA7n3ho_M&s=VxKdpvAtML6hx_YSJvwTk8HbEGokhg-ggKHeHoHlHus&e=

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
ila mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ila&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-F864AK6wkXjJpYYA7n3ho_M&s=BED8duZn-Ncr_o3-UfRWyUJBrmHp-9VJpHFVY3919_M&e=

---

From: Tom Herbert <[email-masked]>
Date: Wed, 24 Jan 2018 15:02:28 -0800

Kalyani,

Thanks for  posting this. This raises some interesting questions especially
in the differences of use cases.

The goal of identifier/locator split in network and datacenter
virtualization is to create network overlays so that packets can be
forwarded to virtual nodes. Other than a tenant ID (VNID) and maybe some
security bits to ensure isolation between tenants, there's not a whole lot
more that needs to be included in the packets to perform the primary
function.

The mobile use case seems to be different, at least on the surface.
Services and QoS are being built in to core architectures like 5G.
Identifier/locator split is still fundamental for mobility, but there also
the need for the framework for the services. The question is whether
routing and services need to be intertwined into the same IP layer. This
seems to be the intent of SR, it basically allows a service function chain
to be expressed in segments along with locator forwarding. In ILA (probably
LISP, ILNP, most encapsulations as well) routing is considered separate
from services. Service can be provide via SFC or other layer 2
functionality. In that model, the mobile use case isn't all that different
for ILA (a good property for leveraging a common protocol).

Thoughts?

Tom

On Wed, Jan 24, 2018 at 12:27 PM, Bogineni, Kalyani <
[email-masked]> wrote:

> I've posted a draft for problem areas, motivation, and use cases of ILA.
> Please take a look. For the use cases, there are currently just
> placeholders to add content. If you would like to contribute please let me
> know!
>
> Tom
>
>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_internet-2Ddrafts_draft-2Dherbert-2Dila-2Dmotivation-2D00.txt&d=
> DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=
> IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUd
> pT&m=ZtuvtiaSSzJYxd7HqkZ-F864AK6wkXjJpYYA7n3ho_M&s=
> CtggSNAD63b34w8Fiik4Iy2PJKinTg_4_j5SgoIVZNE&e=
> Status:         https://urldefense.proofpoint.com/v2/url?u=https-3A__
> datatracker.ietf.org_doc_draft-2Dherbert-2Dila-2Dmotivation_&d=DwICAg&c=
> udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=
> IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUd
> pT&m=ZtuvtiaSSzJYxd7HqkZ-F864AK6wkXjJpYYA7n3ho_M&s=
> a46zGiTnUWsEjoLPgmowM6oxqEvc72EheFJ95NVZoX0&e=
> Htmlized:       https://urldefense.proofpoint.
> com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dherbert-
> 2Dila-2Dmotivation-2D00&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LR
> xpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_
> YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-
> F864AK6wkXjJpYYA7n3ho_M&s=ulaeasv1BEkZKjhMbRrNfmfc0OeASvASVtLuGHJauBY&e=
> Htmlized:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__
> datatracker.ietf.org_doc_html_draft-2Dherbert-2Dila-
> 2Dmotivation-2D00&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LR
> xpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_
> YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-
> F864AK6wkXjJpYYA7n3ho_M&s=VxKdpvAtML6hx_YSJvwTk8HbEGokhg-ggKHeHoHlHus&e=
>
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_ila&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LR
> xpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_
> YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-
> F864AK6wkXjJpYYA7n3ho_M&s=BED8duZn-Ncr_o3-UfRWyUJBrmHp-9VJpHFVY3919_M&e=
>

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Sun, 28 Jan 2018 18:01:21 +0000

Tom:

Service function chaining is on the SGi interface in 4G and on N6 interface in 5G. Each operator decides whether to
deploy mobile core network as an overlay on IP/MPLS network or integrated. Standards should allow both deployment
options. Similarly operators could choose to implement several of the SGI/N6 functions into PGW/UPF.

In going through your document again, some comments:

Section 2.2: It appears that you are using ‘nodes’ for network elements/functions as well as for end device like UE in
3GPP terminology. Is your sentence “Mobility is likely a rate event….” related to network functions or to UEs?

Section 2.5: This section seems to be about mobility of UEs, but ‘node’ is used. Some clarification between the two sections
is needed.

Section 2.6.2: Relative to mobile traffic there is Uplink (UL) traffic and Downlink (DL) traffic. I think you need to address
caching relative to both UL and DL traffic. With anchor-less mobility, ILA-R will need to send the DL traffic to the correct
ILA-N/gNB.
In this section you describe a Pub/Sub model. Can it be implemented as RESTful APIs? 5G services based architecture
uses APIs from network functions. ILA can be incorporated in 5G services based architecture in one of two ways.
In the diagram below, I show ILA-DB connected via APIs to the services based functions and ILAMP between ILA-DB
and ILA-N/R. The SMF does not have interfaces to ILA-N/R. In the second model, ILA-N/R can also be connected to the
services based functions via APIs. Both of these seem to support the pub/sub model you describe in 2.6.2.

             +------+    +------+   +------+   +-----+  +-----+
             |NSSF|    |AUSF|   |UDM|   |NRF|  |NEF|
             +------+    +------+   +------+   +-----+  +-----+
          _____|______|______|_____|_____|______________
                                        |             |            |              |
                                   +------+    +-----+    +----+    +---------+
       ______________|AMF|    |SMF|    |PCF|    |ILA-DB|
      |                           +------+    +-----+    +-----+    +--------+
      |                                 |                                 ____|__________
      N1                             N2                               |                           |
      |                                |                                 |                           |
    +---+                         +-------+                   +------+                   +------+                 +----+
    |UE|_____NR_____|(R)AN|____N3___|ILA-N|____N9___|ILA-R|___N6___|DN|
    +---+                         +-------+                   +------+                   +------+                 +----+

This thread may need to be moved to discussion on architectural topics.

Kalyani

From: Tom Herbert [mailto:[email-masked]]
Sent: Wednesday, January 24, 2018 6:02 PM
To: Bogineni, Kalyani <[email-masked]>
Cc: [email-masked]
Subject: Re: [E] [Ila] Fwd: New Version Notification for draft-herbert-ila-motivation-00.txt

Kalyani,

Thanks for  posting this. This raises some interesting questions especially in the differences of use cases.

The goal of identifier/locator split in network and datacenter virtualization is to create network overlays so that packets can be forwarded to virtual nodes. Other than a tenant ID (VNID) and maybe some security bits to ensure isolation between tenants, there's not a whole lot more that needs to be included in the packets to perform the primary function.

The mobile use case seems to be different, at least on the surface. Services and QoS are being built in to core architectures like 5G. Identifier/locator split is still fundamental for mobility, but there also the need for the framework for the services. The question is whether routing and services need to be intertwined into the same IP layer. This seems to be the intent of SR, it basically allows a service function chain to be expressed in segments along with locator forwarding. In ILA (probably LISP, ILNP, most encapsulations as well) routing is considered separate from services. Service can be provide via SFC or other layer 2 functionality. In that model, the mobile use case isn't all that different for ILA (a good property for leveraging a common protocol).

Thoughts?

Tom

On Wed, Jan 24, 2018 at 12:27 PM, Bogineni, Kalyani <[email-masked]<mailto:[email-masked]>> wrote:
Tom:

The ICN for 5G I-D has mobility use cases . They are applicable for ILA as well.
https://tools.ietf.org/html/draft-ravi-icnrg-5gc-icn-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dravi-2Dicnrg-2D5gc-2Dicn-2D00&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=tY-8-vy_qVFIf4O_vlYHQH9aVTml0fOe_7mTf8KzUqc&s=Ee9jVHhgxAEniWkFuGdAzxW_0Od8NK1pdQ1Xuva9Bvk&e=>

Regarding Network Function virtualization, here is one I-D that has a good description of
5G services based architecture even though it is focused on YANG models.
https://tools.ietf.org/html/draft-chin-nfvrg-cloud-5g-core-structure-yang-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dchin-2Dnfvrg-2Dcloud-2D5g-2Dcore-2Dstructure-2Dyang-2D00&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=tY-8-vy_qVFIf4O_vlYHQH9aVTml0fOe_7mTf8KzUqc&s=Nxy0ZejMchRagPmJBSs9W2Xrv_U8dUM-lpGxHYvN0wE&e=>

This document provides the ETSI NFV framework.
https://www.ietf.org/id/draft-irtf-nfvrg-gaps-network-virtualization-08.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_id_draft-2Dirtf-2Dnfvrg-2Dgaps-2Dnetwork-2Dvirtualization-2D08.txt&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=tY-8-vy_qVFIf4O_vlYHQH9aVTml0fOe_7mTf8KzUqc&s=8V6b45rFN3Ef7JvFIlUUMD29TVNajGYXXvFgwdHmVuc&e=>

Kalyani

-----Original Message-----
From: ila [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Tom Herbert
Sent: Monday, January 22, 2018 5:17 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [E] [Ila] Fwd: New Version Notification for draft-herbert-ila-motivation-00.txt

Hello,

Tom

---------- Forwarded message ----------
From:  <[email-masked]<mailto:[email-masked]>>
Date: Mon, Jan 22, 2018 at 2:13 PM
Subject: New Version Notification for draft-herbert-ila-motivation-00.txt
To: Tom Herbert <[email-masked]<mailto:[email-masked]>>

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=tY-8-vy_qVFIf4O_vlYHQH9aVTml0fOe_7mTf8KzUqc&s=TOwBNQGen-8GzyydswhD-MwpT2_hhU0zcbj792xLshU&e=>.

The IETF Secretariat

_______________________________________________
ila mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ila&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=ZtuvtiaSSzJYxd7HqkZ-F864AK6wkXjJpYYA7n3ho_M&s=BED8duZn-Ncr_o3-UfRWyUJBrmHp-9VJpHFVY3919_M&e=

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Mon, 29 Jan 2018 16:10:27 +0000

Seems like the ASCII diagram is not clear in some email formats. Here are

Hopefully these diagrams are better.

Services based 5G architecture

Two possible architectures for use of ILA in the 5G architecture.

Architecture 1:

Architecture 2:

Kalyani

From: Bogineni, Kalyani
Sent: Sunday, January 28, 2018 1:01 PM
To: Tom Herbert <[email-masked]>
Cc: [email-masked]; Bogineni, Kalyani <[email-masked]>
Subject: RE: [E] [Ila] Fwd: New Version Notification for draft-herbert-ila-motivation-00.txt

Tom:

Kalyani

From: Tom Herbert [mailto:[email-masked]]
Sent: Wednesday, January 24, 2018 6:02 PM
To: Bogineni, Kalyani <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [E] [Ila] Fwd: New Version Notification for draft-herbert-ila-motivation-00.txt

Kalyani,

Thoughts?

Tom

Kalyani

-----Original Message-----
From: ila [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Tom Herbert
Sent: Monday, January 22, 2018 5:17 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [E] [Ila] Fwd: New Version Notification for draft-herbert-ila-motivation-00.txt

Hello,

Tom

---------- Forwarded message ----------
From:  <[email-masked]<mailto:[email-masked]>>
Date: Mon, Jan 22, 2018 at 2:13 PM
Subject: New Version Notification for draft-herbert-ila-motivation-00.txt
To: Tom Herbert <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat

---

From: Tom Herbert <[email-masked]>
Date: Mon, 29 Jan 2018 09:49:57 -0800

> Two possible architectures for use of ILA in the 5G architecture.

Hi Kalayni,

I think this architecture looks good. I would suggest that ILA-DB should be
ILA-M, where ILA-M abstacts out the ILA management function (the data base
is contained within ILA). Also, there is a control plane protocol (ILAMP)
between ILA-N and ILA-R that could represented here.

Tom

> Architecture 2:
>
>
>
>
>
>
>
> Kalyani
>
>
>
> *From:* Bogineni, Kalyani
> *Sent:* Sunday, January 28, 2018 1:01 PM
> *To:* Tom Herbert <[email-masked]>
> *Cc:* [email-masked]; Bogineni, Kalyani <Kalyani.Bogineni@
> VerizonWireless.com>
> *Subject:* RE: [E] [Ila] Fwd: New Version Notification for
> draft-herbert-ila-motivation-00.txt
>
>
>
> Tom:
>
>
>
> Service function chaining is on the SGi interface in 4G and on N6
> interface in 5G. Each operator decides whether to
>
> Section 2.2: It appears that you are using ‘nodes’ for network
> elements/functions as well as for end device like UE in
>
> Section 2.5: This section seems to be about mobility of UEs, but ‘node’ is
> used. Some clarification between the two sections
>
> is needed.
>
>
>
> Section 2.6.2: Relative to mobile traffic there is Uplink (UL) traffic and
> Downlink (DL) traffic. I think you need to address
>
> caching relative to both UL and DL traffic. With anchor-less mobility,
> ILA-R will need to send the DL traffic to the correct
>
> ILA-N/gNB.
>
> In this section you describe a Pub/Sub model. Can it be implemented as
> RESTful APIs? 5G services based architecture
>
> and ILA-N/R. The SMF does not have interfaces to ILA-N/R. In the second
> model, ILA-N/R can also be connected to the
>
>                                         |             |            |
>             |
>       |                                 |
>                    ____|__________
>       N1                             N2
>                        |                           |
>       |                                |
>                    |                           |
> *From:* Tom Herbert [mailto:[email-masked] <[email-masked]>]
> *Sent:* Wednesday, January 24, 2018 6:02 PM
> *To:* Bogineni, Kalyani <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [E] [Ila] Fwd: New Version Notification for
> draft-herbert-ila-motivation-00.txt
>
>
>
> Kalyani,
>
>
>
> Thanks for  posting this. This raises some interesting questions
> especially in the differences of use cases.
>
>
>
> On Wed, Jan 24, 2018 at 12:27 PM, Bogineni, Kalyani <Kalyani.Bogineni@
> verizonwireless.com> wrote:
>
> Tom:
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dravi-2Dicnrg-2D5gc-2Dicn-2D00&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=tY-8-vy_qVFIf4O_vlYHQH9aVTml0fOe_7mTf8KzUqc&s=Ee9jVHhgxAEniWkFuGdAzxW_0Od8NK1pdQ1Xuva9Bvk&e=>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dchin-2Dnfvrg-2Dcloud-2D5g-2Dcore-2Dstructure-2Dyang-2D00&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=tY-8-vy_qVFIf4O_vlYHQH9aVTml0fOe_7mTf8KzUqc&s=Nxy0ZejMchRagPmJBSs9W2Xrv_U8dUM-lpGxHYvN0wE&e=>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_id_draft-2Dirtf-2Dnfvrg-2Dgaps-2Dnetwork-2Dvirtualization-2D08.txt&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=tY-8-vy_qVFIf4O_vlYHQH9aVTml0fOe_7mTf8KzUqc&s=8V6b45rFN3Ef7JvFIlUUMD29TVNajGYXXvFgwdHmVuc&e=>
>
> Status:         https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dherbert-2Dila-
> 2Dmotivation_&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=
> Htmlized:       https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dherbert-2Dila-2Dmotivation-
> 2D00&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=
> ulaeasv1BEkZKjhMbRrNfmfc0OeASvASVtLuGHJauBY&e=
> Htmlized:
> tools.ietf.org
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org&d=DwMFaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=tY-8-vy_qVFIf4O_vlYHQH9aVTml0fOe_7mTf8KzUqc&s=TOwBNQGen-8GzyydswhD-MwpT2_hhU0zcbj792xLshU&e=>
> .
>
> The IETF Secretariat
>

---

From: Tom Herbert <[email-masked]>
Date: Mon, 29 Jan 2018 10:07:59 -0800

> options. Similarly operators could choose to implement several of the SGI/N6
Okay, we'll mention that in the doc.

> used. Some clarification between the two sections
Yes. I think mobile node should be the generic term for something that
can move around a network. UE and mobile devices a real devices that
move around.

> caching relative to both UL and DL traffic. With anchor-less mobility, ILA-R
> will need to send the DL traffic to the correct
>
> ILA-N/gNB.
>
Yes, I believe that describes the Downlink traffic and an ILA router
in the path will do the mapping. For Uplink traffic destined to
Internet, ILA is not needed. For Uplink traffic destined to another
node within the ILA  domain ILA transformation is done by either and
ILA router or forwarding node with a cache entry. Does this
description address it?

> based architecture in one of two ways.
Good point. I think we should consider if ILAMP and an protocols into
ILA-M (ILA management) can be RESTful. The protocol between the ILA
routers might also be considered, but I tend to think this more like
either a routing protocol (like BGP) or would implement a distributed
database that already has its own protocol.

Tom

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Mon, 29 Jan 2018 18:12:07 +0000

-----Original Message-----
From: ila [mailto:[email-masked]] On Behalf Of Tom Herbert
Sent: Monday, January 29, 2018 1:08 PM
To: Bogineni, Kalyani <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ila] [E] Fwd: New Version Notification for draft-herbert-ila-motivation-00.txt

> Section 2.5: This section seems to be about mobility of UEs, but 
> ‘node’ is used. Some clarification between the two sections
>
> is needed.
>
Yes. I think mobile node should be the generic term for something that can move around a network. UE and mobile devices a real devices that move around.

>
>
> Section 2.6.2: Relative to mobile traffic there is Uplink (UL) traffic 
> and Downlink (DL) traffic. I think you need to address
>
Yes, I believe that describes the Downlink traffic and an ILA router in the path will do the mapping. For Uplink traffic destined to Internet, ILA is not needed. For Uplink traffic destined to another node within the ILA  domain ILA transformation is done by either and ILA router or forwarding node with a cache entry. Does this description address it?

[KB] Yes

> uses APIs from network functions. ILA can be incorporated in 5G 
> services based architecture in one of two ways.
>
Good point. I think we should consider if ILAMP and an protocols into ILA-M (ILA management) can be RESTful. The protocol between the ILA routers might also be considered, but I tend to think this more like either a routing protocol (like BGP) or would implement a distributed database that already has its own protocol.

Tom

_______________________________________________
ila mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ila&d=DwIGaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=j5P3Tjt0cLBHFo3ZR0qm5bhvdqmoXwjmoR4HsCsJYrA&s=qDV7PKCfXih4cmKUvbyWw1RCR6Gp_jIsI40A3ywlMuI&e=