Subject: [Ila] Welcome and reference materials

From: Tom Herbert <[email-masked]>
Date: Tue, 16 Jan 2018 10:58:00 -0800

Welcome to the ILA mailing list!

We'll be discussing problem statement, use cases, and architecture and
the direction of ILA in IETF.

To kick things off, here are some reference materials on ILA...

---- Related drafts that have been posted:

* Identifier-locator addressing for IPv6
https://datatracker.ietf.org/doc/draft-herbert-intarea-ila/

* Mobility Management Using Identifier Locator Addressing
https://tools.ietf.org/html/draft-mueller-ila-mobility-03

* Use of BGP for dissemination of ILA mapping information
https://tools.ietf.org/html/draft-lapukhov-bgp-ila-afi-02

* Identifier Locator Addressing Mapping Protocol
https://tools.ietf.org/html/draft-herbert-ila-ilamp-00

* Deploying Identifier-Locator Addressing (ILA) in datacenter networks
https://tools.ietf.org/html/draft-lapukhov-ila-deployment-01

---- Presentations and papers:

* Internet-scale Virtual Networking Petr Lapukhov Network Engineer
Using Identifier-Locator Addressing
https://www.nanog.org/sites/default/files/20161018_Lapukhov_Internet-Scale_Virtual_Networking_v1.pdf

* Identifier locator addressing (LWN)
https://lwn.net/Articles/657012/

* Feasibility of ILA as Network Virtualisation Overlay in
multi-domain, multi-tenant Cloud
http://www.delaat.net/rp/2016-2017/p82/presentation.pdf

* Identifier Locator Addressing with IPv6
https://datatracker.ietf.org/meeting/100/materials/slides-100-intarea-identifier-locator-addressing-for-ipv6/

---- Implementation

* ILA was integrated into 4.3 Linux
https://lwn.net/Articles/654540/

* ILA router code for BPF and XDP
https://www.mail-archive.com/[email-masked]/msg130088.html

* IETF96 hackathon project to implement on ILA router in VPP

---- Related WGs and previous discussion in IETF

* ILA has been presented in nvo3, v6ops, and int-area

* There has also been considerable discussion about ILA on the 5GangIP
list and some related discussion on the IDEAS list

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Wed, 17 Jan 2018 20:28:01 +0000

Tom:

Thanks for initiating this email list. This will provide an opportunity to discuss various aspects 
of ILA.

Here is a draft being developed for discussion in DMM WG that can respond to a study item in
3GPP CT4 Working Group. It has description of the 3GPP 5G architecture relevant to the N9
interface which is the scope of the CT4 study. ILA is a candidate for N9 interface and it would
be good to discuss on this list how ILA would work in that architecture and how ILA can meet
3GPP requirements.

Kalyani Bogineni
Verizon

> -----Original Message-----
> From: ila [mailto:[email-masked]] On Behalf Of Tom Herbert
> Sent: Tuesday, January 16, 2018 1:58 PM
> To: [email-masked]
> Subject: [E] [Ila] Welcome and reference materials
> 
> We'll be discussing problem statement, use cases, and architecture and the
> direction of ILA in IETF.
> 
=

---

From: "Bogineni, Kalyani" <[email-masked]>
Date: Sun, 28 Jan 2018 18:10:03 +0000

Tom:

Some comments on your ILAMP document.

My comments may be more related to difference in how specs are written in 3GPP and IETF. 

Section 2.2 seems to combine both network functions and functionalities. Section 2.2.1 and 2.2.2 describe
Network functions whereas 2.2.3 and 2.2.4 describe functionalities that the network functions perform. 
Similarly 2.3.1 and 2.3.2 describe network functions whereas 2.3.3 calls out one functionality that
the network functions perform.

Section 2.3.2 mentions that Mapping routers implement ILAMP. It needs to be mentioned in Section 2.2 also
that the nodes and hosts also implement ILAMP. 

Kalyani

-----Original Message-----
From: ila [mailto:[email-masked]] On Behalf Of Tom Herbert
Sent: Tuesday, January 16, 2018 1:58 PM
To: [email-masked]
Subject: [E] [Ila] Welcome and reference materials

We'll be discussing problem statement, use cases, and architecture and the direction of ILA in IETF.

* Identifier-locator addressing for IPv6 https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dherbert-2Dintarea-2Dila_&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=tFmKi03TnR--hFIgDTYMCqhsT_Pdmckpe53F0Cq9QG4&e=

* Mobility Management Using Identifier Locator Addressing https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dmueller-2Dila-2Dmobility-2D03&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=khMxZMKoFO9Dgpl6wnf4tEj3bBv1qJPRVDgpwqjzhCg&e=

* Use of BGP for dissemination of ILA mapping information https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dlapukhov-2Dbgp-2Dila-2Dafi-2D02&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=JTeY5jlgrxbsSkS6crs2pt5Ru4oJFWpg2N18Y9PGwq4&e=

* Identifier Locator Addressing Mapping Protocol https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dherbert-2Dila-2Dilamp-2D00&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=KsovbqU72s0ox8lg7i-d6-Z-Vz3zKNKs8T6I69BvLXs&e=

* Deploying Identifier-Locator Addressing (ILA) in datacenter networks https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dlapukhov-2Dila-2Ddeployment-2D01&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=jtpSEn-15uCTqwKNabysbX0hvanecOd3aWX9nE9AaG8&e=

* Internet-scale Virtual Networking Petr Lapukhov Network Engineer Using Identifier-Locator Addressing https://urldefense.proofpoint.com/v2/url?u=https-3A__www.nanog.org_sites_default_files_20161018-5FLapukhov-5FInternet-2DScale-5FVirtual-5FNetworking-5Fv1.pdf&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=zcKnZhq41k41fwT7nhmqRo5GlBicQQ7eHFMTAUyCRN0&e=

* Identifier locator addressing (LWN)
https://urldefense.proofpoint.com/v2/url?u=https-3A__lwn.net_Articles_657012_&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=puz-ElfBduxpJ70M0Fm51H2jwPeSp9fLnulY-kPZIHs&e=

* Feasibility of ILA as Network Virtualisation Overlay in multi-domain, multi-tenant Cloud https://urldefense.proofpoint.com/v2/url?u=http-3A__www.delaat.net_rp_2016-2D2017_p82_presentation.pdf&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=7cMJsLbwXira5QWX7mZKQS7YT3Z-c7Sf2BBYD9fMqZY&e=

* Identifier Locator Addressing with IPv6 https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_100_materials_slides-2D100-2Dintarea-2Didentifier-2Dlocator-2Daddressing-2Dfor-2Dipv6_&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=c1vIM1OJR_BRcdMwPw0rGTbaNcUDcLrRmrt2NWoUv88&e=

---- Implementation

* ILA was integrated into 4.3 Linux
https://urldefense.proofpoint.com/v2/url?u=https-3A__lwn.net_Articles_654540_&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=0wC8VjnOTtvcCsoi6jd00BqsEGbr_K9tjzThfo9FIkI&e=

* ILA router code for BPF and XDP
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.mail-2Darchive.com_netdev-40vger.kernel.org_msg130088.html&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=d_J_uSS2ZHKvaNYwEQpT1xSdYCgSXJiVJeCuPmOyz6E&e=

* There has also been considerable discussion about ILA on the 5GangIP list and some related discussion on the IDEAS list

_______________________________________________
ila mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ila&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=IdiSODh8aDRjdCeGgd9MznLHMYKgKcs_YSwXBDiaofh47oilzaXYRYETcBynUdpT&m=B3eamilehBPGdn1FQwPcxaZDTlUgQW-X7gMzSPoVvas&s=2nyiil8jIcvL6I2VBfoOgHYEpiStEtU_u8nSINka7J8&e=