Subject: Re: [EAI] Proposal for decision, approach for downgrading in UTF8SMTP

From: Kari Hurtta <[email-masked]>
Date: Mon, 9 Oct 2006 10:04:20 +0300 (EEST)

>>> Harald Alvestrand
> Kari Hurtta wrote:
> > Harald Alvestrand <[email-masked]> writes in  gmane.ietf.ima:
> >
> >   
> >> In draft-ietf-eai-downgrade-01 section 5, the editors have identified
> >> a design decision that the WG needs to take: Whether to use an
> >> encapsulation strategy or a conversion strategy when downgrading
> >> messages from an UTF8SMTP user to an ASCII user.
> >>
> >> A few of us (editors + chairs) have had a discussion about this, and
> >> reached a proposed resolution:
> >>
> >> - It is of paramount importance that ASCII users are able to interpret
> >> downgraded messages without special software. Therefore, a conversion
> >> approach MUST be used, and this will be documented in the next version.
> >>     
> >
> > Is there differences between these two strategies (encapsulation strategy  
> > and a conversion strategy) on what situations these strategies are 
> > possible when   downgrading is required?
> I'm sorry, but I can't parse this question. Can you try again?

Lets assume that dowgrade is required for message

Case
	1) Select encapsulation strategy 

	   When this is succeed and when bounce is required ?

Case  

        2) Select conversion strategy

           When this is succeed and when bounce is required ?

/ Kari Hurtta

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 09 Oct 2006 10:48:23 +0200

Kari Hurtta wrote:
> 	   When this is succeed and when bounce is required 
>   
> Case  
>
In both cases, the message has to bounce when the senders' email address 
cannot be represented to the recipient in an usable format (that is, on 
the From: line of the message, not inside any encapsulation). Otherwise 
"reply" won't work.

I think the same has to apply to To: and Cc: addresses (same argument, 
but for "reply all"), but am not 100% sure here.

Anyway, the decision seems to be to go for the conversion strategy.

                          Harald