Subject: Re: [EAI] "downgrade must able to fail" -- or comment about draft-ietf-eai-smtpext-01.txt

From: "Yao Jiankang" <[email-masked]>
Date: Tue, 10 Oct 2006 09:32:49 +0800

----- Original Message ----- 
From: "Kari Hurtta" <[email-masked]>
To: "EAI mailing list" <[email-masked]>
Sent: Tuesday, October 10, 2006 12:14 AM
Subject: [EAI] "downgrade must able to fail" -- or comment about draft-ietf-eai-smtpext-01.txt

> 
> Perhaps there is needed warning that downgrading
> EAI message must be able to fail.
> 
> In other words MTA must be prepared to bounce
> message if downgrade is not possible.
> 
> That means that downgrade must be done before 
> MTA issues DATA -command.

Yes.
EAI solution has already provided such mechanism.
Client SMTP issued a EHLO command to Server SMTP.
if  Server SMTP failed to response with the UTF8SMTP keywords.
The client SMTP will bounce the message or do some downgrading.

Yao Jiankang
CNNIC

> 
> 
> Sendmail does that mistake when it is downgrading
> 8BITMIME messages. It does downgrading on fly
> and therefore is not able to bounce message if
> downgrade is not possible.
> 
> / Kari Hurtta
> 
> ( documentation:
> 
>      $=s  contains the set of subtypes of message that  can
>           be  treated  recursively.  By default it contains
>           only "rfc822".  Other "message/*" types cannot be
>           8->7  bit encoded.  If a message containing eight
>           bit data is sent to a seven bit  host,  and  that
>           message  cannot  be  encoded  into seven bits, it
>           will be stripped to 7 bits.
> 
> )
> 
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ima

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: "Kari Hurtta" <[email-masked]>
Date: 10 Oct 2006 12:57:26 +0300

> The client SMTP will bounce the message or do some downgrading.

I was warning about sequence

      client SMTP  
             - issues DATA command
             - does some downgrading  
             - notices that all data is not downgradeable
             ...  you lost ...  it is not possible to cancel 
                  mail on that point ...

In other words downgrading must not do on fly. 

But perhaps it is more obvious on here that downgrade
is not always possible that it was on 8BITMIME, so that this
"optimization" is not tried. 

/ Kari Hurtta

---

From: John C Klensin <[email-masked]>
Date: Tue, 10 Oct 2006 13:19:38 -0400

--On Tuesday, 10 October, 2006 12:57 +0300 Kari Hurtta
<[email-masked]> wrote:

>...

Sure it is.   It is bad to just close the connection, but it is
certainly done.   The design of SMTP might have been better if,
after sending CRLF.CRLF, the client was forced to either send
"CONFIRM" or "ABOR", but the fact that we didn't do that doesn't
imply that things never go wrong after DATA is sent and
confirmed.

> In other words downgrading must not do on fly. 

Certainly it isn't a wonderful idea, but it is well short of a
MUST NOT.

> "optimization" is not tried. 

I'm not certain I understand that comment, but it may not make
much difference.

    john