Subject: Re: [EAI] header (822) address syntax

From: Kari Hurtta <[email-masked]>
Date: 05 Oct 2006 23:05:21 +0300

Tony Finch <[email-masked]> writes in gmane.ietf.ima:

> 	mailbox = (utf8-name-addr / utf8-addr-spec) [downgrade]
> 	downgrade = "[" ascii-addr-spec "]"
> 
> i.e. one of
> 
> 	From: Tony Finch <[email-masked]> [[email-masked]]
> 	From: [email-masked] (Tony Finch) [[email-masked]]
> 
> The downgraded form could be
> 
> 	mailbox = (name-addr / addr-spec) [downgrade-comment]
> 	downgrade-comment = "([" rfc2047-addr-spec "])"
> 
> where the latter part is the RFC 2047 encoding of the UTF8 address. The
> ([]) is a comment wrapping a [] bracketed address, so that it parses as a
> comment but still has a distinctive form. For example,
> 
> 	From: Tony Finch <[email-masked]> ([=?utf-8?q?d=F6t@dot=A4t.at])
> 	From: [email-masked] (Tony Finch) ([=?utf-8?q?d=F6t@dot=A4t.at])

I think you mean
        From: Tony Finch <[email-masked]> ([ =?utf-8?q?d=F6t@dot=A4t.at?= ])    (***)

otherwise it does not work. (*)
 
> This might get mangled into one of the following, which I think is OK.
> 
> 	From: Tony Finch "[=?utf-8?q?d=F6t@dot=A4t.at]" <[email-masked]>

  =? and " are alternative ways to do quotation, so that does not make sense. (**)

  'Correct' mangling is perhaps

        From: Tony Finch =?utf-8?q?=5Bd=F6t=40dot=A4t=2Eat=5D?= <[email-masked]>

or if (***) is used 

        From: Tony Finch "[" =?utf-8?q?d=F6t=40dot=A4t=2Eat?= "]" <[email-masked]>

> 	From: [email-masked] (Tony Finch [=?utf-8?q?d=F6t@dot=A4t.at])

        From: [email-masked] (Tony Finch =?utf-8?q?=5Bd=F6t@dot=A4t.at=5D?= )

of from (***) becomes

        From: [email-masked] (Tony Finch [ =?utf-8?q?d=F6t@dot=A4t.at?= ])

> 
> Note that this proposal makes the UTF8 header and downgraded ASCII header
> forms look quite similar, and keeps the UTF8 email address easily
> accessible.
> 
> Tony.

Dowgraded form should be compatible with current standards.

/ Kari Hurtta

(*) RFC 2047:

| (2) An 'encoded-word' may appear within a 'comment' delimited by "(" and
|    ")", i.e., wherever a 'ctext' is allowed.  More precisely, the RFC
|    822 ABNF definition for 'comment' is amended as follows:
|
|    comment = "(" *(ctext / quoted-pair / comment / encoded-word) ")"
|
|    A "Q"-encoded 'encoded-word' which appears in a 'comment' MUST NOT
|    contain the characters "(", ")" or "
|    'encoded-word' that appears in a 'comment' MUST be separated from
|    any adjacent 'encoded-word' or 'ctext' by 'linear-white-space'.

(**) RFC 2047:

|   + An 'encoded-word' MUST NOT appear within a 'quoted-string'.

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: Kari Hurtta <[email-masked]>
Date: 06 Oct 2006 07:37:11 +0300

>         From: Tony Finch <[email-masked]> ([ =?utf-8?q?d=F6t@dot=A4t.at?= ])    (***)

Seems that I have sleeping.   That charset is actually iso-8859-1 and not
utf-8 :-)  So if enconding is fixed:

        From: Tony Finch <[email-masked]> ([ =?UTF-8?Q?d=C3=B6t=40dot=C3=A4t=2Eat?= ])

/ Kari Hurtta

---

From: Kari Hurtta <[email-masked]>
Date: 06 Oct 2006 20:07:57 +0300

"Charles Lindsey" <[email-masked]> writes in gmane.ietf.ima:

> On Fri, 11 Aug 2006 02:08:39 +0100, Tony Finch <[email-masked]> wrote:
> 
> 
> Having been on holiday for 10 days, and just seen this, I am surprised
> to  find that there has been no response to this proposal on the list.
> 
> It seems to have some merit, insofar as it is a less drastic change to
> the  present syntax, and it would seem to permit CFWS in more
> reasonable  places. I certainly think it is worth looking at
> (especially, as we still  have not really decided on a precise syntax
> for the current proposal).

Yes, specially

may (perhaps) work with (some) existing parsers (without changes).

For

there is no that advantage.

/ Kari Hurtta

---

From: Tony Finch <[email-masked]>
Date: Mon, 9 Oct 2006 00:21:56 +0100

On Thu, 5 Oct 2006, Kari Hurtta wrote:
> I think you mean [...]

Thanks for the corrections.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
FORTIES CROMARTY FORTH: SOUTHERLY 6 TO GALE 8, DECREASING 5 OR 6 LATER. RAIN
OR SHOWERS. MODERATE OR GOOD.