Subject: [EAI] MIME type selection - finishing the process

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 20 Jul 2007 08:19:35 -0700

The poll result on the MIME type name ended up with a fairly inconclusive 
result, with quite a few names having multiple people on both the "good" 
and "bad" sides.

Here is the list of candidates, culled according to the following criteria:
- At least 2 people need to say "good"
- More people need to say "good" than "bad"

That leaves us with:

A: message/utf8smtp (5:2)
B: message/i18n (3:1)
C: message/international (6:1)
D: message/global (5:1)
E: message/mail (3:0)
F: message/i18n-email (5:0)
G: message/eai (5:0)
H: message/utf8eai (4:0)
I: message/utf8-email (4:0)
J: message/ima (2:0)
K: message(intl-email (4:0)

I'm ignoring the 3 "write-in candidates", since each was proposed by only 
one participant.

I suggest, as an input to the discussion in Chicago and subsequent mailing 
list discussion, the following procedure:

- Each participant ranks the proposals he has an opinion about, in order of 
preference, and sends that to the mailing list. (It's OK to not give an 
opinion for all proposals.)
- The chairs will perform an Instant Runoff Voting algorithm on the ranked 
lists.

The procedure for Instant Runoff Voting is:

- We count the number of "first" positions for each candidate
- If there is more than 50% for one candidate, that is the winner
- If not, the candidate with the least "first" position is removed from all 
ballots, and on the ballots with that in the first place, the second choice 
is moved up to first place. (If there are no more candidates, discard 
ballot.)
- Repeat until a winner is found

The nice thing about this method is that people need to "vote" only once, 
and it's guaranteed to produce a result no matter what the distribution is.

In this particular issue, I think making a decision is more important than 
what decision is made - so even though we do not do voting in the IETF, 
making the pick based on an opinion poll of active email participants is 
better than not making a choice at all.

Comments?

                   Harald

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: John C Klensin <[email-masked]>
Date: Sun, 22 Jul 2007 15:19:21 -0400

--On Friday, 20 July, 2007 08:19 -0700 Harald Tveit Alvestrand 
<[email-masked]> wrote:

> The poll result on the MIME type name ended up with a fairly
> inconclusive result, with quite a few names having multiple
> people on both the "good" and "bad" sides.
>

Preferences:
1  E
2  C
3  D
4  K

For me and given this list, there is a large preference gap 
between 1 and 2 and all of the others (i.e. past preference 4) 
fall into the "disaster we almost certainly will regret later" 
category.

> I suggest, as an input to the discussion in Chicago and
> subsequent mailing list discussion, the following procedure:
>
> - Each participant ranks the proposals he has an opinion
> about, in order of preference, and sends that to the mailing
> list. (It's OK to not give an opinion for all proposals.)
>...

> - If not, the candidate with the least "first" position is
> removed from all ballots, and on the ballots with that in the
> first place, the second choice is moved up to first place. (If
> there are no more candidates, discard ballot.)

The difficulty with this plan is that some of us feel much more 
negatively about some options than we feel positively about 
others.  For example, given a choice between anything containing 
the string "UTF-8" (with or without a hyphen), I prefer any 
other option, including things that are not on the list such as 
message/2008.

> The nice thing about this method is that people need to "vote"
> only once, and it's guaranteed to produce a result no matter
> what the distribution is.

Perhaps the wrong one :-(.   Incidentally, if anyone might be 
amused by less crude statistics, I spent an hour before I left 
trying to see if multidimensional scaling would produce a clear 
winner from the original poll.   It does not, but it produces 
some interesting rankings, especially if one ranks the "bad"s 
more strongly than the "goods"

> In this particular issue, I think making a decision is more
> important than what decision is made - so even though we do
> not do voting in the IETF, making the pick based on an opinion
> poll of active email participants is better than not making a
> choice at all.

Agree.  But I'd like to see a process that weights "Hate this 
because..." more strongly than "like that": there are some 
substantive issues in this name and, as with "Punycode" when we 
pick something techie/geeky on the assumption that users won't 
see it, we often turn out to regret that.

    john

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 23 Jul 2007 11:02:15 +0100

On Fri, 20 Jul 2007 16:19:35 +0100, Harald Tveit Alvestrand  
<[email-masked]> wrote:

> inconclusive result, with quite a few names having multiple people on  
> both the "good" and "bad" sides.
>

1. F
2. K
3. I
4. A
5. B
6. C
7. D
8. E
9. H
10.G
11.J

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Chris Newman <[email-masked]>
Date: Mon, 23 Jul 2007 08:37:48 -0500

> K: message(intl-email (4:0)

 1. C
 2. D
 3. K
 4. E
 5. I
 6. F
 7. B
 8. H
 9. G
10. J

I concur making a decision is more important than the name.

                - Chris

---

From: <[email-masked]>
Date: Mon, 23 Jul 2007 16:54:17 +0300

1. C
2. K
3. I
4. F
5. A
6. E
7. D
8. B
9. J
10. G
11. H

---

From: Tony Hansen <[email-masked]>
Date: Tue, 24 Jul 2007 08:49:31 -0400

1 C: message/international (6:1)
| D: message/global (5:1)
v K: message(intl-email (4:0)
  F: message/i18n-email (5:0)
  B: message/i18n (3:1)
  J: message/ima (2:0)
  G: message/eai (5:0)
  I: message/utf8-email (4:0)
  H: message/utf8eai (4:0)
  E: message/mail (3:0)
  A: message/utf8smtp (5:2)