Subject: Re: [EAI] ascii@UTF-8 and ascii@Punycode

From: "YAO Jiankang" <[email-masked]>
Date: Wed, 19 Mar 2008 13:18:48 +0800

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, March 19, 2008 12:05 PM
Subject: [EAI] ascii@UTF-8 and ascii@Punycode

> Is ASCII@UTF-8 equal to ASCII@Punycode ?

yes,  I think so.

> 
> I prepared UTF8SMTP Email address: fujiwara@ U+65E5 U+672C U+8A9E .dnslab.jp.
> 
> MX resolution for fujiwara@ U+65E5 U+672C U+8A9E .dnslab.jp results
> the same SMTP server for XN--WGV71A119E.dnslab.jp, but the SMTP server
> can be configured to reject "[email-masked]".
> 
> I should accept "[email-masked]" ?

yes.

> 
> Currently, I allow both addresses.
> 
> Regards,
> 
> --
> Kazunori Fujiwara, JPRS <[email-masked]>
> 
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>
_______________________________________________
IMA mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ima

---

From: [email-masked]
Date: Fri, 21 Mar 2008 14:13:19 +0900 (JST)

> From: "YAO Jiankang" <[email-masked]>

If ASCII@Punycode is equivalent to ASCII@UTF-8 and
the SMTP server must receive both ASCII@Punycode and ASCII@UTF-8,

The thread "Add requirement for punycode conversions in downgrade"
results 2 or 3, I think.

When downgrading, If no alt-address is specified for ASCII@UTF-8,
ASCII@Punycode should be treated its alt-address.

If MUA added alt-address, the downgrading uses it.