Subject: [EAI] I-D Action:draft-ietf-eai-pop-04.txt

From: [email-masked]
Date: Sun, 13 Jul 2008 15:15:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Email Address Internationalization Working Group of the IETF.

	Title           : POP3 Support for UTF-8
	Author(s)       : C. Newman, R. Gellens
	Filename        : draft-ietf-eai-pop-04.txt
	Pages           : 14
	Date            : 2008-07-13

This specification extends the Post Office Protocol version 3 (POP3)
to support un-encoded international characters in user names,
passwords, mail addresses, message headers, and protocol-level
textual error strings.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-eai-pop-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
IMA mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ima

---

From: Bill McQuillan <[email-masked]>
Date: Sun, 13 Jul 2008 15:51:18 -0700

In the LANG examples, I noticed an oddity:

      < A LANG command with no arguments is a request for
      a language listing. >

      C: LANG
      S: +OK Language listing follows:
      S: en English
      S: en-boont English Boontling dialect
      S: de German
      S: it Italian
      S: i-default Default language
      S: .

I would have expected 3rd and 4th response lines to be:

      S: de Deutsch
      S: it italiano

This raises the issue of what language should the "human readable
description of that language" be in.

I could imagine:

1 - the server's preferred language
2 - the language itself
3 - i-default
4 - the current language

Since the "human" most likely to read the "description" is the user trying
to find a language s/he understands, I vote for #2.

Also #4 might be combinatorily difficult.  ;-)

-- 
Bill McQuillan <[email-masked]>

---

From: Randall Gellens <[email-masked]>
Date: Mon, 28 Jul 2008 06:57:07 -0700

>  Also #4 might be combinatorily difficult.  ;-)

Hi Bill,

Good to see you still active in this stuff.

This is a good point, and one I'm inclined to agree with.  The text 
already says that the language listing uses UTF-8.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Perhaps the real reason why we have always been able to champion free
speech in this country is that we know perfectly well that hardly
anybody has got anything to say, and that no one will listen to anyone
that has.       -- Editorial, Daily Mail [British Paper, date unknown]
_______________________________________________
IMA mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ima