Subject: Re: [EAI] Unicode / ASCII fallback mappings?

From: "YAO Jiankang" <[email-masked]>
Date: Sun, 28 Jun 2009 17:43:52 +0800

I personally like the method 3)aliasing where the ASCII alias doesn't necessarily correlate with the native-script form.
I think that it is the suggested direction for creation of generating the ASCII address.
in our current promotion of EAI for commercial use, many email providers care for this issue very much.

Yao Jiankang
CNNIC
  ----- Original Message ----- 
  From: Shawn Steele 
  To: [email-masked] 
  Sent: Saturday, June 27, 2009 7:31 AM
  Subject: [EAI] Unicode / ASCII fallback mappings?

  I realize that a UTF-8 email address and the ASCII fallback for that address are left to the server to figure out, but I was wondering if anyone had any preconceptions?

  I can think of 3 basic ways to solve generating ASCII addresses: 1) Some sort of encoding mechanism that is algorithmic and likely makes an unreadable ASCII address, 2) aliasing, where aliasing happens automagically, like perhaps Cyrillic to ASCII transliteration, and 3) aliasing where the ASCII alias doesn't necessarily correlate with the native-script form.

  My preconception is that the last is the most useful, unless the native script has well-defined transiliteration to Latin rules.  

  Furthermore I'd expect that when I created a new account on something like live mail/gmail/yahoo mail, that it'd be nice to get prompted for both the Unicode and ASCII aliases, possibly with a generate ASCII alias button for users that aren't as familier with that form.  

  Lastly, I'd assume that "enabling" EAI on such a system, such as with a Chinese ISP, would mean that when I log in with an existing ASCII address, I could be prompted with a "Get your chinese alias now!" button, so that I wouldn't have to make a new account or lose service/migrate messages, etc. from my old account.

  It occurred to me that what I think is obvious may not be what everyone/anyone else is thinking.  Does anyone care to share any other options or whether they agree?  I know that earlier Mark had suggested a punycode form, but I'd assumed that most end-users would prefer a more friendly alias.  One that would make sense on a double-sided business card for example.

  -Shawn

------------------------------------------------------------------------------

  _______________________________________________
  IMA mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/ima

---

From: Shawn Steele <[email-masked]>
Date: Tue, 30 Jun 2009 17:37:41 +0000

> The sort of scenario I would expect is a 'sign up' window (in Chinese, of
> course) that invites you to to fill in some 'User ID' box (in Chinese, and
> probably with a little '*' beside to show it was an obligatory field).

> Then there would be another (non-obligatory) box for 'ASCII User ID',
> perhaps with a little "click here for explanation" (in Chinese) beside it;
> and if you clicked that the popup would explain that if it was likely you
> would need to exchange email messages with non-Chinese correspondents
> using non-Chinese characters, it wold be a Good Idea to fill in some ASCII
> ID here; but otherwise to leave it blank.

Exactly.  I was more focused on the migration/adoption of EAI from existing accounts though.  Most users don't want to have to tell everyone a new address, so existing accounts would have to "add" the EAI address.  Presumably it'd become "primary", however I don't think we want to have to force everyone to get a brand new mailbox.

The more abstract problem I'm trying to solve is "How fast is EAI going to be adopted?" so that I can provide business guidance.  The fastest adoption path would be adding EAI to existing accounts :)

-Shawn