Subject: [EAI] Fw: I-D Action:draft-yao-eai-deployment-01.txt

From: "YAO Jiankang" <[email-masked]>
Date: Tue, 30 Jun 2009 09:53:06 +0800

I updated draft-yao-eai-deployment to version 1.
any comment is welcomed.

Yao Jiankang
CNNIC
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, June 30, 2009 9:30 AM
Subject: I-D Action:draft-yao-eai-deployment-01.txt 

>A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> Title           : EAI Deployment Practices
> Author(s)       : J. Yao, X. Lee
> Filename        : draft-yao-eai-deployment-01.txt
> Pages           : 11
> Date            : 2009-06-29
> 
> This document captures experience in implementing systems based on
> the EAI protocols.  Its aim is to help the engineers to implement
> these protocols.  This document gives some suggestions about
> implementaions and reports on the prototype implementation and the
> inter-operability test results, as well as the lessons and insights
> gained from this test.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-yao-eai-deployment-01.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

--------------------------------------------------------------------------------

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Shawn Steele <[email-masked]>
Date: Tue, 30 Jun 2009 19:57:02 +0000

You mention twice "Although it is not possible to support EAI protocol within one night,"

This is true of the entire Internet, however in a vertical, such as a large ISP, or a cell phone provider, EAI would likely be enabled in one night.  At that point users would be able to communicate with others of that ISP using EAI regardless of whether my mailbox recognized it.  (Of course they'd have to have clients that supported it, but many have web interfaces that would presumably be "turned on" at the same time.)

In 2.1 "From non-EAI world to EAI world" perhaps you'd like to mention migration of existing non-EAI servers?

2.1a  Migration of Existing Servers
Existing servers and mailboxes may be upgraded to support EAI.  In that case an appropriate EAI address must be chosen for the mailbox, and the existing non-EAI address must be downgraded to the alt-address for that mailbox.  New mail would be sent using the new EAI address, when supported by the recipient system.  If the address is also used as an identity for logon, the server may want to recognize either form during the transition period.

Section 4 confused me with this sentence: "The EAI protocol
   allows only UTF-8 encoding in the local part in the email header and
   envelop."

UTF-8 is also used in the body, but I think you were saying the header MUST be in UTF-8?  I think you were intending to only discuss the header, but I could read it as it is only allowed in the header?

Thanks,

-Shawn

------------------------------

Message: 3
Date: Tue, 30 Jun 2009 09:53:06 +0800
From: "YAO Jiankang" <[email-masked]>
Subject: [EAI] Fw: I-D Action:draft-yao-eai-deployment-01.txt
To: "EAI WG" <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="iso-8859-1"

Yao Jiankang
CNNIC