Subject: Re: [EAI] The first commercial eai products were released in China

From: "Jiankang Yao" <[email-masked]>
Date: Tue, 18 Jun 2013 19:01:51 +0800

for question 1,

 the current UI is english and chinese only.

for quesiton 2,

the coremail system can configure the ascii address as the alias address of EAI address. for example, [email-masked] can be alias of the [email-masked]. both cas.cn and non-ascii.cn domain share the same mailbox system.

the legacy pop and imap can not access to core mail system via [email-masked] account, but can access to core mail system via [email-masked] account.

Jiankang Yao

From: John C Klensin
Date: 2013-05-29 23:45
To: yaojk; Shawn Steele; ima
Subject: Re: [EAI] The first commercial eai products were released in China

--On Wednesday, May 29, 2013 09:25 +0800 Jiankang Yao
<[email-masked]> wrote:

> coremail's new version of email system (Coremail XT V3.0)
> supports EAI RFC such as rfc6531/6532. the coremail system has
> more than 600,000,000 users. If all coremail systems are
> upgraded to Coremail XT V3.0 in the future, there will  have
> potential 600,000,000 EAI users.

This is great and 600M EAI users would certainly be impressive.

Two questions, mostly out of curiosity:

(1)  6531/6532 are mostly about the in-transit and between-hosts
environments.  Does this new version of Coremail also provide
reasonable user interface support?  If so, are those UI's
Chinese-only or adapted for other scripts and languages as well?
Do the Chinese UIs preserve the ASCII header field names between
systems but show them in Chinese to the user in the UI?

(2) What is the state of POP/IMAP support and, if POP and IMAP
are supported as in RFCs 6855 and 6856, what is being done about
legacy clients?

This is an impressive step forward regardless of the answers to
those two questions, but I'd like to better understand where we
stand on the many dimensions of the i18n email issues.

best regards,
   john

---

From: Shawn Steele <[email-masked]>
Date: Wed, 19 Jun 2013 01:42:18 +0000

> the coremail system can configure the ascii address as the alias address of EAI address. 
> for example, [email-masked] can be alias of the [email-masked]. both cas.cn and 
> non-ascii.cn domain share the same mailbox system.

That sounds like a good approach.  Has anyone deployed it somewhere that there could be test accounts created for interoperability testing?

-Shawn