Subject: [imapext] IMAP Idle for Multiple folders

From: Jayantheesh S B <[email-masked]>
Date: Wed, 18 Feb 2015 20:05:11 +0000

Dear All,

As part of IMAP IDLE connection (https://tools.ietf.org/html/rfc2177) any changes like EXISTS, EXPUNGE, FETCH to one particular mailbox can be pushed to IMAP client.

But in case, if IMAP client want to receive notification for multiple folders then multiple IMAP connection has to be opened.

Is there a way to receive updates for multiple folders in same IMAP connection ? Please share your thoughts.
Regards,
Jay

---

From: Michael M Slusarz <[email-masked]>
Date: Wed, 18 Feb 2015 13:11:25 -0700

Quoting Jayantheesh S B <[email-masked]>:

> As part of IMAP IDLE connection  
> (https://tools.ietf.org/html/rfc2177) any changes like EXISTS,  
> EXPUNGE, FETCH to one particular mailbox can be pushed to IMAP client.
>
> But in case, if IMAP client want to receive notification for  
> multiple folders then multiple IMAP connection has to be opened.
>

The NOTIFY extension.

michael

___________________________________
Michael Slusarz [[email-masked]]

---

From: "Adrien de Croy" <[email-masked]>
Date: Wed, 18 Feb 2015 20:11:44 +0000

anyone know of any clients supporting NOTIFY?  It's a very interesting 
extension.

Regards

Adrien de Croy

------ Original Message ------
From: "Michael M Slusarz" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Sent: 19/02/2015 9:11:25 a.m.
Subject: Re: [imapext] IMAP Idle for Multiple folders

>>As part of IMAP IDLE connection (https://tools.ietf.org/html/rfc2177) 
>>any changes like EXISTS, EXPUNGE, FETCH to one particular mailbox can 
>>be pushed to IMAP client.
>>
>>But in case, if IMAP client want to receive notification for multiple 
>>folders then multiple IMAP connection has to be opened.
>>
>_______________________________________________
>imapext mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/imapext

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 18 Feb 2015 21:13:24 +0100

On Wednesday, February 18, 2015 9:05:11 PM CEST, Jayantheesh S B wrote:
> Is there a way to receive updates for multiple folders in same 
> IMAP connection ? Please share your thoughts.

RFC5465, by me, rather a poor RFC I'm afraid. I wrote about that on 
http://rant.gulbrandsen.priv.no/good-bad-rfc

What people seem to be doing if they want to look at all the mail is select 
gmail's "all mail" mailbox.

Arnt

---

From: Jayantheesh S B <[email-masked]>
Date: Thu, 19 Feb 2015 20:04:02 +0000

Anyone knows which IMAP server supports this NOTIFY  extension ?

Regards,
Jay
-----Original Message-----
From: Adrien de Croy [mailto:[email-masked]] 
Sent: Wednesday, February 18, 2015 3:12 PM
To: Michael M Slusarz; [email-masked]
Subject: Re: [imapext] IMAP Idle for Multiple folders

anyone know of any clients supporting NOTIFY?  It's a very interesting extension.

Regards

Adrien de Croy