Subject: [imapext] IMAP BODY STRUCTURE

From: Nigar Sultana <[email-masked]>
Date: Sat, 29 Aug 2015 02:26:06 +0000 (UTC)

Hello All,
As per RCS5.3 recommendation the IMAP message archived on server includes MIME content-type Message/CPIM. CPIM wrapped MIME can have attachment content-type=multipart/related.
Eg: From:tel:+4917112345678

To:Joe User <[email-masked]>, tel:0401234567

Cc:tel:+358501234567

Date:Tue, 27 01 2015 17:57:16 +0100

Subject:This is an example

Message-Context:multimedia-message

Content-Type:Message/CPIM

From:tel:+4917112345678

To:Joe User <[email-masked]>

To:tel:0401234567

cc:tel:+358501234567

DateTime:2015-01-27T16:32:55+01:00

Subject:This is an example

NS: imdn <urn:ietf:params:imdn>
NS:rcs <http://www.gsma.org>

imdn.Message-ID:654131a654131a654131a654131a8994123

imdn.Disposition-Notification:display

rcs.Mms-Message-Class:"Personal"

Content-Type:Multipart/Related;boundary="example-1";start=<950118>;type=application/smil

--example-1

Content-Type:application/smil

Content-ID:<950118>"

 [presentation]

--example-1

Content-Type:text/plain

Content-ID:<950119>

[text]

--example-1

Content-Type:image/jpeg

Content-ID:<950120>

--example-1--

The question we have is the Body Structure is returning only Message/CPIM body part information and it is not sending sub body structure information. Due to which on client side CPIM message parsing has to be developed. 
Wanted clarification from the group whether it is server issue. Ideally sub body part info server has to pass 
RegardsNigar Sultana

---

From: Jamie Nicolson <[email-masked]>
Date: Mon, 31 Aug 2015 20:51:16 -0700

As far as I can tell, RFC 3501 only requires the server to parse internal
messages of type message/rfc822. In fact, it might be considered a
violation of the IMAP protocol to provide such details about a message/cpim
part in the bodystructure response.

On Fri, Aug 28, 2015 at 7:26 PM, Nigar Sultana <[email-masked]>
wrote:

> Hello All,
>
> As per RCS5.3 recommendation the IMAP message archived on server includes
> MIME content-type Message/CPIM. CPIM wrapped MIME can have attachment
> content-type=multipart/related.
>
> Eg:
> From: tel:+4917112345678
> To: Joe User <[email-masked]>, tel:0401234567
> Cc: tel:+358501234567
> Date: Tue, 27 01 2015 17:57:16 +0100
> Subject: This is an example
> Message-Context: multimedia-message
> Content-Type: Message/CPIM
>
> From: tel:+4917112345678
> To: Joe User <[email-masked]>
> To: tel:0401234567
> cc: tel:+358501234567
> DateTime: 2015-01-27T16:32:55+01:00
> Subject: This is an example
> NS: rcs <http://www.gsma.org>
> imdn.Message-ID: 654131a654131a654131a654131a8994123
> imdn.Disposition-Notification: display
> rcs.Mms-Message-Class: "Personal"
> Content-Type: Multipart/Related;boundary="example-1";start=<950118>;
> type=application/smil
> --example-1
> Content-Type: application/smil
> Content-ID: <950118>"
>  [presentation]
> --example-1
> Content-Type: text/plain
> Content-ID: <950119>
> [text]
> --example-1
> Content-Type: image/jpeg
> Content-ID: <950120>
> --example-1--
>
>
> The question we have is the Body Structure is returning only Message/CPIM
> body part information and it is not sending sub body structure information.
> Due to which on client side CPIM message parsing has to be developed.
>
> Regards
> Nigar Sultana
> _______________________________________________
> imapext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/imapext
>
>