Subject: RE: [IMRG] clock synchronization

From: "Ayyasamy, Senthilkumar (UMKC-Student)" <[email-masked]>
Date: Sat, 19 Jul 2003 22:25:20 -0500

> Is there advantages in use GPS clock synchronization for network
> measurements?

 time stamps play a crucial role in the probing based measurement 
 studies. Possibly, RIPE-NCC test traffic will give an idea about 
 its importance. 

 Also, you should read 

   PC Based Precision Timing Without GPS 
   Attila Pasztor, Darryl Veitch 
   http://parapet.ee.princeton.edu/~sigm2002/papers/p1-pasztor.pdf

 and check Darryl Veitch/David Mills website for more details.

 The related advantage of GPS can be inferred from the ranking of 
 the timing accuracy as below (as per my understanding of the
 above paper; i may be wrong):

    o software clock + NTP 
    o GPS based
    o TSC + driver timestamp  
    o RT-TSC + driver timestamp
    o GPS sync DAG + TSC + driver timestamp
    o ???

 I have no clue about the cost factors which plays an important
 role. 

_______________________________________________
IMRG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imrg

---

From: [email-masked]
Date: Mon, 21 Jul 2003 11:08:42 -0700

To all:
I was copied on the message below. You may be interested in IEEE 1588, a new standard for synchronizing clocks in relatively compact systems (a few subnets). The standard was targeted at test and measurement, industrial control, etc but there has been some interest from the telecommunications industry. (see the tentative workshop program on the 1588 website). Further information on IEEE 1588 may be found at the website http://ieee1588.nist.gov 

regards,
john eidson
chair IEEE 1588 working group

-----Original Message-----
From: 	Henk Uijterwaal (RIPE-NCC) [mailto:[email-masked]] 
Sent:	Monday, July 21, 2003 1:01 AM
To:	Augusto Castelan Carlson
Cc:	[email-masked]
Subject:	Re: [IMRG] clock synchronization

Hi,

> Is there advantages in use GPS clock synchronization for network

Clock synchronization is essential for one way measurements that involve timing.  The most obvious is one way delay: one box sending packets, the other one receiving it, if the clocks aren't synchronized then it is impossible to do these measurements.
There are many ways to synchronize a clock: over the network using NTP or from an outside source (GPS, CDMA, DCF77 and other long-wave radio clocks, atomic clocks).
NTP suffers from the problem that it often uses the same network to synchronize the clocks and do the measurement.  That unfortunately means that clock accuracy goes down when the network behaves badly (losses, delay variations) and this is usually the time that you are interested in accurate measurements.
The advantage of GPS over other solutions is that it works everywhere _if you can see the sky_.  Units are relatively cheap (500-1000 US$).  CDMA is a good alternative if you live in an area with CDMA coverage.
> If so, which GPS product is recommended for it?

That depends on several factors.  In theory, any GPS receiver that can output a pulse-per-second (clock pulse) can be used to sync a clock. In practice, things like distance between receiver and antenna, availability of drivers for receiver and O/S, are also important.
Henk

------------------------------------------------------------------------------
Henk Uijterwaal                             Email: [email-masked]
RIPE Network Coordination Centre            WWW: http://www.ripe.net/home/henk
P.O.Box 10096          Singel 258           Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam    Fax: +31.20.5354445
The Netherlands        The Netherlands      Mobile: +31.6.55861746
------------------------------------------------------------------------------

That problem that we weren't having yesterday, is it better? (Big ISP NOC)