Subject: [imss] Vancouver Minutes (DRAFT)

From: [email-masked]
Date: Wed, 9 Nov 2005 13:27:37 -0500

Please send any corrections, etc. to the list.

Thanks,
--David

Internet and Management Support for Storage (imss) WG
Meeting - Vancouver, Canada
Tuesday, November 8, 2005: 1740-1840
Minutes - DRAFT
------------------------------------------------------

Administrivia, agenda bashing, draft status review, etc.: 15 min
		David L. Black, EMC (new imss WG chair)
	Blue sheets
	Note Well
	Milestones (see WG charter page on IETF web site)
	WG Draft status
		- IP over FC draft is in IETF Last Call
		- FAM and NSM MIBs should go to IETF Last Call by the
			end of next week (Keith McCloghrie and Bert Wijnen
			will coordinate to make this happen).
		- Remaining 3 WG MIBs will go to WG Last Call by end
			of November.

--> Record status

T11.5 Status, Fibre Channel MIBs under development: 20 min
		Roger Cummings (Symantec, T11.5 chair)

See slides.

T11.5 has 3 more MIBs that will be sent to the imss WG - Zone Server
MIB, Registered State Change Notification MIB, and Fabric Configuration
Server MIB.  The imss WG's current Apr 06 milestone to determine what
to do next will be replaced by a milestone (later in 2006) to work on
these 3 MIBs.  These 3 MIBs may not be ready for handoff to imss prior
to the next IETF meeting, but the mechanism used in Paris for the VF
MIB can be reused - the imss WG can decide to accept the drafts
as official WG drafts subject to a pending T11 formal votes to pass
change control to the IETF.

T11.5 is considering assigning MIB development responsibility to protocol
development work groups instead of the current approach of having a separate
group that works on MIBs.  This will be discussed at the T11 meetings in
early December.

FLIP (FAIS Line Interface Protocol) Conceptual Discussion: 25 min
		Roger Cummings (Symantec, T11.5 chair)
	 draft-cummings-imss-flip-00.txt

See presentation.  Netconf appears promising for the configuration
aspects of FLIP, but currently contains no support for events or
notifications from the configured device.  Use of netconf would
result in functionality at the level of the configuration model
instead of a 1-1 match between FAIS API calls and RPCs.  The
required event/notification mechanism needs to be capable of
carrying a fair amount of structured information - it is somewhat
analogous to the use of COPS to ask a policy decision point
"I just received this RSVP reservation request, what should I do
about it?".  There are also concerns about effective transmission
of bulk binary data (encoding in XML is unworkable, but encapsulation
or wrapping in XML is probably ok).  The netconf group is not currently
standardizing schemas, but will want/need to, so this could be a
timely interaction between imss and netconf.

The FLIP concept and suggested use of netconf will be discussed
further in the early December T11 meetings.

_______________________________________________
imss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imss

---

From: [email-masked]
Date: Wed, 9 Nov 2005 17:08:19 -0500

Roger,

1) is an AI to you (Roger).  Please cc: me so that I
	can track the results.

2) will be corrected in the final minutes.

I will also remove your T11.5 chair affiliation from the
FLIP agenda item in the minutes to match the bashed agenda.

Thanks,
--David
p.s.  How come none of the Symantec pens here at IETF
	work? I'm sitting in front of a pile of them.
	I know ... they're not Veritas pens ;-).
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> David,
> 
> Thanks for posting the minutes so promptly.
> 
> Two minor points:
> 
> 1) Bert made a suggestion that a message is sent to the Netconf mailing
> list soliciting interest in helping with the schema definition. Is that
> an AI to you or I?
> 
> 2) I'd like to modify the last sentence to read " The FLIP concept and
> suggested use of netconf will be discussed further at T11 before the
> next imss meeting." The focus for December has to be resolving FAIS
> Letter Ballot comments, and if that means that the FLIP discussion
> doesn't get done until later, that's the way it should be.
> 
> Regards,
> 
> 
> 
> 
> Roger
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of [email-masked]
> > Sent: Wednesday, November 09, 2005 1:28 PM
> > To: [email-masked]
> > Subject: [imss] Vancouver Minutes (DRAFT)
> > 
> > Internet and Management Support for Storage (imss) WG Meeting 
> > - Vancouver, Canada Tuesday, November 8, 2005: 1740-1840 
> > Minutes - DRAFT
> > T11.5 has 3 more MIBs that will be sent to the imss WG - Zone 
> > Server MIB, Registered State Change Notification MIB, and 
> > Fabric Configuration Server MIB.  The imss WG's current Apr 
> > 06 milestone to determine what to do next will be replaced by 
> > a milestone (later in 2006) to work on these 3 MIBs.  These 3 
> > MIBs may not be ready for handoff to imss prior to the next 
> > IETF meeting, but the mechanism used in Paris for the VF MIB 
> > can be reused - the imss WG can decide to accept the drafts 
> > as official WG drafts subject to a pending T11 formal votes 
> > to pass change control to the IETF.
> > 
> > T11.5 is considering assigning MIB development responsibility 
> > to protocol development work groups instead of the current 
> > approach of having a separate group that works on MIBs.  This 
> > will be discussed at the T11 meetings in early December.
> > 
> > See presentation.  Netconf appears promising for the 
> > configuration aspects of FLIP, but currently contains no 
> > support for events or notifications from the configured 
> > device.  Use of netconf would result in functionality at the 
> > level of the configuration model instead of a 1-1 match 
> > between FAIS API calls and RPCs.  The required 
> > event/notification mechanism needs to be capable of carrying 
> > a fair amount of structured information - it is somewhat 
> > "I just received this RSVP reservation request, what should I 
> > do about it?".  There are also concerns about effective 
> > transmission of bulk binary data (encoding in XML is 
> > unworkable, but encapsulation or wrapping in XML is probably 
> > ok).  The netconf group is not currently standardizing 
> > schemas, but will want/need to, so this could be a timely 
> > interaction between imss and netconf.
> > 
> > The FLIP concept and suggested use of netconf will be 
> > discussed further in the early December T11 meetings.
> >

---

From: "Roger Cummings" <[email-masked]>
Date: Wed, 9 Nov 2005 14:19:47 -0500

David,

Two minor points:

Regards,

Roger

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 11 Nov 2005 16:51:53 +0100

Inline

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Roger Cummings
> Sent: Wednesday, November 09, 2005 20:20
> To: [email-masked]; [email-masked]
> Subject: RE: [imss] Vancouver Minutes (DRAFT)
> 
> 
> David,
> 
> 1) Bert made a suggestion that a message is sent to the 
> Netconf mailing list soliciting interest in helping with the schema 
> definition. Is that an AI to you or I?
> 

We can go back to listen to the audio if we want to, but I think I mentioned
that I suggested to send a msg to netconf list to inform them about your
FLIP draft and sollicit partcipation/help.

I think I also mentioned that doing a XML schema might be an option,
but if that should be standardized right away is to be determined.
NetConf sofar has not gotten approval from the ADs to do any standardization
work foe XML Schemas. Once we have a schema definition and once we see
people implement/play with it/use it, then we can discuss if we can or
should standardize.

They also are discussing events. And since you seem to have a requirement,
it would be good to clearly specify them and see how well they match with
requirements that others claim in this space.

Bert

---

From: "Roger Cummings" <[email-masked]>
Date: Tue, 15 Nov 2005 10:42:32 -0500

Thanks for the clarification, Bert. I'll get a message out to the
netconf list this week once I've posted a new version of the I-D with a
section about requirements for events. I'll also see if I can put in a
summary of the types of function calls in the current API to serve as a
basis for a discussion on the types of operation that will be required.

Regards,

Roger Cummings
Symantec

[email-masked]

> From: Wijnen, Bert (Bert) [mailto:[email-masked]] 
> Sent: Friday, November 11, 2005 10:52 AM
> To: Roger Cummings; [email-masked]; [email-masked]
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of 
> > Roger Cummings
> > 1) Bert made a suggestion that a message is sent to the Netconf 
> > mailing list soliciting interest in helping with the schema 
> We can go back to listen to the audio if we want to, but I 
> think I mentioned that I suggested to send a msg to netconf 
> list to inform them about your FLIP draft and sollicit 
> partcipation/help.
> 
> I think I also mentioned that doing a XML schema might be an 
> option, but if that should be standardized right away is to 
> be determined.
> NetConf sofar has not gotten approval from the ADs to do any 
> standardization work foe XML Schemas. Once we have a schema 
> definition and once we see people implement/play with it/use 
> it, then we can discuss if we can or should standardize.
> 
> They also are discussing events. And since you seem to have a 
> requirement, it would be good to clearly specify them and see 
> how well they match with requirements that others claim in this space.
> 
> Bert
> > > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > > Of [email-masked]
> Minutes - 
> > > DRAFT
> > > MIB, Registered State Change Notification MIB, and Fabric 
> > > Configuration Server MIB.  The imss WG's current Apr
> > > 06 milestone to determine what to do next will be replaced by a 
> > > milestone (later in 2006) to work on these 3 MIBs.  These 
> 3 MIBs may 
> > > not be ready for handoff to imss prior to the next IETF 
> meeting, but 
> > > the mechanism used in Paris for the VF MIB can be reused 
> - the imss 
> > > WG can decide to accept the drafts as official WG drafts 
> subject to 
> > > a pending T11 formal votes to pass change control to the IETF.
> > > 
> > > T11.5 is considering assigning MIB development responsibility to 
> > > protocol development work groups instead of the current 
> approach of 
> > > having a separate group that works on MIBs.  This will be 
> discussed 
> > > at the T11 meetings in early December.
> > > 
> configuration 
> > > analogous to the use of COPS to ask a policy decision 
> point "I just 
> > > received this RSVP reservation request, what should I do 
> about it?".  
> > > There are also concerns about effective transmission of 
> bulk binary 
> > > data (encoding in XML is unworkable, but encapsulation or 
> wrapping 
> > > in XML is probably ok).  The netconf group is not currently