Subject: Re: [imss] Acceptance of draft-kzm-imss-fc-fcsp-mib-00.txt as an imss

From: Keith McCloghrie <[email-masked]>
Date: Sat, 7 Jul 2007 06:47:03 -0700 (PDT)

David,

The document is certainly larger than normal.  However, I think
that on balance it would be disadvantageous to split the document.
Doing so would make each of multiple documents be "easier to handle"
but at the cost of an increase in the sum total amount of work, e.g.,
N documents incur N times as much IETF-process overhead, and more
time/work to be spent in checking the cross-references between the N
documents.  From a technical point of view, I think the necessary
modularity is already obtained by having six MIB modules, i.e., without
needing any MIB module to be in a separate document.  Having a single
document will also be the most efficient way to review the document,
i.e., one large review, rather than a set of individually-smaller
reviews which incur a larger aggregate of review effort.  So, if WG is
willing and if Dan can find a MIB Doctor to review the work as a single
document, then I think that's the most efficient.

Keith.

> As Keith noted to the list last month, the draft
> draft-kzm-imss-fc-fcsp-mib-00.txt has been posted to
> the Internet-Draft servers.  This contains security
> management MIB modules that have been worked on in T11,
> and is intended as the starting point for the final
> work item on the imss WG's charter:
> 
> Dec 2007	Submit Fibre Channel Security MIB modules
> 		to IESG for consideration as proposed standard
> 
> In the absence of objection, this draft will be accepted
> as an official imss WG draft during the IETF meeting
> week in Chicago, July 22-27.  Note: the imss WG is not
> meeting in Chicago as my intent is to handle work on
> this draft almost entirely on the mailing list.  There
> will be a meeting in Vancouver if there are technical
> issues to discuss.
> 
> I would like to see comments on acceptance of this draft,
> and particularly on its size.  The draft is nearly
> 250 pages - security is not easy to manage ;-).  It
> contains 6 MIB modules, and so I'm interested in hearing
> whether the draft ought to be split into multiple smaller
> drafts that may be easier to handle.
> 
> Thanks,
> --David (imss WG chair)
> ----------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 176 South St., Hopkinton, MA  01748
> +1 (508) 293-7953             FAX: +1 (508) 293-7786
> [email-masked]        Mobile: +1 (978) 394-7754
> ----------------------------------------------------
> 

_______________________________________________
imss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imss

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 8 Jul 2007 12:00:18 +0200

Speaking as a contributor I agree with the arguments presented by David
and Keith. Splitting the documents will make in no way the life easier
to implementers, will create an overhead in repeated boilerplate text
can create potential cross-reference and document synchronization
issues. 

Speaking as AD, the task of finding reviewers for say three or four
mid-sized documents is not easier than the task of finding a reviewer
for one large sized document :-)

>From both perspectives I support accepting the document in its current
one document format.  

Dan

> -----Original Message-----
> From: Keith McCloghrie [mailto:[email-masked]] 
> Sent: Saturday, July 07, 2007 4:47 PM
> To: [email-masked]
> Cc: [email-masked]; Romascanu, Dan (Dan)
> Subject: Re: [imss] Acceptance of 
> draft-kzm-imss-fc-fcsp-mib-00.txt as an imss
> 
> David,
> 
> The document is certainly larger than normal.  However, I 
> think that on balance it would be disadvantageous to split 
> the document.
> but at the cost of an increase in the sum total amount of 
> work, e.g., N documents incur N times as much IETF-process 
> overhead, and more time/work to be spent in checking the 
> cross-references between the N documents.  From a technical 
> point of view, I think the necessary modularity is already 
> obtained by having six MIB modules, i.e., without needing any 
> MIB module to be in a separate document.  Having a single 
> document will also be the most efficient way to review the 
> document, i.e., one large review, rather than a set of 
> individually-smaller reviews which incur a larger aggregate 
> of review effort.  So, if WG is willing and if Dan can find a 
> MIB Doctor to review the work as a single document, then I 
> think that's the most efficient.
> 
> Keith.
> 
> > draft-kzm-imss-fc-fcsp-mib-00.txt has been posted to the 
> > Internet-Draft servers.  This contains security management 
> MIB modules 
> > that have been worked on in T11, and is intended as the 
> starting point 
> > for the final work item on the imss WG's charter:
> > 
> > In the absence of objection, this draft will be accepted as an 
> > official imss WG draft during the IETF meeting week in 
> Chicago, July 
> > 22-27.  Note: the imss WG is not meeting in Chicago as my 
> intent is to 
> > handle work on this draft almost entirely on the mailing 
> list.  There 
> > will be a meeting in Vancouver if there are technical issues to 
> > discuss.
> > 
> > I would like to see comments on acceptance of this draft, and 
> > particularly on its size.  The draft is nearly 250 pages - 
> security is 
> > not easy to manage ;-).  It contains 6 MIB modules, and so I'm 
> > interested in hearing whether the draft ought to be split into 
> > multiple smaller drafts that may be easier to handle.
> > 
> > Thanks,
> > --David (imss WG chair)