Subject: Re: [Insipid] INSIPID Req#6 - comments?

From: Laura Liess <[email-masked]>
Date: Thu, 3 May 2012 11:01:41 +0200

Paul,

We had a parallel discussion on this issue and agreed to change the
REQ-6 as follows:

 "REQ6: The identifier must not reveal to the receiver of it the
 Call-ID, tags, or any other SIP header or body portion. "

This requirement still ensures topologies and peering relationships
remain protected, but it is easier to comply to it than the REQ6 in
its current form.

Would this be OK for you?

See http://www.ietf.org/mail-archive/web/insipid/current/msg00079.html

Thanks,
Laura

2012/4/30 Paul E. Jones <[email-masked]>:
> I thought somebody replied on this one.  In any case, the intent is to not
> reveal to the world that a call has passed through an SBC. I assume this is
> to ensure topologies and peering relationships remain protected.
>
> Paul
>
>
> On 4/27/2012 9:07 AM, Laura Liess wrote:
>>
>> Hi,
>>
>> The benefit of having this requirement is not clear to me. What may
>> happen if we do not have it?
>> We have REQ5, which ensure hiding of every kid of device identity, in
>> order to avoid B2BUAs to change the Session-ID. REQ5 is important. But
>> REQ6? If we can not find out what the reason for it is, I propose to
>> drop it, because having REQ6  may complicate the solution, I think.
>>
>> Thanks
>> Laura
>>
>> 2012/4/26 James M. Polk<[email-masked]>:
>>>
>>> Figure it is about time I sent these requirements out to the list.
>>> Comments,
>>> questions and wordsmithing are encouraged. Let's see if we can leave much
>>> of
>>> the wordsmithing till the end of the discussion, once we have agreed on
>>> the
>>> requirement's worthiness and contents.
>>>
>>> Let's also keep the discussion on *this* thread to just *this*
>>> requirement
>>> for tracking purposes. There are 9 current requirements. Therefore, there
>>> will be 9 different messages sent to this list.
>>>
>>> Here is REQ#6 as currently written in
>>>
>>> http://www.ietf.org/internet-drafts/draft-jones-insipid-session-id-reqts-00.txt
>>>
>>>   REQ6: The identifier must not reveal to the receiver of it
>>>   that the Call-ID, tags, or any other SIP header or body
>>>   portion have been changed by middleboxes, with as high a
>>>   probability as possible.
>>> _______________________________________________
>>> insipid mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/insipid
>>
>> _______________________________________________
>> insipid mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/insipid
>
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 03 May 2012 09:29:57 -0400

Laura,

No objection.  Just trying to make this requirement a little easier to 
read, I re-ordered it a little.  How does this sound?

REQ6: The identifier must not reveal the Call-ID, tags, or any other SIP 
header or body portion to the receiver.

Paul

On 5/3/2012 5:01 AM, Laura Liess wrote:
> 2012/4/30 Paul E. Jones<[email-masked]>: