Subject: Re: [Insipid] Proposed New Requirement: Marking for Logging

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 4 May 2012 16:09:07 +0200

Coming in on this late.

I think there are several steps in this discussion.

1)	Is the session ID that INSIPID have to define sufficient to identify a tracked call. The original dawes proposal created an entirely separate identifier to identify such calls. Is that a better solution than using the session ID?

Obviously if we agree the reuse of the session ID, we need to make sure it is fit for purpose.

2)	If session ID is used for this, then some tagging is required that says something like, "log anything with this session id" at least at some point in the session. That can either be integrated with the session id, or handled as an entirely separate parameter. If it is integrated it certainly needs to be done by INSIPID. If it is not then it could be, or it could be done elsewhere.

All this is of course dependent on whether people feel logging of specific calls is a useful function. It is perfectly valid for the WG to say it is not.

As WG cochair, I am certainly interested in determining how much of this people are interested in working on, and how much they consider to be in scope fo the group.

Keith

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 27 March 2012 18:33
To: [email-masked]
Subject: Re: [Insipid] Proposed New Requirement: Marking for Logging

I don't quite get this. It sounds like you are bundling two things that 
don't need to be bundled:
- the session-id
- a request to log the call

I see no need to couple those things. If you can mark the call to be 
logged, and if it happens to have a sesson-id, then there will be data 
about the call, including the session-id, in logs of all the systems 
traversed. But you can still have session-ids without logging, and you 
can have logging without session-ids.

	Thanks,
	Paul

On 3/26/12 9:38 PM, Dawes, Peter, Vodafone Group wrote:
> Hello James, All,
> Thanks for presenting your requirements draft for the session identifier. The requirement I propose to add is on slide 7 of my presentation in the INSIPID meeting materials (http://www.ietf.org/proceedings/83/slides/slides-83-insipid-1.pdf) as follows:
>
> "It must be possible to mark a session identifier as inserted for logging purposes"
> "...in order to keep network operations and maintenance steps and also SIP entity data volume and processing load to practical levels when troubleshooting"
>
> Slides 1-6 illustrate the reasons behind this proposed requirement.
>
> Regards,
> Peter
>
> _______________________________________________
> insipid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/insipid
>

_______________________________________________
insipid mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/insipid

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 04 May 2012 11:21:37 -0400

Keith,

I agree with all you say below. But I'll also observe that if there is a 
desire to do this sort of logging, and if the session-id being worked on 
by insipid isn't suitable for the purpose, then it raises the question 
of whether every use of a "session id" requires a distinct id for that 
purpose.

	Thanks,
	Paul