Subject: [Insipid] proposal for replacement of "communication session" in requirements draft

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Sat, 3 Nov 2012 20:37:47 +0000

I was reading  draft-ietf-insipid-session-id-reqts-02 and the corresponding thread:
http://www.ietf.org/mail-archive/web/insipid/current/msg00394.html

How about we call it a SIP message exchange, where a SIP message exchange consists of one of more SIP transactions between two end systems. A very simple SIP exchange may be a single out-of-dialog SIP transaction (e.g. MESSAGE/200) between the two end systems. In the case of a SIP dialog, the SIP message exchange includes a dialog creating INVITE transactions, and  zero of more subsequent SIP transactions within the same dialog (e.g. ACK, re-INVITE, BYE). Due to the existence of middle boxes, there may be multiple related SIP transactions or dialogs chained together along the path from one end system to the other. For example:

A -------middlebox--------B
SIP trans1 -----> SIP trans 2
SIP dialog 1 ---> SIP dialog 2

In such cases, the two SIP transactions or dialogs are part of a single SIP exchange.

Cheers,
Charles

---

From: Paul Kyzivat <[email-masked]>
Date: Sat, 03 Nov 2012 18:12:48 -0400

Charles,

This could work. It doesn't have pizzazz, I haven't thought of anything 
better.

If so, maybe we need to have 'message-exchange-id:nnnnn' :-)

	Thanks,
	Paul

On 11/3/12 4:37 PM, Charles Eckel (eckelcu) wrote:
> _______________________________________________
> insipid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/insipid
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Sun, 4 Nov 2012 01:03:57 +0000

Yah, perhaps not an optimal name. If we get agreement on the definition, we can open a naming contest up to the folks who always chime in with catchy WG names.

Cheers,
Charles

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Paul Kyzivat
> Sent: Saturday, November 03, 2012 6:13 PM
> To: [email-masked]
> Subject: Re: [Insipid] proposal for replacement of "communication session"
> in requirements draft
> 
> Charles,
> 
> > How about we call it a SIP message exchange, where a SIP message
> exchange consists of one of more SIP transactions between two end
> systems. A very simple SIP exchange may be a single out-of-dialog SIP
> transaction (e.g. MESSAGE/200) between the two end systems. In the case
> of a SIP dialog, the SIP message exchange includes a dialog creating INVITE
> transactions, and  zero of more subsequent SIP transactions within the same
> dialog (e.g. ACK, re-INVITE, BYE). Due to the existence of middle boxes,
> there may be multiple related SIP transactions or dialogs chained together
> along the path from one end system to the other. For example:
> >