Subject: [Insipid] Session-ID when B2BUA forks INVITE for audio and video to different locations

From: Brett Tate <[email-masked]>
Date: Tue, 13 Nov 2012 20:19:40 +0000

Hi,

What Session-ID should be communicated when a B2BUA forks a video call so INVITE for audio and INVITE for video go to different locations?  For instance, the INVITE for video is sent the computer and INVITE for audio is sent to the phone.

The concept is mentioned within draft-ietf-straw-b2bua-taxonomy-00 section 3.1.3.

The following uses draft-jones-insipid-session-id-01 to indicate Session-ID.  Hopefully the picture doesn't get too corrupted.

Session-ID
----  Alice        B2BUA     Bob-phone Bob-computer
  {A}   |---INVITE--->|            |          |
  {A}   |             |---INVITE-->|          |
  {A}   |             |---INVITE------------->|
 {Bp,A} |             |<--200 OK---|          |
 {Bc,A} |             |<--200 OK--------------|
 {Bp,A} |<--200 OK----|            |          |
 {A,Bp} |-----ACK---->|            |          |
 {A,Bp} |             |---ACK----->|          |
 {A,Bc} |             |---ACK---------------->|

Is this the expected use of draft-jones-insipid-session-id-01?  Note: Bc does not get communicated to Alice and the B2BUA adjusts the Session-ID before sending ACK to Bob-computer.

There is a similar call flow when Bob-phone originates a call to Alice.  Bob-computer is pulled into the call setup so both audio and video can be offered to Alice.  However, I will ask about that one later.

Thanks,
Brett

This email is intended solely for the person or entity to which it is addressed and may contain confidential and/or privileged information. If you are not the intended recipient and have received this email in error, please notify BroadSoft, Inc. immediately by replying to this message, or by sending an email to [email-masked], and destroy all copies of this message, along with any attachment, prior to reading, distributing or copying it.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 13 Nov 2012 16:14:46 -0500

> There is a similar call flow when Bob-phone originates a call to Alice.  Bob-computer is pulled into the call setup so both audio and video can be offered to Alice.  However, I will ask about that…

IMO there is a philosophical decision here that the B2BUA must make.

As you have shown it, the B2BUA is acting as an *intermediary*, and is 
treating the phone as the callee. The computer is a secondary issue.

Another way to view it is that the B2BUA is the device Alice talks to, 
and that both the phone and computer are just incidental peripherals. In 
that case the B2BUA might assign an ID itself. This might be better if 
the devices used might change - e.g. the phone dropped out while the 
call continues. This also might make sense if the sessions between the 
B2BUA and the phone/computer are long lived rather than being formed 
when the incoming call from Alice arrives.

So there may be no single answer to this. But that does beg the question 
of which choices are valid ways to assign the IDs, and which ways are not.

	Thanks,
	Paul

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 14 Nov 2012 19:59:00 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Paul Kyzivat
> Sent: Tuesday, November 13, 2012 1:15 PM
> To: [email-masked]
> Subject: Re: [Insipid] Session-ID when B2BUA forks INVITE for audio and
> video to different locations
>
> > What Session-ID should be communicated when a B2BUA forks a video call
> so INVITE for audio and INVITE for video go to different locations?  For
> instance, the INVITE for video is sent the computer and INVITE for audio is
> sent to the phone.
> >
> > The following uses draft-jones-insipid-session-id-01 to indicate Session-
> ID.  Hopefully the picture doesn't get too corrupted.
> >
> > Session-ID

I would expect this session ID to be {B,A}, where the B2BUA creates its own uuid (B) and manages the mapping to Bp and Bc.

> > Is this the expected use of draft-jones-insipid-session-id-01?  Note: Bc
> does not get communicated to Alice and the B2BUA adjusts the Session-ID
> before sending ACK to Bob-computer.
> >
> > There is a similar call flow when Bob-phone originates a call to Alice.  Bob-
> computer is pulled into the call setup so both audio and video can be
> offered to Alice.  However, I will ask about that one later.
>

My comment above aligns with this option. I agree, it is not the only option.

Cheers,
Charles

> _______________________________________________
> insipid mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/insipid

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 21 Nov 2012 01:13:14 -0500

Brett,

Well, this is certainly different.  Does the phone ring?  Does the computer
ring?  Does the user independently answer each one of those devices?  And
what would happen if the PC has only audio?  I assume only the B2BUA knows
the capabilities of devices in advance?

Basically, what we have on the right-hand side of the B2BUA is two
completely independent SIP sessions that are more-or-less "conferenced" via
the B2BUA.  The media might be going directly to the endpoints, but it is
still very much like a conference server where there is Alice, Bob, and
Carol all in a conference.

So, given that, I would expect to see these three Session-IDs:
{A,F} - Session ID between Alice and the B2BUA (F)
{F,Bp} - Session ID between the B2BUA and Bob's phone
{F,Bc} - Session ID between the B2BUA and Bob's computer

This means there are three unique identifiers, but there still exists the
possibility to correlate the calls since F is in common across all sessions.

There are limits to the utility of having F in all sessions.  For example, A
is not present anywhere on the right-hand side.  If A happened to be an MCU
that had 100 calls in conference, it might be possible to relate all the
sessions on the left side of the B2BUA, but the diagnostic / monitoring
equipment looking at the right side would never see A.  Thus, it's not
perfect.  Even so, I think that approach would provide a "better than
nothing" solution.

Paul

> Behalf Of Brett Tate
> Sent: Tuesday, November 13, 2012 3:20 PM
> To: [email-masked]
> Subject: [Insipid] Session-ID when B2BUA forks INVITE for audio and
> instance, the INVITE for video is sent the computer and INVITE for audio
> is sent to the phone.
> 
> The following uses draft-jones-insipid-session-id-01 to indicate
> Session-ID.  Hopefully the picture doesn't get too corrupted.
> 
> Session-ID
> There is a similar call flow when Bob-phone originates a call to Alice.
> Bob-computer is pulled into the call setup so both audio and video can
> be offered to Alice.  However, I will ask about that one later.
> 
> Thanks,
> Brett
> 
> This email is intended solely for the person or entity to which it is
> addressed and may contain confidential and/or privileged information. If
> you are not the intended recipient and have received this email in error,
> please notify BroadSoft, Inc. immediately by replying to this message,
> or by sending an email to [email-masked], and destroy all copies
> of this message, along with any attachment, prior to reading,
> distributing or copying it.
> [email-masked]