Subject: Re: [Insipid] Mirja Kühlewind's No Objection on draft-ietf-insipid-logme-reqs-12: (with COMMENT)

From: "Arun Arunachalam (carunach)" <[email-masked]>
Date: Wed, 1 Feb 2017 10:52:30 +0000

Hi Mirja,

Thanks for taking the time to review and sharing your feedback!

We discussed<https://mailarchive.ietf.org/arch/msg/insipid/WW-zjypKhmiAMlFSwJw4BVB5Zwc> about the need to publish the requirement doc with Ben Campbell during AD evaluation process.

We would like to share key points from the discussion to IESG team for consideration:

(1) The primary objective of this requirements draft is to give an high-level understanding of the motivating scenario, concept definitions (e.g. network boundary), and provide clarity on the complete list of requirements that a proposed solution needs to satisfy. In our logging and troubleshooting scenarios, the requirements list has been identified through discussions and consensus among INSIPID working group members. The solution draft defines the protocol mechanism details. Implementors / Developers are expected to reference both documents.

(2) INSIPID working group has been following this top down approach for quite a while as can been seen from the decisions from 2013 and 2014. The group has worked for a long time on acceptable requirements and we think that it is valuable to freeze them now and publish them as a reference that explains the problem scope and defines the target for the solution to fulfil.

(3) Working group decisions:

(a) IETF 87, Berlin, 2013 the meeting notes (https://mailarchive.ietf.org/arch/msg/insipid/08l7_9vrzRlmV0qGkgDxDrBi8Ig) say " Log-me requirements: Alternatives to LogMe draft should be submitted in following weeks. Solution draft will come later."
(b) IETF 88, Vancouver, 2013, it is noted (https://www.ietf.org/proceedings/88/minutes/minutes-88-insipid) that "Proposal is to remove the solution text in the current version and adopt the requirements part as WG draft.- Paul K: Had a bunch of comments.  Not sure the subset of requirements is ready to be adopted. There is still a bunch of trust issues with storing the log.- Gonzalo S: Solution discussion has not even begun yet. This is purely the requirements we are talking about"
(c) And the working group milestones have been stable since February 2014 (https://mailarchive.ietf.org/arch/msg/insipid/vxRRrq_OxJyCWZDtHD25U32chCo):
"Changed milestone "Requirements for marking SIP sessions for logging to IESG (Informational)", set due date to September 2014 from June 2014.
Changed milestone "Protocol for marking SIP sessions for logging to IESG (Proposed Standard)", set due date to December 2014 from November 2014.”

Thanks!
Arun & Peter (co-authors)

On Jan 31, 2017, at 11:31 AM, Mirja Kuehlewind <[email-masked]<mailto:[email-masked]>> wrote:

Mirja Kühlewind has entered the following ballot position for
draft-ietf-insipid-logme-reqs-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-insipid-logme-reqs/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I don't see a value in publishing this draft as a stand-alone document.
If needed content can be merged into draft-ietf-insipid-logme-marking
(maybe in the appendix); especially the security considerations belong in
the spec itself.

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Wed, 1 Feb 2017 12:27:47 +0100

Hi Arun, Hi Peter,

I do see well the value of having and working on this document in the wg process. I just don’t see any archivable value of it that justifies to run through the IETF process to the end and publish it as an RFC.

Alternatively, you can simply declare this document as done in the wg (also mark the milestone as done) and potentially copy parts of it in (the appendix of) the final protocol document if you still think by then that there are parts that should be achieved in the RFC series.

Again, I don’t think this document has a stand-alone value for anybody who is not involved in the wg process and I don’t think it will have any historical value in future, and therefore this document does not need to be published in the RFC series.

Mirja

> Am 01.02.2017 um 11:52 schrieb Arun Arunachalam (carunach) <[email-masked]>:
> 
> Hi Mirja,
> 
> We discussed about the need to publish the requirement doc with Ben Campbell during AD evaluation process. 
> 
>> On Jan 31, 2017, at 11:31 AM, Mirja Kuehlewind <[email-masked]> wrote:
>>