Subject: [Int-area] reorganization of Mobile IPv6 related working groups

From: Jari Arkko <[email-masked]>
Date: Fri, 16 Mar 2007 14:49:30 +0200

Hi all,

We are planning to reorganize the MIP6, MONAMI6, and NEMO
working groups in the Internet Area. The idea is to merge
these three groups, all of which work around the Mobile IPv6
protocol and its extensions. The merge will not happen
immediately, but around the IETF69 time frame when
MIP6 has completed a few more of its work items, MONAMI6
has submitted its main specification, and NEMO has gotten
on its way with its newly chartered work. The resulting
working group will be bigger, but still committed to
completing work on all three aspects, i.e., base features,
support for multiple care-of addresses, and network
mobility. The chartered work items or their planned
delivery dates will not be changed because of this.

The reasons why we are making this change include

- Putting most of work around Mobile IPv6 and its extensions
  into one place, reducing the need to coordinate, and
  making it easier for new people and outsiders to see
  where this work is happening.

- The bigger group makes it easier to find reviewers,
  and have a complete picture of how the protocol is
  being extended.

- Provide a better ability to prioritize work and maybe
  add some competition for resources.

- Easier management for the ADs, needing to deal with
  one instead of three groups.

- Make room in the meeting schedule and area for BOFs
  and new groups. I have groups meeting at the same
  time in Prague, for instance.

- This is a good time for this change in the lifecycle
  of the three groups.

The detailed implementation of this change will take place
in the coming months, but we wanted to give everyone a heads-up
that this is going to happen. And an opportunity for comments,
we do appreciate feedback on this and other issues relating
to the management of the area. Speaking of comments -- this
note goes out to a number of lists, but please direct further
discussion to myself and the int-area list.

Jari and Mark

_______________________________________________
Int-area mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/int-area

---

From: "Jean-Michel Combes" <[email-masked]>
Date: Fri, 16 Mar 2007 17:49:53 +0100

Hi,

Will there be a slot during the INT Area session in Prague about this?

Best regards.

JMC.

2007/3/16, Jari Arkko <[email-masked]>:
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6
>

---

From: Jari Arkko <[email-masked]>
Date: Fri, 16 Mar 2007 19:03:16 +0200

> Will there be a slot during the INT Area session in Prague about this?

No, because we are spending that slot on the routing
and addressing discussion. If you want to talk about it
in the meeting, come to one of the three WGs, or otherwise
just catch me somewhere and we can talk.

Jari

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 16 Mar 2007 18:42:42 +0100

Jari Arkko wrote:
> Hi all,
> 
> We are planning to reorganize the MIP6, MONAMI6, and NEMO working
> groups in the Internet Area. The idea is to merge these three groups,
> all of which work around the Mobile IPv6 protocol and its extensions.
> 
[...]
> And an opportunity for comments, we do appreciate feedback on this
> and other issues relating to the management of the area.

IMHO.

A combined number of 27 WG items (quick count from WG pages, but may
vary until IETF69) with a large chunk from MIP6, then NEMO then MONAMI6.

A combined number of 5 Chairs (not 6).

Sounds like ramping down some activities may happen and maybe offering
more opportunities to BoFs may be good.

(the last such large reorganization of mobility was when MIP WG became
  MIP6/MIP4/MIPSHOP/MOBOPTSRG)

Alex

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

---

From: Francis Dupont <[email-masked]>
Date: Sat, 17 Mar 2007 00:04:50 +0100

=> without argueing whether it is a good or bad idea, this should
be discussed, for instance in one of the 3 WG meetings, or the plenary,
or where you'd like...

Regards

[email-masked]

---

From: Jari Arkko <[email-masked]>
Date: Sat, 17 Mar 2007 17:29:54 +0200

> be discussed, for instance in one of the 3 WG meetings, or the plenary,
Sure. Lets talk about this at the beginning of the Monami6
meeting, on Monday.

Jari

---

From: Thierry Ernst <[email-masked]>
Date: Sat, 17 Mar 2007 17:49:27 +0100

Good idea. I've included a 15min slot in the Monami6 WG agenda at the
beginning, hope you are fine with this. We can extend this slot with a
bit of extra time if needed.

Thierry.

On Sat, 17 Mar 2007 17:29:54 +0200

-- 
Thierry ERNST, PhD 
INRIA Rocquencourt France Project-Team IMARA / JRU LARA
http://www.lara.prd.fr +33 1 39 63 59 30 (office)

---

From: Conny Larsson <[email-masked]>
Date: Sun, 18 Mar 2007 10:38:21 +0100

Jari, Mark,

I believe the reasons you have listed below are fine, but I was 
wondering about the NetLMM work and whether that should fit into this 
work as well given the fact that this protocol (PMIP) is based on MIPv6 
and there are a number of issues related to the interaction of MIPv6 and 
PMIP being discussed right now?

Is the reason for not merging the NetLMM WG with the others that it's a 
network based mobility solution whereas the others are host-based?

/Conny

---

From: Jari Arkko <[email-masked]>
Date: Sun, 18 Mar 2007 12:37:04 +0200

Conny,

> work as well given the fact that this protocol (PMIP) is based on
> MIPv6 and there are a number of issues related to the interaction of
> MIPv6 and PMIP being discussed right now?
>
> Is the reason for not merging the NetLMM WG with the others that it's
> a network based mobility solution whereas the others are host-based?

That's a good question. It is true that Netlmm has a significant connection
to Mobile IPv6. However, when we were thinking about this we came to
the conclusion that the group is in a stage where it needs to work on
its own to produce the main specification, and before that happens its
hard to think about any form of re-organization. The activity level in
the group is also extremely high, so at this point it seems to make more
sense to keep this one separate.

Jari

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Sun, 18 Mar 2007 11:56:16 -0700

Hi Jari,
I think this is much needed and a very good way forward. I agree with
all your points below on why such merging makes sense. Thanks to both
you and Mark for taking the initiative to consolidate the work. 

Regards,
Vidya

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Friday, March 16, 2007 5:50 AM
> To: Mobile IPv6 Mailing List; Monami6 Mailing List; Nemo Mailing List
> Cc: Internet Area
> Subject: [Monami6] reorganization of Mobile IPv6 related 
> working groups
> 
> Hi all,
> 
> MIP6 has completed a few more of its work items, MONAMI6 has 
> submitted its main specification, and NEMO has gotten on its 
> way with its newly chartered work. The resulting working 
> group will be bigger, but still committed to completing work 
> on all three aspects, i.e., base features, support for 
> multiple care-of addresses, and network mobility. The 
> chartered work items or their planned delivery dates will not 
> be changed because of this.
> 
> The detailed implementation of this change will take place in 
> the coming months, but we wanted to give everyone a heads-up 
> that this is going to happen. And an opportunity for 
> comments, we do appreciate feedback on this and other issues 
> relating to the management of the area. Speaking of comments 
> -- this note goes out to a number of lists, but please direct 
> further discussion to myself and the int-area list.
> 
> Jari and Mark
> 
> 
>