Subject: [Int-area] no more work to do for DHCP with CGAs?

From: Sheng Jiang <[email-masked]>
Date: Thu, 20 Sep 2007 11:24:13 +0800

Dear all,

I am recently going over the charter of SEND and CGA Extensions BOF. It
lists an item for DHCP support for CGAs. It recalls me there was a
discussion that DHCP IA option could be used to meet the network management
purpose. DHCP IA option can be used to assign the CGA that is proposed by
the host. It concluded that there is no more work to do for DHCP with CGAs.

However, in my opinion, DHCP could do more to support CGAs. See
http://www.ietf.org/internet-drafts/draft-jiang-sendcgaext-cga-config-00.txt
There are at least two more things DHCP can do for CGAs: a, to propagate the
configuration information that CGA needed, such as the public key of proxy;
b, to delegate the large computational burden of generating CGAs with high
sec value. There are still a lot works to do to make the above requirement
feasible.

Best regards,

Dr. Sheng JIANG

IP Research Department, Networking Research Department, Network Product
Line, Huawei Technologies Co. Ltd.

_______________________________________________
Int-area mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/int-area

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 20 Sep 2007 08:38:28 -0700

Please see attached for a proposal that addresses the MTU
issues for *-in-IPv4 tunnels. It also addresses the multi-mtu
subnet issue, since it does not rely on ICMP "packet too big"
messages from the last-hop router. Elements of the proposal
include:

  - trailing "footer" and data as part of encapsulation
  - tiny echo requests wrapped in encapsulation headers
    and trailing padding - used as probes to elicit tiny
    echo replies
  - tunnel endpoint discovers tunnel far end EMTU_R and
    reassemby timeout values in initial probes 
  - periodic probing to discover the tunnel path MTU,
    plus EMTU_R; reassembly timeout fluctuations
  - inner fragmentation to create inner packets no larger
    than EMTU_R
  - outer fragmentation to create outer packets no larger
    than the tunnel path MTU
  - coservative use of fragmentation to avoid packet loss
    within the tunnel
  - TE drops unfragmentable packets larger than EMTU_R
    and sends ICMP PTB w/o wasting tunnel resources
  - protection against fragment misassociations
  - protection against off-path attacks
  - protection against wrapped ip_id
  - backwards compatibility
  - incremental deployment
  - NAT traversal

Please review and send comments. 

Thanks - Fred
[email-masked]

Subject: I-D ACTION:draft-templin-inetmtu-00.txt
From: <[email-masked]>
To: <[email-masked]>
Date: Tue, 18 Sep 2007 12:15:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title		: Packetization Layer Path MTU Discovery for 
                          IP/*/IPv4 Tunnels
	Author(s)	: F. Templin
	Filename	: draft-templin-inetmtu-00.txt
	Pages		: 20
	Date		: 2007-9-18
	
   The nominal Maximum Transmission Unit (MTU) MTU of the Internet has
   become 1500 bytes, but existing IP/*/IPv4 tunneling mechanisms impose
   an encapsulation overhead that can reduce the effective path MTU to
   smaller values.  Additionally, existing IP/*/IPv4 tunneling
   mechanisms are limited in their ability to discover and utilize
   larger MTUs.  This document specifies new mechanisms for conveying
   packets over IP/*/IPv4 tunnels that address these issues.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-templin-inetmtu-00.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-templin-inetmtu-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-templin-inetmtu-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
Int-area mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/int-area