Subject: [Int-area] Stateless IPv4-in-IPv6 experiments

From: <[email-masked]>
Date: Wed, 6 Apr 2011 16:57:18 +0800

Dear all,
 
An I-D about stateless IPv4-in-IPv6 experiments has been submitted. A
URL for this Internet-Draft is:
http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00
<http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00> .
 
A website introducing the detail of experiment results is also
accessible via: http://opensourceaplusp.weebly.com/
<http://opensourceaplusp.weebly.com/> 
 
BR,
Xiaohong

---

From: Rémi Després <[email-masked]>
Date: Wed, 6 Apr 2011 18:20:47 +0200

Thank you, Xiahong, for sharing this interesting information.

In the case of BitComet and uTorrent, I wonder what happens if the host has both A+P IPv4 and IPv6, as opposed to just A+P IPv4.
Did you try that?

Regards,
RD

Le 6 avr. 2011 à 10:57, <[email-masked]> <[email-masked]> a écrit :

> Dear all,
>  
> An I-D about stateless IPv4-in-IPv6 experiments has been submitted. A URL for this Internet-Draft is: http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00.
>  
> A website introducing the detail of experiment results is also accessible via: http://opensourceaplusp.weebly.com/
>  
> BR,
> Xiaohong
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: <[email-masked]>
Date: Thu, 7 Apr 2011 12:12:05 +0800

We have tested how applications behave when it has both DS-Lite IPv4 and NAT64 IPv6 (but not native IPv6). Firefox, IE, Skype, Google Earth v5.2.1, Live Messenger, uTorrent, BitComet, were on our test list. 

Despres,regarding your question ( maybe not answering your question exactly as we tested NAT64 IPv6 instead of native IPv6 ), uTorrent v2.2 used IPv6 for login/authentication but IPv4 for the data exchange, for IPv6 peer was not able to talk to IPv4 peer. Although BitComet v1.23 issued both A and AAAA quires, it completely ignored AAAA RR and only used IPv4 for communication.

Please also see some of other test results below. DS-Lite/NAT64 experiments could be documented if it is of interests. 

Tested Apps                   IPv4/IPv6 portion

Firefox (Non-vedio) v3.6.12   All IPv6                             

video website                 Half/ half            

IE (Non-vedio) v6.0           All IPv6                            

Skype v5.0                    Major IPv6                          

Google Earth v5.2.1           Major IPv6                    

Live Messenger 2009           Major IPv4            

uTorrent v2.2                 Major IPv4     

BitComet v1.23                All IPv4       

BR,

Xiaohong

opensource A+P: http://opensourceaplusp.weebly.com/

________________________________

	发件人: Rémi Després [mailto:[email-masked]] 
	发送时间: 2011年4月7日 0:21
	收件人: DENG Xiaohong ESP/PEK
	抄送: [email-masked]
	主题: Re: [Int-area] Stateless IPv4-in-IPv6 experiments

	Regards,
	RD

		Dear all,
		 
		An I-D about stateless IPv4-in-IPv6 experiments has been submitted. A URL for this Internet-Draft is: http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00 <http://tools.ietf.org/html/draft-deng-aplusp-experiment-results-00> .
		 
		A website introducing the detail of experiment results is also accessible via: http://opensourceaplusp.weebly.com/ <http://opensourceaplusp.weebly.com/> 
		 
		BR,
		Xiaohong

---

From: Rémi Després <[email-masked]>
Date: Thu, 7 Apr 2011 09:11:27 +0200

> Despres,regarding your question ( maybe not answering your question exactly as we tested NAT64 IPv6 instead of native IPv6 ), uTorrent v2.2 used IPv6 for login/authentication but IPv4 for the data…

Thank you.

> Please also see some of other test results below. DS-Lite/NAT64 experiments could be documented if it is of interests.

If you can share your results, that's always useful information.
Accordingly, if someone has results concerning native IPv6 (e2e transparent, i.e. without NAT64) plus statelessly tunneled IPv4, that would be nice to have.

Regards,
RD