Subject: Re: [Int-area] Privacy red herrings [ My comments on draft-boucadair-intarea-nat-reveal-analysis-04 from the meeting]

From: [email-masked] (Noel Chiappa)
Date: Thu, 17 Nov 2011 01:03:13 -0500 (EST)

> From: Brian E Carpenter <[email-masked]>

    > users who are not behind a CGN reveal their IP address ... every
    > time they send a packet

Hmm. If we're going to have to have a really big share of our users behind
a CGN _anyway_, to satisfy EU privacy directives, maybe we should just
punt on this whole IPv6 thing and stick with IPv4? ;-)

<Ducks!>

{Sorry, couldn't resist! :-}

	Noel

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 17 Nov 2011 21:18:28 +1300

> {Sorry, couldn't resist! :-}

It was asserted today that Baidu already uses NAT66. So we can
break e2e just as easily with IPv6.

   Brian

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 18 Nov 2011 10:18:18 +0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Brian E Carpenter
> Sent: Thursday, November 17, 2011 4:18 PM
> To: Noel Chiappa
> Cc: [email-masked]
> Subject: Re: [Int-area] Privacy red herrings [ My comments on draft-
> boucadair-intarea-nat-reveal-analysis-04 from the meeting]
> 

Baidu is a content provider.  They know all the applications 
they are running, whereas an ISP does not know all the applications
their users are running.  By virtue of this knowledge of their
own applications they are hosting Baidu's applications either 
experience no harm due to NAT66 (NPTv6?) or their applications 
know how to deal with NPTv6.

I would not want to say that Baidu's use of NAT66 (or NPTv6)
provides justification for an internet service provider to
use NAT66 or NPTv6.

-d

>    Brian
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: Ted Lemon <[email-masked]>
Date: Fri, 18 Nov 2011 02:23:55 +0000

> provides justification for an internet service provider to

Indeed, when this showed up on the chart, it was difficult to understand what purpose the NAT66 devices served in the diagram.   That is to say, we have not even heard a justification for why Baidu needed or wanted this functionality, much less why someone else would.