Subject: [Int-area] IP Connectivity Provisioning Profile (draft-boucadair-connectivity-provisioning-profile)

From: <[email-masked]>
Date: Fri, 12 Oct 2012 11:20:30 +0200

Dear all,

We submitted this new I-D which may be of interest of this WG. 

This is an effort trying to capture and expose the IP connectivity service provided by the network layer to upper services, to adjacent networks, offered/delivered to customers, etc. The document focuses on the definition of the CPP itself and does not discuss for instance how this is translated into configuration data/policies to be enforced in underlying nodes.

Abstract:
   This document describes the Connectivity Provisioning Profile (CPP)
   and proposes a CPP Template to capture IP connectivity requirements
   to be met in the context of delivery of services (e.g.  Voice over IP
   or IP TV) which are to be plugged upon an IP/MPLS infrastructure.
   The CPP defines the set of IP transfer parameters to be supported by
   the underlying IP/MPLS transport network together with a reachability
   scope and bandwidth/capacity needs.  Appropriate performance metrics
   such as one-way delay, one-way delay variation are used to
   characterize an IP transfer service.  Both global and restricted
   reachability scopes can be captured in the CPP.

   Having the generic CPP template allows for (1) automating the process
   of service negotiation and activation, thus accelerating service
   provisioning, (2) setting the (traffic) objectives of Traffic
   Engineering functions and service management functions and (3)
   enriching service and network management systems with 'decision-
   making' capabilities based on negotiated/offered CPPs.

https://datatracker.ietf.org/doc/draft-boucadair-connectivity-provisioning-profile
http://tools.ietf.org/html/draft-boucadair-connectivity-provisioning-profile-02

Comments are welcome.

Cheers,
Med

---

From: Scott Brim <[email-masked]>
Date: Fri, 12 Oct 2012 09:32:36 -0400

Would it be interesting to subsume IRS under this?

https://datatracker.ietf.org/doc/draft-atlas-irs-problem-statement/

---

From: <[email-masked]>
Date: Fri, 12 Oct 2012 15:54:19 +0200

Dear Scott,

As currently defined in draft-boucadair-connectivity-provisioning-profile, IRS level is not in the scope. 

IRS does not intervene in the same level as the proposed CPP but some IRS actions (e.g., tweak RIB entries, add a new routing topology (using MT-ISIS or MT-OSPF) or adding a new routing instance (OSPF-MI), etc.) can be used to put into effect a CPP...These actions can be also enforced using COPS or NETCONF or any other provisioning mechanism. Also, note translating a CPP into a network configuration may not be limited to routing actions: forwarding actions and resource control filters may be required too. 

As I see it, IRS is a tool among others which can be invoked to put into effect a CPP. 

Cheers,
Med 

>-----Message d'origine-----
>De : Scott Brim [mailto:[email-masked]] 
>Envoyé : vendredi 12 octobre 2012 15:33
>À : BOUCADAIR Mohamed OLNC/OLN
>Cc : [email-masked]
>Objet : Re: [Int-area] IP Connectivity Provisioning Profile 
>(draft-boucadair-connectivity-provisioning-profile)
>