Subject: Re: [Int-area] Fwd: New Version Notification for draft-nordmark-intarea-ippl-01.txt

From: Dave Thaler <[email-masked]>
Date: Thu, 5 Nov 2015 09:24:43 +0000

I notice that currently RFC 4389 is not referenced at all.
It’s Experimental since there are many ways of proxying and it just describes one of them,
but I still think it bears referencing informatively, especially since section 6 of that RFC is
very relevant to the discussion on loops in the document.

Dave

From: Int-area [mailto:[email-masked]] On Behalf Of Erik Nordmark
Sent: Tuesday, October 20, 2015 3:39 AM
To: Internet Area <[email-masked]>
Subject: [Int-area] Fwd: New Version Notification for draft-nordmark-intarea-ippl-01.txt

This update adds one more issue about Proxy ARP/ND when there are multiple routers.

   Erik

-------- Forwarded Message --------
Subject:

New Version Notification for draft-nordmark-intarea-ippl-01.txt

Date:

Mon, 19 Oct 2015 11:34:04 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

Erik Nordmark <[email-masked]><mailto:[email-masked]>

A new version of I-D, draft-nordmark-intarea-ippl-01.txt

has been successfully submitted by Erik Nordmark and posted to the

IETF repository.

Name:          draft-nordmark-intarea-ippl

Revision:      01

Title:         IP over Intentionally Partially Partitioned Links

Document date: 2015-10-19

Group:         intarea

Pages:         11

URL:            https://www.ietf.org/internet-drafts/draft-nordmark-intarea-ippl-01.txt<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2finternet-drafts%2fdraft-nordmark-intarea-ippl-01.txt&data=01%7c01%7cdthaler%40microsoft.com%7c8ffc9ba75e0f4c85b95708d2da8f0702%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=zj%2b6dMfG1dO5XaChivn3HhaPj5W3m6ppjqDTmFazqz0%3d>

Status:         https://datatracker.ietf.org/doc/draft-nordmark-intarea-ippl/<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fdatatracker.ietf.org%2fdoc%2fdraft-nordmark-intarea-ippl%2f&data=01%7c01%7cdthaler%40microsoft.com%7c8ffc9ba75e0f4c85b95708d2da8f0702%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=wlAdu3Uoe2o%2bYd2c%2fyUAuSDW5GXpxJO2sFnc6zw5s2U%3d>

Htmlized:       https://tools.ietf.org/html/draft-nordmark-intarea-ippl-01<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-nordmark-intarea-ippl-01&data=01%7c01%7cdthaler%40microsoft.com%7c8ffc9ba75e0f4c85b95708d2da8f0702%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=1ZE87Hn665vt5%2bmIO%2fRS9JjpIqfaD3x%2fCikCWIikA7o%3d>

Diff:           https://www.ietf.org/rfcdiff?url2=draft-nordmark-intarea-ippl-01<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2frfcdiff%3furl2%3ddraft-nordmark-intarea-ippl-01&data=01%7c01%7cdthaler%40microsoft.com%7c8ffc9ba75e0f4c85b95708d2da8f0702%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=OCw2%2fxbBn1NCymhy6snJXV4g%2f2%2bZce3IWtXEC1Ax1xk%3d>

Abstract:

   IP makes certain assumptions about the L2 forwarding behavior of a

   multi-access IP link.  However, there are several forms of

   intentional partitioning of links ranging from split-horizon to

   Private VLANs that violate some of those assumptions.  This document

   specifies that link behavior and how IP handles links with those

   properties.

Please note that it may take a couple of minutes from the time of submission

until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 5 Nov 2015 10:28:35 +0100 (CET)

> very relevant to the discussion on loops in the document.

I have in live networks running spanning tree and HSRP seen issue with the 
L2 mac learning timeout being 300 second (cisco default) and arp timeout 
being 4 hours (also cisco timeout) where in certain topologies the L2 
switch would not see one of the routers mac address until the arp 
timeouted, and flooded all traffic to that router to all switches.

The problem was "fixed" by turning down the arp timeout to 270 seconds.

THis is not exactly what your draft describes, but it might still be worth 
mentioning?

-- 
Mikael Abrahamsson    email: [email-masked]