Subject: [Int-area] Mail regarding draft-bonica-intarea-eping

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Sat, 25 Jun 2016 21:35:20 +0000

HI Authors,

I was reading this draft. I understand that the extended echo uses some reachable address as the destination and use address/id to probe the status of some other interface on the node. But I am trying to understand the use case it can benefit with. Is it to check if an unnumbered interface or some interface outside the domain is up?.

Regards,
Nagendra

---

From: Ronald Bonica <[email-masked]>
Date: Mon, 27 Jun 2016 14:59:10 +0000

Hi Nagendra,

The most obvious use case is for unnumbered interfaces. Assume that you are about to deploy an Internet Core Router with a loopback interface and some number of point-to-point interfaces. Deployment would be easy if you could assign a /32 to the loopback interface and leave all of the point-to-point interfaces unnumbered. But if you did that, you would lose the ability to ping the point-to-point interfaces.

This draft allows you to ping the point-to-point interfaces, even if they are unnumbered. You do that by addressing and ICMP Extended Echo packet to the loopback interface. The ICMP Extended Echo packet carries an Interface Identifier Object. The Interface Identifier Object identifies the interface whose status is being queried either by ifName or ifIndex.

The ICMP Extended Echo packet elicits an ICMP Extended Echo Reply that contains the status of the queried point-to-point interface.

                                                                            Ron

> 
> HI Authors,
> 
> I was reading this draft. I understand that the extended echo uses some
> reachable address as the destination and use address/id to probe the status
> of some other interface on the node. But I am trying to understand the use
> case it can benefit with. Is it to check if an unnumbered interface or some
> interface outside the domain is up?.
> 
> Regards,
> Nagendra