Subject: [Int-area] FW: New Version Notification for draft-ietf-intarea-probe-02.txt

From: Ron Bonica <[email-masked]>
Date: Sat, 22 Jul 2017 19:28:41 +0000

Folks,

I have updated draft-intarea-probe-02 to reflect Dave Thaler' s comment.

Dave,

Please look at the diff to see of this change reflects your recommendation.

Chairs,

If Dave thinks that his comment has been addressed, could we initiate a WG last call?

                                                                        Ron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Saturday, July 22, 2017 9:21 PM
To: Ron Bonica <[email-masked]>; Mohamed Boucadair <[email-masked]>; Jen Linkova <[email-masked]>; Reji Thomas <[email-masked]>; J. Linkova <[email-masked]>; Chris Lenart <[email-masked]>
Subject: New Version Notification for draft-ietf-intarea-probe-02.txt

A new version of I-D, draft-ietf-intarea-probe-02.txt has been successfully submitted by Ron Bonica and posted to the IETF repository.

Name:		draft-ietf-intarea-probe
Revision:	02
Title:		PROBE: A Utility For Probing Interfaces
Document date:	2017-07-22
Group:		intarea
Pages:		17
URL:            https://www.ietf.org/internet-drafts/draft-ietf-intarea-probe-02.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-intarea-probe/
Htmlized:       https://tools.ietf.org/html/draft-ietf-intarea-probe-02
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-intarea-probe-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-intarea-probe-02

Abstract:
   This document describes a network diagnostic tool called PROBE.
   PROBE is similar to PING, in that it can be used to test the status
   of a probed interface.  It differs from PING in that it does not
   require bidirectional connectivity between the probing and probed
   interfaces.  Alternatively, PROBE requires bidirectional connectivity
   between the probing interface and a proxy interface.  The proxy
   interface can reside on the same node as the probed interface or it
   can reside on a node to which the probed interface is directly
   connected.  This document updates RFC 4884.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dave Thaler <[email-masked]>
Date: Sun, 23 Jul 2017 04:35:30 +0000

It's partly there, but not quite ready.

>   If the Interface Identification Object identifies the probed
>   interface by name, the object payload contains the human-readable
>   interface name.  The interface name SHOULD be the full MIB-II ifName,
>   if less than 255 octets, or the first 255 octets of the ifName, if
>   the ifName is longer.

First, you and I talked about it being required to be an ifName, where above
still has a SHOULD.  Second, ifName is defined as a DisplayString, and
DisplayString is defined as 0-255 ASCII characters, so the truncation part is
irrelevant.  I would replace the paragraph with just:

   If the Interface Identification Object identifies the probed interface by name,
   the object payload MUST be the MIB-II [RFC2863] ifName.

Dave

> From: Ron Bonica [mailto:[email-masked]]
> Sent: Saturday, July 22, 2017 12:29 PM
> To: [email-masked]; [email-masked]; Dave Thaler
> <[email-masked]>
> Subject: FW: New Version Notification for draft-ietf-intarea-probe-02.txt
> 
> Folks,
> 
> To: Ron Bonica <[email-masked]>; Mohamed Boucadair
> <[email-masked]>; Jen Linkova <[email-masked]>; Reji
> Thomas <[email-masked]>; J. Linkova <[email-masked]>; Chris
> Lenart <[email-masked]>
> A new version of I-D, draft-ietf-intarea-probe-02.txt has been successfully
> submitted by Ron Bonica and posted to the IETF repository.
> 
> URL:
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.i
> etf.org%2Finternet-drafts%2Fdraft-ietf-intarea-probe-
> 02.txt&data=02%7C01%7Cdthaler%40microsoft.com%7Ce8cc698fc9b94b1f35
> 5b08d4d137dddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636
> 363485276071855&sdata=3l%2Fi4WAtbXZ2uVedTddXWgVRjPSoHDCcavUH2lp
> Lf90%3D&reserved=0
> Status:
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatr
> acker.ietf.org%2Fdoc%2Fdraft-ietf-intarea-
> probe%2F&data=02%7C01%7Cdthaler%40microsoft.com%7Ce8cc698fc9b94b
> 1f355b08d4d137dddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C
> 636363485276071855&sdata=sYgNOiyesuofXlBYj%2F9LhZ6yDsyx6VDS9nV%2B
> 17uRbcY%3D&reserved=0
> Htmlized:
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.i
> etf.org%2Fhtml%2Fdraft-ietf-intarea-probe-
> 02&data=02%7C01%7Cdthaler%40microsoft.com%7Ce8cc698fc9b94b1f355b0
> 8d4d137dddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636363
> 485276071855&sdata=ri9slj0Joixtj7k3cpd4PP56eduGh941783bRVAK9mY%3D
> &reserved=0
> Htmlized:
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatr
> acker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-intarea-probe-
> 02&data=02%7C01%7Cdthaler%40microsoft.com%7Ce8cc698fc9b94b1f355b0
> 8d4d137dddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636363
> 485276071855&sdata=LAIOJahlwvEKNYddfaJ7ARDmYZSR%2FiG%2B3JqP6kAG
> DZI%3D&reserved=0
> Diff:
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.i
> etf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-intarea-probe-
> 02&data=02%7C01%7Cdthaler%40microsoft.com%7Ce8cc698fc9b94b1f355b0
> 8d4d137dddb%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636363
> 485276071855&sdata=5ZOJy6AIPCx9pErz7Mw96t8u6eB7gZvWUJ%2F9V%2Bq
> DmRw%3D&reserved=0
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Ron Bonica <[email-masked]>
Date: Sun, 23 Jul 2017 09:00:26 +0000

Dave,

I have just made that change and posted it in Version 04.

Chairs,

This clears the last comment of which I am aware. We may be ready for WGLC.

                   Ron

> From: Dave Thaler [mailto:[email-masked]]
> Sent: Sunday, July 23, 2017 12:36 AM
> To: Ron Bonica <[email-masked]>; [email-masked]; int-
> [email-masked]
> Subject: RE: New Version Notification for draft-ietf-intarea-probe-02.txt
> 
> > A new version of I-D, draft-ietf-intarea-probe-02.txt has been
> > successfully submitted by Ron Bonica and posted to the IETF repository.
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat