Subject: [Int-area] Call for support: IPmix I-D (was IPv10)

From: Juan Carlos Zuniga <[email-masked]>
Date: Thu, 5 Oct 2017 03:08:17 +0000

Dear all,

The IntArea mailing list has been repeatedly used to debate draft-omar-ipv10. So far, comments posted on the mailing list have consistently pointed towards a highly controversial topic on multiple levels. This includes the lack of a valid problem statement as well as a clear and persistent disconnect between the suggested proposal in draft-omar-ipv10 and the current market trends, deployments and available solutions.

The IntArea AD and WG chairs are not satisfied with the nature and tone of the current exchange on the IntArea ML, nor enthusiastic about its potential prospect within the IntArea WG.

However, the IntArea AD and WG chairs would like to encourage pursuing the discussion outside the IntArea WG if there is sufficient interest in the topic, e.g., on a separate mailing list. For this purpose, we would like to gauge the community interest to work on the problem statement and proposal described in draft-omar-IPv10 (possibly to be renamed IPmix).

If you are interested in participating in the work mentioned above, please respond to this mail expressing your support by October 17, 2017.

Regards,

Juan Carlos, Wassim and Suresh
IntArea WG Chairs + AD

---

From: Melinda Shore <[email-masked]>
Date: Wed, 4 Oct 2017 19:22:49 -0800

I'm somewhat astonished to see this email - I thought
the sensible thing to do would have been for them to go off
and self-organize and try to see if they can figure something
out in a non-IETF context, and bring the work back once (and/or
if) they've got something even a little bit credible.  Given everything
else going on and given the extremely poor state of the work,
putting any organizational resources at all into this seems like
a bad idea and as if it might give false encouragement to the
author(s).

Melinda

---

From: Erik Kline <[email-masked]>
Date: Thu, 5 Oct 2017 12:26:40 +0900

I think the subject line was a wee bit misleading, relative to the
actual content of the mail, which may not help.

On 5 October 2017 at 12:22, Melinda Shore <[email-masked]> wrote:
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Rolf Winter <[email-masked]>
Date: Thu, 5 Oct 2017 11:42:02 +0200

Hi,

I am quite strongly opposed to assign any further IETF ressources to 
this work. This has gone on too long for my taste. In April (!!, 
https://www.ietf.org/mail-archive/web/int-area/current/msg05634.html) 
the WG has already determined that it does not want to pursue this work 
any further. There has only been a single proponent, who at some point 
wanted to have his text removed from the IETF servers and threatened to 
even use legal actions, just to come back days later with another 
version of this idea. The whole discussion around this is unfounded 
claims which industry professionals have dismissed repeatedly such as 
the ease of software updates to deploy this. As others have said, 
interested people can go someplace else and further discuss and develop 
this, but AFAICT, the IETF community as agreed to NOT pursue this 
further. Please make this stop! It is one thing to be nice to newcomers, 
which I believe is important, but THIS is not healthy to the community 
and it is wasting a lot of people's time. Rewarding this behaviour with 
additional IETF ressources will set a bad precedence in my oppinion.

Best,

Rolf

Am 05.10.17 um 05:08 schrieb Juan Carlos Zuniga:
> Dear all,
> 
> The IntArea mailing list has been repeatedly used to debate 
> draft-omar-ipv10. So far, comments posted on the mailing list have 
> consistently pointed towards a highly controversial topic on multiple 
> levels. This includes the lack of a valid problem statement as well as a 
> clear and persistent disconnect between the suggested proposal in 
> draft-omar-ipv10 and the current market trends, deployments and 
> available solutions.
> 
> The IntArea AD and WG chairs are not satisfied with the nature and tone 
> of the current exchange on the IntArea ML, nor enthusiastic about its 
> potential prospect within the IntArea WG.
> 
> However, the IntArea AD and WG chairs would like to encourage pursuing 
> the discussion outside the IntArea WG if there is sufficient interest in 
> the topic, e.g., on a separate mailing list. For this purpose, we would 
> like to gauge the community interest to work on the problem statement 
> and proposal described in draft-omar-IPv10 (possibly to be renamed IPmix).
> 
> If you are interested in participating in the work mentioned above, 
> please respond to this mail expressing your support by October 17, 2017.
> 
> Regards,
>

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 5 Oct 2017 15:15:11 -0400

Hi Melinda,
  First of all, I share your sentiments. This mail is a last ditch effort to get this proposal away from intarea (in one of two ways). More details below.

> On Oct 4, 2017, at 11:22 PM, Melinda Shore <[email-masked]> wrote:
> 

The author requested a non-WG mailing list for this proposal on September 12 and I immediately rejected the proposal telling the author that there is insufficient interest to form a mailing list. He promptly forwarded my private mail to the list (You can see my message downthread in this message along with Lee’s message)

https://mailarchive.ietf.org/arch/msg/int-area/gOHqX4GU73uzoxTM_bQsXhrvW1E

In that message it seemed that the author had realized that there is no support for his proposal and did not post further into the list.

Then this message resurrected a dead discussion and people started having conversations about the future of IP itself while being on the same IPv10/IPmix thread.

https://mailarchive.ietf.org/arch/msg/int-area/fJ4_MpNFDhLm2GdBvoZE-FDTz0g

Then the draft author saw this as support for his proposal and requested a mailing list again.

https://mailarchive.ietf.org/arch/msg/int-area/TWo2VU2wWYcD9TGyahneIithzKA

This has all been very disruptive to the intarea mailing list greatly lowering the SNR. Something had to change. Initially, I was considering a PR action, but after careful consideration I realized that it was not applicable yet in this case. The goal of this mail is to establish the relevancy (or, as I suspect, irrelevancy) of this proposal and that will aid me in either moving it to a better home or to invoke PR action to put a stop to the disruption.

Thanks
Suresh

P.S.: Yes, this is all a colossal waste of the organizational resources (taking countless hours of people’s time) but I am resigned to the fact that dealing with DOS attacks is the cost of openness.

---

From: Khaled Omar <[email-masked]>
Date: Sat, 7 Oct 2017 16:41:23 +0000

Hi,

Seems like you are against the author or the idea or even both, your own opinion is respected, but don't force someone to do something, people started to participate and shows their own comments and this will take the I-D further.

Best regards,

Khaled

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Rolf Winter
Sent: Thursday, October 5, 2017 11:42 AM
To: [email-masked]
Subject: Re: [Int-area] Call for support: IPmix I-D (was IPv10)

Hi,

I am quite strongly opposed to assign any further IETF ressources to this work. This has gone on too long for my taste. In April (!!,
https://www.ietf.org/mail-archive/web/int-area/current/msg05634.html)
the WG has already determined that it does not want to pursue this work any further. There has only been a single proponent, who at some point wanted to have his text removed from the IETF servers and threatened to even use legal actions, just to come back days later with another version of this idea. The whole discussion around this is unfounded claims which industry professionals have dismissed repeatedly such as the ease of software updates to deploy this. As others have said, interested people can go someplace else and further discuss and develop this, but AFAICT, the IETF community as agreed to NOT pursue this further. Please make this stop! It is one thing to be nice to newcomers, which I believe is important, but THIS is not healthy to the community and it is wasting a lot of people's time. Rewarding this behaviour with additional IETF ressources will set a bad precedence in my oppinion.

Best,

Rolf

Am 05.10.17 um 05:08 schrieb Juan Carlos Zuniga:
> levels. This includes the lack of a valid problem statement as well as 
> a clear and persistent disconnect between the suggested proposal in
> The IntArea AD and WG chairs are not satisfied with the nature and 
> tone of the current exchange on the IntArea ML, nor enthusiastic about 
> its potential prospect within the IntArea WG.
> 
> the discussion outside the IntArea WG if there is sufficient interest 
> in the topic, e.g., on a separate mailing list. For this purpose, we 
> would like to gauge the community interest to work on the problem 
> statement and proposal described in draft-omar-IPv10 (possibly to be renamed IPmix).
>

---

From: Joe Touch <[email-masked]>
Date: Sat, 7 Oct 2017 14:44:48 -0700

> On Oct 7, 2017, at 9:41 AM, Khaled Omar <[email-masked]> wrote:
> 
> people started to participate 

Can you provide the list of who you think will participate?

To make my position clear, I cared only about making sure the name does no further damage to the IP version codepoint. I will not be participating further. 

Joe

---

From: Khaled Omar <[email-masked]>
Date: Sat, 7 Oct 2017 21:56:41 +0000

-----Original Message-----
From: Khaled Omar 
Sent: Saturday, October 7, 2017 11:56 PM
To: 'Joe Touch'
Subject: RE: [Int-area] Call for support: IPmix I-D (was IPv10)

> Can you provide the list of who you think will participate?

You can check all e-mails sent to the int-area WG discussing IPmix (IPv10).

> I will not be participating further.

This is up to you.

Best regards,

Khaled Omar

-----Original Message-----
From: Joe Touch [mailto:[email-masked]] 
Sent: Saturday, October 7, 2017 11:45 PM
To: Khaled Omar
Cc: Rolf Winter; int-area
Subject: Re: [Int-area] Call for support: IPmix I-D (was IPv10)

Joe

---

From: Joe Touch <[email-masked]>
Date: Sat, 7 Oct 2017 15:33:05 -0700

To others on the list: yes, this is another example of unauthorized forwarding of private mail. 

However, in this case I’m glad.  

In encourage others who have posted about this topic to make their position clear as well. 

Joe

> On Oct 7, 2017, at 2:56 PM, Khaled Omar <[email-masked]> wrote:
> 
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sun, 08 Oct 2017 09:07:24 +0200

Forwarding private emails in public is an unlawful act (at least in general in EU is considered “breach of correspondence”).

I’ve doubts of what is the jurisdiction here, if the email receiver’s countries, if the email sender country, or the country where the IETF email servers are located, maybe even several of them.

Should IETF allow unlawful acts in the email exploders or should we do something about it?

I’m saying this not just by this email, but a sender that has done this many times.

Regards,
Jordi

-----Mensaje original-----
De: Int-area <[email-masked]> en nombre de Joe Touch <[email-masked]>
Responder a: <[email-masked]>
Fecha: domingo, 8 de octubre de 2017, 0:33
Para: <[email-masked]>
Asunto: Re: [Int-area] FW:  Call for support: IPmix I-D (was IPv10)

    
    
    Joe

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Alexandre Petrescu <[email-masked]>
Date: Sun, 8 Oct 2017 10:04:29 +0200

Khaled,

There are many ways in which to replicate a private discussion to the 
public email list.

In this particular case, if someone asks you to not forward private 
messages, but still discuss publicly, you can do this: send again the 
initial message from you but to the email list.

You can do that by re-editing the same message and setting the 
destination accordingly.  You should do that, rather than forwarding a 
message that you already sent privately.

The hotmail email user agent must have some facility to move messages 
from the "Sent" folder to the "Drafts" folder, before sending.

Clicking "Forward" is too easy, and disturbs.

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Sun, 8 Oct 2017 10:09:04 +0200

Le 08/10/2017 à 00:33, Joe Touch a écrit :
[...]

> In encourage others who have posted about this topic to make their 

I suggest discussing it on another email list:
https://groups.google.com/d/forum/ip-versions

Alex

---

From: Joe Touch <[email-masked]>
Date: Sun, 8 Oct 2017 07:28:23 -0700

> On Oct 8, 2017, at 1:09 AM, Alexandre Petrescu <[email-masked]> wrote:
> 

A call for interest in this topic was issued.

It asked for positive replies. I’m saying negative replies are helpful too.

Joe

---

From: Suresh Krishnan <[email-masked]>
Date: Sun, 8 Oct 2017 19:40:46 -0400

Hi Khaled,

> On Oct 7, 2017, at 12:41 PM, Khaled Omar <[email-masked]> wrote:
> 
> Hi,
> 
> Seems like you are against the author or the idea or even both, your own opinion is respected, but don't force someone to do something,

He clearly mentioned he is against the idea. He does not seem to be forcing anybody to do anything.

> people started to participate and shows their own comments and this will take the I-D further.

Let’s see. I am yet to see anybody chime in support other than you. Once the call completes, we will evaluate the support. Until then, let’s wait to hear from other people who have not commented.

Thanks
Suresh

---

From: Suresh Krishnan <[email-masked]>
Date: Sun, 8 Oct 2017 20:02:54 -0400

Hi Jordi,

> On Oct 8, 2017, at 3:07 AM, JORDI PALET MARTINEZ <[email-masked]> wrote:
> 

Not sure about the legality, but forwarding private mails publicly is considered poor etiquette. Several of us have conveyed this to the sender but this keeps on repeating. At this point, I am working under the assumption that my private emails will be forwarded somewhere. At the moment, the sole point of this thread is to determine if there is interest to work in this proposal. If you would like to discuss the legal aspects of this, please send me a private mail so that I can discuss that with the IESG/IAOC/IETF legal counsel if necessary.

Regards
Suresh

---

From: Suresh Krishnan <[email-masked]>
Date: Sun, 8 Oct 2017 20:03:12 -0400

> On Oct 8, 2017, at 10:28 AM, Joe Touch <[email-masked]> wrote:
> 
> 
> 

Yes. For sure. Thanks for your input.

Regards
Suresh

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 9 Oct 2017 08:20:19 +0200 (CEST)

Hi,

So while I have previously pointed out to Khaled that he's not supposed to 
forward private email to the list (which he has repeatedly done), in this 
specific incident it seems to me that you did actually cc int-area here? 
It can be seen in the "CC" below, and I did receive the email you sent 
that Khaled repled to.

Nontheless, I would like to say that people interested in IPmix should go 
somewhere outside the IETF and work on their ideas. There has already been 
press indicating that "the IETF is working on the successor to IPv6" which 
is just further causing problem with FUD regarding IPv6 deployment.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Matthew Ford <[email-masked]>
Date: Mon, 9 Oct 2017 09:31:32 +0100

> On 7 Oct 2017, at 23:33, Joe Touch <[email-masked]> wrote:
> 

Really? You cc’d int-area on your original note as far as I can tell.

Mat

---

From: Khaled Omar <[email-masked]>
Date: Mon, 9 Oct 2017 10:47:54 +0000

Hi,

Regarding sending e-mails. I reply to the sender and Cc the int-area, sometimes I forget to Cc the int-area so I forward the e-mail again to the int-area.

Usually, I reply publicly when the sender Cc'd the int-area and privately in case of the sender is sending only to me so it is fine. 

> , I would like to say that people interested in IPmix should go somewhere outside the IETF and work on their ideas.

What's the problem in having a mailing list within the IETF to discuss IPmix I-D, I think people can participate freely once it will be created.

Khaled

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Mikael Abrahamsson
Sent: Monday, October 9, 2017 8:20 AM
To: Joe Touch
Cc: [email-masked]
Subject: Re: [Int-area] FW: Call for support: IPmix I-D (was IPv10)

Hi,

So while I have previously pointed out to Khaled that he's not supposed to forward private email to the list (which he has repeatedly done), in this specific incident it seems to me that you did actually cc int-area here? 
It can be seen in the "CC" below, and I did receive the email you sent that Khaled repled to.

Nontheless, I would like to say that people interested in IPmix should go somewhere outside the IETF and work on their ideas. There has already been press indicating that "the IETF is working on the successor to IPv6" which is just further causing problem with FUD regarding IPv6 deployment.

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 9 Oct 2017 12:22:20 +0100

Whilst I have no opinion on this technical proposal, I do think that the 
IETF needs to support the ability to discuss and develop ideas that are 
not mainstream.

The "rough consensus and running code" IETF tag line implies a pragmatic 
approach that seems lacking when it comes to the evolution of the 
Internet layer, where IPv6 has acquired a status that is almost 
religious in nature.

At the end of the day we are talking about a tiny amount of storage to 
support this list request. If it does not get used so what? If it does 
get used maybe it will trigger some useful thoughts.

In wider scope, I am particularly concerned that this discussion will 
cause others to resist proposing non-mainstream ideas for fear of the 
reaction that will get, and that is not in the long term best interests 
of the Internet.

So where the cost is small, and the cost of a list is small, I would 
like to see us take a libertarian approach to  requests such as this.

- Stewart

---

From: Melinda Shore <[email-masked]>
Date: Mon, 9 Oct 2017 03:35:54 -0800

> IETF needs to support the ability to discuss and develop ideas that are

I do, as well, and there are certainly examples of protocols
that, er, weren't well-received when the first drafts were
published.  I don't think that's entirely the issue here -
the argument behind the proposal is incoherent, the author
is abusing the mailing list, and he seems reluctant to take
it off the mailing list and work on it.

It's probably worth noting that the fellow with the proposal
to expand the IPv4 address space by using octets with values
from 256-999, and who kept updating his draft, caused far less
disruption.  Out-of-the-mainstream, or even wrong, proposals
aren't a problem per se, and certainly not the problem here.

Melinda

---

From: Tom Herbert <[email-masked]>
Date: Mon, 9 Oct 2017 08:31:41 -0700

On Wed, Oct 4, 2017 at 8:08 PM, Juan Carlos Zuniga
<[email-masked]> wrote:
> draft-omar-ipv10 and the current market trends, deployments and available
> solutions.
>
>
>
> The IntArea AD and WG chairs are not satisfied with the nature and tone of
> the current exchange on the IntArea ML, nor enthusiastic about its potential
> prospect within the IntArea WG.
>
>
>
> However, the IntArea AD and WG chairs would like to encourage pursuing the
> discussion outside the IntArea WG if there is sufficient interest in the
> topic, e.g., on a separate mailing list. For this purpose, we would like to
> gauge the community interest to work on the problem statement and proposal
> described in draft-omar-IPv10 (possibly to be renamed IPmix).
>
>
>
> If you are interested in participating in the work mentioned above, please
> respond to this mail expressing your support by October 17, 2017.
>
The draft and the concept have been thoroughly discussed on int-area
list (twice). I don't see that the problem is worth solving, the
proposed solution is remotely feasible, or that the author is willing
to apply feedback from the discussion. I am not interested in further
discussions about this.

Tom

---

From: "Black, David" <[email-masked]>
Date: Mon, 9 Oct 2017 15:49:49 +0000

> to apply feedback from the discussion. I am not interested in further

+1, --David

> From: Int-area [mailto:[email-masked]] On Behalf Of Tom Herbert
> Sent: Monday, October 9, 2017 11:32 AM
> To: Juan Carlos Zuniga <[email-masked]>
> Cc: [email-masked]; intarea-chairs <[email-masked]>
> available
> the

---

From: Gabor LENCSE <[email-masked]>
Date: Tue, 10 Oct 2017 10:13:09 +0900

>> to apply feedback from the discussion. I am not interested in further

+1

Gabor

---

From: Bob Hinden <[email-masked]>
Date: Tue, 10 Oct 2017 10:14:04 -0700

> to apply feedback from the discussion. I am not interested in further

I have read the draft and agree with Tom’s summary.

Bob

---

From: <[email-masked]>
Date: Wed, 11 Oct 2017 07:47:50 +0000

+1

Nic

-----Ursprüngliche Nachricht-----
Von: Int-area [mailto:[email-masked]] Im Auftrag von Gabor LENCSE
Gesendet: Dienstag, 10. Oktober 2017 03:13
An: [email-masked]
Betreff: Re: [Int-area] Call for support: IPmix I-D (was IPv10)

+1

Gabor