Subject: [Int-area] Liaison statement received from ITU-T regarding a "Reference Model of IPv6 Addressing Plan for Internet of Things Deployment"

From: Suresh Krishnan <[email-masked]>
Date: Mon, 2 Oct 2017 22:53:45 -0400

Hi all,
  The IETF has received a liaison statement from the ITU-T that their Study Group SG20 is inviting inputs from the IETF regarding a work item titled "Reference Model of IPv6 Addressing Plan for Internet of Things
Deployment” and the deadline for providing inputs is 2018/01/28. The statement can be found at 

https://datatracker.ietf.org/liaison/1546/

I have no further info and I am trying to get access to the referenced documents. I just want to provide a heads up while that is in process.

Thanks
Suresh

---

From: Samita Chakrabarti <[email-masked]>
Date: Tue, 3 Oct 2017 01:42:22 -0700

Thanks Suresh, for sharing the information. It looks quite relevant to 6lo
WG workarea. We, 6lo-chairs will contact Scott and the ITU-T contact person
provided in the liaison note.
Will discuss with you on a separate email regarding the steps to connect.

-Samita

On Mon, Oct 2, 2017 at 7:53 PM, Suresh Krishnan <[email-masked]>
wrote:

> Hi all,
>   The IETF has received a liaison statement from the ITU-T that their
> Study Group SG20 is inviting inputs from the IETF regarding a work item
> titled "Reference Model of IPv6 Addressing Plan for Internet of Things
> I have no further info and I am trying to get access to the referenced
> documents. I just want to provide a heads up while that is in process.
>
> Thanks
> Suresh
>
>
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 3 Oct 2017 09:30:10 -0700

6man as well, depending on what is in the actual document.

Bob

> On Oct 3, 2017, at 1:42 AM, Samita Chakrabarti <[email-masked]> wrote:
> 
> Thanks Suresh, for sharing the information. It looks quite relevant to 6lo WG workarea. We, 6lo-chairs will contact Scott and the ITU-T contact person provided in the liaison note.
> On Mon, Oct 2, 2017 at 7:53 PM, Suresh Krishnan <[email-masked]> wrote:
> Hi all,
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Fred Baker <[email-masked]>
Date: Tue, 3 Oct 2017 10:09:52 -0700

Thanks. I would like to also get operational commentary from v6ops. Like you, when I search for the document, I come up to a paywall; the document is not openly available. Please forward either the document or the link when ITU decides to get serious about asking for comment.

A general comment: the model being followed in RFC 4861 and in the various IOT groups is fundamentally as follows. The IPv6 address consists of a prefix and an IID. In the general Internet, routing operates on prefixes, and a subnet is identified by a prefix. Within a subnet defined by WiFi, Bluetooth, IEEE 802.15.4/4g, Power Line Communication technologies, and the like, network elements generally use some form of host routing, whether source or distributed, on the presumption that topologies may be continuously changing or devices may be moving. 6LowPAN specifically has some recommendations on the structure of the address designed to minimize the actual size of an IPv6 header, and in many of them, that is treated as a lower layer problem. I'd like to believe that the work party is sufficiently clued in to not want to materially change that without discussing it with us (putting documents behind a paywall not being a great example of open discussion).

> On Oct 2, 2017, at 7:53 PM, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi all,