Subject: Re: [Int-area] Which CRC to use to enhance payload integrity in GUE extensions

From: G Fairhurst <[email-masked]>
Date: Mon, 19 Mar 2018 17:08:29 +0000

I spoke at the Mic today arguing for considering just a CRC-32.

This is the size of CRC that was for a similar purpose used in SCTP is 
32b in iSCSI and SCTP.

CRC-32c was the selected method, and I think this should be considered 
for this ID. The choice of the CRC-32c algorithm is described in RFC 
3309, along with considerations and a code example. The CRC32c algorithm 
was also chosen in iSCSI (see RFC 3385 for some considerations).

Gorry
TSVWG Co-Chair

(I feel free to discuss the merits of different CRC's on the tsvwg list.)

---

From: "Black, David" <[email-masked]>
Date: Mon, 19 Mar 2018 17:10:56 +0000

CRC-32c is the CRC that I referred to in my remarks at the microphone, including the existence of CPU instruction support.

Thanks, --David

> -----Original Message-----
> From: Int-area [mailto:[email-masked]] On Behalf Of G Fairhurst
> Sent: Monday, March 19, 2018 1:08 PM
> To: G Fairhurst <[email-masked]>; [email-masked]
> Subject: Re: [Int-area] Which CRC to use to enhance payload integrity in GUE
> extensions
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area