Subject: [Int-area] An extension to PROBE [RFC8335] diagnostic tool

From: Manoj Nayak <[email-masked]>
Date: Sat, 17 Aug 2019 15:05:04 +0000

Folks,

We have posted 01 version of the draft “Probing IP Interfaces By Vendor Specific Identifiers”.
This draft is extension to  PROBE [RFC8335] diagnostic tool. The tool is extended so that the
tool can identify the probed interface by Vendor Specific Identifiers , i.e Virtual Function
Index (VFI) [SR-IOV].

This version of the draft has taken care of  review comments provided for 00 version of the draft.

Our draft is available at:

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_internet-2Ddrafts_draft-2Dnayak-2Dintarea-2Dprobe-2Dby-2Dvfi-2D00.txt&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=yA4ZWVIeZge8k5n5C9m5Z-zj1dDJa0l6co6CaJ-JuJI&m=XUXYC3xqcaLYKixeq5vjqYz44nVjof_RBcsgZEe5Mw0&s=-V7zNXS7z4KClqgl40QrcWV4ZKfFZ_esDg_BAYZYmbU&e=

The Abstract is:

  This document enhances the PROBE diagnostic tool so that it can

   identify the probed interface by Vendor Specific Identifiers.

   In order to achieve that goal, this document also extends the

   Interface Identification Object.  The Interface Identification

   Object is an ICMP Extension Object class.

Any comments will be welcome.

Thanks!

Cheers,
--
Manoj Nayak
Juniper Networks
e-mail: [email-masked]

---

From: Job Snijders <[email-masked]>
Date: Fri, 23 Aug 2019 12:46:04 +0000

Dear Manoj,

On Sat, Aug 17, 2019 at 03:05:04PM +0000, Manoj Nayak wrote:
> We have posted 01 version of the draft “Probing IP Interfaces By
> Vendor Specific Identifiers”.  This draft is extension to  PROBE
> [RFC8335] diagnostic tool. The tool is extended so that the tool can
> identify the probed interface by Vendor Specific Identifiers , i.e
> Virtual Function Index (VFI) [SR-IOV].
> 

I've not been able to find any implementations of the PROBE tool so far,
(I also shared that observation here https://www.spinics.net/lists/ietf/msg86865.html)

I'm not sure what's being standardized and what IETF's role is if there
is no running code, but hopefully I'm behind the times!

Can you perhaps share interopability reports, or show what testing
between vendors has been done in context of PROBE? Are there open source
implementations by now?

Kind regards,

Job

---

From: Bob Hinden <[email-masked]>
Date: Fri, 23 Aug 2019 08:34:57 -0700

Manoj,

> On Aug 17, 2019, at 8:05 AM, Manoj Nayak <manojnayak=[email-masked]> wrote:
> 
> 
> Folks,
> 

I can’t open this link.  I suspect it only works inside of Juniper.

In the future if you are going to ask for comments, please include a link that is usable.  Like one that starts with:

https://tools.ietf.org/html/xxxxx

Bob

> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area