Subject: Re: [Int-dir] Proposed change to review assignment email subject

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Mon, 4 Apr 2022 12:58:06 +0200

Hi,

I think sending two e-mails would be an overkill. I think the consensus so
far is to use something like:

Your <team name> review assignment of <draft-foo> by <deadline>

Can we move forward with this? We'll need to inform reviewers so they can
update their filters if needed.

Thanks,

Carlos

On Thu, Mar 31, 2022 at 5:18 PM Tim Chown <Tim.Chown=
[email-masked]> wrote:

> Well, then just send two emails, one in old school format, one as a
> ‘flare’ for attention.
>
> Then those who like it as it is have what they need, and those who are
> missing assignments have a greater chance of not doing so.
>
> Tim
>
> > On 31 Mar 2022, at 15:42, Robert Sparks <[email-masked]> wrote:
> >
> >
> > On 3/31/22 3:58 AM, Tim Chown wrote:
> >> On 30 Mar 2022, at 21:03, Robert Sparks <[email-masked]> wrote:
> >>> On 3/30/22 12:43 PM, Ted Lemon wrote:
> >>>> Sure, but I would think that we /wouldn't/ want a review notification
> to match that rule, right? Otherwise it's going to get filed in the bucket
> for the draft and possibly not land on the reviewer's to-do list.
> >>> Ted - Other people _want_ these to go into their draft buckets. People
> have their own workflows, and having draft names in these announcements are
> already part of them.
> >> So send a separate alert to the reviewer, please, that is in a format
> least likely to be misfiled, parsed or spam foldered.
> > That assumes that the likelihood function you point to is the same for
> everyone, and we're seeing already that it is not. Removing the draft name
> will introduce errors for some and apparently introduce them for others.
> >>
> >> The subject can simply be “New INT-DIR assignment” or something simple
> like that.  Without any draft name.
> >>
> >> That MUST be possible.
> > This is starting to sound like a need for personalized subject lines.
> Would the calendar subscription suggestion made earlier better fill the
> need?
> >>
> >> And I really think this should be discussable and resolved here and not
> require us to engage in the Git issue tracker
> > I already said that it was I thought? But this should move to
> tools-discuss so we can get all the concerned review team members on one
> thread (I've added a Reply-To).
> >>
> >>> When I am scanning email, I _personally_  want to see the draft name
> in the subject - a long string of things with a semantic of "you have a new
> review assignment, read the message or click on some links to find out what
> it is" is not welcome. Further, if I had some reason to go back later and
> find the message that pertained to a particular draft, such mining would
> not be ok.
> >> A search can include the message body.
> >
> > Not really the right answer in modern mail clients with the volume of
> mail someone on the I* or who does work in many working groups has to see
> through.
> >
> >>   The current problem is clean receipt.
> >
> > And we're disagreeing on one part of what clean receipt requires.
> >
> >>
> >> Tim
>
> _______________________________________________
> Int-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-dir
>

---

From: Tim Chown <[email-masked]>
Date: Mon, 4 Apr 2022 11:03:06 +0000

OK.  The deadline in the subject is handy.

> On 4 Apr 2022, at 11:58, CARLOS JESUS BERNARDOS CANO <[email-masked]> wrote:
> 
> Hi,
> 
> I think sending two e-mails would be an overkill. I think the consensus so far is to use something like:
> 
> Can we move forward with this? We'll need to inform reviewers so they can update their filters if needed.
> 
> Thanks,
> 
> Carlos
> 
> On Thu, Mar 31, 2022 at 5:18 PM Tim Chown <Tim.Chown=[email-masked]> wrote:
> Well, then just send two emails, one in old school format, one as a ‘flare’ for attention.
> 
> Then those who like it as it is have what they need, and those who are missing assignments have a greater chance of not doing so.
> 
> Tim
> 
> >>>> Sure, but I would think that we /wouldn't/ want a review notification to match that rule, right? Otherwise it's going to get filed in the bucket for the draft and possibly not land on the reviewer's to-do list.
> >>> Ted - Other people _want_ these to go into their draft buckets. People have their own workflows, and having draft names in these announcements are already part of them.
> >> So send a separate alert to the reviewer, please, that is in a format least likely to be misfiled, parsed or spam foldered.
> > That assumes that the likelihood function you point to is the same for everyone, and we're seeing already that it is not. Removing the draft name will introduce errors for some and apparently introduce them for others.
> >> 
> >> The subject can simply be “New INT-DIR assignment” or something simple like that.  Without any draft name.
> >> 
> >> That MUST be possible.
> > This is starting to sound like a need for personalized subject lines. Would the calendar subscription suggestion made earlier better fill the need?
> >> 
> >> And I really think this should be discussable and resolved here and not require us to engage in the Git issue tracker
> > I already said that it was I thought? But this should move to tools-discuss so we can get all the concerned review team members on one thread (I've added a Reply-To).
> >> 
> >>> When I am scanning email, I _personally_  want to see the draft name in the subject - a long string of things with a semantic of "you have a new review assignment, read the message or click on some links to find out what it is" is not welcome. Further, if I had some reason to go back later and find the message that pertained to a particular draft, such mining would not be ok.
> > Not really the right answer in modern mail clients with the volume of mail someone on the I* or who does work in many working groups has to see through.
> >

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 4 Apr 2022 11:06:49 +0000

One email is indeed enough and to add more flavors to the Subject line matter, I would suggest:

Please accept your <team name> review assignment of <draft-foo> by <deadline>

As having the draft name in the Subject line makes it easier to find all relevant emails

Regards

-éric

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Monday, 4 April 2022 at 12:58
To: Tim Chown <[email-masked]>
Cc: tools-discuss <[email-masked]>, Eric Vyncke <[email-masked]>, Ted Lemon <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Int-dir] Proposed change to review assignment email subject

Hi,

Thanks,

Carlos

On Thu, Mar 31, 2022 at 5:18 PM Tim Chown <Tim.Chown=[email-masked]<mailto:[email-masked]>> wrote:
Well, then just send two emails, one in old school format, one as a ‘flare’ for attention.

Tim

> On 31 Mar 2022, at 15:42, Robert Sparks <[email-masked]<mailto:[email-masked]>> wrote:
>
>
>> On 30 Mar 2022, at 21:03, Robert Sparks <[email-masked]<mailto:[email-masked]>> wrote:

_______________________________________________
Int-dir mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/int-dir

---

From: Tim Chown <[email-masked]>
Date: Mon, 4 Apr 2022 11:14:53 +0000

> On 4 Apr 2022, at 12:06, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 

Well, it’s the draft name that cause the problems, but I’ve lost the will to debate it further.  For me I only get the missing alerts for OPS DIR, not INT DIR, so not a problem for you Eric :)

Tim

---

From: Tero Kivinen <[email-masked]>
Date: Thu, 7 Apr 2022 15:08:04 +0300

> Please accept your <team name> review assignment of <draft-foo> by <deadline>

I think the shorter proposed "Your <team name> review assignment of
<draft-foo> by <deadline>" is better, as for example in secdir almost
nobody uses the accept/reject features, and the deadline is for
review, not for accepting the review request.

And I think it is mandatory to keep the team name and draft name in
the subject line, deadline is also nice, otherwise keeping it shorter
is better, as then you see all relevant information also if only part
of subject is visible. 
-- 
[email-masked]