Subject: (ION) ALL1 SRTS computation on a link-by-link basis

From: Dilip Raj Pandit <[email-masked]>
Date: Mon, 20 Apr 1998 16:46:56 -0530 (IST)

Hi all,

I would like to know about how the AAL1 goes about 
determining the SRTS (i.e, the difference between 
the service clock and network clock) at each link 
along a multi=hop/multi-link real-time application's
connection wherein the link speeds at the next hop 
is different. This scenario is illustrated below:

    _______          _________          _______ 
    |      | 155MBPS |        | 622MBPS |      |
    |SOURCE|__link___| Switch |__link___|DEST  |
    |      |         |        |         |      |
    |______|         |________|         |______|
     
 SRTS1=Serv Clk       SRTS2 ???        SRTS3 =? SRTS1
      - N/W Clk 

Is SRTS1 equal to SRTS3? I don't think so since the 
n/w clk freq has changed from the source to the dest.
And is the SRTS (=SRTS2) recomputed at the switch 
and every other transit node along the connection?

Thanks 

Bye

DILIP

X-Info: To unsubscribe, email [email-masked]' with
X-Info: 'unsubscribe ion' in the body of the message.

---

From: Dilip Raj Pandit <[email-masked]>
Date: Tue, 21 Apr 1998 10:09:51 -0530 (IST)

Hi Alan,

Thanks for a very comprehensive reply. But still I am
not convinced as to how the DEST node drives the E1
(i.e., obtains the service/SLAVE clk) with the difference 
between the OC12 (=622Mbps) and the SRTS in the received cell. 
This, obviously will not be equal to the difference 
 which was originally generated (i.e., SRTS) at the SOURCE node,
where we had SRTS = Service Clk - OC3 rate
		  = Service Clk - (1/155Mbps)

Hope you can clarify this. I may be missing out on something
here.

Thanks once again,

DILIP

+-------------------------+-----------------------------+
| DILIP R PANDIT 	  |E-MAIL:[email-masked]|
| Senior Engineer - D & D |PHONE :91-080-8410148 Ext:239|
| Design & Dev. Centre    |                             |
| Tata Elxsi (India) Ltd. |                 	        |
| 26,28/2 Hoody           |                 	        |
| Whitefield Road         |                             |
| Mahadevapura Post       |                             |
| BANGALORE - 48          |				|
+-------------------------+-----------------------------+

On Mon, 20 Apr 1998, Alan Bartky wrote:

> Dilip,
> 
> The SRTS information isn't processed by intermediate
> ATM switches.  The only place SRTS is processed is
> where the conversion from bit oriented (i.e. E1)
> to cell oriented occurs.
> 
> Also for SRTS to work, there is a requirement for
> the ATM network along the path of the VC be
> syncrhonized to the same reference clock.  As
> long as they are synchronized to the same reference
> (OC3 and OC12 use a 19.44 MHz reference), it
> doesn't matter to the SRTS algorithm that they
> are different bit rates.
> 
> So to enhance your diagram, lets add clock sources and
> PBXs to show how it works.
> 
>                                 ATM Master
>                                   Clock
>                ________         __________         ________ 
>      PBX-------|SOURCE|__link___| Switch |__link___|DEST  |---PBX
>     E1 Master  |      |         |        |         |      |   E1 Slave 
>      Clock     |______|         |________|         |______|   Clock
>       
>   SRTS1=Serv Clk                SRTS ignored        Slave Clk = N/W Clck
>        - N/W Clk                                                - SRTS1
> 
> For SRTS there must be always two sources of clock.  The ATM
> network is synchronized via a master clock source and
> distributed to all nodes.
> 
> The SOURCE node derives the reference timing from the OC3 link
> and the derived clock from the E1 line uses them to calculate 
> the SRTS information information to be stuffed into the AAL1 cells.
> 
> The DEST node derives the same ATM reference timing from the 
> OC12 link and extracts the SRTS information from the cell
> and uses the difference to calculate and drive the E1
> clock out to the end device.
> 
> Regards,
> 
> Alan 4/20/98 8:54
> 
> ***********************************************************************
> *   /\                                                                *
> *  /\/\    Alan K. Bartky                       Email:[email-masked]  *
> * /\  /\   Manager WAN software development                           *
> * \/  \/   XYLAN Corporation                    Voice:(714) 450-9162  *
> *  \/\/    1 TECHNOLOGY DR STE J709             FAX:  (714) 450-9170  *
> *   \/     IRVINE CA 92618-2353                                       *
> *  XYLAN                                                              *
> ***********************************************************************
> 
> 
> > From [email-masked] Mon Apr 20 04:30:34 1998
> > Date: Mon, 20 Apr 1998 16:46:56 -0530 (IST)
> > From: Dilip Raj Pandit <[email-masked]>
> > Reply-To: Dilip Raj Pandit <[email-masked]>
> > Subject: (ION) ALL1 SRTS computation on a link-by-link basis
> > To: Cell-Relay Mail List <[email-masked]>
> > Cc: [email-masked]
> > Mime-Version: 1.0
> > Content-Type> : > TEXT/PLAIN> ; > CHARSET=US-ASCII> 
> > Sender: [email-masked]
> > X-Info: [Un]Subscribe to [email-masked]
> > X-Info: Submissions to [email-masked]
> > X-Info: Hypermail archive at http://netlab.ucs.indiana.edu/hypermail/ion/
> > Content-Length: 998
> > 
> > Hi all,
> >

---

From: [email-masked] (Alan Bartky)
Date: Tue, 21 Apr 98 09:29:22 PDT

Dilip-

What you are missing (I believe) is the concept of
the ATM network having a single reference clock for
SRTS to work.

The speed of the optical, coaxial, or twisted pair
media doesn't matter.  What matters is the reference clock.
For Optical networks they use a reference clock frequency
of 19.44 Mhz, and the legacy coaxial (DS3 and E3) and twisted pair
technologies (T1 and E1) use an 8 Khz reference clock.
The 19.44 Mhz clock can be divided down to 8 Khz or the 8 Khz
clock can be multiplied up to 19.44 Mhz in ATM switches to
keep connections between switches in clock synchronization.
That is the key.  SRTS will work in syncrhonized Networks,
it won't work in plesiochronous networks.

The calculation for SRTS is done based on reference frequency,
not the actual line rate of the physical interfaces. So
as long as the Virtual Connection passes through
a path with all physical connections being synchronized
to a common reference frequency, SRTS will work.
If you don't have a common clock, then it won't work
and you have to use adaptive clocking rather than SRTS.

So your statement of SRTS being calculated from 155 MBPS 
isn't correct, it is calculated from the reference frequency.

So going back to your original example, as long as the OC3 and OC12
connections run synchronized using the same reference frequency,
SRTS will work.  The end systems will (and Must) use the same
reference frequency to either generate/calculate the SRTS
information into the cell, or on the other side to extract
the SRTS from the cell and generate/calucluate the T1/E1
clock on the exit side base on the difference between the
reference clock (not the physical access rate clock)
and the SRTS data.

Regards,

Alan 4/21/98 4/21/98 9:15

* /\  /\   Manager WAN Software Devlopment                            *

> From [email-masked] Mon Apr 20 22:01:57 1998
> Date: Tue, 21 Apr 1998 10:09:51 -0530 (IST)
> Subject: Re: (ION) ALL1 SRTS computation on a link-by-link basis
> To: Alan Bartky <[email-masked]>
> Cc: Cell-Relay Mail List <[email-masked]>, [email-masked]
> Mime-Version: 1.0
> Content-Type> : > TEXT/PLAIN> ; > charset=US-ASCII> 
> Content-Length: 5456
> 
> 
> Hi Alan,
>