Subject: (ION) Query on RFC 1483

From: sutirtha saha <[email-masked]>
Date: Wed, 1 Mar 2000 11:54:25 -0800 (PST)

Hello
I am implementing a system which has the following layers:

---------------
802.1D Bridge
---------------
RFC 1483
---------------
SAR Driver (AAL5)
---------------
Utopia

The BPDUs generated by the 802.1D has the following header:
Ethernet Hdr - 01-80-C2-00-00-00,Src address(6 bytes), 2 byte length
(0x003c)
LLC Snap Header - 42-42-03
Protocol id, Version id and rest of BPDU...

Now when I am sending the BPDU to the SAR Driver, I understand, that
according to RFC 1483, I put a header on top of it. Now what header do
I use ? Is it the one for 802.3 or is it the one given on page 9 of the
RFC , ie 0xAA-AA-03-00-80-C2-00-0E ?

If I use the one on Pg 9 of RFC 1483,  my frame becomes:

------------------------
RFC Header (8 bytes)
------------------------
Ethernet Hdr(14 bytes)
----------------------
LLC Snap Hdr (3 bytes)
------------------------
Rest of BPDU
------------------------

Please confirm if my understanding is correct or am I missing anything.
Also, I understand, that the BPDU will not need a LAN-FCS at the end.
I was recommended this mailing list by Juha Heinanen, the author of RFC
1483 and I would be grateful to anyone who can answer me.

Thanks and Regards
Sutirtha

__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

X-Info: To unsubscribe, email [email-masked]' with
X-Info: 'unsubscribe ion' in the body of the message.

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 2 Mar 2000 11:20:25 -0500

RFC 2684 obsoletes RFC 1483.

As this RFC explains, you have the option of assuming that a particular VC
only carries one type of link layer protocol, in which case the PDU contains
only the fields that would appear over that type of link layer.

Or you can add a second wrapper around that, and identify explicitly that
the enclosed PDU is 802.3, 802.4, 802.5, or 802.6. This might involve two
different LLC headers: the one telling you that an encapsulated link layer
PDU follows, and the LLC header that belongs to that encapsulated PDU. This
is sort of a double-wrapped PDU.

If the top LLC header reads LLC 0xAA-AA-03 OUI 0x00-80-C2, then you know
that this is double-wrapped. A Protocol ID must follow this, and that
Protocol ID will identify the encapsulated link layer (i.e. will tell you
whether it's 802.3, 802.4, etc.). And inside that encapsulated PDU, you will
maybe see another LLC header. For IEEE 802.3, you might see no other LLC
header. For the others, you will.

Bert
[email-masked]

> -----Original Message-----
> From: sutirtha saha [mailto:[email-masked]]
> Sent: Wednesday, March 01, 2000 2:54 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: (ION) Query on RFC 1483
> 
> 
> Hello